none
No aplica politica para instalar un msi RRS feed

  • Pregunta

  • Buenos días.

    He creado una politica para instalar un paquete msi. La politica la aplico a nivel de equipo.

    Al reiniciar el Pc no me instala nada. Cuando realizo un gpupdate me da el siguiente mensaje de error.

    C:\Users\moreno.david>gpupdate
    Actualizando directiva...

    Se completó correctamente la Actualización de directiva de usuario.
    La actualización de la directiva de equipo se completó correctamente.

    Se produjeron las siguientes advertencias al procesar la directiva de equipo:

    La Extensión del lado cliente de la directiva de grupo Software Installation no
    se pudo aplicar a una o más configuraciones porque los cambios se deben procesar
     antes de que se inicie el sistema o de que el usuario inicie la sesión.  El sis
    tema esperará hasta que finalice completamente el procesamiento de la directiva
    de grupo antes de reiniciar el sistema o iniciar la sesión de este usuario; a ca
    usa de esta mediada, es posible que el rendimiento del inicio y del arranque sea
     más lento.

    Para obtener información más detallada, consulte el registro de eventos o invoqu
    e gpmc.msc para tener acceso a información sobre los resultados de directivas de
     grupos.

    miércoles, 16 de diciembre de 2009 8:06

Respuestas

  • damova, hay varias cosas para revisar.

    Cuando dices que si te mapeas el recurso funciona ¿lo estás haciendo con una letra de disco? porque hay aplicaciones que así funcionan, pero si se accede con \\servidor\recuso\app no funcionan

    Segundo, cuando tú lo ejecutas se hace con la conexión de tu cuenta, pero cuando lo hace por GPO se accede con la cuenta de máquina, y por lo tanto es ésta la que tiene que tener permisos. Asegúrate que tenga permisos la cuenta de máquina en el recurso compartido, por ejemplo con el grupo Usuarios Autentificados.

    Tercero, la aplicación tiene que soportar instalación desatendida. Si cuando tú la instalas a máquinas debes ingresar configuración manualmente, el sistema no puede hacerlo. Revisa si en la línea de comando de instalación le puedes dar parámetros de configuración.

    Para darte más ideas habría que conocer más datos:
    - Si es por máquina o por usuario
    - Si publicas o asignas
    - Eventualmente el nombre de la aplicación

    Guillermo Delprato - MVP-MCT-MCITP-MCTS-MCSE MCITP: Server Administration MCTS:Active Directory/Network Infrastructure Buenos Aires, Argentina
    jueves, 17 de diciembre de 2009 10:58
    Moderador
  • La documentación de la aplicación del MSI debería darte información de cómo implementarla por GPO.

    Guillermo Delprato - MVP-MCT-MCITP-MCTS-MCSE MCITP: Server Administration MCTS:Active Directory/Network Infrastructure Buenos Aires, Argentina
    viernes, 18 de diciembre de 2009 15:19
    Moderador

Todas las respuestas

  • Buenos dias Damova,
    Supongo que habras ejecutad el gpupdate /force.
    Deberías comprobar si en el visor de sucesos hay algun error tipo Userinit en el pc.
    Tambien deberias comprobar si esta sincronizado correctamente con el dominio.
    Saludos.

    MCSE Formador y Consultor Microsoft.
    miércoles, 16 de diciembre de 2009 8:40
  • Muchas gracias Raul.

    He realizado el /force y me ha obligado a reiniciar pero nada. En el visor de sucesos no tengo nada.

    Es posible que sea un tema de seguridad, pero si mapeo el recurso compartido donde tengo el msi y lo ejecuto, me deja perfectamente.
    miércoles, 16 de diciembre de 2009 10:36
  • damova, hay varias cosas para revisar.

    Cuando dices que si te mapeas el recurso funciona ¿lo estás haciendo con una letra de disco? porque hay aplicaciones que así funcionan, pero si se accede con \\servidor\recuso\app no funcionan

    Segundo, cuando tú lo ejecutas se hace con la conexión de tu cuenta, pero cuando lo hace por GPO se accede con la cuenta de máquina, y por lo tanto es ésta la que tiene que tener permisos. Asegúrate que tenga permisos la cuenta de máquina en el recurso compartido, por ejemplo con el grupo Usuarios Autentificados.

    Tercero, la aplicación tiene que soportar instalación desatendida. Si cuando tú la instalas a máquinas debes ingresar configuración manualmente, el sistema no puede hacerlo. Revisa si en la línea de comando de instalación le puedes dar parámetros de configuración.

    Para darte más ideas habría que conocer más datos:
    - Si es por máquina o por usuario
    - Si publicas o asignas
    - Eventualmente el nombre de la aplicación

    Guillermo Delprato - MVP-MCT-MCITP-MCTS-MCSE MCITP: Server Administration MCTS:Active Directory/Network Infrastructure Buenos Aires, Argentina
    jueves, 17 de diciembre de 2009 10:58
    Moderador
  • Buenos días

    He revisado el tema de permisos y esta todo ok.

    La politica la tengo a nivel de usuario y la tengo Publicada.

    Lo que seguro que tengo mal es el msi ya que es de instalacion, no es desatendido.

    Por cierto, alguna aplicacion para crear msi?
    viernes, 18 de diciembre de 2009 10:42
  • La documentación de la aplicación del MSI debería darte información de cómo implementarla por GPO.

    Guillermo Delprato - MVP-MCT-MCITP-MCTS-MCSE MCITP: Server Administration MCTS:Active Directory/Network Infrastructure Buenos Aires, Argentina
    viernes, 18 de diciembre de 2009 15:19
    Moderador
  • Hola Damova,

    Por favor, háganos saber si usted tiene más preguntas relacionadas con este tema, ok?

    Estoy seguro de que será un gran placer ayudarle!

    Un saludo,
    Átilla Arruda - Microsoft Corporation
    lunes, 21 de diciembre de 2009 15:07
    Moderador