none
Sincronización y logon de usuarios RRS feed

  • Pregunta

  • Empecé a trabajar hace poco en un nuevo trabajo, y tengo la siguiente situación:

    1 servidor Windows 2000 Server
    1 servidor Windows 2003 Server
    50 terminales Windows XP

    El servidor 2000 es el controlador de dominio.
    Como necesito redundancia, configuré el 2003 para que también lo fuera, para que si el servidor 2000 llegara a fallar, el 2003 pudiera permitirle a los usuarios al menos iniciar sesion.

    Concretamente, el problema que tengo, es que cuando el 2000 server está apagado, es como si las terminales XP no vieran al 2003 server. No encuentran el dominio, y por lo tanto no pueden iniciar sesion.

    Sin embargo, si abro la consola de Active Directory en el 2003 con el 2000 apagado, y me conecto al servidor (es decir, me debo conectar al propio equipo), veo todos los usuarios y objetos. O sea, la replicación la está haciendo, y el 2003 tiene el catalogo global.

    Qué me está faltando? Qué debo revisar?
    jueves, 1 de febrero de 2007 11:03

Todas las respuestas

  • No tengo mucha idea pero creo que deberias mirar en tus xp que si están con ip fija tengan un segundo DNS configurado (el win 2k3) y si están por DHCP, configuralo para decirle que tiene un segundo DNS
    jueves, 1 de febrero de 2007 14:23
  • Si, todos mis equipos tienen IP fija. No tengo DHCP.
    Ambos servidores tienen DNS funcionando.

    Se supone que debería usar DHCP?

    Estamos hablando de los laboratorios de una universidad, y por algun motivo la gente de Redes no me permite utilizar DHCP. De hecho, no hay ningun servidor DHCP en toda la universidad (estamos hablando de unos 2000 PCs).
    jueves, 1 de febrero de 2007 15:45
  • ¿Las carpetas Netlogon y Sysvol se ha replicado correctamente?
    jueves, 1 de febrero de 2007 18:54
  • Los puestos tienen que tener como DNS a los dos DC, no pongas DNS que no sean DCs.

    Si tienes que resolver nombres de internet, usa este tutorial para configurar los forwarders.

    http://geeks.ms/blogs/dmatey/archive/2007/01/16/basicos-configuraci-n-de-dns.aspx

    2000 pcs sin dhcp es el infierno, no se me ocurre ninguna razon para no usar DHCP y mira que he montado redes grandes.

    Un saludo

    *******************************************************************************************************************

    Colabora con el foro: Si la respuesta te es de utilidad marca la pregunta como respondida.

    *******************************************************************************************************************

    Daniel Matey.

    MVP

    MCSE, MCSA, MCSD, MCDBA.

    Blog: http://geeks.ms/blogs/dmatey

     

     

    jueves, 1 de febrero de 2007 19:14
  • Todos los equipos tienen como DNS primario al servidor 2000, y como secundario al 2003.

    Cada servidor se tiene a sí mismo como DNS primario, y al otro como secundario.

    Según me comentan en algunos foros, es necesario el DHCP para que esto funcione, aunque tenga IPs fijas. Es correcto?
    No tengo el servicio DHCP corriendo en estos momentos.
    viernes, 2 de febrero de 2007 10:00
  • Supongo que si. Por lo menos puedo ver correctamente los usuarios y objetos en la consola en el servidor 2003 cuando el otro está apagado. Eso significa que replica correctamente? En caso contrario, cómo lo reviso?
    viernes, 2 de febrero de 2007 10:01
  • Mira en el servidor con windows 2003 si existen las carpetas C:\Windows\Sysvol\sysvol y c:\Windows\SYSVOL\sysvol\nombre_dominio\SCRIPT. Y que el contenido de éstas carpetas sea el mismo que las carpetas del DC con windows 2000. Además asegurate que las tiene compartidas correctamente.

     

    viernes, 2 de febrero de 2007 13:52
  • Aparentemente tengo algun problema ahí.
    En el servidor que funciona (Windows 2000 Server), tengo los siguientes directorios en \sysvol\nombre_dominio\

    • "Policies" (sin compartir)
    • "scripts" (compartido)
    En el que no funciona (Windows 2003 Server), no tengo nada ahi. Pero existe el directorio \nombre_dominio en sysvol.

    Qué debo hacer?
    viernes, 2 de febrero de 2007 15:17
  • Tienes un problema de replicación, mira en el visor de sucesos y debe de aparecer errores referentes a FRS.

    Puedes hecharle un vistazo a :

    http://support.microsoft.com/kb/253859/en-us

    http://support.microsoft.com/kb/257338/EN-US/

    http://support.microsoft.com/kb/842162

    No se cual será el problema por el cual no se replica correctamente, habria que ver el error. Tambien puedes provar o despromocionar y posteriormente promocionar denuevo, eso si, asegurandote que todo está bien configurado como el servidor DNS.

    viernes, 2 de febrero de 2007 16:11
  • Estuve revisando y leyendo, pero no comprendi mucho esos links. Incluso hay alguno que directamente no se aplica, porque habla solo de Windows 2000.
    A mi me falta NETLOGON en el Windows 2003 solamente.
    Qué puede causar eso?
    viernes, 9 de febrero de 2007 10:50
  • Corrí dcdiag y Netdiag, y obtuve los siguientes errores:

    En dcdiag:
    Starting test: NetLogons
    Unable to connect to the NETLOGON share! (\\MATERIALES\netlogon)
    [MATERIALES] An net use or LsaPolicy operation failed with error 1203, Ning£n proveedor de red ha aceptado la ruta de acceso de la red..
    ......................... MATERIALES failed test NetLogons
    Starting test: Advertising
    Warning: DsGetDcName returned information for \\lecorbu.pocqt.ort.edu.uy, when we were trying to reach MATERIALES.
    Server is not responding or is not considered suitable.
    ......................... MATERIALES failed test Advertising

    Starting test: frsevent
    There are warning or error events within the last 24 hours after the

    SYSVOL has been shared. Failing SYSVOL replication problems may cause

    Group Policy problems.
    ......................... MATERIALES failed test frsevent


    Starting test: systemlog
    An Error Event occured. EventID: 0xC0070023
    Time Generated: 02/12/2007 07:25:22
    (Event String could not be retrieved)
    An Error Event occured. EventID: 0xC0070023
    Time Generated: 02/12/2007 08:05:40
    (Event String could not be retrieved)
    ......................... MATERIALES failed test systemlog
    En Netdiag:
    Domain membership test . . . . . . : Failed
    [WARNING] Ths system volume has not been completely replicated to the local machine. This machine is not working properly as a DC.

    Qué debería hacer?
    lunes, 12 de febrero de 2007 11:24
  • Has actualizado el esquema de windows 2000 para que sea compatible con servidores de dominio 2003?
    jueves, 15 de febrero de 2007 23:50
  • Si, ya ejecuté sin problemas el forestprep y adprep.

    Estoy escribiendo sobre este mismo caso en otro foro, y ahi está descrita la situación:

    http://www.petri.co.il/forums/showthread.php?t=13008&page=11

    Se les ocurre qué puede estar causando esto?
    lunes, 19 de febrero de 2007 13:25