none
Problema al instalar exchange 2016 RRS feed

  • Pregunta

  • Hola:

    Tengo un problema al instalar exchange 2016, resulta que tengo un dominio con fines de estudios y estamos llevando la instalación de este producto. la infraestructura estaba con un dominio de réplica por lo que al momento de intentar preparar el directorio activo para el exchange tiraba un error con schema. Esto lo solucioné despromoviendo la réplica y luego ya pude preparar mi AD, preparar mi bosque y preparar todo para la instalación. 

    Después de tener todo preparado, lo que estoy haciendo es instalar el ISO con la opción setup como administrador de dominio (es un servidor independiente del controlador de dominio). 

    En el paso 6 de 13 me aparece el siguiente error:

    Error:
    Se ha generado el siguiente error cuando se ejecutó "$error.Clear(); 
              $maxWait = New-TimeSpan -Minutes 8
              $timeout = Get-Date;
              $timeout = $timeout.Add($maxWait);
              $currTime = Get-Date;
              $successfullySetConfigDC = $false;
    
              while($currTime -le $timeout)
              {
                $setSharedCDCErrors = @();
                try
                {
                  Set-SharedConfigDC -DomainController $RoleDomainController -ErrorVariable setSharedCDCErrors -ErrorAction SilentlyContinue;
                  $successfullySetConfigDC = ($setSharedCDCErrors.Count -eq 0);
    
                  if($successfullySetConfigDC)
                  {
                    break;
                  }
                  Write-ExchangeSetupLog -Info ("An error ocurred while setting shared config DC. Error: " + $setSharedCDCErrors[0]);
                }
                catch
                {
                  Write-ExchangeSetupLog -Info ("An exception ocurred while setting shared config DC. Exception: " + $_.Exception.Message);
                }
    
                Write-ExchangeSetupLog -Info ("Waiting 30 seconds before attempting again.");
                Start-Sleep -Seconds 30;
                $currTime = Get-Date;
              }
    
              if( -not $successfullySetConfigDC)
              {
                Write-ExchangeSetupLog -Error "Unable to set shared config DC.";
              }
            ": "System.Exception: Unable to set shared config DC.
       en Microsoft.Exchange.Configuration.Tasks.Task.ThrowError(Exception exception, ErrorCategory errorCategory, Object target, String helpUrl)
       en Microsoft.Exchange.Management.Deployment.WriteExchangeSetupLog.InternalProcessRecord()
       en Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__c()
       en Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)".
    

    Alguien podrá darme una mano para saber qué estoy haciendo mal o qué adicional debo hacer en mi AD. Gracias.

    martes, 13 de junio de 2017 22:25

Todas las respuestas

  • ¿IPV6 esta desactivado?
    miércoles, 14 de junio de 2017 14:14
  • Hola, gracias por responder. De hecho, estuve viendo en varios lugares que hacen referencia a IPV6. El punto es que tanto IPV6 en el DC y en el servidor exchange se encuentran activos y hacen ping entre sí. ¿Tú crees que sea conveniente desactivar IPV6 en ambos lados para que no haya problema?
    miércoles, 14 de junio de 2017 15:05
  • Si, en algunos casos se soluciona habilitando IPV6. Prueba y nos cuentas.
    miércoles, 14 de junio de 2017 15:33
  • La verdad es que no hubo forma, desactivé IPV6 en el controlador de dominio y en el servidor de exchange y el error persistió. Ambos lo tenían activado como lo comenté y tenían el error. Tendré que levantar toda la infraestructura nuevamente.
    miércoles, 14 de junio de 2017 19:09
  • ¿En ese ambiente hubo una version de Exchange anteriormente?
    miércoles, 14 de junio de 2017 19:11
  • No, para nada. Nunca hubo Exchange. Fue la primera vez que lo iba a instalar. Voy a implementar todo nuevamente solo con IPV4 y después agregaré las IPV6 que son necesarias.

    Exactamente no veo el origen del error, y el mensaje aquel no dice nada en referencia.

    miércoles, 14 de junio de 2017 19:41