none
Lentitud perfiles Terminal Server RRS feed

  • Pregunta

  • Buenos días,

    llevamos tiempo con un problema en un servidor con Windows Server 2008 Foundation, con los perfiles de terminal server. Este servidor dispone de 5 licencias de terminal server por dispositivo. El problema basico, radica en que, despues de un tiempo, el programa que se ejecuta en terminal server se ralentiza muchisimo al abrir. Pensemos que podria ser un problema del programa sin mas, pero este, desde la cuenta de administrador, funciona perfectamente y rapido. Si borramos la cuenta de usuario, y volvemos a crearla, el programa vuelve a ejecutarse fluido y con normalidad, pero otra vez, tras un tiempo, aprox una semana, vuelve a ralentizarse. Se han revisado los permisos, y las directivas de dominio, y ninguna deberia de estar bloqueando nada. Por lo que estamos viendo, tardan mas tiempo en ralentizarse las sesiones, los usuarios que menos lo usan, y por lo que veo, cuando borras la cuenta de un usuario que le va muy lento, tiene un monton de archivos ¿temporales???, en uso en C:\Windows\SysWOW64\config\systemprofile\AppData\LocalLow\Microsoft\CryptnetUrlCache\MetaData

    con nombres aleatorios.

    Alguna idea de a que puede ser debido esto??

    Gracias por anticipado. Saudos

    lunes, 8 de octubre de 2012 8:31

Todas las respuestas

  • Hola Sico,

    Deberías revisar el tamaño de los perfiles de los usuarios. En general, los problemas de lentitud son debidos a que el tamaño de los perfiles de los usuarios crecen y alcanzan tamaños de cientos de megas. Esto, si se junta con "Perfiles roaming" amenta la lentitud.

    En tu caso, el directorio que comentas está relacionado con el caché de certificados SSL del Internet Explorer.
    Se supone que se llena porque cada usuario navega por internet y se van cacheando los certificados y CRL's de las webs visitadas.

    La ruta para cada usuario sería:
    C:\Users\username\AppData\LocalLow\Microsoft\CryptnetUrlCache

    La ruta por servidor:
    C:\Windows\System32\config\ systemprofile\AppData\LocalLow\Microsoft\CryptnetUrlCache

    Usa el comando certutil para eliminar esa información:

    certutil -urlcache * delete

    Esperamos tus comentarios.


    Un saludo,

    Tomas Hidalgo

    Colobora con el foro: Si la respuesta es de utilidad para resolver tu duda/problema, usa la opción "Marcar como repuesta". Otros usuarios con dudas similares -en un futuro- lo agradecerán.

    lunes, 8 de octubre de 2012 11:01
    Moderador
  • Buenas tardes Tomas, y gracias por responder ante todo.

    He tomado en cuenta lo que me has dicho y lo he realizado, lo unico que no tuve tiempo para conectarme, y postearte los resultados. Pero bueno, el resultado ha sido el mismo, tras borrar la cache tanto como administrador como desde las propias cuentas de los usuarios, sigue arrancando el programa exactamente igual.

    Los perfiles, son perfiles de terminal server, y solo los usan para conectarse, y ejecutar un programa, ni navegan, ni almacenan documentos, con lo cual el peso de los perfiles, en el mayor de los casos es de 8 Mb

    El unico evento que se me repite casi constantemente en el visor de sucesos es el siguiente:

    Nombre de registro:Application
    Origen:        Microsoft-Windows-User Profiles Service
    Fecha:         17/10/2012 12:04:25
    Id. del evento:1530
    Categoría de la tarea:Ninguno
    Nivel:         Advertencia
    Palabras clave:
    Usuario:       SYSTEM
    Equipo:        CENTRAL2.bolsaplast2.local
    Descripción:
    Windows detectó que otras aplicaciones o servicios siguen usando el archivo de Registro. El archivo se descargará ahora. Puede que las aplicaciones o servicios que lo usen no funcionen correctamente más adelante. 

     DETALLE - 
     1 user registry handles leaked from \Registry\User\S-1-5-21-2691779239-3792093145-782809939-1133:
    Process 268 (\Device\HarddiskVolume1\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-2691779239-3792093145-782809939-1133\Printers\DevModePerUser

    XML de evento:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Microsoft-Windows-User Profiles Service" Guid="{89B1E9F0-5AFF-44A6-9B44-0A07A7CE5845}" />
        <EventID>1530</EventID>
        <Version>0</Version>
        <Level>3</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2012-10-17T11:04:25.904793300Z" />
        <EventRecordID>14362</EventRecordID>
        <Correlation />
        <Execution ProcessID="964" ThreadID="976" />
        <Channel>Application</Channel>
        <Computer>CENTRAL2.bolsaplast2.local</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData Name="EVENT_HIVE_LEAK">
        <Data Name="Detail">1 user registry handles leaked from \Registry\User\S-1-5-21-2691779239-3792093145-782809939-1133:
    Process 268 (\Device\HarddiskVolume1\Windows\System32\svchost.exe) has opened key \REGISTRY\USER\S-1-5-21-2691779239-3792093145-782809939-1133\Printers\DevModePerUser
    </Data>
      </EventData>
    </Event>

    Al final, tome la determinacion al dia siguiente de arrancar el post, de renombrar el ntuser.dat de los usuarios a .man, y parece, que desde entonces, lo que antes se ralentizaba al al abrir el programa varios minutos, ahora solo se ralentiza cuestion de unos 20 sg. Pero bueno, esto no es solucion, ya que tengo miedo, que como pasaba antes, con el tiempo se acabe ralentizando mas.

    

    miércoles, 17 de octubre de 2012 11:29