none
versiones .Net RRS feed

  • Pregunta

  •  

    Hola,

     

    Me gustaría saber como resuelven uds. que versiones de .net Framwork mantener, quiero decir; si sale la versión 3 quito la 2, si sale la 4 quitio la tres? es decir mantengo todas según salgan las instalo y a correr o voy quitando la versión anterior?

    Muchas gracias

    martes, 30 de septiembre de 2008 7:33

Respuestas

  • Son versiones "acumulativas", esto es, que si instalas la 3.0, te instalará la 2.0 y la 1.1. Lo mismo con la 3.5

     

    Por tanto, no has de instalar/tocar nada.

     

    martes, 30 de septiembre de 2008 19:48
    Moderador
  • Veamos, hasta ahora hay cinco versiones publicadas (sin contar service packs) de lo que se ha dado en llamar Microsoft .NET Framework: 1.0, 1.1, 2.0, 3.0 y 3.5. Las versiones 1.0, 1.1 y 2.0 son independientes entre sí; cada versión intenta mantener la compatibilidad con la anterior, aunque en algunos casos es inevitable algún cambio que rompe la compatibilidad en algún aspecto (breaking change). Por otro lado, .NET 2.0 es un requisito indispensable de .NET 3.0 y éste lo es a su vez de .NET 3.5. Dicho de otro modo: las versiones 3.5 y 3.0 no son versiones independientes sino "capas" añadidas sobre el entorno de ejecución de .NET 2.0.

    Expuesto lo anterior, se supone que solamente nos harían falta .NET 2.0, .NET 3.0 y .NET 3.5, pues la mayor parte de las aplicaciones diseñadas para .NET 1.0 y .NET 1.1 funciona perfectamente sobre .NET 2.0. Instalar .NET 1.1 tampoco haría mucho mal (la versión 1.0 puede considerarse obsoleta), pero he observado algunos comentarios de problemas de instalación y actualización sobre todo en Windows Vista; sugiero precaución. Ojo: .NET 1.1 es componente integral de Windows Server 2003, mientras que .NET 2.0 y .NET 3.0 lo son de Windows Vista y Windows Server 2008.

    Desconozco los detalles de la futura versión 4.0.

    jueves, 9 de octubre de 2008 3:56

Todas las respuestas

  • Son versiones "acumulativas", esto es, que si instalas la 3.0, te instalará la 2.0 y la 1.1. Lo mismo con la 3.5

     

    Por tanto, no has de instalar/tocar nada.

     

    martes, 30 de septiembre de 2008 19:48
    Moderador
  • Veamos, hasta ahora hay cinco versiones publicadas (sin contar service packs) de lo que se ha dado en llamar Microsoft .NET Framework: 1.0, 1.1, 2.0, 3.0 y 3.5. Las versiones 1.0, 1.1 y 2.0 son independientes entre sí; cada versión intenta mantener la compatibilidad con la anterior, aunque en algunos casos es inevitable algún cambio que rompe la compatibilidad en algún aspecto (breaking change). Por otro lado, .NET 2.0 es un requisito indispensable de .NET 3.0 y éste lo es a su vez de .NET 3.5. Dicho de otro modo: las versiones 3.5 y 3.0 no son versiones independientes sino "capas" añadidas sobre el entorno de ejecución de .NET 2.0.

    Expuesto lo anterior, se supone que solamente nos harían falta .NET 2.0, .NET 3.0 y .NET 3.5, pues la mayor parte de las aplicaciones diseñadas para .NET 1.0 y .NET 1.1 funciona perfectamente sobre .NET 2.0. Instalar .NET 1.1 tampoco haría mucho mal (la versión 1.0 puede considerarse obsoleta), pero he observado algunos comentarios de problemas de instalación y actualización sobre todo en Windows Vista; sugiero precaución. Ojo: .NET 1.1 es componente integral de Windows Server 2003, mientras que .NET 2.0 y .NET 3.0 lo son de Windows Vista y Windows Server 2008.

    Desconozco los detalles de la futura versión 4.0.

    jueves, 9 de octubre de 2008 3:56