none
La opción conectar usando http en Microsoft Outlook se activa sola RRS feed

  • Pregunta

  • Hola,

    Tengo un problema desde principios de año y sospecho que fué a raiz de una actualización. Tengo un Exchange 2007 y el Outlook siempre pide contraseña al acceder. Despues de leer y probar de todo he visto que la opción de conectarse usando http (en la configuración de la cuenta) se activa sola y al activarse es cuando pide contraseña. Si está desactivada no pide contraseña. Lo que pasa es que la desactivo, entro en Outlook y al salir se vuelve a activar ¿Alguien sabe como puedo hacer que no se active esta opción?

    Gracias!

    jueves, 19 de mayo de 2011 9:46

Respuestas

Todas las respuestas

  • Tienes habilitado y correctamente configurado el Outlook Anywhere en el servidor de Exchange?
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    jueves, 19 de mayo de 2011 10:07
    Moderador
  • Si y funciona perfectamente desde fuera de la oficina. Pero no acabo de entender porque la opción de conectar por http se activa automáticamente en el Outlook...
    jueves, 19 de mayo de 2011 10:45
  • Esa opción la habilita el Autodiscover cuando Outlook se autoconfigura la cuenta de usuario en el primer inicio del programa y cada vez que refresca la configuración.

    La contraseña la suele pedir cuando el campo "msstd" que Outlook configura no coincide con el del certificado SSL que tienes publicado en Internet.


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    jueves, 19 de mayo de 2011 10:52
    Moderador
  • Si, pero la opción donde está el msstd puedes desmarcarla para que no haga falta que coincida con el certificado. Yo la desmarco. De todas formas el OUtlook anywhere está funcionando bien con lo que no creo que sea problema del certificado...
    jueves, 19 de mayo de 2011 11:21
  • Haz una prueba de autoconfiguración desde Outlook (crtl + botón derecho sobre el icono de Outlook de la Barra de tareas de Windows) y dinos qué canta.

    Y ejecuta este cmdlet "Get-OutlookProvider" y pon por aquí el resultado.

    También revisa que no tengas configurado el pedir password, http://www.petri.co.il/configure_outlook_xp_2003_2007_to_prompt_for_a_password.htm


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    jueves, 19 de mayo de 2011 11:35
    Moderador
  • Te paso lo que sale en un Outlook que pide la contraseña constantemente y le desactivo la conexión por https y se vuelve a activar sola:

    Display Name: Inma

    Protocol: Exchange RPC

    Server: exchangeDB.midominio.com

    Login Name: Inma

    Availability Service URL: https://exchangeCAS.midominio.com/EWS/Exchange.asmx

    OOF URL: https://exchangeCAS.midominio.com/EWS/Exchange.asmx

    OAB URL: Public Folder

    Unified Message Service URL: https://exchangeCAS.midominio.com/UnifiedMessaging/Service.asmx

    Auth Package: Unspecified

    Protocol Exchange HTTP

    Server: mail.midominio.es

    Login: Inma

    SSL: yes

    Mutual Authentication: yes

    OAB URL: Public Folder

    Auth Package: Basic

    Certificate Principal Name: msstd:mail.midominio.es

    --------------------------------

    Esto mismo lo hago con un Outlook que no pide contraseña y el resultado es que autoconfiguation was unable to determine your settings.

    Te paso también lo que sale con el comando Get-OutlookProvider:

    Name EXCH Server mail.midominio.es TTL 1

    Name EXPR Server en blanco y TTL 1

    Name WEB Server mail.midominio.es TTL 1

    Saludos y grácias por todo!!

    jueves, 19 de mayo de 2011 15:24
  • Ok.

    Si yo hago lo mismo en mi equipo (estoy usando Outlook Anywhere y estoy fuera de mi oficina) me sale:

    --------------------------

    Display Name: Marc

    Protocol: Exchange RPC

    Server: serverMBX.midominio.net

    Login Name: mss

    Availability Service URL: https://autodiscover.midominio.net/EWS/Exchange.asmx

    OOF URL: https://autodiscover.midominio.net/EWS/Exchange.asmx

    OAB URL: https://autodiscover.midominio.net/OAB/64291ef3-64a3-42cf-aa8a-c8bb37088d5f/

    Unified Message Service URL: https://autodiscover.midominio.net/UnifiedMessaging/Service.asmx

    Auth Package: Unspecified

    Protocol Exchange HTTP

    Server: mail.midominio.net

    Login: mss

    SSL: yes

    Mutual Authentication: yes

    Availability Service URL: https://autodiscover.midominio.net/EWS/Exchange.asmx

    OAB URL: https://autodiscover.midominio.net/OAB/64291ef3-64a3-42cf-aa8a-c8bb37088d5f/

    Auth Package: Basic

    Certificate Principal Name: msstd:mail.midominio.net

    -----------------

    Como puedes ver, tenemos definido el valor "autodiscover" tanto en la parte pública como la privada y, creo, que es lo que te falta/falla en tu configuracion porque dices que los PCs que no piden contraseña no son capaces de localizar el Exchange de modo automático.

    Revisa esto: http://technet.microsoft.com/en-us/library/bb232838(EXCHG.80).aspx


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    • Propuesto como respuesta Ismael Borche viernes, 20 de mayo de 2011 18:19
    • Marcado como respuesta Ismael Borche lunes, 6 de junio de 2011 22:54
    jueves, 19 de mayo de 2011 15:44
    Moderador
  • Gracias de nuevo por contestar.

    No creo que vaya por ahi la cosa, eso se define en la configuración del CAS. Yo lo tengo definido de otra forma pero que funciona igual (siguen habiendo Outlooks que funciona bien, pocos pero algunos, como el mio que no me pide contraseña nunca). De hecho el mio es de los pocos que no se activa automaticamente la conexión por hhtps y por eso creo que no pide contraseña... ¿porque? no tengo ni idea y me estoy volviendo loco :( 

    La prueba está en que hasta hace unos meses funcionaba perfectamente sin pedir contraseña y ahora la gran mayoria de Outlooks pide contraseña al acceder.

    Una pregunta, tu cuando estás con el anywhere fuera de la oficina, al abrir el Outlook te pide contraseña?

    Gracias de nuevo.

    lunes, 23 de mayo de 2011 11:17
  • Una pregunta, tu cuando estás con el anywhere fuera de la oficina, al abrir el Outlook te pide contraseña?


    No, no me la pide.
    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    lunes, 23 de mayo de 2011 11:21
    Moderador
  • mmm eso me lia aun más, porque el Outlook anywhere siempre me ha pedido contraseña desde fuera, incluso cuando en la oficina el Outlook no pedia contraseña y funcionaba correctamente.

    ¿En Outlook, en la configuración de la cuenta, la url del anywhere tienes mail.midominio.com o autodiscover.midominio.com?

    lunes, 23 de mayo de 2011 11:51
  • Tengo https://mail.midominio.net

    El autodiscover es un alias del nombre del servidor "servermail.corp.midominio.net" para la resolución interna y "servermail.midominio.net" para la externa


    Saludos,

    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator (Windows Server 2008)
    MCITP: Enterprise Messaging Administrator (Microsoft Exchange 2007 & Exchange 2010)
    MCC: Microsoft Community Contributor 2011
    Citrix CCA
    lunes, 23 de mayo de 2011 14:12
    Moderador