locked
windows installer deja de funcionar RRS feed

  • Pregunta

  • buenos dias, he ido a instalar actualizacion de openofficce y me sale la leyenda de windows installer ha dejado de funcionar. ¿alguein sabe como lo puedo hacer?

     

     

    domingo, 24 de agosto de 2008 17:21

Respuestas

  • Lanza la instalación con boton derecho sobre ella y "Ejecutar como Administrador". Se necesitan permisos de Administrador para instalar y aunque seas Administrador, en Vista, no se tienen todos los privilegios de instalacion y hay que "subirse" los atributos en algun caso. Lo normal es que no haya que hacerlo y salga una pantalla pidiendote permiso, pero en ciertos caso y con ciertas actualizaciones es necesario forzarlo de esa manera.

    Un saludo,
    domingo, 24 de agosto de 2008 17:24
  • Tambien te habria fucnionado pero no es aconsejable y es de osados el tenerlo desactivado.

    El UAC es el User accoint Control, o Control de cuentas de Usuario que en Vista viene preactivado pero puede desactivarse en Panel de Control, Cuentas de usuario.

    La desactivacion conlleva que realmente tengas todos los permisos administrativos y por tanto no te saldrá nunca la pantalla de elevacion de privilegios al hacer cosas cosas que lo requieren, pero por contra, por ejemplo, el IE no podrá estar en modo protegido que es el funcionamiento normal, y puede ser un gran coladero de bichos al navegar. 

    Desde luego, es de locos estar sin esa proteccion (que es la minima), siendo todavia mejor consejo, el que no uses, excepto para instalar o configurar, ningun usuario Administrador y que se intente usar para todo usuarios limitados. Recordemos que los bichos se ejecutan con los permisos del usuario en ese momento y si es un usuario limitado, poco o nada podrá hacer.

    Un saludo,
    domingo, 24 de agosto de 2008 17:34

  • Un saludo,
    domingo, 24 de agosto de 2008 17:46

Todas las respuestas

  • Lanza la instalación con boton derecho sobre ella y "Ejecutar como Administrador". Se necesitan permisos de Administrador para instalar y aunque seas Administrador, en Vista, no se tienen todos los privilegios de instalacion y hay que "subirse" los atributos en algun caso. Lo normal es que no haya que hacerlo y salga una pantalla pidiendote permiso, pero en ciertos caso y con ciertas actualizaciones es necesario forzarlo de esa manera.

    Un saludo,
    domingo, 24 de agosto de 2008 17:24
  • gracias por la rapidez. ahora lo intento.

     

    otra cosa, me habian dicho que desactivase el UAC. q es eso?

     

     

     

    domingo, 24 de agosto de 2008 17:29
  • Tambien te habria fucnionado pero no es aconsejable y es de osados el tenerlo desactivado.

    El UAC es el User accoint Control, o Control de cuentas de Usuario que en Vista viene preactivado pero puede desactivarse en Panel de Control, Cuentas de usuario.

    La desactivacion conlleva que realmente tengas todos los permisos administrativos y por tanto no te saldrá nunca la pantalla de elevacion de privilegios al hacer cosas cosas que lo requieren, pero por contra, por ejemplo, el IE no podrá estar en modo protegido que es el funcionamiento normal, y puede ser un gran coladero de bichos al navegar. 

    Desde luego, es de locos estar sin esa proteccion (que es la minima), siendo todavia mejor consejo, el que no uses, excepto para instalar o configurar, ningun usuario Administrador y que se intente usar para todo usuarios limitados. Recordemos que los bichos se ejecutan con los permisos del usuario en ese momento y si es un usuario limitado, poco o nada podrá hacer.

    Un saludo,
    domingo, 24 de agosto de 2008 17:34
  • gracias: ya está actualizado.

     

    y el consejo que me has dado del UAC me parece sensato con lo que me has dicho y me parece insensato lo que me habian aconsejado.

     

    domingo, 24 de agosto de 2008 17:45

  • Un saludo,
    domingo, 24 de agosto de 2008 17:46