locked
Outlook no conecta con Exchange 2013 despues de migrar desde Exchage 2007 RRS feed

  • Pregunta

  • <style type="text/css">P { margin-bottom: 0.21cm; }A:link { }</style>

    Hola,

    recientemente hemos echo una migración de Exchange 2007 SP3 a Exchange 2013 SP1. Los usuarios pueden conectar por OWA a sus buzones sin problemas y también pueden conectar desde su iphone con el cliente que este lleva.

    El problema es que no pueden conectar desde Outlook (2010, 2013), ni internamente ni externamente, siempre da el error de La conexión a Exchange no se encuentra disponible...

    Para intentar solucionarlo hemos echo lo siguiente tras buscar en google:

    - Revisar la configuración de Outlook Anywhere en el EAC, esta configurado con una dirección externa mail.empresa.com y una interna tipo servidor.dominio.local. La seguridad esta por defecto en Negociación, aunque la hemos probado de todas formas.

    - Revisar el dns interno: en el dns interno hay registros para mail.empresa.com y servidordeexchange.dominio.local apuntando a la ip local del servidor de exchange. También hay una zona publica empresa.com con mail.empresa.com apuntando al servidor local. También hemos creado entradas Autodiscover.empresa.com y Autodiscover.dominio.local apuntando al exchange interno.

    En el dns de nuestro proveedor de dominio esta la entrada host A apuntando a mail.empresa.com. No tenemos ninguna tipo Autodiscover.empresa.com pero entendemos que aunque no valla el autodiscover si que debe ir la conexión.

    - Revisar certificado: hemos creado un nuevo certificado self-signed incluyendo todos estos dominios externos e internos y para todos los servicios.

    -Revisar bloqueo de OutlookAnywhere: hemos revisado que este servicio no estuviese bloqueado.

    Estado de los servidores:

    - El servidor antiguo de Exchange 2007 en estos momentos no arranca, estaba en muy mal estado y tras conseguir pasar los buzones al nuevo intentamos desinstalarlo, nos dio un error sobre la replicación de las carpetas publicas (aunque era algo que no se utilizaba ni se habían creado ningunas) conseguimos quitar todos los roles desde el desinstalador menos el de Buzón. Ahora no arranca.

    - El servidor de Exchange 2013 aparece con todo correcto y no hay ningún rastro del servidor antiguo, o que nosotros hallamos visto ni en el EAC ni en el shell.

    Os pego abajo el resultado de la herramienta Remote conectivity analaizer de Microsoft, probando el Outlook Anywhere. Queda claro que no puede conectar.

    Por el momento seguimos investigando pero no damos con la solución. Gracias de antemano por la ayuda.

    Saludos!

    Probando la conectividad RPC/HTTP.

    Error en la prueba de RPC/HTTP.

    Detalles adicionales

    Tiempo transcurrido: 24295 ms.

    Pasos de la prueba

    El Analizador de conectividad de Microsoft está intentando probar Detección automática para test1@empresa.com.

    Error en la prueba de detección automática.

    Detalles adicionales

    Tiempo transcurrido: 24294 ms.

    Pasos de la prueba

    Intentando cada método de contacto con el servicio de detección automática.

    No se pudo contactar correctamente con el servicio de detección automática mediante todos los métodos.

    Detalles adicionales

    Tiempo transcurrido: 24294 ms.

    Pasos de la prueba

    Intentando probar posible URL de detección automática https://empresa.com/AutoDiscover/AutoDiscover.xml

    Error en la prueba de esta posible URL de detección automática.

    Detalles adicionales

    Tiempo transcurrido: 1509 ms.

    Pasos de la prueba

    Intentando resolver el nombre de host empresa.com en DNS.

    Se resolvió el nombre de host correctamente.

    Detalles adicionales

    Direcciones IP devueltas: 80.36.252.194

    Tiempo transcurrido: 507 ms.

    Probando el puerto TCP 443 en el host empresa.com para garantizar que escucha o está abierto.

    El puerto se abrió correctamente.

    Detalles adicionales

    Tiempo transcurrido: 464 ms.

    Probando el certificado SSL para asegurarse de que es válido.

    El certificado SSL no superó una o más comprobaciones de validación de certificados.

    Detalles adicionales

    Tiempo transcurrido: 537 ms.

    Pasos de la prueba

    El Analizador de conectividad de Microsoft está intentando obtener el certificado SSL del servidor remoto empresa.com en el puerto 443.

    El Analizador de conectividad de Microsoft obtuvo correctamente el certificado SSL remoto.

    Detalles adicionales

    Sujeto de certificado remoto: CN=mail.empresa.com, emisor: CN=mail.empresa.com.

    Tiempo transcurrido: 454 ms.

    Validando el nombre del certificado.

    Se validó correctamente el nombre del certificado.

    Detalles adicionales

    Se encontró el nombre de host empresa.com en la entrada del nombre alternativo del asunto del certificado.

    Tiempo transcurrido: 1 ms.

    Se está validando el certificado de confianza.

    Error de validación de certificado de confianza.

    Pasos de la prueba

    El Analizador de conectividad de Microsoft está intentando generar cadenas de certificados para el certificado CN=mail.empresa.com.

    No se pudo construir una cadena de certificados para el certificado.

    Quiero saber más sobre este problema y cómo resolverlo

    Detalles adicionales

    La cadena de certificados no terminó en una raíz de confianza. Raíz = CN=mail.empresa.com

    Tiempo transcurrido: 31 ms.

    Intentando probar posible URL de detección automática https://autodiscover.empresa.com/AutoDiscover/AutoDiscover.xml

    Error en la prueba de esta posible URL de detección automática.

    Detalles adicionales

    Tiempo transcurrido: 21723 ms.

    Pasos de la prueba

    Intentando resolver el nombre de host autodiscover.empresa.com en DNS.

    Se resolvió el nombre de host correctamente.

    Detalles adicionales

    Direcciones IP devueltas: 46.16.56.40

    Tiempo transcurrido: 498 ms.

    Probando el puerto TCP 443 en el host autodiscover.empresa.com para garantizar que escucha o está abierto.

    El puerto especificado está bloqueado, no escucha o no genera la respuesta esperada.

    Quiero saber más sobre este problema y cómo resolverlo

    Detalles adicionales

    Error de red al comunicarse con el host remoto.

    Tiempo transcurrido: 21224 ms.

    Intentando contactar al servicio de detección automática con el método de redireccionamiento HTTP.

    Error al tratar de contactar con la detección automática con el método de redirección de HTTP.

    Detalles adicionales

    Tiempo transcurrido: 606 ms.

    Pasos de la prueba

    Intentando resolver el nombre de host autodiscover.empresa.com en DNS.

    Se resolvió el nombre de host correctamente.

    Detalles adicionales

    Direcciones IP devueltas: 46.16.56.40

    Tiempo transcurrido: 14 ms.

    Probando el puerto TCP 80 en el host autodiscover.empresa.com para garantizar que escucha o está abierto.

    El puerto se abrió correctamente.

    Detalles adicionales

    Tiempo transcurrido: 202 ms.

    El Analizador de conectividad de Microsoft está comprobando la detección automática del host empresa.com para un redireccionamiento HTTP al servicio Detección automática.

    El Analizador de conectividad de Microsoft no pudo obtener una respuesta de redireccionamiento HTTP para Detección automática.

    Detalles adicionales

    Se produjo una excepción de Web porque se recibió una respuesta HTTP 404 - NotFound de Unknown. Encabezados recibidos: Connection: close Content-Length: 1209 Content-Type: text/html Date: Wed, 12 Mar 2014 15:27:58 GMT Server: Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch X-Powered-By: PHP/5.2.6-1+lenny3 Encabezados de respuesta HTTP: Connection: close Content-Length: 1209 Content-Type: text/html Date: Wed, 12 Mar 2014 15:27:58 GMT Server: Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny3 with Suhosin-Patch X-Powered-By: PHP/5.2.6-1+lenny3

    Tiempo transcurrido: 388 ms.

    Intentando contactar con el servicio de detección automática con el método de redireccionamiento del servidor DNS SRV.

    El Analizador de conectividad de Microsoft no pudo contactar con el servicio Detección automática mediante el método de redireccionamiento DNS SRV.

    Detalles adicionales

    Tiempo transcurrido: 186 ms.

    Pasos de la prueba

    Intentando encontrar el registro SRV _autodiscover._tcp.empresa.com en DNS.

    No se encontró el registro SRV de detección automática en DNS.

    Quiero saber más sobre este problema y cómo resolverlo

    Detalles adicionales

    Tiempo transcurrido: 186 ms.

    Comprobando si hay un registro CNAME de detección automática en DNS para su dominio "empresa.com" para Office 365.

    No se pudo validar el registro CNAME de detección automática en DNS. Si su buzón de correo no está en Office 365, puede ignorar esta advertencia.

    Quiero saber más sobre este problema y cómo resolverlo

    Detalles adicionales

    No hay ningún registro CNAME de detección automática para su dominio 'empresa.com'.

    Tiempo transcurrido: 268 ms.


    jspt

    miércoles, 12 de marzo de 2014 15:33

Respuestas

  • Hola JS,

    En muchas ocasiones al migrar usuarios no se migran algunos permisos. Podrias como prueba:

    1. 1)irte a AD users & Computers
    2. 2)Buscar un usuario de prueba
    3. 3)click derecho e irte a propiedades
    4. 4)irte a seguridad e irte a las opciones avanzadas
    5. 5)habilitar la herencia de permisos

    Saludos 

    • Marcado como respuesta Uriel Almendra martes, 18 de marzo de 2014 16:01
    martes, 18 de marzo de 2014 2:55

Todas las respuestas

  • Hola JS,

    En muchas ocasiones al migrar usuarios no se migran algunos permisos. Podrias como prueba:

    1. 1)irte a AD users & Computers
    2. 2)Buscar un usuario de prueba
    3. 3)click derecho e irte a propiedades
    4. 4)irte a seguridad e irte a las opciones avanzadas
    5. 5)habilitar la herencia de permisos

    Saludos 

    • Marcado como respuesta Uriel Almendra martes, 18 de marzo de 2014 16:01
    martes, 18 de marzo de 2014 2:55
  • Hola, al final dieron con el problema?
    lunes, 15 de diciembre de 2014 6:55