none
Acceso denegado a unidad de red desde Internet Explorer RRS feed

  • Pregunta

  • Hola, buenos días.

    Tengo un problema en un servidor con Server 2008 R2.

    Los usuarios se conectan por terminal server y todos tienen una unidad de red creada que da la casualidad que apunta al mismo servidor debido a que es un requisito imprescindible para una aplicación.

    La carpeta donde apunta la unidad de red está compartida para todos y todos los usuarios pueden acceder a ella sin problemas y ejecutar la aplicación correctamente.

    El problema viene cuando se intenta acceder a ficheros ubicados en dicha unidad desde el navegador. Cuando se abre la ventana de buscar el fichero, pinchas en la unidad y da error de ubicación no disponible y acceso denegado.

    No me sirve buscar el fichero por su ruta absoluta, ya que ciertas páginas, tal y como las de hacienda, requieren que el fichero esté en una carpeta que cuelgue del raíz, de ahí que si funcione cuando dicha carpeta está en la unidad de red (y cuando no da el error).

    ¿Alguien sabe como solucionar esto?

    Gracias.

    P.D.: probado con IE 9, 10 y 11.

    martes, 14 de enero de 2014 12:11

Respuestas

  • Hola:

            Creo que puedo aportar algo al respecto, espero que no sea tarde para echar un cable.

             Recientemente me he topado con las implicaciones que tiene eliminar el botón "ejecutar" del menú de inicio. Esto provoca que desde internet explorer no se puedan hacer accesos basados en rutas UNC o basadas en mapeos de red. De momento es innegable que eliminar el botón vía política provoca ese efecto, pero sospecho que si no lo haces por política si no que lo haces en un perfil que luego usas para maquetar una imagen también ocurre igual. Esto me resulta más complicado de demostrar en estos instantes, pues antes tengo que generar una imagen sin esa caracterísitca para demostrarlo, pero por las pruebas que he hecho todo apunta a que es tal y como lo cuento y si, para mi también es un gran problema a día de hoy:(

            No es un tema de permisos porque desde explorer si se pueude acceder.

             En cuanto a la política, la propia descripción de la política desde la consola de las GPOs lo explica. Si editas una política y vas a la siguiente seccion (user configuration, administrative templates, start menu and taskbar, remove run menu from start menu) se indica lo que pego a continuación:

    "Allows you to remove the Run command from the Start menu, Internet Explorer, and Task Manager.

    If you enable this setting, the following changes occur:

    (1) The Run command is removed from the Start menu.

    (2) The New Task (Run) command is removed from Task Manager.

    (3) The user will be blocked from entering the following into the Internet Explorer Address Bar:

    --- A UNC path: \\<server>\<share>

    ---Accessing local drives:  e.g., C:

    --- Accessing local folders: e.g., \temp>

    Also, users with extended keyboards will no longer be able to display the Run dialog box by pressing the Application key (the key with the Windows logo) + R.

    If you disable or do not configure this setting, users will be able to access the Run command in the Start menu and in Task Manager and use the Internet Explorer Address Bar.



    Note:This setting affects the specified interface only. It does not prevent users from using other methods to run programs.

    Note: It is a requirement for third-party applications with Windows 2000 or later certification to adhere to this setting"

         Si saco tiempo para confirmar el mismo efecto configurando un perfil para maquetar una imagen os lo comentaré aquí.

    Ánimo

     

     

      

      

    • Propuesto como respuesta GuilleGo viernes, 3 de octubre de 2014 10:00
    • Marcado como respuesta Moderador M martes, 7 de octubre de 2014 14:55
    jueves, 18 de septiembre de 2014 10:35

Todas las respuestas

  • Hola Murray,

    Cuando creas una carpeta compartida, hay 2 lugares donde tienes que aplicar los permisos:

    1. Carpeta --> Propiedades --> Compartir --> Compartir Esta Carpeta --> Permisos --> "Todos" tiene que tener "Control Total".

    2. Carpeta --> Propiedades --> Seguridad --> tu "grupo de usuarios" debe tener al acceso necesario. Ejem: Lectura y Ejecución -- Modificar, etc.

    Checa esos 2 lugares para ver que estén bien configurados. 

    Saludos!


    Ricardo Fuentes

    miércoles, 15 de enero de 2014 6:40
  • Eso está comprobado. Si no estuviera correctamente compartida, los usuarios no podrían ejecutar la aplicación. Es simplemente cuando una web accedida con Internet Explorer solicita un fichero de esa unidad de red. Entonces da error de ubicación no disponible y acceso denegado. Teniendo ese error en pantalla, te vas a mi pc, pinchas en la unidad de red y puedes acceder, modificar, borrar ficheros perfectamente.
    miércoles, 15 de enero de 2014 9:29
  • La web de la que hablas, es una web de Internet o una web local para tus usuarios en tu Red de Area Local?

    Si es lo segundo, entonces el IIS de la applicacion web no esta apropiadamente configurado y necesita una cuenta que tenga permisos suficientes al fichero.  

    Saludos!


    Ricardo Fuentes

    miércoles, 15 de enero de 2014 14:06
  • Yo tambien tengo este problema y no se como solucionarlo, para arrojar algo de luz, en google chrome funciona bien, pero en internet explorer no. Ademas solo funciona con algunos enlaces no en todos, por lo que es algo muy raro.
    jueves, 3 de julio de 2014 12:32
  • Hola, MurrayLCD:

    Lo primero sería conocer qué dice exactamente el Visor de Sucesos, referente al error que señalas.. y lo segundo sería averiguar si se trata de un aplicativo que se ejecuta en LAN o por el contrario, desde WWW (y/o requiere algún control ActiveX para ejecutarse correctamente).
    Asimismo, es MUY importante conocer si se requiere algún tipo de certificado digital emitido por tu CA (o de terceros) para tener acceso a todos los recursos del aplicativo web, por no mencionar los permisos NTFS y SHARED de los recursos compartidos para el usuario (que te recomiendo coincidan).

    Mi recomendación es que establezcas las unidades de red por GPO a nivel de dominio. Crea todas las carpetas compartidas como recursos de red en la consola DSA.msc del DC y asígnalas a los usuarios en función a la OU/grupo de seguridad a los que pertenezcan. Por lo general, con habilitar en ambos casos "Modificar, Leer & ejecutar, Listar contenidos, Lectura y Escritura" es suficiente.. pero sólo en Grupos!!!


    Desiderio Ondo | Bachellor Science in Computer engineering | MCSE certified | ITIL certified | Exchange mailing certified

    • Propuesto como respuesta Desiderio Ondo viernes, 4 de julio de 2014 18:58
    viernes, 4 de julio de 2014 18:58
  • El IE no es buscar archivos de esa forma. En el Explorador, el de las carpetitas y archivos, permite mapear por ejemplo  T:  \\server\shared esa via debes usar porque el puerto del SMB por defecto te da paso.
    sábado, 5 de julio de 2014 15:17
  • Hola:

            Creo que puedo aportar algo al respecto, espero que no sea tarde para echar un cable.

             Recientemente me he topado con las implicaciones que tiene eliminar el botón "ejecutar" del menú de inicio. Esto provoca que desde internet explorer no se puedan hacer accesos basados en rutas UNC o basadas en mapeos de red. De momento es innegable que eliminar el botón vía política provoca ese efecto, pero sospecho que si no lo haces por política si no que lo haces en un perfil que luego usas para maquetar una imagen también ocurre igual. Esto me resulta más complicado de demostrar en estos instantes, pues antes tengo que generar una imagen sin esa caracterísitca para demostrarlo, pero por las pruebas que he hecho todo apunta a que es tal y como lo cuento y si, para mi también es un gran problema a día de hoy:(

            No es un tema de permisos porque desde explorer si se pueude acceder.

             En cuanto a la política, la propia descripción de la política desde la consola de las GPOs lo explica. Si editas una política y vas a la siguiente seccion (user configuration, administrative templates, start menu and taskbar, remove run menu from start menu) se indica lo que pego a continuación:

    "Allows you to remove the Run command from the Start menu, Internet Explorer, and Task Manager.

    If you enable this setting, the following changes occur:

    (1) The Run command is removed from the Start menu.

    (2) The New Task (Run) command is removed from Task Manager.

    (3) The user will be blocked from entering the following into the Internet Explorer Address Bar:

    --- A UNC path: \\<server>\<share>

    ---Accessing local drives:  e.g., C:

    --- Accessing local folders: e.g., \temp>

    Also, users with extended keyboards will no longer be able to display the Run dialog box by pressing the Application key (the key with the Windows logo) + R.

    If you disable or do not configure this setting, users will be able to access the Run command in the Start menu and in Task Manager and use the Internet Explorer Address Bar.



    Note:This setting affects the specified interface only. It does not prevent users from using other methods to run programs.

    Note: It is a requirement for third-party applications with Windows 2000 or later certification to adhere to this setting"

         Si saco tiempo para confirmar el mismo efecto configurando un perfil para maquetar una imagen os lo comentaré aquí.

    Ánimo

     

     

      

      

    • Propuesto como respuesta GuilleGo viernes, 3 de octubre de 2014 10:00
    • Marcado como respuesta Moderador M martes, 7 de octubre de 2014 14:55
    jueves, 18 de septiembre de 2014 10:35