none
Ayuda con Contar valores repetidos según el numero de formulario RRS feed

  • Pregunta

  • Saludos. 

    Mi problema es el siguiente:

    Necesito programar una base de datos para generar un informe resumen, pero debido a que lleva una gran cantidad de hojas (más de 50), no puedo insertar una tabla dinámica en cada hoja porque haría el archivo inmanejable.

    Necesito contar la cantidad de formularios distintos que hay en la base de datos, esto ya lo hice, de estos formularios necesito saber, de acuerdo a cada categoría, cuantas "No Conforme" hay, pero separados por numero de formulario.

    Probé con la función =CONTAR.SI(D5:D33;"No Conforme") pero el problema que tengo es que me cuenta todos los no conforme que hay, pero hay formularios que se repiten varias veces en la base de datos y de estos necesito saber cuantos hay de cada uno.

    No se si me logro explicar bien.

    Lo que necesito es que la formula me diga, por ejemplo, cuantos formularios 153 tienen "No conforme" en Maquinaria y equipo, cuantos en personal, cuantos en inventario y así sucesivamente.

    Adjunto el archivo de ejemplo para una idea mas clara.

    https://www.dropbox.com/s/rcdlsx2h2z1abu3/ejemplo.xlsx?dl=0

    Gracias por su tiempo.
    viernes, 23 de octubre de 2015 15:22

Todas las respuestas

  • Hola Forgius, contar.si no vale para este tipo de problemas, prueba con contar.si.conjunto.

    He puesto esta fórmula en la celda K5:

    =CONTAR.SI.CONJUNTO($C$5:$C$26;$J5;D$5:D$26;"No Conforme")

    Atención porque yo utilizo el ";" como separador de fórmulas si el tuyo es la "," lo has de cambiar.

    Arrastras para copiar hacia la derecha y hacia abajo y tendrás todos los resultados.

    Xavier

    viernes, 23 de octubre de 2015 19:22