locked
Autodiscover y Outlook Anywhere RRS feed

  • Pregunta

  • Hola,

    tengo una infraestructura de Exchange2007 sp2  montada para 2000 usuarios, la configuración es:

    2 servers HUB/CAS en NLB

    4 servers de Mailbox

     

    por un tema de puertos cerrados, el Autodiscover no funciona en la red LAN y solo funciona desde internet, pero resuelve el nombre DNS de los servidores exchange e intenta realizar la configuracion, y al haber puertos cerrados no puede.

    ¿hay alguna manera de decirle al Autodiscover que siempre vaya por internet y que no intente realizar la configuracion via LAN?

    otra duda:

     Tengo habilitado Outlook Anywhere.

    Lo que quiero saber es si hay alguna posibilidad a la hora de configurar Outlook 2007 con Outlook Anywhere y no tener que saber en que nombre de servidor se encuentra el buzon del usuario, y utilizar un nombre genérico y que el se encargue de resolver en donde está ubicado el buzón.

    La configuracion de los clientes Outlook es siembre con Outllok Anywhere,y usando HTTP tanto en redes rapidas como en redes lentas

     

    Gracias por vuestra ayuda.

    lunes, 3 de mayo de 2010 9:54

Todas las respuestas

  • Outlook Anywhere usa el Autodiscover para configurar las cuentas de usuario, por lo que si haces que éste funcione dentro de la LAN y fuera de ella, tendrás el problema solucionado.

    Lo que no entiendo es cómo en la LAN están los puertos cerrados y en Internet no. Si acaso, la cosa debería ser al revés, no?

    Autodiscover and Exchange 2007

    http://technet.microsoft.com/en-us/library/bb232838(EXCHG.80).aspx


    Saludos,
    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator
    MCTS: Exchange 2007
    lunes, 3 de mayo de 2010 10:17
  • Gracias por tu respuesta,

    el problema es que Autodiscover empieza a realizar la configuracion, e intenta conectarse via mapi, pero el puerto 135 esta capado, y da error.

    Si al usuario de la LAN que le configuro Outlook Anywhere no le marco la opcion "en redes rapidas usar primero http...." no puede establecer la conexion.

    El tema es que Autodiscover no marca esta opcion por defecto, y al estar el puerto capado no puede terminar de realizar la configuracion automatica.

     

    gracias.

    lunes, 3 de mayo de 2010 12:06
  • Y, pregunto, qué problema hay en abrir el 135 sólo a equipos de la LAN? Porque el CAS tiene que estar DENTRO de la LAN, no en una DMZ (no está soportado)
    Saludos,
    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator
    MCTS: Exchange 2007
    lunes, 3 de mayo de 2010 12:38
  • el problema es que usan una ConnectLAN, entre las delegaciones, y como han tenido problemas de virus, han cerrado el puerto 135, el tema es que desde todas las delegaciones dejan pasar trafico DNS ya que tienen reenviadores condicionales hacia el DNS principal, que es donde se encuentran los servidores de Exchange.la verdad que no tiene mucho sentido( ya se lo hemos dicho) pero no quieren habrir el puerto 135, asi que hay que buscar otras opciones para que pueda funcionar Autodiscover.

    lunes, 3 de mayo de 2010 13:23
  • Pues en tu caso, se me ocurre intentar cambiar la configuración del Oulook vía GPOs del dominio para que se fuerce la autoconfiguración vía Internet (vía RPC over HTTP).

    Configure Outlook Anywhere in Outlook 2007

    http://technet.microsoft.com/en-us/library/cc179036.aspx

    Y respecto al tema de puertos, el Autodiscover "sólo" necesita que se abra el 443 (o el 80, si no usas SSL) para que funcione, dado que busca siempre una ruta del tipo https://nombreFQDNExchange/autodiscover/autodiscover.xml. Ese nombre puede ser tanto interno como externo (de hecho, se suele configurar de las dos formas)

    No deberían darte largas para abrir esos dos puertos, no?


    Saludos,
    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator
    MCTS: Exchange 2007
    lunes, 3 de mayo de 2010 13:37
  • el Autodiscover esta bien configurado, funciona correctamente desde el exterior y desde una LAN sin el puerto 135 cerrado, esta configurado para que la url interna y externa sea la misma(en este caso la externa)

    Los usuarios no inician sesion en el dominio de correo, este domino es solo para el correo.

     

    lunes, 3 de mayo de 2010 13:48
  • No me lo pones nada fácil :)

    Y es que ahora mismo no se me ocurre cómo hacer que funcione como quieres sin abrir el 135 :(


    Saludos,
    Marc
    MCSA/MCSE 2003
    MCITP: Enterprise Administrator
    MCTS: Exchange 2007
    lunes, 3 de mayo de 2010 14:12
  • Gracias por tu ayuda Marc,

    Yo tampoco  se que hacer, no quieren abrir el puerto 135 en la Connectlan, y quieren usar Autodiscover( si realizan la configuracion manual marcando las 2 opciones de conexion, en redes lentas.... y redes rapidas....) funciona a las mil maravillas, pero claro, configurar 2000 clientes a mano, pues como que se les atraganta un poco, por eso quieren usar autodiscover.

    Otra pregunta,

     los usuarios en la configuracion manual, han de saber el nombre del servidor donde se encuentra su buzon, ¿ hay alguna posibilidad de usar un nombre generico para todos los servidores de buzon, para que asi no se tenga que saber en que servidor esta el buzon?, no se si existe esta opcion, pero creo que mas de uno se habra encontrado con este problema ¿no?, imaginate tener 10 servidores de correo y tener que recordar en que servidor esta tu buzon a la hora de configurar Outlook Anywhere....un suplicio.

     

    Gracias por tu tiempo.

    un saludo

     

    lunes, 3 de mayo de 2010 14:32