none
Falta Disco Dinámico Windows 2008 server RRS feed

  • Pregunta

  • Buenas tardes,

    me gustaría hacerles una consulta de un problema que lleva ya tiempo dandome quebraderos de cabeza pero no entiendo bien por qué.

    Tengo un Windows 2008 server con dos discos montados en espejo. Ambos discos son Wester Digital de 1 Tera con varias particiones y todos ellas estan reflejadas en su disco espejo. Lo curioso es que últimamente (a lo mejor cada dos semanas, pero sin un tiempo fijo) me aparece el error en el administrador de discos "falta disco dinámico" "error de redundancia ciclica". Le doy a reactivar disco y no hay manera. Reinicio y tampoco. Tengo que apagar el equipo y volverlo a encender y entonces reactivo el disco y vuelve a empezar a sincronizar... y después de ello todo bien. Como si nada.

    A ver si me podeis orientar.

    Muchas gracias.

    lunes, 2 de julio de 2012 15:28

Respuestas

  • Todo da para pensar en una falla de hardware: disco, controladora o cables

    Comienza por lo más fácil, cambiando los cables y ver si vuelve a producir

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 2 de julio de 2012 18:08
    Moderador
  • Pues edito este post con la solución.

    Paso 1. Parece ser que el problema de los discos espejos mediante software es que te obliga a tener la misma caché ambos discos.

    Paso 2. Dos discos de un tamaño medio para uso exclusivo de S.OP. (Termina siendo más cómodo y más rápido).

    Paso 3. Clonar con Norton Ghost 11.5 sin particionar al disco entero (de partición a particion-disco entero) y después reducir el volumen ya que si no tampoco dejará hacer el espejado.

    Solucionado. Eso si. La próxima...POR HARDWARE. Clarísimo lo tengo.

    Gracias Gullermo y Alex por vuestra paciencia. Ahí los dejo sincronizando... puffff. Ahora lo que me queda es hacer una imagen del S.OP. y guardarla por si las moscas. ¿Me recomendais algun soft. aparte del Ghost?. Este ya lo conocia pero no se si habrá otro mejor porque me suena el Acronis. 

    jueves, 19 de julio de 2012 22:47
  • Como bien dice Guillermo puede ser el cable. Aunque no fallen siempre puede salir alguno defectuoso. Aunque si da error de redundancia cíclica yo me decanto más porque sea el disco que puede ser que vaya a fallar.

    Si vuelve a fallar el mismo disco podrías testear el disco con alguna herramienta de WD para salir de dudas.

    martes, 3 de julio de 2012 11:00
  • Si, es raro en esos cables que tengan problemas, pero como te decía antes, comenzar por lo más fácil, inclusive revisar si están bien los contactos.

    Luego, ya habría que pensar para el lado de problemas en el disco. Si siempre el que falla es el mismo, ya será hora de cambiarlo

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    martes, 3 de julio de 2012 18:05
    Moderador
  • No me refería al Checkdisk, sino a las Data Lifeguard Diagnostic de Western Digital (creo que son estas) que son herramientas de chequeo del propio fabricante y este te detectará enseguida si está el disco defectuoso (deberías activar el disco en otro equipo).

    martes, 3 de julio de 2012 18:14

Todas las respuestas

  • Todo da para pensar en una falla de hardware: disco, controladora o cables

    Comienza por lo más fácil, cambiando los cables y ver si vuelve a producir

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 2 de julio de 2012 18:08
    Moderador
  • Muchas gracias Guillermo.

    voy a cambiar los cables aunque ¿los cables SATA no suelen dar problemas no?. Creo que es raro. Una cosa que he revisado son las temperaturas de los discos y del sistema en general. Los discos rondan por los 36 º C por lo que no creo que den problemas por temperatura.

    Cambio los cables y lo observo.

    Muchas gracias de nuevo.

    martes, 3 de julio de 2012 8:19
  • Como bien dice Guillermo puede ser el cable. Aunque no fallen siempre puede salir alguno defectuoso. Aunque si da error de redundancia cíclica yo me decanto más porque sea el disco que puede ser que vaya a fallar.

    Si vuelve a fallar el mismo disco podrías testear el disco con alguna herramienta de WD para salir de dudas.

    martes, 3 de julio de 2012 11:00
  • Gracias Alex,

    el disco le pasé en varias ocasiones cada vez que me dio el error un CHKDSK (que me aconsejaba en el mensaje emergente cuando lo intentaba reactivar) y me dio todo bien.

    Lo curioso es que solo me permita reactivarlo si apago el equipo. Reiniciando no me deja.


    Ahora mismo por ejemplo, despues de sincronizar, están funcionando perfectamente. Tampoco creo que el equipo haya sufrido algún reinicio porque al acceder imagino que veria el mensaje de que el equipo se ha reiniciado y especifique el tipo de error.
    martes, 3 de julio de 2012 11:20
  • Si, es raro en esos cables que tengan problemas, pero como te decía antes, comenzar por lo más fácil, inclusive revisar si están bien los contactos.

    Luego, ya habría que pensar para el lado de problemas en el disco. Si siempre el que falla es el mismo, ya será hora de cambiarlo

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    martes, 3 de julio de 2012 18:05
    Moderador
  • No me refería al Checkdisk, sino a las Data Lifeguard Diagnostic de Western Digital (creo que son estas) que son herramientas de chequeo del propio fabricante y este te detectará enseguida si está el disco defectuoso (deberías activar el disco en otro equipo).

    martes, 3 de julio de 2012 18:14
  • Ok Alex.

    Ahora mismo está funcionando lo que me parece extraño porque entiendo que si tuviese un error de disco a nivel hardware tendría que haber dado la cara ya ¿no?.

    De todas formas, voy a desmontarlo y en otro equipo le pasaré el diagnóstico de Western Digital.

    Luego os cuento.

    Thanks

    miércoles, 4 de julio de 2012 8:08
  • No necesariamente :)

    Hay discos que hace automáticamente "remapeo" de sectores defectuosos, y entonces a medida que van fallando el sistema mueve la info a otro.

    Sin duda que ejecutaría las herramientas de diagnóstico de WD

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    miércoles, 4 de julio de 2012 19:23
    Moderador
  • Pues es curioso... jajaja o para volverse loco no se como describirlo.

    Después de pasar el test toda la tarde no encuentra ningun error. Monto el disco de nuevo y sigue funcionando.

    Lo único que me queda es cambiar el cable. Y además lo cambiare de SATA a ver si no da más problemas.

    Os informaré a ver que le da por hacer ahora pero imagino que se tirará unos días funcionando como ha ocurido antes...

    viernes, 6 de julio de 2012 7:49
  • Hola de nuevo,

    quería comentaros y agradeceros la ayuda facilitida con el tema. He realizado las pruebas que me comentasteis con las herramientas de diagnóstico de WD Y tres días ha tardado en dar la cara pero lo ha hecho. Sobretemperatura. La controladora se calentaba demasiado... entorno a los 180 º C.

    Lo cierto es que he intentado cambiar el disco, pero si lo desconecto no arranca el sistema. Uno está en el disco 0 y otro en el disco 2. Si arranco con ambos conectados no me deja quitar el reflejo de ninguno de los dos porque me dice que es de arranque.

    ¿Qué pasos puedo seguir para sustituirlo?. Ya tengo el nuevo disco conectado.

    Muchas gracias y perdonad las molestias.

    martes, 17 de julio de 2012 11:30
  • Menos mal que has encontrado el problema. :)

    Yo lo primero de todo aconsejaría un backup del sistema entero.

    Luego si tu controladora permite extracción en caliente desconectaría el disco y volvería a conectar el nuevo y que se reconstruyese la imagen.

    martes, 17 de julio de 2012 13:33
  • jajajajaja.. si el disco este es un gracioso... nada mas que ver el tiempo que lleva dandome la lata y que aparentemente esta bien.

    El problema que tengo es que si desconecto el disco (físicamente) no puedo arrancar. Puedo intentar desconectarlo y no reiniciar.

    EDITO: haciendolo he conseguido dejar el disco bueno y el nuevo, pero al "agregar reflejo" me lo convierte a dinámico perfectamente y después sale el siguiente mensaje:

    "Todos los discos con extensiones de un volumen específico deben tener el mismo tamaño de sector y este debe ser válido"

    He de decir que ambos discos tienen la misma capacidad. Asi que no entiendo muy bien que ocurre... a ver si me podeis echar un cable por favor, porque me da hasta miedo reiniciar.

    martes, 17 de julio de 2012 15:04
  • Ya haz aprendido algo: los RAIDs hay que hacerlos por hardware, no por software :)

    Por lo que comentas es evidente que el que tiene la falla es el original, y no la copia

    Con W2003 te podría guiar fácil porque me ha pasado, pero con W2008, que no tiene el BOOT.INI la casa es más complicada

    El sistema seguramente tiene por lo menos dos particiones:

    - System: la que no tiene letra asignada, y donde están los archivos de arranque
    - Boot: donde está el sistema operativo (C:\Windows)

    ¿Están espejadas ambas? porque una sin la otra no va a ir

    Y ahora te doy un lugar para comenzar, pero debes investigarlo por tu cuenta, salvo que alguien contribuya porque nunca he tenido que hacerlo
    Arranca con el DVD, elige reparar, selecciona línea de comandos, e investiga qué se puede hacer con:
    - BOOTREC
    - BCDEDIT

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    martes, 17 de julio de 2012 17:04
    Moderador
  • Hola Guillermo, gracias por contestar.

    Lo cierto es que tiene que ser algo del disco nuevo ya que he colocado uno más pequeño que tenia por ahí (concretamente de la mitad de capacidad) y me hace el espejo perfectamente. Con el único que no me deja es con el nuevo.

    Efectivamente el disco original (que ahora mismo está funcionando sin problemas tiene varias particiones). Lo que quiero hacer es un espejo entero de ese disco junto con sus particiones tal y como estaba en el otro.

    Voy a mirar lo que me comentas... pero si lo hace con el pequeño por qué no lo hace con el nuevo?. ¿Puede ser que no sean completamente iguales?. Obviamente aunque el nuevo tiene el mismo tamaño es mas actual.

    martes, 17 de julio de 2012 17:39
  • Pues una cosa que se me ocurre es que utilices Ghost 11.5 o superior para clonar el disco tal cual. 

    A lo mejor te funciona el invento.

    Usando un Hirens Boot CD 9.9 por ejemplo y arrancando desde CD a lo mejor te vale. Eso si, acuérdate de desconectar el disco que "no" quieres clonar.

    martes, 17 de julio de 2012 18:50
  • ¿Igual marca/modelo de disco? porque con el tema que para los fabricantes de discos 1MB son 1000B y no 1024 ...


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    martes, 17 de julio de 2012 19:48
    Moderador
  • Pues misma marca pero mismo modelo diría que no porque es algo más fino lo cual es lógico porque el original tiene un par de años, pero sobre el que hice la prueba no es el mismo modelo seguro porque es de la mitad de capacidad y en cambio me hace el espejo sin problema.
    martes, 17 de julio de 2012 21:21
  • Pues no sé, como no sea compatibilidad, quizás por la BIOS del disco, o la geometría, no se me ocurre otra cosa

    Los tipos de puerto que usa ¿son los mismos?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    miércoles, 18 de julio de 2012 17:58
    Moderador
  • Pues si Guillermo,

    son identicos. Lo único que cambia es la cache. Marca, modelo, capacidad. Lo curioso es que no puedo achacarle a nada de eso puesto que he probado hacerlo con otro de otra marca, modelo pero de menos capacidad y si que va. Eso es lo que me tiene rayado.

    En definitva, porque no tiene ninguna lógica, la solución que voy a probar es bastante simple. Cogeré Norton Ghost y clonare el disco al nuevo. Pondré el otro que tengo igual al nuevo como espejo.

    Ya os contaré mañana que tal.

    miércoles, 18 de julio de 2012 18:20
  • Pues edito este post con la solución.

    Paso 1. Parece ser que el problema de los discos espejos mediante software es que te obliga a tener la misma caché ambos discos.

    Paso 2. Dos discos de un tamaño medio para uso exclusivo de S.OP. (Termina siendo más cómodo y más rápido).

    Paso 3. Clonar con Norton Ghost 11.5 sin particionar al disco entero (de partición a particion-disco entero) y después reducir el volumen ya que si no tampoco dejará hacer el espejado.

    Solucionado. Eso si. La próxima...POR HARDWARE. Clarísimo lo tengo.

    Gracias Gullermo y Alex por vuestra paciencia. Ahí los dejo sincronizando... puffff. Ahora lo que me queda es hacer una imagen del S.OP. y guardarla por si las moscas. ¿Me recomendais algun soft. aparte del Ghost?. Este ya lo conocia pero no se si habrá otro mejor porque me suena el Acronis. 

    jueves, 19 de julio de 2012 22:47

  • Gracias Gullermo y Alex por vuestra paciencia. Ahí los dejo sincronizando... puffff. Ahora lo que me queda es hacer una imagen del S.OP. y guardarla por si las moscas. ¿Me recomendais algun soft. aparte del Ghost?. Este ya lo conocia pero no se si habrá otro mejor porque me suena el Acronis. 

    Felicidades por haberlo solucionado al fin.

    Yo soy bastante fiel a Ghost, ya que una de las posibilidades que tiene es poder exportarlo a VMDK (VMware) por si he de "virtualizar" alguna máquina física dentro de mis ESX.

    viernes, 20 de julio de 2012 12:10
  • Primero que nada, mira mi mensaje del 17 de julio de 2012 17:04 :)
    A veces se aprende de la (mala) experiencia

    Segundo, "nunca nunca nunca le demuestres a una máquina que estás apurado o enojado":D

    Y tercero, cuidado con las imágenes, pueden ser soluciones en ambiente de grupo de trabajo, pero en ambiente de Dominio pueden causar problemas difíciles de resolver. Nunca lo hagas sobre un controlador de dominio por ejemplo

    Me alegro que lo solucionaras :)

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP - MCT - MCSE - MCSA
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    viernes, 20 de julio de 2012 17:28
    Moderador
  • EDITO: haciendolo he conseguido dejar el disco bueno y el nuevo, pero al "agregar reflejo" me lo convierte a dinámico perfectamente y después sale el siguiente mensaje:

    "Todos los discos con extensiones de un volumen específico deben tener el mismo tamaño de sector y este debe ser válido"

    He de decir que ambos discos tienen la misma capacidad. Asi que no entiendo muy bien que ocurre... a ver si me podeis echar un cable por favor, porque me da hasta miedo reiniciar.

    En efecto y en principio, el inconveniente sería que los dos discos no tienen un mismo tamaño de sector físico, incluso siendo de la misma marca pero de diferente referencia. Las especificaciones del disco nos sacarán de dudas, o algún software que nos entregue esta información. En mi caso pude constatarlo con la herramienta Intel Rapid Storage Technology (no es para todos los equipos, ya que trabaja con chipset especificados de Intel). Uno de los discos tenía 512 bytes de sector físico, mientras que el otro tenía 4096 bytes.

    Luego pude constatar que -tratándose de estos dos discos- podía crear un volumen reflejado desde el disco con sector físico de 4096 bytes seleccionando luego el otro disco con sector físico de 512 bytes, pero no al contrario.

    Hasta aquí creo esto tendría cierta lógica, sin embargo, al conectar un tercer disco con sector físico de 512 bytes, el sistema sí me permitió crear un volumen reflejado seleccionando el disco con sector físico de 4096 bytes. Y es aquí dónde entonces surgen las preguntas.

    Los puertos SATA 0 y SATA 1 son de 6Gb/s, y los puertos SATA 2 y 3 son de 3Gb/s, y los discos quedan así:

    SATA 0: Disco 1 de 300 GB, sector físico 512 bytes; SATA 1: Disco 2 de 1 TB, sector físico 4096 bytes; SATA 2: Disco 3 de 1 TB, sector físico 512 bytes.

    Ahora, se permite la creación de un volumen reflejado?

    De Disco 1 a Disco 2, sí

    De Disco 2 a Disco 1, sí

    De Disco 1 a Disco 3, sí

    De Disco 3 a Disco 1, no

    De Disco 2 a Disco 3, sí

    De Disco 3 a Disco 2, no

    Como se puede ver se puede crear un volumen reflejado en cualquier configuración, excepto si se intenta crear desde el Disco 3. Por qué?

    Porque el Disco 3 es booteable?

    Porque el Disco 3 se encuentra conectado a un puerto SATA de 3 Gb/s y los otros discos a puertos de 6 Gb/s? Obs. Todos los discos trabajan a 3 Gb/s.

    Es necesario configurar algún parámetro en el Setup?

    Por supuesto, la idea de darle continuidad a este hilo, es la de tener claridad acerca del tema porque seguramente luego tendremos que abordarlo nuevamente.

    Saludos.

    jueves, 19 de febrero de 2015 17:21