none
Problema con arp -s RRS feed

  • Pregunta

  • Hola!!

    Tengo el siguiente problema, al intentar agregar una entrada con "arp -s" me devuelve el error "Error en la adición de la entrada ARP: Acceso denegado", soy administrador local del equipo y algunas entradas sí me las agrega sin problemas, pero por ejemplo con la puerta de enlace me devuelve el error citado.

    Gracias

    martes, 19 de abril de 2011 8:42

Respuestas

  • Despues de mucho probar encontré la respuesta,

    Por alguna razón el comando arp -s falla en su intento pese a tener privilegios elevados en la consola de sistema.

    He resuelto el problema con el comando netsh. Supongamos los siguientes valores:

    Nombre del adaptador de red: Red1

    IP a registrar: 192.168.137.1

    MAC asociada: 00-00-00-11-11-11

    Digite en el símbolo de sistema:

    • Netsh [Enter]
    • Interface [Enter]
    • ipv4 [Enter]
    • add neighbors "Red1" "192.168.137.1" "00-00-00-11-11-11" [Enter]
    • exit [Enter]

    Para verificar digite arp -a

    Listo!!!! Se registro la entrada

    José Llantoy

    MCP / MCT / IC3 GS3 Autorized Educator / CompTIA Strata / CCNA

    lunes, 27 de febrero de 2012 14:39
  • Realmente no sé :-(

    Porque las pruebas que hecho con los equipos que tengo a mano funciona sin problemas.

    Por lo que comentas, lo primero que se me ocurrió es que fuera un bug del W7, pero no creo ya que las otras entradas las carga sin problemas.

    Por otro lado, pienso que también podría estar por el lado del Router, pero tampoco me parece probable, ya que los XPs lo hacen sin problema.

    Realmente no se me ocurre cuál es el problema.

    A ver si algún compañero se le ocurre una idea. Si se me ocurriera a mí, posteo

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    • Marcado como respuesta Ismael Borche viernes, 6 de mayo de 2011 18:57
    miércoles, 27 de abril de 2011 18:15
    Moderador

Todas las respuestas

  • Si es W2008/Vista o posterior, recuerda que aunque seas administrador, debes ejecutar el CMD con botón derecho y "Ejecutar como administrador"

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    martes, 19 de abril de 2011 10:26
    Moderador
  • Muchas gracias por la respuesta. Esa opción ya la había probado y sigue igual.
    miércoles, 20 de abril de 2011 6:41
  • Muy raro el problema de que algunas te permita y otra no. Lo único que se me ocurre es que el problema esté en el comando que usas

    ¿La dirección IP de la puerta de enlace estás seguro que es local?

    ¿Hay más de una interfaz de red en el equipo?

    Si quieres, pon la salida de un IPCONFIG /ALL por acá, y cuál es el comando que no funciona, y veo de investigar un poco el tema

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    miércoles, 20 de abril de 2011 11:01
    Moderador
  • Muestro las salidas de los comandos:
    c:\Users\xxxxxxxx\Desktop>ipconfig /all
    Configuración IP de Windows
       Nombre de host. . . . . . . . . : xxxxxxxx
       Sufijo DNS principal  . . . . . : xxxxxxxx.local
       Tipo de nodo. . . . . . . . . . : híbrido
       Enrutamiento IP habilitado. . . : no
       Proxy WINS habilitado . . . . . : no
       Lista de búsqueda de sufijos DNS: xxxxxxxx.local
    Adaptador de Ethernet Conexión de área local:
       Sufijo DNS específico para la conexión. . :
       Descripción . . . . . . . . . . . . . . . : NIC de Gigabit de Ethernet PCI-E
    de la familia Realtek RTL8168C(P)/8111C(P) (NDIS 6.20)
       Dirección física. . . . . . . . . . . . . : 48-5B-39-16-39-C1
       DHCP habilitado . . . . . . . . . . . . . : no
       Configuración automática habilitada . . . : sí
       Vínculo: dirección IPv6 local. . . : fe80::3963:2a4b:62d3:df99%10(Preferido)
       Dirección IPv4. . . . . . . . . . . . . . : 192.168.1.58(Preferido)
       Máscara de subred . . . . . . . . . . . . : 255.255.255.0
       Puerta de enlace predeterminada . . . . . : 192.168.1.90
       IAID DHCPv6 . . . . . . . . . . . . . . . : 239622969
       DUID de cliente DHCPv6. . . . . . . . . . : 00-01-00-01-13-61-C2-F2-48-5B-39-
    16-39-C1
       Servidores DNS. . . . . . . . . . . . . . : 192.168.1.3
       NetBIOS sobre TCP/IP. . . . . . . . . . . : habilitado
    Adaptador de túnel Teredo Tunneling Pseudo-Interface:
       Estado de los medios. . . . . . . . . . . : medios desconectados
       Sufijo DNS específico para la conexión. . :
       Descripción . . . . . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Dirección física. . . . . . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP habilitado . . . . . . . . . . . . . : no
       Configuración automática habilitada . . . : sí
    Antes de lanzar un *.bat:
    c:\Users\xxxxxxxxx\Desktop>arp -a
    Interfaz: 192.168.1.58 --- 0xa
      Dirección de Internet          Dirección física      Tipo
      192.168.1.3           00-15-17-5e-75-84     dinámico
      192.168.1.53          48-5b-39-14-7b-a2     dinámico
      192.168.1.90          00-06-4f-66-3c-51     dinámico
      192.168.1.96          00-26-55-d4-11-d9     dinámico
      192.168.1.97          00-26-55-d4-01-89     dinámico
      192.168.1.168         00-23-18-79-bd-91     dinámico
      192.168.1.176         4c-ed-de-1c-59-69     dinámico
      192.168.1.213         00-20-6b-dd-11-22     dinámico
      192.168.1.226         00-20-6b-52-c2-19     dinámico
      192.168.1.228         00-20-6b-66-e9-84     dinámico
      192.168.1.231         00-00-74-cb-9f-5d     dinámico
      192.168.1.255         ff-ff-ff-ff-ff-ff     estático
      192.168.2.50          00-26-55-15-2b-b9     dinámico
      224.0.0.252           01-00-5e-00-00-fc     estático
    Después de lanzar el *.bat:
    c:\Users\xxxxxxxx\Desktop>arp -a
    Interfaz: 192.168.1.58 --- 0xa
      Dirección de Internet          Dirección física      Tipo
      192.168.1.2           00-11-11-bd-19-3a     estático
      192.168.1.5           00-15-5d-01-60-00     estático
      192.168.1.90          00-06-4f-66-3c-51     dinámico
      192.168.1.92          00-26-2d-05-ed-08     dinámico
      192.168.1.97          00-26-55-d4-01-89     dinámico
      192.168.1.98          00-26-2d-06-46-e5     estático
      192.168.1.100         00-1a-e8-10-14-35     estático
      192.168.1.206         00-27-0d-1e-07-b3     estático
      192.168.1.207         00-27-0d-1d-fc-25     estático
      192.168.1.208         00-27-0d-1e-e1-cf     estático
      192.168.1.209         00-27-0d-1e-c0-d8     estático
      192.168.1.246         00-17-9a-c3-c2-a0     estático
      192.168.2.90          00-06-4f-66-3c-51     estático
    El fallo cuando intento agregar la entrada ARP de la puerta de enlace:
    c:\Users\xxxxxxxx\Desktop>arp -s 192.168.1.90 00-06-4f-66-3c-51
    Error en la adición de la entrada ARP: Acceso denegado.
    Muchas gracias
    lunes, 25 de abril de 2011 9:17
  • Muy raro el tema. Yo lo pruebo y no tengo ese problema...

    Ideas que se me ocurren:

    - El router ¿tiene una sola placa? ¿no hay "teaming"?

    - ¿En todos los equipos o en uno en particular? ¿lo has probado en otra máquina?

    - ¿Qué sistema operativo - SP?

    Igual una pregunta, porque no lo explicas ¿qué es el bat? ¿el que hace la entradas estáticas?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    lunes, 25 de abril de 2011 19:47
    Moderador
  • - El router tiene una sóla interfaz escuchando en una sóla ip.

    - Lo he probado en varios W7 profesional SP 1 y en todos ha fallado esa entrada en concreto. Si hago las mismas pruebas en W XP pro no tengo ese problema, coge todas las entradas arp que le meta.

    - En el bat lo que hago es automatizar todas las entradas arp de nuestros servidores y de la puerta de enlace, para evitar ataques de envenenamiento arp internos. 

    No se, se me ocurre que pueda ser algún tipo de restricción del W7, o que sea por algún tema de directivas de dominio, etc...... lo raro es que en el XP en las mismas circustancias no ocurre. 

    Además también me resulta raro que si fuese algún tema de seguridad del W7, no evitase los ataques de arp, ya que he hecho la prueba a enviar una respuesta ARP de la puerta de enlace a un equipo W7 (sin este haber solicitado la petición ARP) y el sistema se lo ha tragado perfectamente, por lo que los ataques de envenenamiento arp son factibles en W7.

    Por cierto, también tengo como antivirus local el Nod32, que he hecho pruebas con él instalado y desinstalado y no altera en nada los resultados descritos.

    Saludos 

     

    Gracias

    martes, 26 de abril de 2011 7:55
  • Realmente no sé :-(

    Porque las pruebas que hecho con los equipos que tengo a mano funciona sin problemas.

    Por lo que comentas, lo primero que se me ocurrió es que fuera un bug del W7, pero no creo ya que las otras entradas las carga sin problemas.

    Por otro lado, pienso que también podría estar por el lado del Router, pero tampoco me parece probable, ya que los XPs lo hacen sin problema.

    Realmente no se me ocurre cuál es el problema.

    A ver si algún compañero se le ocurre una idea. Si se me ocurriera a mí, posteo

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    • Marcado como respuesta Ismael Borche viernes, 6 de mayo de 2011 18:57
    miércoles, 27 de abril de 2011 18:15
    Moderador
  • Gracias de todas formas por las respuestas e ideas aportadas.
    jueves, 28 de abril de 2011 6:11
  • Despues de mucho probar encontré la respuesta,

    Por alguna razón el comando arp -s falla en su intento pese a tener privilegios elevados en la consola de sistema.

    He resuelto el problema con el comando netsh. Supongamos los siguientes valores:

    Nombre del adaptador de red: Red1

    IP a registrar: 192.168.137.1

    MAC asociada: 00-00-00-11-11-11

    Digite en el símbolo de sistema:

    • Netsh [Enter]
    • Interface [Enter]
    • ipv4 [Enter]
    • add neighbors "Red1" "192.168.137.1" "00-00-00-11-11-11" [Enter]
    • exit [Enter]

    Para verificar digite arp -a

    Listo!!!! Se registro la entrada

    José Llantoy

    MCP / MCT / IC3 GS3 Autorized Educator / CompTIA Strata / CCNA

    lunes, 27 de febrero de 2012 14:39