none
Credenciales Samba en explorador de archivos no funcionan en windows 10 enterprise RRS feed

  • Pregunta

  • Hola Tengo Windows 10 enterprise v1809 compilación 17763.1817 y estoy tratando acceder a servidores samba desde el explorador de archivos, pero cada vez que ingreso las credenciales no permiten hacerlo.

    Tengo una máquina virtual con Centos 7 en donde está configurado el servidor samba. Esta VM está con Oracle VM en Windows 10.

    Tengo otro pc con Fedora en donde también está configurado samba.

    Desde Fedora puedo ingresar a la máquina virtual Centos que está en el computador con Windows, via explorado de archivos smb://ip/recurso con el usuario y contraseña de fedora, sin ningún problema.

    Lo mismo sucede desde la VM Centos bajo Windows, instalé gnome y desde "Archivos" puedo ingresar a la máquina de Fedora con el usuario de la máquina de fedora.

    En windows descarge el programa "LAN Drive" de Webrox y en la sección "Cliente Samba" puedo ver los dos recursos, el de Fedora y Centos, y puedo acceder a ellos sin problemas,

    La única parte en donde no puedo hacerlo es en el explorador de archivos de windows.

    Intenté mucha configuraciones de forma individual y alternadas.

    Al momento de solicitar las credencias, cuando primero siempre me pide el pin de mi cuenta de windows, pongo "más opciones" > "Usar otra cuenta", en usuario he puesto el nombre de usuario o incluso nombreusuario@ip, pero aún así no permite el ingreso.

    En Windows.

    Abrí regedit y cambie AllowInsecureGuestAuth de 0 a 1, hice lo mismo con RequireSecuritySignature, cambiando el valor de 0 a 1.

    Ingresé a gpedit.msc y cambié los registros de "Configuración del equipo > Plantillas administratrivas > Red > Estaciónd de Trabajo Lanman > Habilitar inicios de sesión de invitado no seguros" de No configurado a Habilitado

    También en gpedit.msc deshabilité "Configuración del equipo > Configuración de Windows > Configuración de seguridad > Directivas locales > Opciones de Seguridad > Clientes de redes de Microsoft: firmar digitalmente las comunicaciones (siempre)" de Habilitado a Deshabilitado.

    En la aplicación de servicios procuré que estuvieran en ejecución y automático los servicios "Cliente DNS", "Publicación de recurso de detencción de función", "Dispositivo de Host UPnP" y "Detección SSDP"

    Activé la detección de redes en el Perfil Actual (Privado) y desactive el "Uso compartido con protección por contraseña" en Todas las redes.

    Deshabilité y Habilité el NetBios a través de TCP/IP en Wins del adaptador.

    Ingresé a Credenciales de Windows y agregué las credenciales en Windows

    Ingresé a secpol.msc y deshabilité "Configuración de seguridad > Directivas locales > Opciones de seguridad > Cuentas: Limitar el uso de cuentas locales con contraseñas en blanco solo para iniciar sesión en la consola"

    También en secpol.msc cambie el registro de Configuración de seguridad > Directivas locales > Opciones de seguridad > Seguridad de red: nivel de autenticación de LAN Manager" de No definido a "Enviar solo respuesta NTLMv2 y rechazar LM y NTLM" esto también lo hice por medio de Regedit en "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel" cambiando el valode de DWORD de 0 a 5

    En las configuraciones avanzadas de Firewall de Windows habilité las "reglas de entrada" para perfil "Privado, Público" y "Dominio" de [Compartir archivos e impresoras: nombre NB de entrada],[Compartir archivos e impresoras: sesión NB de entrada], [Compartir archivos e impresoras: SMB entrada] y [Compartir archivos e impresoras: datagrama NB de entrada]

    En las caracerísticas de windows habilité "SMB 1.0/CIFS File Sharing support" Cliente, Servidor y eliminación automática.

    De igual manera active y desactive SMB1 desde línea de comando "Disable-WindowsOptionalFeature -Online -FeatureName smb1protocol", "Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol".

    Activé y desactivé desde comando el protocolo SMB2 "Set-SmbServerConfiguration -EnableSMB2Protocol $true" Set-SmbServerConfiguration -EnableSMB2Protocol $false"

    En Centos (smb.conf)

    Agregue muchas configuraciones globales, por ejemplo

    ntlm auth = true
    encrypt passwords = yes
    server min protocol = SMB2_10 intenté con SMB2 y SMB3
    client min protocol = SMB2 lo mismo acá
    client max protocol = SMB3 lo mismo acá

    Por nombrar algunas, ahora volví a las configuraciones básicas.

    Ya no se que más problar para que el explorador de windows se conecte a los recursos samba de las máquinas virtuales o de los otros computadores con linux.

    Muchas gracias por su ayuda.

    lunes, 22 de marzo de 2021 23:31

Todas las respuestas

  • Hola RobinHead

     

    Gracias por levantar tu consulta en los foros de TechNet. Entendimos su pregunta y vamos a darle seguimiento para buscar la mejor repuesta pertinente al caso.

     

    Cualquier duda referente a productos Microsoft, puedes consultarnos. Es un gusto informarte.

    Gracias por usar los foros de TechNet.

     

     

    Miguel Mosquera

     

    --------------------------------------------------------------------------

     

    Por favor recuerde "Marcar como respuesta" las respuestas que hayan resuelto su problema, es una forma común de reconocer a aquellos que han ayudado, y hace que sea más fácil para los otros visitantes encontrar la solución más tarde. 

     

    Microsoft ofrece este servicio de forma gratuita, con la finalidad de ayudar a los usuarios y la ampliación de la base de datos de conocimientos relacionados con los productos y tecnologías de Microsoft.  

     

    Este contenido es proporcionado "tal cual" y no implica ninguna responsabilidad de parte de Microsoft.

    martes, 23 de marzo de 2021 18:30
    Moderador
  • Muchas gracias, estaré atento.

    Si encuentro la solución también lo informaré.

    jueves, 25 de marzo de 2021 14:15