none
SharePoint2010: Problema con GUID en columan de sitio RRS feed

  • Pregunta

  • Buenos días,

    tengo problemas con el GUID en una columna de sitio. Te Cuento:

    En Visual Studio, he creado una columna de sitio de lookup declarativamente que enlaza dos sitios padre-hijo.

    Esta columna de sitio está en un Tipo de Contenido y este a su vez en una definición de lista.

    Cuando instalo esta estructura padre e hijo una sola vez, no hay problema ya que desde el hijo el campo lookup apunta correctamente al padre.

    Pero cuando la intalación es múltiple, es decir, son varias instalaciones iguales padre-hijo. Todos los hijos apuntan a la columna de sitio del último padre instalado.

    ¿qué puedo hacer?


    Saludos y gracias por anticipado.

    miércoles, 13 de febrero de 2013 12:31

Todas las respuestas

  • Hola mi primera pregunta por qué se hizo personalizado esto, por qué no te funciona con lo que trae Sharepoint?

    Ahora bien, esto se refiere a crear varias columnas en una misma lista, o son padres e hijos en diferentes listas?

    ¿Te das cuenta del problema porque los hijos cargan la misma información del padre?

    Puedes compartir el código?

    Por qué dices que el error es el GUID de la columna?

    Saludos


    Andrés

    martes, 19 de febrero de 2013 12:51
  • Hola,

    ¿Has conseguido solucionar el problema? Si te estoy entendiendo bien, estás definiendo una columna de tipo lookup entre dos listas del sitio utilizando la aproximación declarativa...¿Qué ámbito tiene la feature qué estás usando para desplegar todo? El problema puede estar ahí ya que el campo GUID de la columna tiene que ser único.

    Saludos


    ------------------------------------------------------------
    Juan Carlos González Martín MVP de SharePoint Server
    Director revista CompartiMOSS: http://www.compartimoss.com
    Blog: http://geeks.ms/blogs/ciin
    Twitter: @jcgm1978
    ------------------------------------------------------------

    martes, 19 de febrero de 2013 14:11