none
Servidor Segundario en un Dominio no se activa RRS feed

  • Pregunta

  • Buenos días, quería ver si alguien acá me podrían ayudar.

    Resulta que tenemos dos servidores en de dominio primario y el segundario, hace poco el UPS del dominio primario se dañó y apago todo, pero el Exchange reportaba problemas de Kerberos, que no encontraba el Active Directory, revisando en la consola de active directory del Exchange no había ningún controlador de dominio, luego decidí buscar por nombre del servidor y apareció Online el servidor de réplica pero daba error de conexión, decidí buscarlo por IP, y apareció Online y luego conectado el servidor de dominio segundario pero el Exchange nunca pudo conectar con este.

    Me preocupa ya que se supone que si es segundario debería responder si el primario no está.

    Luego de encender el servidor primario y pasar unos minutos, recién conecto el Exchange.

    <Nota:

    Todo el controlador de dominio está conforme, inclusive con la herramienta Ad Replication Status Tool muestra que la réplica funciona.

    Los Servidores de Dominio están en plataforma Windows Server 2012 y el Exchange en Windows Server 2010

    He leido herramientas para verificar las replicas y las he corrido y funcionan. Al crear la replica la creo bien sin ningun inconveniente.

    Gracias espero tener aportes


    domingo, 16 de agosto de 2015 17:51

Todas las respuestas

  • Hola GaldamezM, creo que mejor deberías poner la pregunta en el foro de Exchange ya que de ahí proviene el problema

    Pero para orientarte, dices que el Exchange nombra problemas de Kerberos, y por otro lado confirmas que si accedes por nombre, donde usa justamente Kerberos no se conecta, pero si lo haces por IP, que no usa Kerberos, confirmas dónde está el problema

    Deberías revisar el visor de eventos en cada uno y ver cuáles son los errores relacionados. Para poder darte ayuda simpre indica de cada evento el Origen y el ID, con esa información se puede buscar y tratar de solucionar

    De todas formas te comento creo que te conviene poner la pregunta en el foro de Exchange, porque si replican bien, no es Active Directory

     


    Guillermo Delprato
    Buenos Aires, Argentina
    El Blog de los paso a paso

    MVP - MCSE - MCSA2012
    MCITP: Enterprise Administrator / Server Administrator
    MCTS: Active Directory/Network Configuration/Applications Configuration/Server Virtualization/Windows 7 Configuration/Windows 7 & Office 2010 Deployment/Vista Configuration

    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.

    lunes, 17 de agosto de 2015 10:21
    Moderador
  • Hola, GaldamezM:

    Por lo que comentas, la causa de tu consulta se debe a que tanto el servicio DNS como el rol de ADDS no están completamente configurados en los servidores, amén que la configuración como cliente DNS del servidor MS Exchange ha de tener incluida la IP del servidor secundario (dejando a un lado que hayan problemas de conexión física). Lo bueno es que parece que la "cagada" no ha traido consecuencias graves, tu tú (y no tu jefe) te has dado cuenta del potencial desgarrador que pudiera haber tenido.

    Te recomiendo que te aprietes los "machos" y sigas los siguientes pasos:

    1.- Revisa que la configuración DNS del MS Exchange sea la correcta: Desde las propiedades de la ethernet (EJECUTAR => NCPA.cpl) accede a las propiedades TCP/IPv4 y confirma que IP DC maestro = DNS primario y que IP DC secundario = DNS alternativo. Asimismo, confirma el acceso PERMANENTE a ambos DC's desde el PROMPT de sistema (que en PING no haya un "lack" de conexión). Es MUY importante! Más info para que no preguntes:

    · Configurar los parámetros del cliente DNS:
    https://msdn.microsoft.com/es-es/library/Cc778792%28v=WS.10%29.aspx?f=255&MSPPError=-2147217396

    2.- Desde el DC que te salga del "cirolo", accede a la consola EJECUTAR => DNSMGMT.msc y verifica tanto desde la zona directa como la inversa que ambos servidores están correctamente configurados. No olvides limpiar la caché y actualizar los datos de ambos servidores. Más info sobre procedimientos:

    · How to Install and Configure Microsoft DNS Server: https://support.microsoft.com/en-us/kb/172953
    · Configure a Secondary Name Server in Windows Server 2003: https://support.microsoft.com/en-us/kb/816518

    NOTA. Asegúrate que el DNS secundario sea tambien GC, y añádelo como DNS secundario a todos los bichos cliente. Más info:
    · Agregar o quitar el catálogo global: https://technet.microsoft.com/es-es/library/Cc755257.aspx

    3.- La prueba de estrés definitiva: SOLO cuando casi no haya clientes haciendo uso de la LAN, procede a hacer pruebas desde estaciones cliente (a la vez que desde el MS Exchange) que tanto DC/DNS primario como DC/DNS secundario son accesibles. Como extremo de funcionalidad, sólo deshabilita (o desconecta) la ethernet de DC/DNS primario y sigue con las pruebas de conectividad y resolución de nombres. Sólo así estarás completamente seguro que el día de mañana ante una nueva caída del DC primario, el servicio seguirá funcionando.
    REPITO: Sólo cuando no haya gente haciendo uso de servicios críticos (correo, acceso al web y/o datos en red.. etc). Por eso normalmente se hacen en fin de semana o en vacaciones del personal..

    Desiderio Ondo || Engineer

    lunes, 17 de agosto de 2015 11:07
  • Estimado,

    Antes de dar una respuesta, me gustaría saber si el Exchange 2010 o los AD 2012, vienen de una migración, Upgrade o algo parecido.

    En espera de una pronta respuesta.

    Gracias,


    Edwin Duran Ospina _____________________________________________ Si la respuesta ha sido la solución, favor marcarla.

    lunes, 17 de agosto de 2015 13:15
  • Buenos dias DO.

    Te comento que revise a detalle lo que me indicaste y efectivamente habia un tercer servidor en los DNS que pense que causa interferencia digamos: Hay un DC01 activo, un DC03 activo y reflejaba alguna ves en un DC02 que al parecer existio y se daño.

    Realice todo lo indicado y sigue sin funcionar, hago las pruebas en las mañanas o en las noches para que no haiga interferencia en los usuarios.

    Si existen los dns. Estan configurados como DNS 1 y DNS 2 en los servidores y en cada equipo

    Las zonas directas e inversas estan los servidores.

    Todo esta normal pero sigue dando el mismo problema al desconectar mi controlador de dominio principal:

    Error en la conexion

    Gracias

    miércoles, 19 de agosto de 2015 16:09
  • Buenos dias.

    Te comento que no vienen de una migracion ni Upgrade.

    La configuracion es:

    1 - Servidor de Dominio No1 Server 2012 (Contiene Active Directory y DHCP)

    1 - Servidor de Dominio No2 Server 2012 (Contiene Active Directory)

    1 - Servidor de Exchanger Server 2010 (Solo Exchange)

    1 - Servidor de TMG Pagina Web Server 2010

    1 - Servidor de TMG Correo Electronico Server 2010

    1 - Servidor de Pagina Web.

    Saludos.

    miércoles, 19 de agosto de 2015 16:14
  • Hola "GaldamezM" como estas,

    Por el lado de foro "Windows Server"

    Para poder comprender bien tu pregunta necesitamos de algunas cuestiones a tener en cuenta, por ejemplo,

    1 - Una vez que se apagó "todo", como se encendieron los servers ? todos a la vez o consecutivamante ?
    2 - Se apartó la UPS de la estructura de red fisica ? o sigue conectada ?
    3 - Solo los servers están conectados a la UPS o tambien tienes algun dispositivo como router o switch ?
    4 - Verificastes que todos los servicios esten automaticos y corriendo ? cuales no se iniciaron ?
    5 - De que manera la replica por nombre da error de conexión ? postea mensaje exacto.

    Aviso: no siempre un servidor secundario responde cuando el primario no está presente, depende la configuración.

    Si ADRST avisa todo ok ! entonces se puede decir que todos los DCs de Active Directory estan bien y solo te queda que Exchange Server no ve de Active Directory. Postea un nueva pregunta en el foro "Exchange".

    Si es necesario, postea el mensaje de replicación.


    jueves, 20 de agosto de 2015 21:08