none
Problemas DNS Windows 2008 RRS feed

  • Pregunta

  • Buenas Noche:

     Tengo un problema muy parecido a unos de los compañeros que estan en el foro:

     Desde hace unas semana detecto que un cliente no recibe correos, empiezo hacer algunas prueba y detecto que no solo es el correo tampoco puede entrar en la pagina web, pero dos portatiles que no estan unido al dominio y las DNS apunta  directamente con el ISP funciona perfectamente, en cambio todos los equipos que estan unido al dominio no pueden entrar unicamente a la web que esta alojada externamente ni recibir correo.

      Ejemplo:

          Web (Del cliente

             www.prueba.com  ( No puedo Acceder )

           Correo

             Correo Entrantey Saliente : mail.prueba.com

      Unicamente no accedo a ese dominio, el resto funciona perfectamente

    Configuracion DNS en el servidor

      Inicialmente no tenia ningun reenviador simplemente tenia las sugerencia de raiz.

    Cuando me dio el problema he revisado si tenia algun virus y eso esta descartado.

    He puesto unos reenviadores y todo empezo a funcionar perfectamente, al cabo de 10 dias todo se repite de nuevo, vuelvo a cambiar lor reenviadores por otros y todo vuelve a funcionar bien, al cabo de una semana se vuelve a repetir. Me he quedado sin ideas si alguien puede sugerirme algo.

    Un Saludo

    Informacion del Servidor

      Windows 2008 Server Standard

      Antivirus Mcafee Asap

     

     

     

     


    Tecnico
    viernes, 28 de mayo de 2010 22:12

Respuestas

  • Primero una aclaración de lo que pones, porque no sé si estás enmascarando los nombres reales :-)
    Nunca se va a resolver en Internet www.angelcode.local ya que el sufijo "local" se puede usar internamente, pero no es resoluble en Internet.
    ¿Está enmascarado o es ese?

    Si usando reenviadores funciona, pero usando sugerencias de raíz no funciona, entonces el problema que da para pensar es que a nivel de Internet no está correctamente la delegación del dominio público.

    Si el dominio que no resuelve, no fuera ".local" sino con un sufijo verdadero, entonces hay que entra a ver con NSLOOKUP usando diferentes DNSs de Internet a ver qué resuelve en cada caso.

    Un poco menos de trabajo que con NSLOOKUP para verificar la resolución la tienes con:
    - http://www.dnscolos.com/free-dns-report.html
    - O en Microsoft hay una utilidad para bajar, muy buena, llamada DNSLINT

     


    Guillermo Delprato - MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration --- Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos. --- Buenos Aires, Argentina
    lunes, 31 de mayo de 2010 11:40
    Moderador
  • Hola MIguel-On,

    primero de todo, no hagas caso a lo comentado en el otro post ya que los dns que puse eran para el dominio angelcode.com que fue el que pusiste en el otro post y ahora veo que has puesto que es angelconde.com, asi que no es aplicable.

    Lo que comentas es muy raro, no deberia producirse ese comportamiento a menos que externamente hubiera fallos con los Dns autoritativos de la zona, a veces he visto ISPs que daban un mal servicio con servidores DNS o habia problemas de conectividad para llegar hasta ellos y provocaban efectos parecidos a lo que comentabas, dependiendo de que servidores DNS utilices (reenviadores), algunos podian haber conseguido cachear correctamente las IPs correctas y otros no, de manera que dependiendo de cual utilizases podia funcionar o no durante un tiempo.

    Al margen de la prueba que estas haciendo que me parece correcta podrias tratar de conectarte desde una estacion cliente y desde el servidor (para comparar) con nslookup al servidor dns que tienes configurado como reenviador en el servidor DNS, consultas el registro mail.angelconde.com y www.angelconde.com y anotas las IPs . Cuando vuelva a fallar, en lugar de cambiar el reenviador, primero conectate de nuevo desde la misma estacion y desde el servidor con nslookup y repite la consulta y compara los resultados, asi podras saber si es un problema del servidor DNS (no te devuelve ningun valor lo cual significa que de pronto ese reenviador ya no es capaz de llegar al servidor autoritativo de tu zona ) o de tu servidor (seria un tema mas profundo a revisar) 

    Tip: Para conectarte con nslookup a otro servidor dns, una vez dentro de nslookup, debes utilizar el comando Server nombre_servidor, acto seguido cualquier consulta que hagas se resolvera directamente en ese servidor y es una buena manera de hacer troubleshooting.


    MCTS: Windows Server 2008 Active Directory, Configuring
    lunes, 31 de mayo de 2010 23:07
    Moderador

Todas las respuestas

  • Hola,

    y el dominio interno que nombre tiene? prueba.local?  prueba.int? o coincide con prueba.com?


    MCTS: Windows Server 2008 Active Directory, Configuring
    viernes, 28 de mayo de 2010 22:31
    Moderador
  • Miguel cual es la configuracion DNS del DC , es decir cuales son los DNS de tu DC

    A la espera de tus comentarios

    Saludos
    JA
    Jose Antonio Cermeño- Caracas-Venezuela
    sábado, 29 de mayo de 2010 6:12
  • Miguel, por los síntomas que nombras es el caso típico de cuando el nombre de dominio de Directorio Activo, coincide con el nombre de prescencia en Internet ¿es así?

    Suponiendo que fuera así, el tema es que aún cuando a tu DNS le configues Reenviadores, éste no puede reenviar los nombres para los que es autoridad. Esto es, si tiene una zona "dominio.com" no va a reenviar a otro DNS un nombre que no pueda resolver y tenga la forma "loquesea.dominio.com".

    Se soluciona muy fácil. En tu DNS en la zona "dominio.com" debes crear manualmente los registros A correspondientes "www" y "mail" apuntando cada uno a la correspondiente IP externa.

     


    Guillermo Delprato - MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration --- Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos. --- Buenos Aires, Argentina
    sábado, 29 de mayo de 2010 10:30
    Moderador
  • Hola Pep Lopez,

     

       En primer lugar agradecerte que hallas respondido. Intentare describir algo mejor el escenario.

     

       Servidor que es el controlador de dominio y dns.

     

           Nombre Servidor: DCSRV01

                                      IP: 192.168.0.100

                                           255.255.255.0

                                     P.E: 192.168.0.1

                                    NOMBRE DEL DOMINIO: ANCON.LOCAL

                                                                   Nombre del Dominio publico. angelcode.com 

       Como comentaba anteriormente en un principio no configure ningun reenviador, normalmente no suelo configurarlo, suelo usar las sugerencia de raiz, cuando empeze a tener el problema que no podia acceder a (angelconde.com) lo que hice fue nslookup www.angelcode.local y no lo encontraba, el resto de la web lo hacia bien. Déspues de comprobar que no había ningún virus procedi poner unos reenviadores ( 208.67.222.222) y todo empezo a funcionar bien, al cabo de unos días la historia se repite, vuelvo a cambiar los reenviadores (195.235.113.3) y todo vuelve a funcionar bien,  no tengo niguna zona dns creada con el mismo nombre (angelcode.com) interna. 


    Tecnico
    domingo, 30 de mayo de 2010 17:57
  • Hola Guillermo:

       En primer lugar agradecerte que hallas respondido. Intentare describir algo mejor el escenario.

     

       Servidor que es el controlador de dominio y dns.

     

           Nombre Servidor: DCSRV01

                                      IP: 192.168.0.100

                                           255.255.255.0

                                     P.E: 192.168.0.1

                                    NOMBRE DEL DOMINIO: ANCON.LOCAL

                                   Nombre del Dominio publico. angelcode.com 

       Como comentaba anteriormente en un principio no configure ningun reenviador, normalmente no suelo configurarlo, suelo usar las sugerencia de raiz, cuando empeze a tener el problema que no podia acceder a (angelconde.com) lo que hice fue nslookup www.angelcode.local y no lo encontraba, el resto de la web lo hacia bien. Déspues de comprobar que no había ningún virus procedi poner unos reenviadores ( 208.67.222.222) y todo empezo a funcionar bien, al cabo de unos días la historia se repite, vuelvo a cambiar los reenviadores (195.235.113.3) y todo vuelve a funcionar bien,  no tengo niguna zona dns creada con el mismo nombre (angelcode.com) interna. 


    Tecnico
    domingo, 30 de mayo de 2010 17:58
  • Hola Jacermeno:

     

     

       En primer lugar agradecerte que hallas respondido. Intentare describir algo mejor el escenario.

     

       Servidor que es el controlador de dominio y dns.

     

           Nombre Servidor: DCSRV01

                                      IP: 192.168.0.100

                                           255.255.255.0

                                     P.E: 192.168.0.1

                                    NOMBRE DEL DOMINIO: ANCON.LOCAL

                                   Nombre del Dominio publico. angelcode.com 

       Como comentaba anteriormente en un principio no configure ningun reenviador, normalmente no suelo configurarlo, suelo usar las sugerencia de raiz, cuando empeze a tener el problema que no podia acceder a (angelconde.com) lo que hice fue nslookup www.angelcode.local y no lo encontraba, el resto de la web lo hacia bien. Déspues de comprobar que no había ningún virus procedi poner unos reenviadores ( 208.67.222.222) y todo empezo a funcionar bien, al cabo de unos días la historia se repite, vuelvo a cambiar los reenviadores (195.235.113.3) y todo vuelve a funcionar bien,  no tengo niguna zona dns creada con el mismo nombre (angelcode.com) interna. 


    Tecnico
    domingo, 30 de mayo de 2010 17:59
  • Hola Miguel-On,

    si tu dominio interno y tu dominio publico son diferentes entonces descartamos la "mala" configuracion del DNS interno ya que eso explicaria los problemas de resolucion de los servicios publicos consultando a un servidor interno y que se resolveria como te ha respondido el compañero Guillermo.

    Mi hipotesis es que tienes problemas con los servidores DNS publicos, es decir, seguramente el hosting del dominio publico y los servicios necesarios para que este funcione  no estan funcionando correctamente. Cuando registras tu dominio uno de los requisitos principales es proporcionar las IPs de los 2 Servidores DNS publicos que son autoritativos para esa zona (angelcode.com), en tu caso ns1.zwave.com y ns2.zwave.com , digamos que el resto de servidores de DNS del mundo le preguntan a el por la IP de www.angelcode.com o mail.angelcode.com o lo que sea, luego la almacenan en cache y la ultilizan durante un tiempo para las siguientes consultas, luego pasado ese tiempo vuelven a preguntar y comienza de nuevo el proceso. Ese mismo proceso se realiza de forma jerarquica entre varios servidores DNS pero quedate con la idea de que en un momento u otro se acaba preguntando a los DNS autorizados para esa zona.

    Si esos servidores DNS no esta correctamente configurados o no responden correctamente (problemas en las comunicaciones) pueden provocar errores intermitentes que provoquen lo que justamente dices.. que todo va bien menos eso, digamos que todo va bien porque el resto de dominios que consultas estan en otros servidores autoritativos y no hay problema con ellos pero si con los tuyos.

    Yo te aconsejaria que te pusieras en contacto con la empresa con la que tienes contratado el registro del dominio y administra los servidores DNS autoritativos y que verifiquen que la zona esta correctamente creada y que responden correctamente.

    Ya nos contaras


    MCTS: Windows Server 2008 Active Directory, Configuring
    domingo, 30 de mayo de 2010 21:41
    Moderador
  • Primero una aclaración de lo que pones, porque no sé si estás enmascarando los nombres reales :-)
    Nunca se va a resolver en Internet www.angelcode.local ya que el sufijo "local" se puede usar internamente, pero no es resoluble en Internet.
    ¿Está enmascarado o es ese?

    Si usando reenviadores funciona, pero usando sugerencias de raíz no funciona, entonces el problema que da para pensar es que a nivel de Internet no está correctamente la delegación del dominio público.

    Si el dominio que no resuelve, no fuera ".local" sino con un sufijo verdadero, entonces hay que entra a ver con NSLOOKUP usando diferentes DNSs de Internet a ver qué resuelve en cada caso.

    Un poco menos de trabajo que con NSLOOKUP para verificar la resolución la tienes con:
    - http://www.dnscolos.com/free-dns-report.html
    - O en Microsoft hay una utilidad para bajar, muy buena, llamada DNSLINT

     


    Guillermo Delprato - MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration --- Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos. --- Buenos Aires, Argentina
    lunes, 31 de mayo de 2010 11:40
    Moderador
  • Buenas Tardes Guillermo:

     

       Creo me no me he explicado bien, el nombre es real es angelconde.com.

    Con la sugerencia de raiz funcionaba perfectamente hasta que dejo de funcionar, estubo funcionando unos 20 dias. cuando me surge el problema el cambio que hago es poner los reenviadores y el problema se resuelve, al cabo de de unas semana el problema se repite, no puedo llegar a la web publica angelconde.com,ni tampoco puedo recibir correo mail.angelconde.com, todo alojado fuera en proveedores externo y no gestionado por mi. Pero el resto de paginas funciona perfectamente, lo unico que hago para que funcione otra vez es ponerle otros reenviadores diferentes, en cosa de tres meses he tenido que cambiar los reenviadores 4 veces, nunca habia tenido este problema com windows 2003 server, es mi primera instalacion en produccion con 2008 server, y mi duda es si hay algun cambio en la configuracion del 2008 server en la parte de dns ha tener en cuenta. Estoy montando otra instalacion y en principio me funciona perfectamente todo, de la misma forma que esta funcionaba todo bien.  Estoy haciendo otras prueba con otro antivirus por ver si Mcafee no me este detectando algun virus que  este bloqueando ese dominio en concreto.

     

     Un Saludo, agradecerte las molestias que te tomas.  


    Tecnico
    lunes, 31 de mayo de 2010 21:04
  • Hola MIguel-On,

    primero de todo, no hagas caso a lo comentado en el otro post ya que los dns que puse eran para el dominio angelcode.com que fue el que pusiste en el otro post y ahora veo que has puesto que es angelconde.com, asi que no es aplicable.

    Lo que comentas es muy raro, no deberia producirse ese comportamiento a menos que externamente hubiera fallos con los Dns autoritativos de la zona, a veces he visto ISPs que daban un mal servicio con servidores DNS o habia problemas de conectividad para llegar hasta ellos y provocaban efectos parecidos a lo que comentabas, dependiendo de que servidores DNS utilices (reenviadores), algunos podian haber conseguido cachear correctamente las IPs correctas y otros no, de manera que dependiendo de cual utilizases podia funcionar o no durante un tiempo.

    Al margen de la prueba que estas haciendo que me parece correcta podrias tratar de conectarte desde una estacion cliente y desde el servidor (para comparar) con nslookup al servidor dns que tienes configurado como reenviador en el servidor DNS, consultas el registro mail.angelconde.com y www.angelconde.com y anotas las IPs . Cuando vuelva a fallar, en lugar de cambiar el reenviador, primero conectate de nuevo desde la misma estacion y desde el servidor con nslookup y repite la consulta y compara los resultados, asi podras saber si es un problema del servidor DNS (no te devuelve ningun valor lo cual significa que de pronto ese reenviador ya no es capaz de llegar al servidor autoritativo de tu zona ) o de tu servidor (seria un tema mas profundo a revisar) 

    Tip: Para conectarte con nslookup a otro servidor dns, una vez dentro de nslookup, debes utilizar el comando Server nombre_servidor, acto seguido cualquier consulta que hagas se resolvera directamente en ese servidor y es una buena manera de hacer troubleshooting.


    MCTS: Windows Server 2008 Active Directory, Configuring
    lunes, 31 de mayo de 2010 23:07
    Moderador