locked
Exchange 2010 Readiness Check failed - Organization Prequisites RRS feed

  • Question

  • Hey guys!

    I will an E14 LAB! I have an W2008 R2 DC and an W2008 with all Exchange Prequisites on (IIS,....) When i try to install E14 the org preq. failed with the following error:

     Summary: 5 item(s). 4 succeeded, 1 failed.
    Elapsed time: 00:00:50


    Organization Prerequisites
    Failed

    Error:
    The forest functional level of the current Active Directory forest is not Windows Server 2003 native or later. To install Exchange Server 2010, the forest functional level must be at least Windows Server 2003 native.

    Warning:
    Setup is going to prepare the organization for Exchange 2010 by using 'Setup /PrepareAD'. No Exchange 2007 server roles have been detected in this topology. After this operation, you will not be able to install any Exchange 2007 server roles.


    Elapsed Time: 00:00:11


    Languages Prerequisites
    Completed

    Elapsed Time: 00:00:03


    Hub Transport Role Prerequisites
    Completed

    Elapsed Time: 00:00:15


    Client Access Role Prerequisites
    Completed

    Elapsed Time: 00:00:12


    Mailbox Role Prerequisites
    Completed

    Elapsed Time: 00:00:08

    Can anyone help me?

    I have downloaded the ISO again! And setup a new domain! Nothing works.....

    Friday, October 23, 2009 2:27 PM

All replies

  • Have you checked what the domain and forest functional level currently are?... (Can be done in "Active Directory Domains and Trusts".)
    Friday, October 23, 2009 2:44 PM
  • You will need to set up a 2003 DC.  It is a known issue that will be resolved in the RTM. 
    Friday, October 23, 2009 6:42 PM
  • The forest and domain function level are set WIndows Server 2008 R2
    Saturday, October 24, 2009 9:27 AM
  • The funnny thing is that i have also tried with a 2003 DC in Windows 2003 function Level (Forest and Domain) Same error! I also checked ADSIEDIT for msDS-Behavior-Version and the value ist right!. Is this the value that Exchange 2010 checks by Readiness check? I have tried the Exchange 2010 beta and Exchange 2010 RC! If anyone have an idea please let me not! Otherwise i will start again. But i fear the same error!
    Saturday, October 24, 2009 9:34 AM
  • I assume your 2003 DC was at least SP1? 
    Saturday, October 24, 2009 11:41 PM
  • No, 2003 R2 SP2
    Sunday, October 25, 2009 5:41 PM
  • 2003 R2 SP2 is fine, but your functional level can't be 2008 R2.  It will have to be at the 2003 level. 
    Monday, October 26, 2009 1:40 PM
  • i have the same error message with 2003 R2 and with 2003 Function Level! The i set up a new DC and Migrate AD to the the new DC. I uninstalled the old one and raise the function Level to 2088 - same error! So now my function level ist 2008 R2.

    Tuesday, October 27, 2009 8:09 AM
  • Ok, I was able to get myself in the same bind.  I had installed a 2003 R2 Std SP2 domain controller and a 2008 R2 Core DC running the adprep /forestprep and adprep /domainprep /gpprep for 2008 R2.  From there I was unable to get the prereq check to pass.  I rebuilt my 2003 R2 DC and did not readd the 2008 R2 DC.  I then raised my Forest and Domain levels to 2003 and ran the setup /prepareschema. 

    My guess is that the Exchange 2010 /prepareschema doesn't work well with the 2008 R2 prepared schema. 
    Tuesday, October 27, 2009 4:39 PM
  • now i am at a loss with this stuff! I thought that the AD has some kind of defekt! So i delete my DC and my Server Maschines installed a new W2003 R2 Sp2 with a new Domain and a new w2008 Ent x64 Ed. I raised the function level to 2003 native and installed the Exchange 2010 Preq. on the 2008 Server! And then the Surprise - Same Error! Anyone an idea? Help is welcomed!

    Wednesday, October 28, 2009 7:56 AM
  • Did you raise the domain or the forest functional level to 2003? They are in different places.
    Brian Day / MCSA / CCNA, Exchange/AD geek.
    Wednesday, October 28, 2009 3:12 PM
  • Ok, here is a laundry list:
    Just to triple check: Open Active Directory Domains and Trusts and Right Click Active Directory Domains and Trusts in the left pane and select Raise Forest Functional Level.  I assume is does show that it is Server 2003? 
    From you 2008 server, can you ping your dc?  (I am sure you can)
    Have you added ADDS on that machine?  (from the command prompt: servermanagercmd -i RSAT-ADDS)
    Make sure you are running the command prompt or powershell with elevated permissions (even if you are logged in as the domain admin, shift and right click to select the run as administrator) and run setup /PrepareAD /OrganizationName: <Name>
    Wednesday, October 28, 2009 3:54 PM
  • Hey Guys! Thanks for your reply! I have solved the Problem! So the Domain and Forest function Level ist set to 2003!! So i raised the Schema to Exchange 2007 Sp2! The the Prequ. Check runs Successfully and i can install E14! Now i have a wonderful Exchange 2010 Cluster in my Costumer Test Enviromenet! Microsoft approved this Problem, but it should be fixed in RTM!

    Thanks for your time and help!

    Kind Regards
    HB
    Thursday, October 29, 2009 10:28 AM
  • Hi All,

    I have a same issue can you please tell me how to sort out this issue

    Friday, September 10, 2010 5:10 AM
  • you need to transfer de 5 domain controller roles from 2003 to the 2008 domain controller server and then change the functional level.
    Tuesday, October 26, 2010 2:39 PM
  • Hi All,

    I have a same issue can you please tell me how to sort out this issue


    Can you please start a new thread? This one was during the beta period of Exchange 2010 and many thinsg have changed since then. :)
    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Wednesday, October 27, 2010 1:51 AM
  • As Brian said Please start the new thread as the resolution for your issue would be different.

    -Gulab

    Wednesday, October 27, 2010 11:24 AM
  • What?
    Seems like you didn't checked the 2007 SP level..LOL

    End of the day what matters is, issue resolved.

    -Gulab

    Wednesday, October 27, 2010 11:26 AM
  • H

    Ii guys,

     

    I encountered the same issue in my lab. My environment had one exchange 2003 server and I was introducing exchange 2010 into it.

    All the prereuisites were met but the issue apperaing was same.

    Observed that the exchange organization in the Exchange 2003 server was in mixed mode. (System manager- click on the organization- properties- operation mode(should be exchange native and not mixed).

    After changing it to native mode the installation was successful.

    Thank you

    Rashmi

    Tuesday, August 9, 2011 1:44 PM