none
Exchange Linked Accounts Simply Don't Work RRS feed

  • Question

  • Hello - 

    I'm attempting to accomplish a couple things at once: clean up our domain structure and move to Office 365. We've moved our user accounts from our old domain to a new AD forest structure as shown in this image:

    That being said, the old domain still has the Exchange mailboxes...simple enough, I thought: I'll covert those mailboxes into linked mailboxes. So I grabbed an account to test and used the following PS command to convert it:

    Set-User jeremy@<email domain> -LinkedMasterAccount co1001\jeremyc -LinkedDomainController vio-co1001.co1001.<domain name> -LinkedCredential $cred

    Sure enough, it disables the account in the resource domain (old domain), and I can verify the account is linked from EMS. The problem? It just doesn't work! The user for the test account cannot access his mailbox using Outlook, OWA, or any other way for that matter. When digging into Event Viewer logs on the Exchange Server, it shows the "account is disabled." 

    I've tried this with multiple accounts...trust relationship is fine...I'm at my wits end, nearing the point of putting $500 down for MS support to come fix this. Much more I could say, but hoping not to gush unneeded information.

    Any suggestions? This should be "easy" (just like all things in IT, right?)

    Jeremy

    Wednesday, February 28, 2018 2:19 PM

All replies

  • Hello - 

    I'm attempting to accomplish a couple things at once: clean up our domain structure and move to Office 365. We've moved our user accounts from our old domain to a new AD forest structure as shown in this image:

    That being said, the old domain still has the Exchange mailboxes...simple enough, I thought: I'll covert those mailboxes into linked mailboxes. So I grabbed an account to test and used the following PS command to convert it:

    Set-User jeremy@<email domain> -LinkedMasterAccount co1001\jeremyc -LinkedDomainController vio-co1001.co1001.<domain name> -LinkedCredential $cred

    Sure enough, it disables the account in the resource domain (old domain), and I can verify the account is linked from EMS. The problem? It just doesn't work! The user for the test account cannot access his mailbox using Outlook, OWA, or any other way for that matter. When digging into Event Viewer logs on the Exchange Server, it shows the "account is disabled." 

    I've tried this with multiple accounts...trust relationship is fine...I'm at my wits end, nearing the point of putting $500 down for MS support to come fix this. Much more I could say, but hoping not to gush unneeded information.

    Any suggestions? This should be "easy" (just like all things in IT, right?)

    Jeremy

    Wednesday, February 28, 2018 2:18 PM
  • Hi,

    I noticed that you have posted a same thread in this forum, to better resolve your issue, I will merge the thread into one.

    Thanks for your understanding!

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, March 1, 2018 3:17 AM
    Moderator
  • Hi,

    Did you also move the mailboxes to the new forest apart from the AD accounts?

    Actually, to use the linked mailbox feature, we should at least have mailbox objects in the Exchange forest and associated AD accounts in the resource forest.

    Besides, we should use the credentials in the resource forest, not the credentials in the new forest.

    For details, refer to Use the Shell to convert a mailbox to a linked mailbox

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, March 1, 2018 6:57 AM
    Moderator
  • Hi,

    It has been a long time since you made the last post on this thread. If you could get any help from the above posts, please be free to mark as answer, it will be helpful for others in this forum.

    Regards,

    Manu Meng


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, March 7, 2018 9:43 AM
    Moderator