none
Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later.

    Question



  • I am getting 'Your Out of Office settings cannot be displayed, because the server is currently unavailable. Try again later.' when one user is trying to use out of office though a local network connection with Outlook 2007 on Exchange 2007. anyone have any ideas?

    Monday, January 21, 2008 6:51 PM

All replies

  • Ilse,
       I looked at your link - but I have ONE USER only that can't get this changed - all other users have no problems / issues at all.  This one user, I turned off the OOF via the web site - and that solved that part of the problem.  But I can't fix it on the clients machine.  I've turned off caching to the OST, deleted the OST, deleted his mailbox settings on the local computer - and then re-created them. 

    I don't believe steps 2-4 could be the issue, since all other users can get into the OOF wizard without any trouble.  But step 1 has me stumped.

    Even though Exchange configured and setup the mailbox (and it configured in MAILBOX settings in Control Panel, as an Exchange mailbox) step 1 results display ONLY this info:

    Protocol:  SMTP
    Server:  mail.[companyname].com
    Port:  25
    Login Name:  [username]
    SPA:  Yes
    Authentication Required:  Yes

    That's it.  None of the settings as they appear in your example.  He has no problems except with OOF - so all other tasks, email, calendars (and sharing) all seem to work just fine.

    Any ideas?  Thanks!
    Shawn
    Thursday, April 02, 2009 2:54 PM
  • Did you ever find a fix for this? I am having the same problem.
    Thursday, January 07, 2010 10:06 PM
  • Did you get any solution?
    I am also facing the same problem. I couldnt get any solution to this problem.

    Thanks
    Rafiq
    Monday, February 08, 2010 8:49 AM
  • We have several users with this issue. The workaround that has "fixed" this for us is recreating the OS profile, so it has something to do with that. We have tried deleting the files found under C:\Documents and Settings\%username%\Application Data\Microsoft\Outlook, but that doesn't fix it. If we do CTRL+right-click on the Exchange icon in the system tray for a machine that is ok, we can properly see the OOF URL. However, on a machine that has this error, we get autodiscover failures.

    Because recreating the profile fixes it, I believe the problem lies with a user that already exists on a machine when Office 2007 gets pushed to it. We used SCCM to push and automatically removed Office 2003 with our MSP settings. The other odd thing is that we did a pilot first without SP2 installed and those machines had no issues. However, once SP2 was included in the push, we have these issues. I don't know if that's related or coincidental, but I thought I'd include these details. Perhaps we can compare notes to see what the common themes are and come up with a solution. I really don't want to have people here recreating profiles for hundreds of machines.
    Wednesday, February 17, 2010 9:28 PM
  • I am having this problem as a user (client side).  I have narrowed my issue down to not being able to access Out of Office 'b/c the server is unavailable message' when I am connected to the internet through my wired or wireless connections. HOWEVER, When I connect to customers via Microsoft VPN connection, I am able to access my Out of Office assistant correctly!  Godaddy hosts my Exchange Email, but I don't think this is an Exchange issue since I can access it while on another server.  However, I don't know what settings to change on my own network connection so that it will work without being connected to another server via MS VPN. Can anyone assist? 

     

    Thanks in advance!

    Thursday, July 01, 2010 3:36 AM
  • Hi Lautermilch

     

    i had this problem 2 or 3 times before with some users, and always the same fix works

    this happens because the corrupted profile, this may happen due to the user login with different profile than the profile used for outlook

    ex: DavidM login windows profile

    SamK login outlook profile 

    To Fix: just create a new outlook profile.

     

    Thanks

     

    • Proposed as answer by mo_anas Thursday, March 03, 2011 12:38 PM
    Thursday, March 03, 2011 12:38 PM
  • i am having the same issue with only a few users but it does not appear to be a profile issue.  it appears to be machine specific.  i logged into the PC having the issue and it created my profile for the first time and i also get the OOO server unavailable error.  i can get to OOO on my PC.  also, the same user can use a different PC and access it.  We do not provide OWA at this time so it is not a viable workaround.  i've run the hotfix from 970123 on the affected machine and nothing changed.  repaired Outlook, nothing.  i've checked the autodiscover settings on my machine (where OOO works) and found an additional key that does reference our exchange set up that was not in the registry on the machine that isn't working.  a little apprehensive to go there but thinking that might be my next attempt.  Thoughts?

    reading lots of posts that indicate it as primarily a server issue, but if that were the case, this issue would be more widespread for me but it appears to be isolated to a couple of users.  ANY ideas would be greatly appreciated!

    Thursday, March 10, 2011 3:46 PM
  • If it's isolated to the computer and not the user, it's possible autodiscover is failing on that machine. Did you do the ctrl+right click on the outlook icon on bottom right tray and test email autoconfiguration? Is it failing? If so it's possible that computer may have registry settings prohibiting autodiscovery lookups. 1.Click Start, and then click Run. 2.In the Run dialog box, type regedit, and then click OK. 3.In Registry Editor, go to the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\AutoDiscover 4.Set the following Autodiscover entries to 0 if you notice they are set to 1 PreferLocalXML=dword:0 ExcludeHttpRedirect=dword:0 ExcludeHttpsAutodiscoverDomain=dword:0 ExcludeHttpsRootDomain=dword:0 ExcludeScpLookup=dword:0 ExcludeSrvLookup=dword:0 ExcludeSrvRecord=dword:0
    • Proposed as answer by E Camacho Thursday, October 13, 2011 4:12 PM
    Thursday, March 10, 2011 4:05 PM
  • i have tried all of this and still nothing.  i did update the system to SP2 because i noticed that was missing.  the autodiscover fails.  our exchange is hosted, but it isn't "finding" it.  it appears all the settings are correct within Outlook.  i am ready to tear my hair out.

    oh and a bonus, this machine isn't getting Windows updates and it fails when i try to do it manually.  AAAAAARRRRRGGGGHHHHH!!!!!!

    Friday, March 11, 2011 8:52 PM
  • run autodiscover test from testexchangeconnectivity.com and post the report.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    Friday, March 11, 2011 9:03 PM
  • it won't let me copy and paste the results. 

    the machine that works correctly redirects to the 3rd party server.  the one that doesn't work shows that Autoconfiguration was unable to determine the settings.  it also does not properly go to the redirect.  i found registry keys on the machine that works that reference the redirect server and imported them into the one that doesn't.  still nothing. 

    • Proposed as answer by infused Wednesday, April 04, 2012 4:18 AM
    • Unproposed as answer by infused Wednesday, April 04, 2012 4:18 AM
    Monday, March 14, 2011 6:42 PM
  • ok, i'm not sure what happened.  maybe i just didn't wait long enough after importing the registry key, but i got the prompt asking to allow the redirect server access and now it's working!!!  glad that it's working but not really sure what actually fixed it. 

    this post helped immensely.  thanks so much!

    Monday, March 14, 2011 7:32 PM
  • I wanted to add my 2 cents here because I had a completely different problem, which netted the same result.

    We are in the middle of a migration to a new domain. Our first phase was to move all user email over to a new Exchange forest on the new domain. I effectively have two Exchange forests on two separate domains with a two-way transitive trust relationship.

    I noticed two symptoms: (1) users were unable to open the Out-of-Office Assistant, and (2) Users were unable to view free/busy information. This only affected users in Outlook (any flavor), but did not affect users in OWA. Moreover, test computers that are joined to the new domain were also unaffected.

    CAUSE

    Users were being directed to their local Exchange forest for the web services that provide both sets of information. Because Outlook was now connected to the new Echange forest in the new domain, it broke both the Out-of-Office Assistant and users were unable to view free/busy data.

    FIX

    I applied the following command from the Exchange Powershell on the old Exchange forest directing the users to the OWA of the new domain/forest.

    Get-WebServicesVirtualDirectory -Server <OLD CAS> | Set-WebServicesVirtualDirectory -InternalUrl https://OWA.newdomain.com/ews/exchange.asmx -ExternalUrl https://OWA.newdomain.com/ews/exchange.asmx

    Once this was done, clients were able to resolve this from the old domain and bothe the Out-of-Office Assistant and Free/Busy started to work.

    This drove me crazy. I hope this helps others with the same configuration.

    • Proposed as answer by MARO35 Tuesday, March 13, 2012 4:25 PM
    Thursday, October 13, 2011 10:18 PM
  • I wanted to add my 2 cents here because I had a completely different problem, which netted the same result.

    We are in the middle of a migration to a new domain. Our first phase was to move all user email over to a new Exchange forest on the new domain. I effectively have two Exchange forests on two separate domains with a two-way transitive trust relationship.

    I noticed two symptoms: (1) users were unable to open the Out-of-Office Assistant, and (2) Users were unable to view free/busy information. This only affected users in Outlook (any flavor), but did not affect users in OWA. Moreover, test computers that are joined to the new domain were also unaffected.

    CAUSE

    Users were being directed to their local Exchange forest for the web services that provide both sets of information. Because Outlook was now connected to the new Echange forest in the new domain, it broke both the Out-of-Office Assistant and users were unable to view free/busy data.

    FIX

    I applied the following command from the Exchange Powershell on the old Exchange forest directing the users to the OWA of the new domain/forest.

    Get-WebServicesVirtualDirectory -Server <OLD CAS> | Set-WebServicesVirtualDirectory -InternalUrl https://OWA.newdomain.com/ews/exchange.asmx -ExternalUrl https://OWA.newdomain.com/ews/exchange.asmx

    Once this was done, clients were able to resolve this from the old domain and bothe the Out-of-Office Assistant and Free/Busy started to work.

    This drove me crazy. I hope this helps others with the same configuration.

    This too drove me nuts for about 3 days.. my situation wasn't exactly the same but GUEETAR's suggestion pointed me in the right direction. we are in mid migration from Exch 2003 and the notion of a distinction between internal and external urls for supporting OOF was very new to me. this suggestion of setting both to one url worked for us. thanks !


    MAR

    Tuesday, March 13, 2012 4:29 PM
  • Hi

    Do you have OWA(Webmail) access to your exchange server? As i work around i logged onto the webmail on exchange and turn off out of office from there as a work around.

    Friday, November 09, 2012 7:56 AM