none
Removal of unwanted DAG networks

    Question

  • Hi,
    Running this cmdlet
    Set-DatabaseAvailabilityGroupNetwork -Identity DAG2\DAGNetwork02 -ReplicationEnabled:$false -IgnoreNetwork:$true

    Shouldn't the expected behaviour be to remove the "DAG2\DAGNetwork02" from the available networks? 
    When running the command against Exchange 2010 SP1 oth the console and the shell continue to display this network as available with just the replication disabled. 

    Thanks,

    Dave

    Thursday, September 30, 2010 5:59 PM

Answers

  • So, as soon as you remove a subnet from a DAG network, it will be automatically rediscovered, and added to a brand-new DAG network

    Per my research, this behavior is by design. After the network has been disabled and ignored, please go to failover cluster management, set the network to be disabled for cluster use

    Because they are disabled at the cluster level, they will not be re-discovered and re-added


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Tuesday, October 05, 2010 7:39 AM
    Moderator

All replies

  • Nope, that will simply ignore that it is there. This is useful if you're going to be doing maintenance on a WAN connection and want to avoid using it.

     

    Use Remove-DatabaseAvailabilityGroupNetwork to delete one you don't need.


    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Thursday, September 30, 2010 6:14 PM
  • Ok,
    So to follow up then, when I try to remove the group I get the following error...

    DatabaseAvailabilityGroupNetwork 'DAGNetwork01' can't be removed because it contains active subnets. To remove the network, all active subnets must first be assigned to other networks. If you want to disable the use of the network, consider using the Set-DatabaseAvailabilityGroupNetwork cmdlet with the -IgnoreNetwork or -ReplicationEnabled parameters.
        + CategoryInfo          : InvalidArgument: (:) [Remove-DatabaseAvailabilityGroupNetwork], DagNetworkManagementException
        + FullyQualifiedErrorId : D1FAAD3E,Microsoft.Exchange.Management.SystemConfigurationTasks.RemoveDatabaseAvailabili
       tyGroupNetwork

    Of course, this is after I run the Set-DatabaseAvailabilityGroupNetwork -Identity DAG2\DAGNetwork02 -ReplicationEnabled:$false -IgnoreNetwork:$true

    Any attempt to remove the subnets results in a new DAGNetwork0X appearing in the Networks with the recently removed subnet.  If I assign the subnet to another network, then I get subnet misconfigured...

    Thursday, September 30, 2010 6:20 PM
  • So, as soon as you remove a subnet from a DAG network, it will be automatically rediscovered, and added to a brand-new DAG network

    Per my research, this behavior is by design. After the network has been disabled and ignored, please go to failover cluster management, set the network to be disabled for cluster use

    Because they are disabled at the cluster level, they will not be re-discovered and re-added


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Tuesday, October 05, 2010 7:39 AM
    Moderator
  • I don't think this solves the problem. After disabling the unneeded networks at the cluster level, the subnets still can't be removed from the dag networks without being automatically recreated. Are these stuck there for good?
    Wednesday, March 23, 2011 2:37 PM
  • I am experiencing the same issue and the above fix does not solve my problem either.

    We connected up two DAG members via integrated 10Gb NICs to test file transfer speed over a 10Gb faux 'crossover' cable briefly.  We created a separate private 192.168.1.x subnet for this test.  Exchange automatically added this network as 'DAGNetwork01', and now I can't remove it using any method.  If I remove the subnets and delete the network 'DAGNetwork02' is created.

    I have another network configured that I am using for DAG cluster traffic.  If this goes down I am happy for it to fall back to the MAPI network, so I don't want to use any other DAG network.

    This is a very frustrating issue since 'Test-ReplicationHealth' powershell script now reports an error that I can't solve.

    Friday, April 27, 2012 1:12 AM
  • Anyone found a solution to this, as we are experiencing the same issue. The cluster has to correct IP/ Subnets but the DAG Networks have incorrect data, need to re-initialze the data for the DAG???
    Tuesday, August 07, 2012 2:54 PM
  • I'm sure there's a way to get Exchange to revalidate the DAG network config and remove anything that isn't correct but I can't find it of course. :-(

    Neill

    Wednesday, August 08, 2012 4:10 PM
  • James Luo was quite correct, but more specifically you need to go to Failover Cluster Manager and connect to your DAG )cluster) name, then go to Nodes, find the server you want to remove and chose Evict.  Confirm the action and then go back to the DAG Network (EMC) and remove it.  You will now be able to remove it and if you go back to the server, the Cluster service will now be disabled.

    Thursday, January 24, 2013 11:39 AM
  • If IPv6 is not being used on that interface, it can also cause the DAG network to be automatically generated after the subnet is removed.  To prevent the auto generation of an unwanted interface, disable IPv6 in network properties.
    Thursday, April 04, 2013 6:21 PM
  • Only on the replication network(s) should this be considered.

    Senior Program Manager, Exchange Customer Advisory Team

    NOTICE: My posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Monday, April 08, 2013 4:15 PM