none
Outlook password prompt

    Question

  • Hello,

    After enabling Outlook Anywhere on my Exchange 2007 server, I'm prompted to enter my logon id and password when I start Outlook 2007.  The pc that runs Outlook 2007 is domain joined, so it shouldn't prompt for a password.  When I enter my credentials, Outlook works without any further problems.  However when I cancel the prompt, Outlook still opens with a 'Need password' message in the right lower corner.  I'm still able to send and receive mails, but when I access the Public folders (PF) or download the Offline Address Book (OAB) I'm prompted for the password again.  After entering the password, I'm allowed access to the PF and I can also download the OAB.

    This makes me believe that there is an incorrect authentication setting, but on all my virtual folders (oab, autodiscover, rpc) are set to Basic Authentication, which should simply work.

    I've searched the internet and found numerous articles but none of the helped. 

    How can I get rid of the password prompt ?

    Thanks

    Regards,

     

    Joeri

     


    JM
    Monday, July 11, 2011 12:50 PM

Answers

  • Hi Joeri,

     

    Basic Authentication?

     

    To drop of the password prompt box, you need to enable NTLM authentication on RPC virtual directory. So now, you need to change the Client authentication method via EMC->Server Configuration->server Properties->Outlook Anywhere. After that, restart IIS service.

     

    Besides, it is required to Domain-joined machine and the domain account, which must be the same as your mailbox account. You may run WHOAMI to verify the current user you are loggin in.

     

     

    Best regards,

    Fiona Liao

    Wednesday, July 13, 2011 3:12 AM
    Moderator

All replies

  • Hi Joeri,

     

    You should try tools>account setting>duble click user account>More settings>Connection>untick connect to excahange using HTTP.

     

    tQ


    lia
    Tuesday, July 12, 2011 2:54 AM
  • Hello,

    I tried that but Autodiscover automatically switches this setting back on. 

    What else could I try ?

    Thanks for your help.

    Regards

    Joeri


    JM
    Tuesday, July 12, 2011 6:47 AM
  • Hello Joeri,

     

    Please correct the authentication methods on the Virtual Directories according to the articles mentioned below.

    Default Authentication Settings for Exchange-related Virtual Directories

    http://technet.microsoft.com/en-us/library/gg263433(EXCHG.80).aspx

     

    OAB: Windows authentication
    Autodiscover: Basic and Windows authentication.

    EWS: Windows authentication

     

     

     

     


    ------------------------------------------------------------Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, July 12, 2011 7:34 AM
  • Hi Joeri,

     

    Basic Authentication?

     

    To drop of the password prompt box, you need to enable NTLM authentication on RPC virtual directory. So now, you need to change the Client authentication method via EMC->Server Configuration->server Properties->Outlook Anywhere. After that, restart IIS service.

     

    Besides, it is required to Domain-joined machine and the domain account, which must be the same as your mailbox account. You may run WHOAMI to verify the current user you are loggin in.

     

     

    Best regards,

    Fiona Liao

    Wednesday, July 13, 2011 3:12 AM
    Moderator