none
Duplicate emails received by an end-user

    Question

  • I am a Consultant and have a client who is receiving duplicate emails.

    The client has a Windows Small Business Server 2003 box running the built-in Exchange software, and the employees use Outlook 2003 on their desktop PCs.

    One of the employees is receiving duplicates of every email received.

    Any ideas on what might be causing this? 

    Thanks.

    Tuesday, August 08, 2006 7:06 PM

All replies

  • Perhaps they've configured an additional email account in Outlook to pull mail through POP/SMTP? I've seen confused people do this. Or perhaps they've configured Exchange to forward a copy of every message to their mailbox, while retaining the original.
    • Proposed as answer by azriq Wednesday, March 16, 2011 1:58 AM
    Tuesday, August 08, 2006 8:51 PM
  • Hi Josh,

    I think you have not got the exact problem.

    Problem :

    In reguler course of acction Outlook first download all new pendign messages & then update the status of mail at server that they are downloaded. But in many cases if link is broken after downloading and prior to updating status at server, the duplicate copy of mail will generated at next downloading process.

    So he is asking solution for this...

     

    Sarang Ratnalikar

    Saturday, November 11, 2006 7:47 PM
  • I am receiving duplicate emails as well from a great number of senders.. and have not created any rules for these particular senders... and often new sendres' emails go directly to my deleted folder, with no duplicate in my Inbox.  I am wondering if it is because my Inbox is so full -- over 5,000 emails sitting in there.  Any ideas?
    • Proposed as answer by deepak.gnu Thursday, August 13, 2009 10:41 AM
    Wednesday, December 20, 2006 5:42 AM
  • I'd like to resurrect this thread as I am having an issue on Office 2003 with only one of my users. This user's profile has been rebuilt, Office has been upgraded from XP to 2003, duplicate Outlook.exe processes do run but have been killed, is not using POP3, has a completely new PST created from scratch and still gets duplicates. My user only has 2 rules which I've checked and verified are not causing an issue.

     

    Aside from completely uninstalling, including deleting registry entries, I am at the end of my rope. Has anyone solved their issue with dups or is this an impossible case?

    • Proposed as answer by wannabatech Tuesday, February 07, 2012 4:48 PM
    • Unproposed as answer by wannabatech Tuesday, February 07, 2012 4:49 PM
    Monday, May 21, 2007 2:24 PM
  • I have exactly the same problem and searched the internet for hours with no luck. It seems to be a common problem but with no solution.

     

    Microsoft should look at giving us a duplicate e-mail remover for Exchange?

     

    Pieter

    Thursday, August 23, 2007 9:28 AM
  • I have seen this issue on several different machines as well with no real fix to it. Sometimes deleting and recreating the mail account works, other times it is never resolved (which is typically the case, more often than not). Definitely not a server-side issue from what I can tell but there's no obvious reason as to why this is happening, or more importantly how to fix it.

     

    I'd really like to see someone from Microsoft step up to the plate on this one. At first it's just mildly inconvenient having to delete a handful of emails over and over whenever downloading new messages but when you're re-downloading thousands of emails at a time it's downright ridiculous, if not crippling.
    Saturday, September 22, 2007 5:36 PM
  • Hi, I'm facing the same problem with you. Using Outlook 2003 SP3, if your read carefully, this problem should be corrected when installing SP1, but it works only a few days, then I'm installing SP2 and 3, today, it happens again. I do not know the actual problem then it means it is not easy to troubleshoot.

     

    Now our users is started calling to ask about this problem, but no concrete answer been given to satisfy them. MICROSOFT, please help us.

     

    Thanks - Sam de Lanun. 

     

     

    Wednesday, September 26, 2007 5:29 AM
  • Hi, I was having the same problem and figure it out.  The problem that I was having is that I had several duplicated and in some cases even triplicated rules.  So what I did was erase all the rules that I had and now is working fine.  I'll leave the procedure just in case you dont know how to do it.

    1. Select "Rules and Alerts" from the "Tools" menu.

    2.Check under "Rule Description" if there are some that are alike then delete one of them.

    That's it.  Hope you find it useful.
    • Proposed as answer by PeachySeaGal71 Thursday, April 07, 2011 7:54 PM
    Wednesday, October 10, 2007 11:01 PM
  • OK some one wake up, there are software vendors out there that have a "plug in" to acomplish this issue, as I am plauged by it also" Someone Knows something and there not sharing. I believe Outlook 2003-07 should have the built in ability to acomplish this simple task so we do not need to spend 30 bucks or more to get it done.

     

    It's in there somewhere, the MS desktop search was a no go, rules don't cut it, but that would be very nice if in the rules ther was a simple check box that said DELETE DUPLICATE MESSAGES AND OR MOVE THEM TO LDADA FOLDER.

     

    How hard could that be?

    It's not I am sure....Hello...

     

     

    J. Theisen

    Friday, October 12, 2007 6:17 AM
  • I have spent the last three weeks with MS Tech support. We are a small company, and just switched to Outlook. I want to leave copies of e:mails on the sever for a few days as a backup. On my office desktop, I get the spontaneous downloads of every email on the server, regardless if it has been read yet. This does not happen on the other machines here at the office, or on my laptop at home.

     

    It is so frustrating to enter the queue with this open case number, get a new person who you have to explain the issue to all over again, turn over control of your computer and watch them stumble through all the steps that I now recognize as useless. They won't aknowledge that this is a known issue, and finally say that I can't leave emails on the server if I want to fix the problem. I have tried to get bumped up the line to a senior tech stateside (no huge issue with Bangalore, but I have hours of valuable time in this already and it's not being resolved) but I seem to be on some kind of tech support Flying Dutchman.

     

    My own research shows up tons of complaints on this issue, and a multitude of third party "delete duplicates" add on programs, but I also wonder why MS can't just issue a patch for this. I'm kind of stuck with Outlook, because my contact software uses Outlook to sync with my cell phone.

     

    I may be looking at something like Thunderbird if this doesn't get resolved fast. I am supposed to get a call back from tech support tomorrow morning, but am not expecting much help. I don't give up easily, but this one has me very frustrated.

     

    Any suggestions?

     

    Monday, November 05, 2007 9:53 PM
  • Okay...I too, am having serious issues with multiple emails.  Until tonight, I was just getting duplicate emails.  But after engaging a computer trouble shooting company, which I thought would solve this problem...I just logged in to find that now I am receiving emails in triplicate!!!  Can somebody PLEASE STOP THE MADDNESS!    What does it take to get Bill Gates to hear the cry of a small minority owned business.  After all...isn't it the "little guy" that helped to make Microsoft "Big Man"
    Wednesday, November 07, 2007 3:03 AM
  • I was able to resolve duplicate emails by not allowing the rules to be in place.  I can't remember exactly where I did this.. but I think there were two places where you shut off the rules you've created.  I had to stop blocking all the blocked email addresses I had entered... which was a drag because I had taken the time to block all the spammers.

    Wednesday, November 07, 2007 4:19 AM
  • The worse it gets the more determined I am. I have had countless sessions with a different support person each time over the last three weeks with this one issue. Each time I re-enter the queue I have to start over. Today alone, after insisting that this go to a higher level of support (it it was easy to fix they would have done it the first 15 times) and was actually on hold twice for 20 minutes................then disconnected. I'm on hold again with an entry level tech who put me back on hold so he can review all the notes. It's Groundhog day.

     

    "If I was the man I was five years ago, I take a FLAMETHROWER to this place"

                                                             --------Al Pacino in the famous scene from "Scent of a Woman"

     

    Thursday, November 08, 2007 8:56 PM
  • Have you tried cancelling your 'rules'?  That worked for me.

    Friday, November 09, 2007 3:53 AM
  • Yep. Actually, I didn't really have any rules-----we just switched to Outlook about a month ago, and have the most basic settings and setup. I have had multiple low level MS Tech support people logging on to my computer. The only changes they have tried is to uncheck all add-ons (nope) deactive Norton e:mail scanning (nein) and deleting and reinstalling the five e:mail accounts we have (nyet). 

     

    I spent most of the day trying to get to a next level tech, got disconnected twice, went through the whole thing again with three different techs (you get a new tech each time you call in with the same case number)----all very frustrating.

     

    I give up. I can't spend any more time with this, but have solved it independently. I installed Thuderbird by Mozilla yesterday, which imported the Outlook emails and folders flawlessly, and I left both up and running overnight. Coming in this morning, Outlook had the typical duplicate downloads from the server, while TB was sqeaky clean.

     

    I know Outlook works fine for most people-----I guess I was just unlucky. But I really resent the circle jerk that MS put me on, with no apparent way to escalate the issue to a senior level.

     

    Good luck to the rest of you.

     

    Friday, November 09, 2007 3:55 PM
  • This is also happening to me. I use Outlook 2003. I receive duplicate emails in the same folder. I have rules created to automatically send emails from senders to certain folders. Previously, it was only happening to one folder. Now it's happening to my general InBox. I have found that if I create a new folder for a sender, for example, Microsoft New, and move all the existing emails in the old Microsoft folder, and then edit the rule to  have all emails from Microsoft sent to the Microsoft New folder, that will eliminate the duplicate emails. I don't know if this will work with the general InBox folder. I have also searched the Internet for a solution, but only found one referring to Outlook Express. And I don't know if this will work with Outlook 2003.
    Wednesday, November 14, 2007 7:32 PM
  • OK, I have not read through all of the postings here but I was able to resolve this issue, thanks

    Monica Tong

    v-30moto@mssupport.microsoft.com

    Microsoft Windows Update Support Professional

    For the follow up with me personally. I do appreciate it.

     

    My problem and resolution were so simple I should have switched my brain to MAC mode, JK MS hugs Bill!! LOL

     

    In all of the cases here, I will almost bet a buffalo nickle that we have in our settings "save a copy on server for xx days" and the box that states delete items from server when I delete them does not work.

    I will almost bet also, we all have more thn one email address and that the "reply to" field is populated with one of the other email addresses we are using.

    I simply turned off "keep a copy on server"

    Now I have over 10-20 accounts I monitor, somewhere in the forwarding proccess (server side) along with the keep copy, and using multiple machines there was a fobar on my end. I like to call it my own little I D ten T error.

     

    So as I admit my failing, the quick and easy way to make this stop is turn off "keep a copy on server" Also as I stated previously, there should be an easy way MS could add a remove duplicate emails from folders and or entire .pst files.

     

    Some coder got it working selling it so it's not rocket surgery.... How bout a plug in MS? It should ALL be hadled by one program Outlook or OE. No need for 3rd party poo poo, too much out there anyway and the MS market place has turned into a software conflict spyware convention which seems to be OK with MS. It should be much stricter as to who can put what up there.

    I am done rambling, bottom line folks turn off "keep a copy on server" see if it stops and make sre you check all your machines you have the accounts on, it only takes one.

     

    Thanks for the follow up Monica Tong,

    let me knowhow u guys make out.

    Thursday, November 29, 2007 11:34 PM
  • Yea, but not leaving the mail on the server provides many limitations that it was designed to overcome.   First, it is a back-up which is especially important if you download email from the road, before you can back-up onto a hard drive at work or home.   Second, at least in my case, if my laptop downloads emails and deletes them before my mopbile device gets a chance to I don't get emails remotely.  I agree with other users.  There has to be a better answer for this as it is quite common.

    I like the rest of the people in this thread really hope we get someone who knows what this problem is all about soon.

    Saturday, December 01, 2007 9:36 PM
  • I've found that this issue is actually due to the 'Rules and Alerts' setup within Outlook. From my experience, Outlook handles rules and POP3 connections differently than a MAPI connection to an Exchange server.

    The issue arises when more than one rule setup in Outlook matches a particular email. A copy of the email is created for each subsequent match in your rule set. If you had 10 rules that all matched a particular email, the user would see 10 copies of the email (assuming they aren't permanently deleted in the rules).

    Try this for testing:

    On the users' machine, disable all the rule checking in Outlook:
    Tools-->Rules and Alerts
    Uncheck all of the boxes next to all of the rules, hit OK, and hit Send/Receive.

    If all of the messages dump into the Inbox without duplication, then you'll need to determine which rules will match that particular email by enabling them one by one (re-check one box at a time using the process above) and Sending/Receiving again.

    Hope this helps.
    Friday, December 14, 2007 12:08 AM
  • I had the same problem and found that i had multiple email rules.

     

    I am sure that this happened after reinstalling outlook 2003.  I had opened a PST file saved before the

    reformatiing and reinstalling. After opening the .pst file i had multiple rules appear. This was not apparent and had no idea that this behaviour was default as this has not happened in previous versions.

     

    To resolve this issue i simply deleted the duplicate email rules. and Voila !!!

     

    Hope this helps

    Monday, December 31, 2007 7:19 PM
  • I trying to find out how to fix a recent problem--I just started receiving duplicate emails for every email.

    Tuesday, February 12, 2008 6:51 PM
  • Thanks for this posting. I'm doing the microsoft dance and have had enough. will now check out other options and say bye bye to OExpress.

    cheers,lncfan

     

    Tuesday, March 04, 2008 5:07 AM
  • My duplicate received e-mails problem in Outlook 2000 was caused by my having duplicate e-mail accounts set up that were using the same incoming mail server.  I did this so I could send e-mails from different addresses as required.

     

    In the Account Properties 'General' tab I have now cleared the 'Include this account when receiving mail or synchronizing' check box for all such accounts, bar one, and I don't expect the problem to recur.

    If it does, I'll post here.

     

    Cheers,

     

    Thursday, April 10, 2008 7:04 AM
  • I have been doing tech support for email (in various roles for various employers)  for the last six years. I have seen this countless times. In most cases the fastest way to correct it is to not leave mail on the server with a POP3 account. (I realize this doesn't work well for some. However, it does correct the problem.) If there is a need/desire to retain mail on the server (for whatever reason) IMAP will generally work much better. This is especially true if more than one email client checks that inbox.

    Some other things I have seen help:
    Extending the time interval between synchronizations. (This is under Tools | Options | Mail Settings | Send/Receive). I believe this defaults to every three minutes.
    Extending the server time out setting. Depending on the Outlook version this may default to 30 seconds or one minute.
    Completely emptying the mailbox, by whichever means, may also provide some temporary relief.

    I gather that the three previous changes matter because the root cause is some sort of timing issue in Outlook and these changes reduce the likelihood of the particular issue. A less popular, though still effective way to address this is moving to a different email client.




    Thursday, April 10, 2008 10:46 AM
  • I have read through the previous posts and I fear that this seems to be a never ending story...

    I can just tell you I have the same thing happening and I'd like to share my experience and see if it helps anyone and if I can get any help.

     

    We have got a central Exchange 2003 server in Europe with many local (LAN connected) users and some remote users (about 200) around the world, which have different slower WAN link connections. We have a mix of Outlook 2002 and Outlook 2003 clients.

     

    Until recently, we have not seen this problem happening at all, but a few weeks ago, when I changed some clients on 2 slow WAN links in Asia (350-400 ms ping time), it immediately started to happen! The 2 sites contain 5+5 users.

     

    Most of the old machines there had Outlook 2002 before, but a few Outlook 2003, and now when installing new machines for them, all got Outlook 2003.

     

    We use the "Use Cached Exchange Mode" on all clients, except on shared computers, and it is working flawlessly on all other remote sites! The other sites do have shorter round trip times though (60-180 ms), and my fear is that the ping time is affecting this.

     

    The duplicates have only been created between users that are located on those two remote sites, also within in the same site and also to external contacts. The thing is that it only happens occasionally!  

    I'm sitting in Europe, and I don't receive any duplicates from them!

     

    When I check the Message Tracking on the Exchange server, I can see that the sender has only sent out one copy of the message, but the receiver gets 2 messages, with different MessageID's, as far as I can see with the next number in the sequence of numbers.

     

    I should also add that we are not using .PST files to store local mails, but they are automatically "synched" down to the .OST file when using Cached Exchange Mode. All mails and other contents (Contacts, Calendar etc.) are sitting on the Exchange server in the user's mailbox as well. Only a copy of it is downloaded / synched to the .OST file.

     

    If this had to do with the Rules and Alerts, why didn't it occur earlier then? No rules or Alerts have been added to these users after the change... And the users that have problems don't even have any rules to start with...

     

    I'm not sure if I have included all important information here now, but I hope it could be of help, both for you and if someone has any suggestions, I'm happy.

    Tuesday, July 08, 2008 12:27 PM
  • yes,

     

    it happens to my client as well,

     

    she is using Office 2003 and connected to Exchange Server 2007 SP1.

     

    the problem exist. but after i upgrade it to Outlook 2007, its all dissapear.

     

    but here comes new episode of problem:

     

    1. Offline Address book error

    2. Shared calendar couldn't display Free/Busy status

    3. Out of office message cannot be set from Outlook 2007

     

    and many more. :-|

     

    Thursday, July 10, 2008 8:48 AM
  •  

    Outlook Express I'm getting too many copies now of each incoming email.

    Net a fix to this?

    Friday, July 18, 2008 4:10 PM
  • You can try reading this article, it may have a fix for you.

    http://support.microsoft.com/kb/284404
    Wednesday, November 26, 2008 3:09 PM
  • J,

    Correct me if I'm wrong, but seems like you are referring to POP based account and not an Exchnage mail account... I am experiencing duplicate mail inside an exchange organization.

    Have not been able to pinpoint it. random users, random scenarios...

    Any thoughts will be apriciated...
    Monday, November 16, 2009 3:24 PM
  • We also have just started to experience this at one of our sites ...... Can't seem to find anything on it.
    Tuesday, November 17, 2009 10:15 PM
  • For the problem started after the upgrade is very normal. Reason being outlook 2003 doesn't use Auto discovery to connect to CAS server.
    But outlook 2007 use auto discover, and in your case surely the problem is that your auto discover is not working.
    To check if auto discovery is working or not open the outlook-press ctrl and then right click outlook icon in task bar-select-test auto discover, there type your email.

    It should show the result  with your email id and path being use to connect to exchange server.

    To correct the auto discover problem tell me the out put first of auto discovery result

    Cheers Nikhil Kalra
    Thursday, December 10, 2009 7:57 AM
  • TRY THIS!! FINALLY works

    1. In Outlook, on the Tools menu, point to Send/Receive Settings, and then click Define Send/Receive Groups.
    2. Double-click the group that contains the two POP3 accounts, and under Accounts, click one of the POP3 accounts.
    3. Click to clear the Receive mail items check box.
    Sunday, April 04, 2010 2:16 AM
  • Try this surely it would work. Trust me Upgrade Exchange 2007 to SP2, it will solve the duplication problem.

    Cheers Nikhil Kalra
    Sunday, April 04, 2010 5:37 AM
  • There are a few things you can check to stop duplicate email messages.

    Start by checking Rules to be sure that copies are not being made to the Inbox, and make sure that all your rules end in "Stop Processing" actions.

    Then check the task manager to be sure that there is only one instance of Outlook running. Two instances of outlook.exe running can produce two messages arriving at the same time. You will need to then determine why two instances of Outlook were running in the first place.

    Another  thing  you can do is to delete/remove ALL your e-mail accounts and recreate them. This worked for some people.



    Finally, another person had this happen when he had two e-mail accounts set up - using two e-mail addresses, but the same POP3 incoming and same SMTP outgoing. What happened is that the second account was getting the e-mails from the POP3 server before they were actually deleted after the first account was finished. If this is the problem you can disable the receive on the second account. There is a Microsoft article explaining the problem more thoroughly at http://support.microsoft.com/?kbid=284404.

    Wednesday, May 19, 2010 10:52 AM
  • You can try reading this article, it may have a fix for you.

    http://support.microsoft.com/kb/284404

    Forget the Rules part. I didn't have any rules to change anyway. Go to this link. It absolutely works! Thank you! And to Dinesh as well. I was plagued by this problem for the past few weeks, ever since I added another email address to the three I already had on Outlook 2003. Just going in and unchecking the box "receive emails" reduced my email from this address from two to one.
    Thursday, June 03, 2010 10:43 PM
  • Hi !

    if you received duplicate e-mails in your outlook express then it can be easily removed using a software. i have used a software that removed all the duplicate e-mails. it works really good. you can find it at :: http://www.removeduplicatecontacts.com

    Friday, August 06, 2010 12:17 PM
  • THIS IS THE ANSWER

     

    The answer is that your mailbox for these users is corrupt and it needs to be repaired. You can run a repair from within the tools in exchange. It may be one users getting duplicates or a few. All we had to do was run a repair on the database and it resolved the issue for us. We just did it and it fixed the issue of duplicates for that user. You can also move the mailbox of the users who are getting duplicates (if you have two exchange boxes) and this will also rebuild the mailboxes on the new exchange server again solving your duplicate issue. 

    Robert Lavigne Kilobytes Data Solutions www.kbytes.com

     

     

    • Proposed as answer by rlavigne Thursday, August 12, 2010 2:41 PM
    Thursday, August 12, 2010 2:41 PM
  • Hi,

    We have decided to move from Windows mobile to the blackberry torch with our mobile provider, on reciving one handset for testing I was also getting duplicate e-mails.  We use a hosted exchange server and BIS through our providor, after a few hours on the phone with our provider deleting our account and recreating the account I have figures out today the problem only occurs when outlook 2007 is open on my desktop, as duplicates would stop when outlook is closed.

    We use Kaspersky Internet Security 2011 on each copy of outlook with built in spam filters which also use rules to move spam to the spam box, when I turn off the spam filter in Kaspersky I stop getting duplicates on the handset even though outlook is open.  Needs a bit more testing but hope this helps.

     

    Darren

    Wednesday, October 27, 2010 1:18 PM
  • You may also want to try out http://www.scrubly.com . This was able to help me out when I had this problem
    Saturday, March 12, 2011 10:23 PM
  • My Solution was to have the POP account download the messages to a temporary pst file and create a rule that applies to all inbound messages to "move a copy of the message", when received, to the inbox of the exchange server.  That way the message comparison between what is being left on the ISP server and the Outlook account all happens between the pst file and the ISP.  The user still does all of the processing of email on the exchange server account.

    Additionally, i added a rule to messages being sent, Since they could also be processed throught the POP account, to move a copy of messages being sent to the "Sent Items" folder on the exchange account. 

    This gives me all messages, wheather inbound or outbound, in my exchange account; Processed through my POP account; while having the "leave messages on the server for 10 Days" active and i get no duplication of messages every time i open Outlook.

    • Proposed as answer by shandtim Friday, June 17, 2011 3:05 AM
    Friday, June 17, 2011 3:04 AM
  • What one really needs to find and delete are the DUPLICATE RULES in the "Rules & ALert" option.
    Thursday, December 08, 2011 9:56 AM
  • Sometimes it is an email that has something quirky with it.

    We have occasionally had this problem, but I have solved it for us.

    When checking email remotely (via the internet, not through Outlook), I can see that there are no duplications.  So..

    After looking at the emails that arrived through Outlook, I delete all those same emails from the remote side.

    Close Outlook and reopen. 

    Solved.

    • Proposed as answer by maultiper Tuesday, May 29, 2012 12:55 PM
    • Unproposed as answer by maultiper Tuesday, May 29, 2012 12:55 PM
    Tuesday, February 07, 2012 6:09 PM
  • Hi,

    Sorry to revive a somewhat old thread. The solution may be as simple as archiving the sent items folder. It seems some versions of outlook have a max size for this. I had this problem. We did an archive and everything cleared right up.

    Tuesday, May 29, 2012 12:58 PM