none
VM 2008 R2 NLB Multicast cas/hub vip not pinging RRS feed

  • Question

  • I have 2 servers, 2008 r2 std with the cas/hub roles installed as well as microsoft nlb.

    There are 2 nics on each server(nic1 is the lan nic, nic2 is the NLB nic)
    Each server is running on a separate esx 4.0 host.

    When setting up the NLB I configured it to use Multicast.
    as suggested in this document:
    http://www.vmware.com/files/pdf/implmenting_ms_network_load_balancing.pdf

    I used the following tutorial to configure the cas/hub installation and the nlb installation
    http://exchangeserverpro.com/how-to-install-an-exchange-server-2010-client-access-server-array

    The 2 nodes converged without an issue using the network load balancing manager in windows.

    i cannot ping the VIP from another server on the same vlan(or from the other cluster node for that matter).

    i can only ping the vip from the machine itself.  For example
    Server1- I can ping the vip of 192.168.1.100
    When i disable the nlb nic on server1, the vip no longer pings(even though the nlb nic on server2 is still up).

    Server2- I can ping the vip of 192.168.1.100
    same issue happens when i disable the nlb nic on this server. the vip is no longer pingable.

    FYI: when i tried to use unicast the 2 nodes would never converge succesfully.  Plus it looks like vmwares suggestion is to use multicast.

    i need to be able to get to that vip from any network.  any help would be much appreciated.

    thank you!

    Monday, September 20, 2010 2:19 PM

Answers

  • the issue was that the gateway needed to have the static route added.

    also this caused a bug in our juniper switches witht he multicast and the network went up and down during the day :) so be careful! 

    Also the forwarding had to be enabled on the servers.

    Friday, October 15, 2010 12:48 PM

All replies

  • Hi

    Try to uninstall IPv6, disable tcp offload and disable chimney

    Do this on both of your "nodes" and restart, then report back status


    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
    Monday, September 20, 2010 3:17 PM
  • uninstall & disable from both nics on both servers?
    Monday, September 20, 2010 3:25 PM
  • uninstall & disable from both nics on both servers?


    ohh sorry, just disable ipv6, it needs to be done in registry

    and yes, on both nics

     


    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
    Monday, September 20, 2010 3:33 PM
  • trying it now ill let you know.

    theres nothing i need to do on teh switches/routers as the following article suggest?

    http://deinoscloud.wordpress.com/2010/02/10/microsoft-network-load-balancing-nlb-on-vmware-esx/

     

    Monday, September 20, 2010 3:43 PM
  • i just unchecked the ipv6 from the nics properties, this is what you meant correct?

    i was able to find the tcp offload, but did not see any chimney settings in the nics.

    still not working.

    Monday, September 20, 2010 3:52 PM
  • disable IPv6

    http://support.microsoft.com/kb/929852

     

    disable tcp offload

    http://www.alacritech.com/Support/FAQs/DisableOffload.aspx

     

    disable tcp chimney

    http://support.microsoft.com/kb/942861

     


    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
    Monday, September 20, 2010 4:21 PM
  • Disable TCP Offload
    Open up regedit and change the value DisableTaskOffload to 1:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TCPIP\Parameters\DisableTaskOffload



    Disable Chimney
    To see the current status, open up an elevated Command-Prompt and type:
    netsh int tcp show global

    Verify that Chimney Offload state is set to disabled.

    To disable type:
    netsh int ip set chimney=disabled



    Disable IPv6
    IPv6 should be disabled on the CAS-servers in order for Outlook Anywhere to operate correctly.

        Start regedit.exe
        Go to the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
        Create the following registry entry:
    Name:        DisabledComponents
    Type:        DWORD (32-bit Value)
    Value (Hexadecimal):    ffffffff
        Close regedit.exe
        Restart the server for the changes to be activated

    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
    Monday, September 20, 2010 4:28 PM
  • Are you doing any NIC pairings in ESX? I have run into random issues with NLB when my VM's have NIC pairings on the back end.
    Jorge R. Diaz PMP, CCNA, MCSE, MCSA Sr. Microsoft Consultant Planet Technologies, Inc.
    Monday, September 20, 2010 4:51 PM
  • no, we have multiple physical nics assign to a vswitch but thats aabout it.

     

    as for the commands its a 2008 server, the command to disable the chimney did not work. but i do see the chimney offload state is set to automatic.

    Monday, September 20, 2010 5:57 PM
  • Have you tried enabled forwarding? It is disabled in 2008 and higher by default. This command would have to be run on both NLB boxes from an elevated command prompt, then rebooted.

     

    netsh interface ipv4 set int "[name of the Cluster NIC]" forwarding=enabled


    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Monday, September 20, 2010 6:25 PM
  • What would the forwarding do? sorry as i am a bit novice to this clustering.

    and i did find the command to disable the chimney it was like you said except tcp not ip.

    Monday, September 20, 2010 6:38 PM
  • ok i set teh forwarind to enabled on both nlb nics on teh servers and still nothing. i cant ping the vip.
    Monday, September 20, 2010 8:46 PM
  • i keep reading about some kind of arp entry in the routing table on the router? does this need to be done?

     

    another note.

    i realized i can ping the vip from a server on the same vlan but it must be on the same esx host as the cluster node.

    Tuesday, September 21, 2010 3:46 PM
  • looks like it was somehing to do with a bad nic in the vmswitch! after removing that nic and recreating the nlb.
    Wednesday, September 22, 2010 6:44 PM
  • Have you applied the arp entry?

    Or you maybe solve the problem in any other way?


    Jonas Andersson MCTS: Microsoft Exchange Server 2007/2010 | MCITP: EMA 2007/2010 | MCSE/MCSA Blog: http://www.testlabs.se/blog
    Thursday, September 23, 2010 7:03 AM
  • i think the cause is probably that you havent used netsh command to enable forwarding on NLB adapter. And double check it because for windows 2008 and r2 they changed netsh commands :)

     

    • Edited by Aivar75 Friday, September 24, 2010 7:17 PM typos
    Friday, September 24, 2010 7:16 PM
  • the issue was that the gateway needed to have the static route added.

    also this caused a bug in our juniper switches witht he multicast and the network went up and down during the day :) so be careful! 

    Also the forwarding had to be enabled on the servers.

    Friday, October 15, 2010 12:48 PM
  • Hi,

     

    I'm having the exact same problem. Could you elaborate on exactly what steps you made? What static route?

     

    Thanks

    Tuesday, November 23, 2010 4:26 PM
  •  

    Hi OldSchoola,

    We are trying to configure NLB with Windows 2003 multicast on ESX servers. We are having the same problem that you were having. We are using Cisco 6509s.

    This link explain everything that we have done so far but we are not able ping the VIP from outside its VLAN. Can you please share with me what was your fix?

    http://communities.vmware.com/message/1875713#1875713

    Thank you!

    Tuesday, December 6, 2011 3:11 PM