none
Outlook 2013 will not connect after moving mailbox from Exchange 2010 to 2013

    Question

  • I am in the process of migrating mailboxes from Exchange 2010 to Exchange 2013. We use Outlook 2013 and can connect to mailboxes on Exchange 2010 with no issue. The problem is that when I migrate the mailbox to the DB on Exchange 2013 Outlook does not redirect Outlook to the new server. If outlook is open when the move is complete a message "The Exchange administrator has made a change that requires you to restart outlook". Upon reopening Outlook a prompt for credentials appears and even though I put the right username/password it keeps promtpting. If I hit cancel I get the "The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete" message. Everything passes in the RPC/HTTP connectivity test at testconnectivity.microsoft.com. Not sure what to do at this point. Any help would be much appreciated.

     -OWA works

    - ActiveSync works

    Thursday, March 20, 2014 8:10 PM

Answers

All replies

  • Is http://support.microsoft.com/kb/2863911 installed? 


    Diane Poremsky [MVP - Outlook]
    Outlook & Exchange Solutions Center
    Outlook Tips
    Subscribe to Exchange Messaging Outlook weekly newsletter


    Thursday, March 20, 2014 8:32 PM
  • Yes, I thought that might fix the issue too, but it made no difference.
    Thursday, March 20, 2014 9:13 PM
  • Check your authentication settings both at the back-end and on the client. 

    This should fix your issue.

    CK

    Thursday, March 20, 2014 9:50 PM
  • Thanks, I followed the Exchange deployment assistant  so I am not sure what else I should be checking in terms of authentication settings
    Thursday, March 20, 2014 9:58 PM
  • what is the internal, external and IIS authentication settings set at the back-end? And how's the RPC over HTTP been configured on the client?

    CK

    Thursday, March 20, 2014 10:13 PM
  • Please have a look at this article: http://support.microsoft.com/kb/2934750

    Hope it helps


    Friday, March 21, 2014 11:27 AM
  • ExternalClientAuthenticationMethods : Negotiate

    InternalClientAuthenticationMethods: Ntlm

    IISClientAuthenticationMethods: basic, ntlm, negotiate

    Rpc over HTTP on client (proxy settings)

    Url to connect to my proxy server: https://owa.(mydomain).com

    connect using ssl only checked

    only connect to proxy servers that have principal name checked

    msstd:owa.(mydomain).com

    on fast networks unchecked

    on slow networks checked

    proxy authentication Basic

    Friday, March 21, 2014 2:28 PM
  • Also when I create a brand new mailbox on Exchange 2013 it works fine and Autodiscover finds it right away. Its only the move from 2010 to 2013 that's the problem.

     
    Friday, March 21, 2014 3:11 PM
  • I guess everyone's just as stumped as me
    Monday, March 24, 2014 2:41 PM
  • Tried to recreate the Outlook profile? 

    CK


    • Edited by CanKILIC Monday, March 24, 2014 3:34 PM
    Monday, March 24, 2014 3:34 PM
  • Re-creating the profile seems to be working about 2 out 3 times. I still have some users that even when I recreate the profile, autodiscover still does not to seem pick up the server guid and put it in there. I seems to be picking up the actual server name instead. very strange. And these are all internal users on the domain.

    Monday, March 24, 2014 8:33 PM
  • Hi,

    According to your description, Autodiscover service pick up server name instead of mailbox GUID for your certain migrated users. If I misunderstand your meaning, please feel free to let me know.

    If yes, I’d like to confirm if the configuration of the problematic users is completed successfully.

    If not, we can try to manually configure the account.
    To get the GUID, we can run : get-mailbox <mailboxname> |fl exchangeGUID
    Please also manually configure Outlook Anywhere settings.

    If you have any question, please feel free to let me know.
    Thanks,

     


    Angela Shi
    TechNet Community Support

    Wednesday, March 26, 2014 3:20 AM
  • This article simply points to http://support.microsoft.com/kb/2863911.

    I have the exact same issue. This update was supposed to fix the problem, but has not. Nothing short of manually repairing or recreating the Outlook profile works, which is not an option when many users are confronted with the problem.

    Friday, March 28, 2014 12:33 AM
  • I finally broke down and opened a case with MS support. According to them, they are having the same problems in the test lab they setup as well. Waiting to hear back about a fix.
    Monday, March 31, 2014 2:54 PM
  • Looks like it may be an issue with the Autodiscover application pool not updating fast enough after the user is moved over to the new server. Re-cycling the app pool seems to help. Still seems like a workaround and not a fix.
    Tuesday, April 01, 2014 7:14 PM
  • Thanks for the update.

    CK

    Tuesday, April 01, 2014 8:14 PM
  • I can confirm that recycling the MSExchangeAutodiscoverAppPool application pool in IIS after completing a migration helps. Until it updates itself, Autodiscover requests are still being sent to the old 2010 server, and a redirect is sent to the 2013 server... This starts a loop and breaks Outlook.

    Seems like a proper fix should be on the Exchange side, not with Outlook.


    • Edited by asidorenko Thursday, April 03, 2014 3:25 AM
    Thursday, April 03, 2014 2:19 AM
  • I agree, hopefully they will come out with a patch for Exchange 2013 to fix this issue.
    Thursday, April 03, 2014 6:22 PM
  • Same issue here... 2013 SP1 on 2012 w/ 2010 SP3 on 2008 R2. Recycling the MSExchangeSyncAppPool and MSExchangeAutodiscoverAppPool seems to fix it. 

    Any update on the premier support ticket(s) on an upcoming fix?

    Cheers,

    Brandon

    Wednesday, April 09, 2014 6:41 AM
  • haven't heard anything
    Friday, April 18, 2014 2:27 PM
  • Any progress someone?

    Also same problem here :(

    Tuesday, April 29, 2014 4:57 PM
  • I have the exact issue it makes doing mailbox moves very difficult any update from microsoft?
    Tuesday, May 20, 2014 4:08 AM
  • I have the exact issue it makes doing mailbox moves very difficult any update from microsoft?

    Please see here

    Thursday, August 21, 2014 1:00 AM
  • Hi,

    We get the same problem with Exchange 2016. Check also the this post.

    You can also edit the Recycling Settings in IIS on the Exchange 2013/16 server for the 4 App bellow and set the fixed Intervals for refresh all 2 minutes during the migration time. :

    Exchange 2013/2016 CAS Server
    •MSExchangeAutodiscoverAppPool
    •MSExchangeRpcProxyFrontEndAppPool

    Exchange 2013/2016 Mailbox Server:
    •MSExchangeAutodiscoverAppPool
    •MSExchangeRpcProxyAppPool

    When the migration finishes Outlook displays a pop-up and asks to be restarted. After restart, Outlook connect to the server automaticly after 1-2  mins max.

    Cheers

    Thierry

    Friday, December 11, 2015 9:55 AM
  • I had a similar if not the same problem after moving a mailbox from Exchange 2010 to Exchange 2016. For me it turned out to be the internalURL of the mapi virtualdirectory, that was set to the internal FQDN of the exchange 2016. When I reconfigured the internalURL to reflect the same URL as the externalURL, the problem was solved.

    Outlook 2010 did not work with internalURL: ex2016.lan.domain.com

    Outlook 2010 did/started to work with internalURL: mail.domain.com

    https://technet.microsoft.com/en-us/library/dn595082%28v=exchg.160%29.aspx

    Strange enough, the configuration of the MAPI URLs is not being described in the Microsoft Exchange Deployment Assistant....

    Wednesday, May 04, 2016 9:39 PM
  • I have the same issue only for  Outlook 2013 clients migrated from Exchange 2010 to 2016.

    The MAPI internal and the external URL are configured same as my external url and the issue is still the same


    Remember to mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you Check out my latest blog posts on http://exchangequery.com Thanks Sathish (MVP)

    Sunday, January 22, 2017 6:17 AM