none
Outlook 2007 on XPsp2 OEM unable to connect to Exchange Server 2003??

    Question

  • Hi

    My outlook 2007 came part and package of the Microsoft Office 2007 Enterprise Edition, and our SBS server runs Exchange 2003.

    After setting up the connection in Outlook to connect too Exchange (when clicking test (check name) on configuration it is successful) --

    The Error Message is so upon start up :

    Cannot Open your Default e-mail Folders, You must connect to microsoft exchange with the current user profile before you can synchronize your folders with your offline folder file..

    When disabling the cached exchange mode the error message changes however, but it is still unable too actually open outlook.

    Cannot open your default E-Mail Folders. The Attempt too log on to the exchange server failed... (after in the configuration the test suceeded.)

    The computer has a fresh copy of XP SP2 OEM, as well as Microsoft Outlook, only other software on is SQL server 2000 (All microsoft Updates installed). The active user is domain controlled and has the same credentials as is used by Exchange.

    After selecting the checkbox under Control Panel -> Mail -> ......... "User Identification" -> Always prompt for login credentials no change is made to this error....

    I then disabled the use of offline folders..... "could not open your default email folders. The information store could not be opened"

    Please provide assistance in any way possible.... ASAP as well if possible.

     

    Thanks a lot

    Marc

    Tuesday, January 23, 2007 9:38 AM

Answers

  • GedMarc,

    I had all the same problems you had, and did the exact same things you did to no avail.

    This is what solved my problem:

    http://support.microsoft.com/kb/913843

    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type DefConnectOpts, and then press ENTER.
    5. Right-click DefConnectOpts, and then click Modify.
    6. In the Value data box, type 0, and then click OK.
    7. Exit Registry Editor.

    Best regards,
    T
    Tuesday, May 29, 2007 3:30 PM

All replies

  • Hi everyone,

    I just installed Office Ultimate 2003 to find that I am having the exact same issue as depicted above. Has anyone found a solution or have any advice as to where I should start?

    • Proposed as answer by bumpomatic Monday, December 19, 2011 12:22 AM
    Sunday, February 04, 2007 11:56 PM
  • I had this issue. To fix it I just closed Outlook. I went into c:\users\%username%\appdata\local\outlook\ and removed any .OST files located within there. Started Outlook again and it rebuilt the mail file. Happy now.

     

    Hope this help!

    Kabe

    Thursday, February 08, 2007 7:31 PM
  • i have tried this, also went into hosts files and added the mainserver to the hosts file.

     

    i have checked all different threads and tried the fixes and still get error message with outlook when i am trying to pick up my email.

    can someone please help as i need to access my emails desperately.

     

    thank you in advance

    Wednesday, February 21, 2007 1:45 PM
  • GEDMARC > > >>> 

    I always forget to edit my host file after a new PC joins the exchange server at a remote site

    If the set up is fine until you actually open outlook for the first time
    Then the usual culprit is your HOST file, it needs to have the following listed

    • the server that the pc logs on to (local dns server)
    • the exchange server
    • the remote dns server

    the host file can be found here -    C:\WINDOWS\system32\drivers\etc

    and should have the above info as below (yours will alter according to your server names) 

    127.0.0.1            localhost
    192.168.0.2       myserver.myservername.local
    192.168.2.1       myexchange01.mydomainname.co.uk
    192.168.2.2       myremotedns01.mydomainname.co.uk

    Sunday, March 04, 2007 8:00 PM
  • The hosts file was not the culprit in this instance... At first i thought it was an thought it was because i was referrencing it by the alias given to the connection. it was not the case either.....

    I have come to realise i think that the actual problem itself is outlook 2007. After tedious tryings and tryings i eventually resorted to a reformat of machine..... setup and re-install all..... create the ost file via outlook 2003, make sure it downloaded the mail and created the first file (as i believe outlook 2007 doesnt do this in certain instances) and then perform an upgrade.

    The problem is not : host files, directory security, access rights, windows group settings, exchange settings, active directory, router firewall, windows firewall, dns names - or complete ip configuration for that matter....

    I have not been able to solve this problem yet..... and as i stated only way around it was a complete reformat (uninstalling office 2007 and installing 2003 did not work either)

    I have a virtual machine to test and try other suggestions too.....

    Marc.

     

    Monday, March 05, 2007 9:58 AM
  • All I did is went to control panel- mail- email account- view or change - reentered my name and hit check name this will establish a connection with the exchange server. restarted outlook and it worked for me.
    Tuesday, March 13, 2007 10:34 PM
  • I had the same error. My solution was:

    Delete all local .ost files

    Reenter my user name in Control Panel-Mail-Accounts-Settings (force me to enter network-login again).

    Then it worked! 

     

    Thursday, March 22, 2007 1:04 PM
  • Anybody happen to have a solution to this?  I'm running into the same issues/symptoms here.
    This time it's Outlook2007 on Vista, connecting to a hosted Exchange server via http proxy.  Any suggestions would be greatly appreciated.
    -C.
    Monday, April 09, 2007 10:27 PM
  • Hi

     

    I had this similar problem today,but it was just with one laptop while the other computers or laptop didnt have this problem..All I did was added the address of the DNS server the tcp/Ip properties and it worked fine..

    Thursday, May 10, 2007 4:51 AM
  • GedMarc,

    I had all the same problems you had, and did the exact same things you did to no avail.

    This is what solved my problem:

    http://support.microsoft.com/kb/913843

    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC
    3. On the Edit menu, point to New, and then click DWORD Value.
    4. Type DefConnectOpts, and then press ENTER.
    5. Right-click DefConnectOpts, and then click Modify.
    6. In the Value data box, type 0, and then click OK.
    7. Exit Registry Editor.

    Best regards,
    T
    Tuesday, May 29, 2007 3:30 PM
  • check this out:

    http://support.microsoft.com/kb/927612/en-us

     

    It worked for me. Peace.

    Tuesday, May 29, 2007 10:43 PM
  • Perfect shot man Wink I'll look up the operations of what exactly that does at some time Smile

    Kind thanks

    Marc.

     

    Wednesday, May 30, 2007 8:42 AM
  • Works great for windows vista  buisness from a remote site over a vpn

     

     

    Thanks

    Sunday, August 19, 2007 8:26 PM
  •  

    This worked like a charm! The only thing is that the RPC folder didn't exist. So I created that too.

     

    Copy and paste this code into a .reg file of your choice (i.e. Outlook2007-FIX.reg) and merge it to you Registry:

     

    Code Snippet

     

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC]
    "DefConnectOpts"=dword:00000000

     

     

    Good luck!

    Regards,

    -Satheesh.net-

    Monday, September 17, 2007 6:25 PM
  • I tried all of the other suggestions listed above.  What worked for me is turning of Windows firewall.  Somehow it was blocking communications.  I need to determine exactly what exception should be made in Windows firewall so that I do not have to leave it off.  Just to note, there was a Microsoft Outlook exception, but it was not allowing Outlook to talk to Exchange.
    Tuesday, September 18, 2007 12:17 PM
  • I found the problem.  An update was installed on the Exchange server,
    Update for Exchange Server 2003 Service Pack 2 (KB924334) - Non-cluster.  Removing this update from the Exchange server allows our computers running Outlook 2007 to connect again without having to disable Windows Firewall.
    Tuesday, September 18, 2007 12:48 PM
  • I have come to find it is only a problem with certain combinations of software installed, Anyways the quick fix is just to install the dotnet 3 SDK and its worked on everypc that i've come across with this problem... I cant say whether or not its registry, i doubt it though... but that sorts out the problem.

    Tuesday, September 18, 2007 8:13 PM
  • Hello,

     

    How do you create the RPC folder?

     

    Thanks,

    JLK

     

    Friday, October 05, 2007 7:02 PM
  • Had a similar problem,  resolved by being sure WINS was set up correctly for the clients.  ie:  don't leave the WINS settings blank, add an internal WINS server if necessary.  Add the WINS server IP to staticly configured TCP/IP clients or add the proper WINS settings for DHCP clients.   

     

    Monday, December 03, 2007 6:40 PM
  • All of these sound like fixes, and believe me I tried them all. What worked for me was to disable "Cached Exchange Mode Settings". You can find it in the Control Panel -> Mail -> E-Mail Accounts -> Change -> More Settings -> Advanced

     

    I am using Outlook 2007 (fresh install)

     

    Hope this helps...

    Thursday, January 24, 2008 2:20 AM
  • Really feel very happy with the solutions. Thanks a lot for your help.
    I was spending more than a week to find the solution. We have renamed the domain AD, SQL, Sharepoint, OWA, OMA,  everything was working but my  clients are unable to check the mail through outlook--RPC connectivity was not working.

    Thanks for your solution,
    clementrosario@gmail.com
    Thursday, March 27, 2008 8:51 AM
  •  

    None of these things helped me, but what DID help in my case was enabling MAPI for my account

    Out of all the accounts, mine was the only one that had MAPI disabled, probably from earlier testing. Tore my hair out on it till I finally compared my account with a coworkers who's RPC was working. Saw the MAPI discrepeancy, and the issue went away. Then proceeded to kick myself for not checking the simple things first

    Wednesday, April 16, 2008 2:40 PM

  • Hi Marc,

    What I did yesterday to solve my problem here is that I force my Domain Controller to Replicate against each other and it seems to solve my Outlook 2007 "Cannot match name in address list" problem.
    Thursday, April 17, 2008 7:20 AM
  •  

    I had this error message pop up recently on my Vista SP1 laptop running Office 2007 against an Exchange 2003 SP2 cluster. I tried everything in this thread, plenty of other suggestions in other threads, and none of them worked for me.

     

    The solution that I eventually found was to login to a different machine entirely (this one happened to be XP) and go through the whole process of setting up and syncing Outlook 2007. This somehow triggered a setting to change, which, after I logged out of that machine and back into my Vista box, allowed me back into Outlook on my regular machine.

     

    Yet another thing to try for this error message.

     

    Thanks,

    -Tim

    Thursday, June 12, 2008 1:29 PM
  • That is for vista not XP!!!
    Wednesday, July 09, 2008 2:43 AM
  •  XwXCrazyloki wrote:
    That is for vista not XP!!!

    Well, I apologize. I didn't realize that providing another potential work-around and/or solution to a very frustrating problem was enough to get people riled up. Seeing as how both XP and Vista are using Office 2007 in my instance, I felt that it was appropriate for me to contribute my story. I see no reason why someone with the same issue running two XP boxes could not attempt the same solution that I proposed, as I don't believe my problem to have been Vista-specific.

     

    Thanks,

    -Tim

    Wednesday, July 09, 2008 1:17 PM
  • none of the above fixed my problem. i did the registry key, completely removed and recreated a mail profile, nothing. if i created a new user account, outlook would work fine, but not on the problematic XP user account.

    the fix that worked: outlook.exe /cleanprofile as listed here: http://www.tech-recipes.com/rx/2161/outlook_2007_clean_up_command_line_switches

    this was on XP sp2 outlook 2007
    Wednesday, July 16, 2008 4:56 PM
  • This fix http://support.microsoft.com/kb/927612/en-us worked well for me. First I tried the reg entry(didn't work) and and had outlook prompt for password(didn't work).

    Thanks
    Thursday, June 11, 2009 11:32 PM
  • outlook.exe /cleanprofile => only this solution works for me thx buddy...

    win XP SP3 ....outlook 2007 (small bussiness office)
    Tuesday, February 02, 2010 6:13 PM
  • I was having the same issue with Outlook 2007 on Windows 7 64-bit. It was driving me insane!  I searched forever online  and I tried a bunch of different solutions.  I deleted the outlook profile, tried VPN connection, or just HTTPS connection and I updated to Office 2007 SP2 but nothing worked.  I finally found the solution today.

    And, the fix was so easy I don't know why it was so hard to find on the internet: outlook.exe was set to run in compatibility mode.  I only had to disable comp. mode to resolve!

    Here is how I fixed it:
    1.  I browsed to the Outlook.exe file in C:\Program Files (x86)\Microsoft Office\Office12
        (for 32 bit OS, the path would be:  C:\Program Files\Microsoft Office\Office12)
    2. I right-clicked on Outlook.exe & clicked on the Compatibility tab
    3. The option called "Run this program in compatibility mode for:" checked & it XP SP3 mode was selected
    4.  I unchecked that option & clicked apply.

    After that, Outlook was able to open my mailbox!

    I checked the other Office exe files and none of the others were set to run in compatibility mode, just Oulook.exe.  I have no idea why.  I didn't change the setting and neither did the guy who had installed Office on that laptop.

    I hope this helps.

    Alicia

    • Proposed as answer by Alicia W. _ Wednesday, February 24, 2010 8:34 PM
    Wednesday, February 24, 2010 8:15 PM
  • Hello Marc..

    Locate and then click the following subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook\RPC


    In my machine there is no RPC. I can go till Outlook but RPC is not present .

    Please guide me on this..

    Thanks in advance
    Monday, March 08, 2010 6:39 AM
  • Dear All

    This RPC Key doesn't help at all however i was able to solve the problem by simply editing the host file like this

    (This solution worked for outlook 2007 and outlook 2010 as well on Windows XP / Windows 7)

     

    10.10.10.100         mail.domainname.local

     

    Regards

     

    Sunday, April 25, 2010 5:26 AM
  • Hi Guys

    had same problem here...

    RPC rege edit didn't help

    I had server names in host file entered as in

    10.10.10.01          server server.domainname.com.au

    and that sort of setup worked fine XP SP2 with office 2003

    upgraded to office 2007

    on first reboot got the exchange connection issue

    in my case, the only thing that fixed it was adding extra entry in hosts file as per Abdul's recommendation so the new hosts file entry is

    10.10.10.01          server server.domainname.com.au server.domainname.local

    that fixed it..

     

    thanks

     

    Wednesday, June 30, 2010 12:32 AM
  • I was have the same issue with outlook 2003 on Windows XP,

    YES it is so easy to sort it out by removing  the compatibility mode check box, the outlook was run as a compatible with windows 2000 not XP.

    Mohamed Ashour, Dubai UAE

     

    Tuesday, July 27, 2010 5:47 AM
  • Thank you Abdul Jaleel Malik!  After much hair pulling, the host file edit worked for me.  
    • Proposed as answer by mizzer Tuesday, September 28, 2010 12:05 PM
    Thursday, July 29, 2010 12:49 AM
  • Compatibility worked a treat for me - what causes it to change though - a user??
    Tuesday, September 28, 2010 12:06 PM
  • This resolved mine problem for a while, but now it went back again.

     

    Friday, January 14, 2011 2:47 AM
  • I thought I would reply to this post with what finally fixed the same issue for me in hopes that the long list of fixes in this post might help the next person.

    The fix that finally worked for me was setting the clock on the user's pc to the correct date and time.  The date and time were incorrect and that was the reason that the pc wouldn't communicate with the Exchange server.  Granted this probably won't be the issue for most people but it just might be the issue for some.

    Thursday, August 09, 2012 8:06 PM
  • This fix worked for me - thank you!
    Thursday, July 10, 2014 9:44 PM
  • After all this work I see here the fix will make some upset.

    1 Control Panel --> mail

    2. Properties of the profile you are having issue with

    3. Click on E-mail Accounts.

    4. Select the Exchange Server account and click on Change.

    5. Uncheck Use Cached...

    6. Click on More Settings.

    7. Select the Security tab and check the Always prompt for logon credentials.

    ok... finish it off. now it should open

    Friday, April 21, 2017 3:22 AM