none
Created DAG But Have Cluster Errors RRS feed

  • Question

  • I recently created a two node DAG. After adding the servers to the DAG the failover cluster manager gave a few errors.

    Event 1205
    The Cluster service failed to bring clustered service or application 'Cluster Group' completely online or offline. One or more resources may be in a failed state. This may impact the availability of the clustered service or application.

    Event 1069:
    Cluster resource 'Cluster IP Address' in clustered service or application 'Cluster Group' failed.

    Event 1240:
    Cluster IP address resource 'Cluster IP Address' failed to obtain a leased IP address.

    I have a valid IP address that I entered in the DAG properties. The two mail servers are listed under the DAG property page as is the witness server and the witness directory. The FSW is located on a file server and the
    Exchange Trusted Subsystem is in the local admin group of the file server.

    Did I configure something incorrectly?

    Monday, November 12, 2012 8:42 PM

Answers

All replies

  • Hi MyKul,

    When i set up my DAG for my 2 Exchange 2010 servers i did not use the failover cluster manager at all, it was all done from the EMC. Could you tell me what steps you followed when you set up your dag? I followed this guide which for me worked a treat http://exchangeserverpro.com/exchange-server-2010-database-availability-group-installation-step-by-step

    See below screenshot for some of my settings. do you see something similar?

    • Marked as answer by mykul Tuesday, November 13, 2012 4:14 PM
    Monday, November 12, 2012 9:36 PM
  • I didn't use the failover cluster to create the DAG either. I used the EMC like whats listed in the link that you provided. I am actually using a guide from that website to perform my migration.

    Everything in your screenshot looks like what I have on my server. I was just concerned about the errors that popped up in the cluster manager. Maybe its nothing to worry about then.


    • Edited by mykul Monday, November 12, 2012 9:52 PM spelling
    Monday, November 12, 2012 9:48 PM

  • Event 1240:
    Cluster IP address resource 'Cluster IP Address' failed to obtain a leased IP address.

    Hello mykul,

    You Cluster IP address resource was configured to obtain IP address from DHCP server?

    If so, change the configuration of the cluster ip address to static and specify an IP address.

    Thanks,

    Evan


    Evan Liu

    TechNet Community Support

    Tuesday, November 13, 2012 9:05 AM
  • Hi

    What do you have on the IP addresses tab from the image above (DAG Properties)?

    Steve

    Tuesday, November 13, 2012 9:09 AM
  • No, its configured with a static IP address.
    Tuesday, November 13, 2012 1:11 PM
  • Try re-configure the IP address of DAG

    Set-DatabaseAvailabilityGroup -Identity <DAG Name> -DatabaseAvailabilityGroupIPAddresses <DAG IP>

    Tuesday, November 13, 2012 1:18 PM
  • When I look in the failover cluster manager the cluster name shows that it is online and that the FSW is online. The DAG propties in Exchange shows the IP address that I entered.

    Is there a powershell command that can show the status of the DAG configuration?

    Tuesday, November 13, 2012 1:22 PM
  • Get-DatabaseAvailabilityGroup

    If it shows everything correct, run this

    Set-DatabaseAvailabilityGroup

    Tuesday, November 13, 2012 1:25 PM
  • The Get command shows the DAG name and the member servers. What is the function of the Set command?
    Tuesday, November 13, 2012 1:27 PM
  • It re-applies the DAG setting to cluster if there's any deviation.
    Tuesday, November 13, 2012 1:37 PM