none
Exchange 2010 sends attachments as winmail.dat

    Question

  • Hi

    Some users are complaining about pdf attachements they received as winmail.dat. This is an internally isue.
    For external mail flow I disabled tnef conversion, seems to work. Is there a possibility to do the same thing for the internal mail flow?

    Regards
    Peter

    Wednesday, March 02, 2011 10:40 PM

All replies

  • hi,

    from Hub Transport server role did you set Rich Text format to never use...

    Organization config - remote domains - default properties - message format tab...

    regards,

     


    Mumin CICEK | www.cozumpark.com
    Wednesday, March 02, 2011 10:52 PM
  • Some users are complaining about pdf attachements they received as winmail.dat. This is an internally isue.
    For external mail flow I disabled tnef conversion, seems to work. Is there a possibility to do the same thing for the internal mail flow?

    Hi Peter,

    Before making any changes it is important to know what clients were involved in both the sending and receiving the messages in question.


    Microsoft Premier Field Engineer, Exchange
    MCSA 2000/2003, CCNA
    MCITP: Enterprise Messaging Administrator 2010
    Former Microsoft MVP, Exchange Server
    My posts are provided “AS IS” with no guarantees, no warranties, and they confer no rights.
    Thursday, March 03, 2011 1:26 AM
  • HI Peter,

    Did you tested by sedning attachment thru OWA to recepient ?. I am agree with Mumin to make changes for Rich format.

    Take a look at below article, which explains you what it winmail.dat and to fight with it... (Its for internet email message) for your knowledge only..

    How e-mail message formats affect Internet e-mail messages in Outlook:

    http://support.microsoft.com/kb/290809

     

     


    Anil
    Thursday, March 03, 2011 3:14 AM
  • Hi Mumin

    I will check that, thanks for the hint.

    Regards
    Peter

    Thursday, March 03, 2011 6:48 AM
  • Hi Mumin

    That setting was already activated. But isn't that only for external mail flow?
    What about internal mail flow? My problem is internally!

    Regards
    Peter

    Thursday, March 03, 2011 4:38 PM
  • Hi PeterN22,

     

    Winmail.dat attachments are included in received e-mail messages is because the Winmail.dat file is used to preserve formatting that the sending client includes in the message, but the receiving client does not recognize the Winmail.dat file.(The original message attachment is not always separate from the Winmail.dat file attachment, and may be included in the Winmail.dat file attachment.)

     

    So it is important to clarify what clients were involved in both the sending and receiving the messages in question.

     

    If this is occur in Outlook, here is a related document for you:

     

    Winmail.dat attachments are included in received e-mail messages in Outlook

    http://support.microsoft.com/kb/278061

     

    Thanks,

     

    Evan


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 08, 2011 4:35 PM
    Moderator
  • Thanks Evan

    I know this kb article.

    There was a migration from exchange 2003 to exchange 2010, and it seems that users could send pdf attachements without problems on the exchange 2003 server, but now the same users have this problem with winmail.dat on exchange 2010.

    Regards
    Peter

    Friday, March 11, 2011 4:43 PM
  • Hi PeterN22,

     

    Do you have any other anti-virus or anti-spam installation when you install the Exchange 2010?

     

    If so, please disable them to have a try.

     

    Thanks,

     

    Evan


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, March 14, 2011 3:00 AM
    Moderator
  • Yes, Forefront 2010 for Exchange, but the problem already existed before Forefront has been installed.

    Monday, March 14, 2011 4:11 PM
  • I thought it would be easier to visualize the solution using a printscreen from Exchange.

    In Microsoft Exchange Server 2010, select Microsoft Exchange On-Premises, select Organization Configuration, select Hub Transport, select the Properties for Default (or Domain name you have defined), select Never Use under Exchange Rich-text format. Save.

    Never Use - Exchange Rich-Text Format - Hub Transport - Organization Configuration - Exchange Server 2010

    • Proposed as answer by dhrosen Tuesday, February 05, 2013 4:05 PM
    Saturday, May 12, 2012 8:18 PM
  • As Brian Day asked above, what clients are involved?

    Is this an Outlook 2007 or 2007 user sending to another Outlook 2007 or 2010 user?

    It would be surprising that you get a winmail.dat attachment in that case.

    Yes, the setting "Exchange Rich-Text Format - Never Use" applies to "Remote Domains" (name of the tab, in fact). Your own domain is not a remote domain so that setting will not help.

    Otherwise, if the client IS Outlook 2007 or 2010, experiment with the options in the link provided by Anil Singh above:

    http://support.microsoft.com/kb/290809


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.

    Sunday, May 13, 2012 11:38 AM
  • Just wanted to say thanks. After months of searching this fixed everything. Thank you thank you thank you. 
    Tuesday, February 05, 2013 4:05 PM
  • TNEF or Exchange Rich-text format or whatever you like to call it should be banned forever!

    Come on!  It's called "neutral" format, but honestly, who else on Earth is using it except Exchange?  And there's something MIME which is a de facto STANDARD out there in the Internet.  Why would we need this "neutral" format which has been causing problem since year 2000 (as far as I could remember)!?

    Oh, I forgot something: I didn't quite understand what "individual user settings" it's talking about.  Where can it be found?  It's talking about every mail contact's "Use MAPI rich text format" option?  Then what if somebody chooses "Use Default Settings" there?  Undefined behaviour??  That's a big loophole in programming!
    • Edited by Horinius Thursday, April 09, 2015 5:15 PM
    Thursday, April 09, 2015 1:36 PM