none
Issue dowloading attachments in OWA, with a correct preview it dowloads corrupted

    Question

  • Hi

    My Exchange is 2010 sp3 RU10

    I am having rather odd issue with some PDF attachment in OWA 2010, in the OWA preview you can see correctly. When I download the attachment (size shown in OWA about 230KB), the downloaded file size is only 1KB, IE, Chrome, Firefox, same result. I can download the same file using Outlook 2010 without any issue.

    Could someone help me?

    thanks in advance.

    Tuesday, March 14, 2017 3:40 PM

Answers

  • Thanks for your response.

    Does this issue affect all of the emails with the PDF attachments? Does it affect both internal and external messages?

    Please try to disconnect this mailbox and re-connect and check the result.

    You can also new-mailboxrepairrequest for this mailbox.

    If it still doesn't work, it's recommended to update the Exchange to the latest version and check the result.

    Hope it helps.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by trank0 Wednesday, June 07, 2017 12:02 PM
    Friday, March 17, 2017 9:41 AM
    Moderator

All replies

  • Have you tried disabling antivirus?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, March 15, 2017 3:24 AM
  • Hi,

    Does this issue affect all of the users or all of the users? What’s the file type after you’ve downloaded the attachments? Still .pdf format?

    Which mailbox policy the problematic uses are using?

    Run the command: (Get-OwaMailboxPolicy). AllowedFileTypes to check if the .pdf type is included or not.

    If not we need to add it with the command as following:

    Get-OwaMailboxPolicy | Set-OwaMailboxPolicy -AllowedFileTypes @{Add="<value1>","<value2>"..}

    Get-OwaVirtualDirectory | Set-OwaVirtualDirectory -allowedFileTypes @{add=".pdf"}

    We also need to check if the user has been already assigned the right OwaMailboxPolicy ( if you’ve several policies) with the following command:

    Get-casmailbox username | fl *policy*

    Hope it helps.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 15, 2017 6:39 AM
    Moderator
  • Here you have the policy, I checked it before write you, it´s fine, but here you have, Antivirus can´t be, if it works fine in Outlook 2010 and 2013 for sure antivirus isn´t the problem. At this momento it only happen to one user, but it happen to me if I enter by OWA with full access right through my mailbox as his mailbox was a sharemailbox.

    Get-OwaMailboxPolicy

    ForceWebReadyDocumentViewingFirstOnPublicComputers  : False
    ForceWebReadyDocumentViewingFirstOnPrivateComputers : False
    ActionForUnknownFileAndMIMETypes                    : ForceSave
    WebReadyFileTypes                                   : {.xlsx, .pptx, .docx, .xls, .rtf, .ppt, .pps, .pdf, .dot, .doc}
    WebReadyMimeTypes                                   : {application/vnd.openxmlformats-officedocument.presentationml.presentation, application/vnd.ope
                                                          nxmlformats-officedocument.wordprocessingml.document, application/vnd.openxmlformats-officedocu
                                                          ment.spreadsheetml.sheet, application/vnd.ms-powerpoint, application/x-mspowerpoint, applicatio
                                                          n/vnd.ms-excel, application/x-msexcel, application/msword, application/pdf}
    WebReadyDocumentViewingForAllSupportedTypes         : True
    WebReadyDocumentViewingSupportedMimeTypes           : {application/msword, application/vnd.ms-excel, application/x-msexcel, application/vnd.ms-powerp
                                                          oint, application/x-mspowerpoint, application/pdf, application/vnd.openxmlformats-officedocumen
                                                          t.wordprocessingml.document, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet,
                                                           application/vnd.openxmlformats-officedocument.presentationml.presentation}
    WebReadyDocumentViewingSupportedFileTypes           : {.doc, .dot, .rtf, .xls, .ppt, .pps, .pdf, .docx, .xlsx, .pptx}
    AllowedFileTypes                                    : {.rpmsg, .xlsx, .xlsm, .xlsb, .tiff, .pptx, .pptm, .ppsx, .ppsm, .docx, .docm, .zip, .xls, .wmv
                                                          , .wma, .wav...}
    AllowedMimeTypes                                    : {image/jpeg, image/png, image/gif, image/bmp}
    ForceSaveFileTypes                                  : {.vsmacros, .ps2xml, .ps1xml, .mshxml, .gadget, .psc2, .psc1, .aspx, .wsh, .wsf, .wsc, .vsw, .v
                                                          st, .vss, .vbs, .vbe...}
    ForceSaveMimeTypes                                  : {Application/x-shockwave-flash, Application/octet-stream, Application/futuresplash, Application
                                                          /x-director}
    BlockedFileTypes                                    : {.vsmacros, .msh2xml, .msh1xml, .ps2xml, .ps1xml, .mshxml, .gadget, .mhtml, .psc2, .psc1, .msh2
                                                          , .msh1, .aspx, .xml, .wsh, .wsf...}
    BlockedMimeTypes                                    : {application/x-javascript, application/javascript, application/msaccess, x-internet-signup, tex
                                                          t/javascript, application/xml, application/prg, application/hta, text/scriplet, text/xml}
    PhoneticSupportEnabled                              : False
    DefaultTheme                                        :

    tell me if there´s something wrong.

    Thanks

    Wednesday, March 15, 2017 1:10 PM
  • Thanks for your response.

    Does this issue affect all of the emails with the PDF attachments? Does it affect both internal and external messages?

    Please try to disconnect this mailbox and re-connect and check the result.

    You can also new-mailboxrepairrequest for this mailbox.

    If it still doesn't work, it's recommended to update the Exchange to the latest version and check the result.

    Hope it helps.


    Regards,

    Jason Chao


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by trank0 Wednesday, June 07, 2017 12:02 PM
    Friday, March 17, 2017 9:41 AM
    Moderator
  • Hi, finally the user left me to disconnect the mailbox, I´ve disconnect and reconnect the mailbox, and I waited 24 hours because the OWA need the mailbox complete the replication, but it doesn´t work for me, I enter on the OWA with the user affected and no work, it still try to download the file with only 1kb, I´ve start to compare this user with my user and others and I find some old AD certificates expired, I remove them but the same.

    BUT.... the most curious, the user informe me right now, it works.... but I´ve tried to check if it really works, and for me, no, it doesn´t work, still downloanding in 1 kb, I´m hallucinating, for now we considerer the issue resolved.

    thanks a lot dude, I will report more info if I found more cases.


    • Edited by trank0 Wednesday, June 07, 2017 12:04 PM
    Wednesday, June 07, 2017 12:02 PM
  • Check Antivirus rules on Exchange server ,AV might have causing the issue and also AV at local desktop where you are tying to download.  disable and check

    check the attachment policies on CAS/HUB

    Check at gateway level  ,there might be issue the attachments?

    Thursday, June 08, 2017 4:39 AM