locked
How to automatically accept meeting request? (Exchange end)

    Question

  •  

    Environment: Outlook2007+Exchange 2007

    I know in OL2007 we can use tools->option->calendar option->resource scheduling->processing meeting request.

     

    But, can we configure it in Exchange side?

     

    (To be mentioned, the mailbox which accept the meeting request are not "Room Mailbox")

     

    Thank you!

    Tuesday, July 8, 2008 9:52 AM

Answers

  • Hello Tony,

     

    For room/resource mailbox you can set it with below command.

     

    Set-MailboxCalendarSettings “RoomMailbox” -AutomateProcessing:AutoAccept

     

    But if it user mailbox then you can not.

     

    However you can try this into test env. first to find the pros & cons, convert user mailbox to room and set automateprocessing and convert it back to room to user mailbox which keeps the calendar processing settings AutoAccept. You need to run this from Exchange Server.

     

    Set-Mailbox “User” -Type Room

    Set-MailboxCalendarSettings “User” -AutomateProcessing:AutoAccept

    Set-Mailbox “User” -Type Regular

    Tuesday, July 8, 2008 10:26 AM

All replies

  • Hello Tony,

     

    For room/resource mailbox you can set it with below command.

     

    Set-MailboxCalendarSettings “RoomMailbox” -AutomateProcessing:AutoAccept

     

    But if it user mailbox then you can not.

     

    However you can try this into test env. first to find the pros & cons, convert user mailbox to room and set automateprocessing and convert it back to room to user mailbox which keeps the calendar processing settings AutoAccept. You need to run this from Exchange Server.

     

    Set-Mailbox “User” -Type Room

    Set-MailboxCalendarSettings “User” -AutomateProcessing:AutoAccept

    Set-Mailbox “User” -Type Regular

    Tuesday, July 8, 2008 10:26 AM
  • Hi, Amit~I tried your proposal and it works well!

     

    I'll hava a futher test about this to see if there is any other effect.

     

    Thank you so much

    Tuesday, July 8, 2008 10:40 AM
  • That’s great…!! It would be appreciated if you update here with any side effects, incase you get.

     

    Thanks...

    Tuesday, July 8, 2008 11:05 AM
  • i too have a similar issue and tried your solution, Amit. It seems to work very well. However, I cannot force calendar appointments if there is a conflict. Do you know how I might make that happen?
    Thursday, April 23, 2009 8:39 PM
  • hello,

    in the Update Rollup 7 for Exchange Server 2007 Service Pack 1

    959952        The Set-Mailbox command does not change the AutomateProcessing attribute for an Exchange Server 2007 user when a regular user mailbox is converted from a room mailbox

    you switch off this chance. how i can disable this hotfix?

    greets

    Monday, October 12, 2009 11:29 AM
  • i tried this on a uer mailbox (converting to room, setting automateprocessing:none, then set back to user).  now the meeting requests go into the users inbox, but after approx 3 minutes, they are auto-accepted.  any ideas as to why?
    Thursday, February 11, 2010 2:03 PM
  • I understand this response is years late but hopefully this can help future users/sys admins.  I was receiving the same issue where our employees were scheduling meetings for a particular conference room and the mailbox was allowing multiple meets on top of other meetings ignoring the "Conflict"

    If you're experiencing this issue, please ensure within Exchange for that mailbox your Resource booking Attendant is enabled.  This can be done by following the steps shown below.

    Exchange Management Console > Mailbox > search the Mailbox in question > open the properties > Resource General (tab) > check box Enable Resource Booking Attendant.

    This feature will allow the mailbox to AutoAccept/Decline depending on if there is already a meeting during that time frame.  Hope this help! :)

    Thursday, May 11, 2017 3:00 PM