none
There is an error with your web service settings that cannot be repaired automatically. Please Contact Product Support RRS feed

  • Question

  • I get the above error message (in the title of this post) when I try to setup my remote website.  When I try to access the remote website, I receive the error message below.

    Please let me know what I need to do to correct the error.  Thanks!

    When accessing my remote website on Windows Server 2012 Essentials, I receive the following error message:

    Server Error in '/' Application.

    Could not load file or assembly 'Wssg.Web.Internal, Version=6.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

                 Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.            

    Exception Details: System.IO.FileNotFoundException: Could not load file or assembly 'Wssg.Web.Internal, Version=6.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    Source Error:
    The source code that generated this unhandled exception can only be shown when compiled in debug mode. To enable this, please follow one of the below steps, then request the URL:

    1. Add a "Debug=true" directive at the top of the file that generated the error. Example:

      <%@ Page Language="C#" Debug="true" %>

    or:

    2) Add the following section to the configuration file of your application:

    <configuration>
       <system.web>
           <compilation debug="true"/>
       </system.web>
    </configuration>

    Note that this second technique will cause all files within a given application to be compiled in debug mode. The first technique will cause only that particular file to be compiled in debug mode.

    Important: Running applications in debug mode does incur a memory/performance overhead. You should make sure that an application has debugging disabled before deploying into production scenario.
                      

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'Wssg.Web.Internal, Version=6.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' could not be loaded.
    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
    
                      

    Stack Trace:
    [FileNotFoundException: Could not load file or assembly 'Wssg.Web.Internal, Version=6.2.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.]
       Microsoft.WindowsServerSolutions.Web.RootSite._Default.InitializeCulture() +0
       ASP.default_aspx.FrameworkInitialize() +42
       System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +68
       System.Web.UI.Page.ProcessRequest() +119
       System.Web.UI.Page.ProcessRequest(HttpContext context) +99
       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +913
       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +165
    
                      


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18447            

    Thanks. Paul Carvajal

    Sunday, February 23, 2014 6:53 PM

All replies

  • I had an issue like this recently, IIS had been enabled to allow 32bit applications.

    http://gallery.technet.microsoft.com/Windows-Server-Essentials-556159c3

    If you run this script, it should tell you which settings are incorrect.

    Usually it is the Application Pools.


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    Sunday, February 23, 2014 7:45 PM
    Moderator
  • Thank you for the quick response.  There were three items in red - any suggestions on how to correct? 

    Testing Dashboard Certificate..

    Dashboard Certificate         : Error

    Pool Name          : ConnectivityAppPool

    Enabled 32bit Apps : False

    .NET Version       : v4.0

    State              : Stopped

    Pool Name          : RemoteAppPool

    Enabled 32bit Apps : False

    .NET Version       : v4.0

    State              : Stopped


    Thanks. Paul Carvajal

    Monday, February 24, 2014 11:48 AM
  • You need to start those App Pools firstly, which you can do via IIS Manager.

    For the certificate thumprint, basically a registry key holds the thumprint of a certificate and it has to match what is inside the personal store.

    I will put some instructions together.


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    Monday, February 24, 2014 12:04 PM
    Moderator
  • I got the app pools started.  And thanks for the quick response!  I look forward to the instructions.

    Thanks again!


    Thanks. Paul Carvajal

    Monday, February 24, 2014 12:17 PM
  • If you run this in PowerShell - what is the Value for LocalMachineCert ?

    Get-ItemProperty "HKLM:\Software\Microsoft\Windows Server\Identity"

    It should match this:

    Get-ChildItem cert:\localmachine\my | where { $_.Subject -eq "CN=$env:COMPUTERNAME" } | foreach {$_.Thumbprint }


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    Monday, February 24, 2014 3:33 PM
    Moderator
  • Here is what was returned:

    PS C:\Windows\system32> Get-ItemProperty "HKLM:\Software\Microsoft\Windows Server\Identity"


    SERVERTYPE        : AD
    CAName            : Workgroup-BEAST-CA
    CATemplate        : CertificateTemplate:WindowsServerSolutionsComputerCertificateTemplate
    LocalMachineCert  : 8782713016B6F5D2AAF7F267017F9E3E081AFB8B
    ServerName        : BEAST
    CertServiceSiteId : 2
    PSPath            : Microsoft.PowerShell.Core\Registry::HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Server\Identity
    PSParentPath      : Microsoft.PowerShell.Core\Registry::HKEY_LOCAL_MACHINE\Software\Microsoft\Windows Server
    PSChildName       : Identity
    PSDrive           : HKLM
    PSProvider        : Microsoft.PowerShell.Core\Registry

     


    Thanks. Paul Carvajal

    Tuesday, February 25, 2014 1:15 AM
  • I'm not getting a return - my server name is Beast - is this correct?

    Get-ChildItemcert:\localmachine\my |where{$_.Subject-eq "CN=$env:BEAST"}|foreach{$_.Thumbprint}


    Thanks. Paul Carvajal

    Tuesday, February 25, 2014 1:25 AM
  • ok I got it - they both equal.


    Thanks. Paul Carvajal

    Tuesday, February 25, 2014 2:06 AM
  • OK, now the AppPools are started, does the website load or do you get the same error?

    If you run the script again, do you see any other errors?


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    Tuesday, February 25, 2014 4:21 PM
    Moderator
  • Same error - no new errors - when I load the website.

    When I run the script again, most of the time it's just the Dashboard Certificate error.  Occassionally the ConnectivityAppPool and RemoteAppPool stop and I restart them.


    Thanks. Paul Carvajal


    Tuesday, February 25, 2014 4:44 PM
  • Actually the dashboard error - is a bug.

    I saved a new version on the gallery which should fix that.

    OK, so i guess at this point the Anywhere Access wizard still gives an error when trying to run?

    Did you choose to manually configure the router or is it set to do it automatically via UPnP?


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+

    • Proposed as answer by waynel 16 hours 29 minutes ago
    Wednesday, February 26, 2014 12:59 PM
    Moderator
  • That is correct I still get the error. I always manually set the router up. Where do I find the gallery?
    Wednesday, February 26, 2014 1:12 PM
  • http://gallery.technet.microsoft.com/Windows-Server-Essentials-556159c3

    If it is failing at the AnywhereAccess wizard stage i doubt my script will identify the issue.

    Have you looked at any of the log files?

    c:\program data\microsoft\windows server\logs ?

    Try the Dashboard.log file first.


    Robert Pearman SBS MVP
    itauthority.co.uk | Title(Required)
    Facebook | Twitter | Linked in | Google+


    Wednesday, February 26, 2014 5:27 PM
    Moderator
  • Thanks again for the reply.

    I have run the new script dated 2/2/2014 and I receive the following errors:

    Virtual Directory   : /home

    Application Pool    : ConnectivityAppPool

    Content Path        : C:\Program Files\Windows Server\Bin\WebApps\CloudTest

    Testing Dashboard Certificate..

    Dashboard Certificate         : Error

    Dashboard Certificate         : Error

    Dashboard Certificate         : Error

    Dashboard Certificate         : OK

    WSS Hosted Email Service                      : Stopped Disabled

    WSS Identity Management Service               : Running Auto

    WSS Initialization Service                    : Running Auto

    WSS Networking Helper Service                 : Running Auto

    WSS Notifications Provider Service            : Running Auto

    WSS Office 365 Integration Service            : Stopped Disabled

    WSS On-Premises Exchange Integration Service  : Stopped Disabled

    WSS Password Synchronization Service          : Stopped Disabled

    As far as the log files, I looked at these, nothing stood out to me, however, I don't have the knowledge to accurately determine this.  I have posted the log files that have been updated since I tried to run the script and Anywhere Wizard.

    http://1drv.ms/1mSAgjz

    Thanks!


    Thanks. Paul Carvajal


    Saturday, March 1, 2014 6:48 PM