none
exchange content index state failed

    Question

  • Hello

    Any body can help me:

    I had configured DAG, unfortunately Server witnes and the second had to be excluded.

    I delete DAG and now i have problem with "exchange content index state failed"

    I trying fixed using command : Update-MailboxDatabaseCopy "STAFF\STJSRV-031" -CatalogOnly" but i got 

    Database "Staff\STJSRV-031" has only one copy. This task is supported only for databases that have more than one copy.
    + CategoryInfo : InvalidOperation: (Staff:ADObjectId) [Update-MailboxDatabaseCopy], InvalidOperationExcep
    tion
    + FullyQualifiedErrorId : 78A7D1AB,Microsoft.Exchange.Management.SystemConfigurationTasks.UpdateDatabaseCopy

    Somebody can me help how fixed this. I have one server, DAG and second server now not exist. 

    Saturday, August 11, 2012 7:32 AM

Answers

  • Thanks for help. This was usefull but problem was related with DATABASE, exacly on ADSI > configuration>Services>Administration group> Exchange Administration Group> DATABASES was items with one more server. 

    I dont know how this items find on this, EMC not showing any others servers. 

    But after delete second server,  now "exchange content index state failed" back to normal.

    • Proposed as answer by Doemae Saturday, August 11, 2012 8:40 AM
    • Marked as answer by Honou Saturday, August 11, 2012 8:47 AM
    Saturday, August 11, 2012 8:36 AM

All replies

  • try to run in the \scripts folder this

    ResetSearchIndex.ps1 –force DatabaseName
    (be sure to run this from an elevated prompt)

    Saturday, August 11, 2012 7:57 AM
  • No, not work: I have this notice:

    [PS] C:\Windows\system32>ResetSearchIndex.ps1 -force Staff
    The term 'ResetSearchIndex.ps1' is not recognized as the name of a cmdlet, function, script file, or operable program.
    Check the spelling of the name, or if a path was included, verify that the path is correct and try again.
    At line:1 char:21
    + ResetSearchIndex.ps1 <<<< -force Staff
    + CategoryInfo : ObjectNotFound: (ResetSearchIndex.ps1:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

    Saturday, August 11, 2012 8:07 AM
  • [PS] C:\Windows\system32>ResetSearchIndex.ps1 -force Staff

    The script is in our exchange folder -> V14 -> scripts
    pls run the script from there

    Saturday, August 11, 2012 8:16 AM
  • Thanks for help. This was usefull but problem was related with DATABASE, exacly on ADSI > configuration>Services>Administration group> Exchange Administration Group> DATABASES was items with one more server. 

    I dont know how this items find on this, EMC not showing any others servers. 

    But after delete second server,  now "exchange content index state failed" back to normal.

    • Proposed as answer by Doemae Saturday, August 11, 2012 8:40 AM
    • Marked as answer by Honou Saturday, August 11, 2012 8:47 AM
    Saturday, August 11, 2012 8:36 AM