locked
Terminal Server redirected printing keeps failing with Error 372 The data area passed to a system call is too small. RRS feed

  • Question

  • Hello,

    I've been battling one of the most annoying issues ever with one of my terminal servers. The server runs Windows 2012 R2 Standard. For some reason the redirected printing keeps failing, and several errors will show up in the log as Print Service -- Event ID 372. 

    Here is an example:

    The document Print Document, owned by nickb, failed to print on printer Dell Color MFP E525w (redirected 10). Try to print the document again, or restart the print spooler. 
    Data type: RAW. Size of the spool file in bytes: 96652. Number of bytes printed: 0. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: \\TS1. Win32 error code returned by the print processor: 122. The data area passed to a system call is too small.

    This will happen to several users, all with the same error message.

    The current fix is to restart the terminal server, and all will be good for a few hours and then randomly they'll all start failing again.

    Restarting the spooler does nothing.

    The issue started about three weeks ago. I removed Windows updates that were run since then and the issue still exists.

    I've also tried swapping out the NIC card as well (Total shot in the dark) and that did not help either.

    It'll be for random users all trying to print to different printers.

    Any ideas or solutions would be greatly appreciated!

    Thank you.
    Friday, June 3, 2016 7:09 PM

Answers

All replies