locked
New users not showing up in GAL RRS feed

  • Question

  • New users are not showing up in the GAL on Outlook clients. If I switch to the All Users address list, the new users do show up. They also do show up via OWA. Downloading the address book in Outlook generates the following error: "0x8004010F. The operation failed. An object cannot be found."

    Also, FYI, we just migrated from Exchange 2003 that was part of Small Business Server to Exchange 2010.

    Thanks in advance for any assistance!

    Thursday, June 23, 2011 4:56 PM

Answers

  • Hi,

     

    From the problem description, I understand that new created users are not displayed in the OAB on the Outlook client. However, the new user could show up in the OWA.

     

    So the issue could be related to the OAB. Firstly, we need to check whether the users have been set the msExchHideFromAddressLists = 1. If so, please change it to the 0.

     

    Firstly, I suggest that you could run the following command in the Exchange Management Shell on your OAB generation server:

     

    Set-EventLogLevel “MSExchangeSA\OAL Generator” -Level “Expert”

     

    Then run the following command to update the offline address book:

     

    Update-OfflineAddressBook -identity “Your Offline Address Book Name

     

    Finally, verify whether the Event ID 9107 has been recorded in the application logging file or not.

     

    Thx,

    James


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by James Xiong Monday, July 18, 2011 9:33 AM
    • Marked as answer by James Xiong Tuesday, July 19, 2011 12:44 AM
    Friday, June 24, 2011 8:22 AM

All replies

  • I believe you are using Web base distribution method for generate OAB. You can also generate OAB in EMC.

    Error message when Outlook synchronizes an offline address book with Exchange Server 2007 and Exchange Server 2010: "0x8004010F"

    http://technet.microsoft.com/en-us/library/cc411331(EXCHG.80).aspx

    http://support.microsoft.com/kb/939765

    http://social.technet.microsoft.com/Forums/en-US/exchange2010/thread/b12fb4e6-9da2-450e-b994-0b90eb5252bc

    I will also suggest you to post this question in SBS forum as SBS has some other feature.


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Thursday, June 23, 2011 5:13 PM
  • hi,

    check your database properties and client tab for OAB assignment to database.

    if not assign it to database.

    then update your OAB and download it at the client side from outlook.

    regards,

     


    Mumin CICEK | www.cozumpark.com | Please click Vote As Helpful if it is helpful for you and Propose as Answer!!!
    Thursday, June 23, 2011 8:13 PM
  • Hi,

     

    From the problem description, I understand that new created users are not displayed in the OAB on the Outlook client. However, the new user could show up in the OWA.

     

    So the issue could be related to the OAB. Firstly, we need to check whether the users have been set the msExchHideFromAddressLists = 1. If so, please change it to the 0.

     

    Firstly, I suggest that you could run the following command in the Exchange Management Shell on your OAB generation server:

     

    Set-EventLogLevel “MSExchangeSA\OAL Generator” -Level “Expert”

     

    Then run the following command to update the offline address book:

     

    Update-OfflineAddressBook -identity “Your Offline Address Book Name

     

    Finally, verify whether the Event ID 9107 has been recorded in the application logging file or not.

     

    Thx,

    James


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Proposed as answer by James Xiong Monday, July 18, 2011 9:33 AM
    • Marked as answer by James Xiong Tuesday, July 19, 2011 12:44 AM
    Friday, June 24, 2011 8:22 AM
  • Hi,

     

    Any update?

     

    Thx,

    James


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, June 30, 2011 9:01 AM
  • Are the outlook users working in offline mode? 

     

    Regards,

    Sree 

    Thursday, June 30, 2011 11:09 AM
  • James... unfortunately I have been swamped with other projects and haven't had the opportunity to try any of these fixes. I will hopefully delve into this over the weekend and report back.

     

    Sree... we are using Outlook in Cached Exchange Mode.

     

    Thanks.

    Thursday, June 30, 2011 7:30 PM
  • Hi,

     

    How is everything going? If there is anything unclear or any inquires towards the issue. Please drop me a note!

     

    Thx,

    James


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 13, 2011 6:19 AM
  • Quick Check.

    Can you confirm whether the email address mentioned in the AD object and the Primary email address are same? If not it wont apear in GAL. I experienced this.

    Please check this as well

    Wednesday, July 13, 2011 6:45 PM
  • Hi Folks. Thanks for the replies. No luck yet, but I still have some suggestions to try. Here is what I know so far...

     

    Rajkumar, how do I know which email address is primary? The Exchange Email Addresse tab shows two email addresses, one that is .com and one that is .local. However, neither is labeled as primary. The AD General tab shows the .com address.

     

    James, I ran the Update-OfflineAddressBook -identity command. I did get the 9107 event ID. This didn't make a difference.

     

    I wasn't sure about how to check whether the users have been set the msExchHideFromAddressLists = 1. Can you provide me with any additional details?

    Tuesday, July 19, 2011 3:19 AM
  • Primary Email-address shows in bold in Email address field TAB.

    To set msExchHideFromAddressLists = 0, Type below cmdlet in PS console and then verify OAB in outlook.

    set-mailbox "user " -HiddenFromAddressListsEnabeld $false


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com
    Tuesday, July 19, 2011 4:50 AM
  • Primary Email-address shows in bold in Email address field TAB.

    To set msExchHideFromAddressLists = 0, Type below cmdlet in PS console and then verify OAB in outlook.

    set-mailbox "user " -HiddenFromAddressListsEnabeld $false


    Anil MCC 2011,ITIL V3,MCSA 2003,MCTS 2010, My Blog : http://messagingschool.wordpress.com


    Here is the result I get when I run that command:

    [PS] C:\Windows\system32>set-mailbox elee -HiddenFromAddressListsEnabeld $false
    A positional parameter cannot be found that accepts argument '-HiddenFromAddressListsEnabeld'.
        + CategoryInfo          : InvalidArgument: (:) [Set-Mailbox], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Set-Mailbox

     

    What am I missing? Thanks!

    Tuesday, July 19, 2011 2:02 PM
  • remove the space and add a colon, like this:

     

    set-mailbox elee -HiddenFromAddressListsEnabeld:$false

    You also need to make sure one address is the primary address on the mailbox.


    DJ Grijalva | MCITP: EMA 2007/2010 SPA 2010 | www.persistentcerebro.com
    Tuesday, July 19, 2011 2:15 PM
  • On the client, check to make sure that it's not setup to use "cache Exchange Mode".
    Tuesday, July 19, 2011 4:03 PM
  • remove the space and add a colon, like this:

     

    set-mailbox elee -HiddenFromAddressListsEnabeld:$false

    You also need to make sure one address is the primary address on the mailbox.


    DJ Grijalva | MCITP: EMA 2007/2010 SPA 2010 | www.persistentcerebro.com


    I am still getting the same error message as specified above:

    [PS] C:\Windows\system32>set-mailbox elee -HiddenFromAddressListsEnabeld:$false
    A positional parameter cannot be found that accepts argument '-HiddenFromAddressListsEnabeld:'.
        + CategoryInfo          : InvalidArgument: (:) [Set-Mailbox], ParameterBindingException
        + FullyQualifiedErrorId : PositionalParameterNotFound,Set-Mailbox

    What am I missing? Thanks.

    Tuesday, July 19, 2011 9:06 PM
  • On the client, check to make sure that it's not setup to use "cache Exchange Mode".

    If I turn off Cached Exchange Mode, the missing users do show up in the GAL. As soon as a I turn Cached Exchange Mode back on, these same users all disappear from GAL.
    Tuesday, July 19, 2011 9:07 PM
  • On Tue, 19 Jul 2011 21:06:10 +0000, EdwardLee wrote:
     
    >
    >
    >remove the space and add a colon, like this:
    >
    >
    >
    >set-mailbox elee -HiddenFromAddressListsEnabeld:$false
    >
    >You also need to make sure one address is the primary address on the mailbox.
    >DJ Grijalva | MCITP: EMA 2007/2010 SPA 2010 | www.persistentcerebro.com
    >
    >I am still getting the same error message as specified above:
    >
    >[PS] C:\Windows\system32>set-mailbox elee -HiddenFromAddressListsEnabeld:$false A positional parameter cannot be found that accepts argument '-HiddenFromAddressListsEnabeld:'. + CategoryInfo : InvalidArgument: (:) [Set-Mailbox], ParameterBindingException + FullyQualifiedErrorId : PositionalParameterNotFound,Set-Mailbox
    >
    >What am I missing? Thanks.
     
    Are you copying and pasting that string from a web page? Try typing
    the entire thing yourself and correcting the typo at the end of the
    parameter name. You've misspelled "Enabled" by transposing the letters
    "e" and "l".
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Wednesday, July 20, 2011 1:17 AM
  • Thanks Rich. I was copying and pasting. So, catching that typo got the command to run correctly. Unfortunately, it didn't fix the issue. The user is still not showing up in the GAL and I am still seeing error 0x8004010F when downloading the address book.
    Wednesday, July 20, 2011 3:11 AM
  • On Wed, 20 Jul 2011 03:11:59 +0000, EdwardLee wrote:
     
    >Thanks Rich. I was copying and pasting. So, catching that typo got the command to run correctly. Unfortunately, it didn't fix the issue. The user is still not showing up in the GAL and I am still seeing error 0x8004010F when downloading the address book.
     
    Well, not showing up in the GAL and not showing up in the OAB are two
    different problems. The problem you just described is a problem
    downloading the OAB, not a problem with the mailbox not being present
    in the GAL or OAB!
     
    Are you using Public Folders or the CAS to distribute the OAB? If it's
    the CAS, make sure that the OAB is present in the folders used by the
    CAS (you should see them in the IIS manager). If ther folder's there
    but the contents hasn't been updated in a while it's probably a
    permission problem on the folder. The OAB Generation Server has to
    transfer the OAB files to the CAS and that may not be working.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Wednesday, July 20, 2011 4:03 AM
  • Hi Rich. Pardon my ignorance... can you tell me what the CAS is?

     

    Also, to clarify... in Outlook, when I choose Send Receive Groups > Download Address Book and set the drop down to \Global Address List I get the 0x8004010F error message. Also, new users do show  up when I choose All Address Lists > All Users. They just aren't showing up in the Global Address List, which is very confusing to our users since GAL is the default option in the Select Names dialog box.

     

    Thanks!

     

    Wednesday, July 20, 2011 2:11 PM
  • On Wed, 20 Jul 2011 14:11:17 +0000, EdwardLee wrote:
     
    >Hi Rich. Pardon my ignorance... can you tell me what the CAS is?
     
    Client Access Server.
     
    >Also, to clarify... in Outlook, when I choose Send Receive Groups > Download Address Book and set the drop down to \Global Address List I get the 0x8004010F error message. Also, new users do show up when I choose All Address Lists > All Users. They just aren't showing up in the Global Address List, which is very confusing to our users since GAL is the default option in the Select Names dialog box.
     
    You're not looking at the GAL (Global Address List), you're looking at
    the OAB (Offline Address Book). Take your Outlook client out of
    cached-mode and I'll bet you see everything.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, July 21, 2011 3:36 AM
  • You're not looking at the GAL (Global Address List), you're looking at
    the OAB (Offline Address Book). Take your Outlook client out of
    cached-mode and I'll bet you see everything.

    --- Rich Matheisen MCSE+I, Exchange MVP


    Well, the certainly managed to confuse me by having it listed as the Global Address List. :-)

     

    Anyway, you are correct that once I turn off cached-mode, all of the missing users appear. So, what does that mean? Is the solution to stop using cached-mode on all of our client workstations, or is there some way to fix this while still using cached-mode?

     

    Thanks!!

    Thursday, July 21, 2011 7:05 PM
  • On Thu, 21 Jul 2011 19:05:35 +0000, EdwardLee wrote:
     
    >You're not looking at the GAL (Global Address List), you're looking at the OAB (Offline Address Book). Take your Outlook client out of cached-mode and I'll bet you see everything.
    >--- Rich Matheisen MCSE+I, Exchange MVP
    >
    >Well, the certainly managed to confuse me by having it listed as the Global Address List. :-)
    >
    >
    >
    >Anyway, you are correct that once I turn off cached-mode, all of the missing users appear. So, what does that mean? Is the solution to stop using cached-mode on all of our client workstations, or is there some way to fix this while still using cached-mode?
     
    Try this:
    http://blogs.msdn.com/b/dgoldman/archive/2006/08/25/how-exchange-2007-oab-files-are-replicated-to-a-client-access-server-for-download.aspx
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Thursday, July 21, 2011 9:40 PM