App-V 5.1 Management Console - Adding .appv package from share RRS feed

  • Question

  • Hello Folks,

    I am getting an error message for adding .appv package to APP-V management console. The error was "An unexpected error occurred while retrieving the package ... Please ensure that it exists and that the package's file permissions allow the management service to access it."

    Of course, I grant all the permissions needed including Everyone on both Share and NTFS permission.
    I also tried different .appv Packages.

    I found that there was a Hotfix for a similiar issue: https://support.microsoft.com/en-us/kb/3168628
    But the Hotfix is no longer available.

    My Setup is a single Server Environment containing Server 2014 SP3, with all APPV-Roles, on a Server 2019 Datacenter.

    Any suggestion would be greatly appreciated. Thanks in advance!


    • Edited by Reittier Monday, April 29, 2019 4:57 PM
    Monday, April 29, 2019 4:55 PM

All replies

  • Hello Reittier

    It seems we are walking the same path. I just recently built a App-V 5.1 Management\Publishing\Reporting Server and Sequenced my first App-V package and received the error you speak of right out of the gate.  After finding the same information you have and your posting I thought I would chime in in the effort. I will add in my findings, hopefully someone will have the answer for us.


    Tuesday, April 30, 2019 5:08 PM
  • Hello Again

    I found errors in the event log under Applications And Services Logs ---> Microsoft ---> AppV ---> Server-Management ---> Admin that refer to COM Errors.

    Error Message: Creating an instance of the COM component with CLSID {####....} from IClassFactory failed due to the following error: 80004002 No such interface supported (Exception from HRESULT: 0x80004002 (E_NOINTERFACE)).

    Tuesday, April 30, 2019 5:29 PM
  • Hello Reittier

    I was able to resolve the issue by installing the Microsoft Deployment Toolkit. Hope this helps


    • Proposed as answer by Jason_Moran Tuesday, April 30, 2019 8:41 PM
    • Unproposed as answer by Reittier Thursday, May 2, 2019 1:26 PM
    Tuesday, April 30, 2019 8:40 PM
  • Thanks for sharing!
    I'm having the same Errors in my Eventlogs.

    But installing MDT it didn't do the trick for me.

    Which version of MDT did you install? I tried MDT 1809.


    • Edited by Reittier Thursday, May 2, 2019 8:05 AM typo
    Thursday, May 2, 2019 7:55 AM
  • I will try to reinstall everything on a Windows Server 2016 with an older SQL-Server Version. Apparently the Microsoft Team in charge, does either not care to support the newer OS Versions, or does not care to update the documentation:



    • Edited by Reittier Thursday, May 2, 2019 11:22 AM
    Thursday, May 2, 2019 8:27 AM
  • Update: It didn't work to use the supported versions of OS and SQLServer.
    Just re-installed everything from scratch with a Windows Server 2016. No success, same Error.


    • Edited by Reittier Thursday, May 2, 2019 3:38 PM
    Thursday, May 2, 2019 12:03 PM
  • MDT adds nothing to the app-v management backend... it's no requirement at all.

    Please have a look at this guideline

    Roy Essers

    Thursday, May 2, 2019 9:46 PM
  • Hey Roy, thanks for your comment!

    Concerning the MDT: I thought so too, just wanted to make sure I try it anyways.

    I will try to rebuild the environment again, using the guide you provided.

    I tried it before using the SQL-Scripts by using another guide (https://wilkyit.com/2017/03/30/installing-microsoft-app-v-5-1-on-windows-server-2016/) , but some of the scripts threw Errors, so I gave up with it because I'm not good at troubleshooting SQL Scripts. But I will try your guide, that one seems more confident.


    • Edited by Reittier Friday, May 3, 2019 6:27 AM
    Friday, May 3, 2019 6:23 AM
  • finally got a solution after long search.

    Issue fixed after installing a particular hot fix


    • Proposed as answer by Roy Essers Wednesday, August 5, 2020 2:24 PM
    Sunday, August 2, 2020 2:43 PM