locked
Blank page in OWA for Exchange 2010 reason=0 RRS feed

  • Question

  • Our OWA stopped work recently. When try to open it gets this message

    https://mail.mydomain.com/owa/auth/logon.aspx?url=https://mail.mydomain.com/owa/&reason=0 .

    I have tried this fix by running updatecas.ps1 in the Exchange Management Shell. You can find the script in C:\Program Files\Microsoft\Exchange Server\V14\Bin . The script updatecas.ps1 will handle the OWA and ECP updates. I have also tried the authentication changes in IIS from Basic to Anonymous with ISUR. I have restarted IIS and Web services but still no avail.  Outlook users are still working fine and mobile configured are working as well but cannot configure new mobile.

    I have also Removed the virtual directory and created again. https://technet.microsoft.com/en-us/library/ff629372.aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.Or please vote as helpful.


    • Edited by Mshak Tuesday, April 28, 2015 3:47 PM more info
    Tuesday, April 28, 2015 2:43 PM

Answers

  • Lee/Winnie,

    I have found the fix and it is working now. After checking the IIS log I spotted that there is 302 error and searched the error and it was related to page redirection. It was redirection set in the IIS. I high lighted the OWA directory http Redirect simply uncheck “Redirect requests to this destination” followed by clicking “Apply”.

    The box was ticked and there was /owa in the filed. After unchecking the box rest the IIS and WWW Publishing services it worked.

    Thank you guys for your help.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.Or please vote as helpful.

    • Marked as answer by Mshak Wednesday, April 29, 2015 3:11 PM
    Wednesday, April 29, 2015 3:11 PM

All replies

  • Hi,

    Please do the following steps to have a try:

    1. Please check whether you can logon mailbox by the following link:

    https://mail.mydomain.com/ecp

    2. Restart IIS service by running IISReset from a Command Prompt window.

    3. If the issue persists, please collect any event logs for further analysis.

    Additionally, we can update the Exchange server with the latest patches and service packs to have a try.

    Regards,


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Winnie Liang
    TechNet Community Support

    Wednesday, April 29, 2015 9:04 AM
  • Where do you see that message? That's the URL for the logon page. It's not so strange to see it in the address bar (although it should have changed after a successful login), but if you see it in the main window, then that's a bit odd.

    OWA For SmartPhone

    Wednesday, April 29, 2015 9:44 AM
  • Winnie,

    Tried the URL and the out come is the same https://mail.domain.com/owa/auth/logon.aspx?url=https://mail.domain.com/ecp/&reason=0

    Restarted the IIS services and World Wide Web Publishing Service.

    I have checked the event logs and only Exchange related logs are 2 x 1033.

    My Exchange version is 14.03.0210.002

    Lee,

    When I put the https://mail.domain.com/owa in the browser I see a blank page it should show the login page but the page is blank and in the URL bar it show this auth/logon.aspx?url=https://mail.domain.com/owa/&reason=0 

    I don't even get to see the login boxes or anything on the page.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.Or please vote as helpful.

    Wednesday, April 29, 2015 10:20 AM
  • Have a look, using Notepad, at your today's IIS log (not the Event Logs) for your Default Web Site, and look for the most recent line (i.e. nearest the bottom of the file) where you see the request for /auth/logon.aspx .

    Can you copy/paste it (and a few of the surrounding lines) for us?


    OWA For SmartPhone

    Wednesday, April 29, 2015 11:19 AM
  • Lee,

    2015-04-29 11:49:26 10.0.0.64 GET /owa/14.3.210.2/scripts/premium/flogon.js - 443 - 10.0.0.241 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://mail.domain.com/owa/auth/logon.aspx?url=https://mail.domain.com/owa/&reason=0 302 0 0 31
    2015-04-29 11:49:26 10.0.0.64 GET /owa/14.3.210.2/scripts/premium/flogon.js - 443 - 10.0.0.241 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://mail.domain.com/owa/auth/logon.aspx?url=https://mail.domain.com/owa/&reason=0 302 0 0 0
    2015-04-29 11:49:26 10.0.0.64 GET /owa/14.3.210.2/themes/resources/owafont.css - 443 - 10.0.0.241 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://mail.domain.com/owa/auth/logon.aspx?url=https://mail.domain.com/owa/&reason=0 302 0 0 31
    2015-04-29 11:49:26 10.0.0.64 GET /owa/14.3.210.2/themes/resources/logon.css - 443 - 10.0.0.241 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://mail.domain.com/owa/auth/logon.aspx?url=https://mail.domain.com/owa/&reason=0 302 0 0 31
    2015-04-29 11:49:26 10.0.0.64 GET /owa/14.3.210.2/scripts/premium/flogon.js - 443 - 10.0.0.241 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://mail.domain.com/owa/auth/logon.aspx?url=https://mail.domain.com/owa/&reason=0 302 0 0 0
    2015-04-29 11:49:26 10.0.0.64 GET /owa/14.3.210.2/themes/resources/owafont.css - 443 - 10.0.0.241 Mozilla/5.0+(Windows+NT+6.3;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://mail.domain.com/owa/auth/logon.aspx?url=https://mail.domain.com/owa/&reason=0 302 0 0 0

    2015-04-29 11:51:55 10.0.0.64 GET /owa/auth/logon.aspx replaceCurrent=1&url=https%3a%2f%2fowa.domain.com%2fowa%2f 443 - 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 200 0 0 0
    2015-04-29 11:51:59 10.0.0.64 POST /owa/auth.owa - 443 j6goodsin 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://owa.domain.com/owa/auth/logon.aspx?replaceCurrent=1&url=https%3a%2f%2fowa.domain.com%2fowa%2f 401 1 1326 1078
    2015-04-29 11:51:59 10.0.0.64 GET /owa/auth/logon.aspx url=https://owa.domain.com/owa/&reason=2 443 - 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://owa.domain.com/owa/auth/logon.aspx?replaceCurrent=1&url=https%3a%2f%2fowa.domain.com%2fowa%2f 200 0 0 0
    2015-04-29 11:51:59 10.0.0.64 GET /owa/auth/logon.aspx replaceCurrent=1&reason=2&url=https%3a%2f%2fowa.domain.com%2fowa%2f 443 - 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 200 0 0 0
    2015-04-29 11:52:02 10.0.0.64 POST /owa/auth.owa - 443 j6goodsin 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://owa.domain.com/owa/auth/logon.aspx?replaceCurrent=1&reason=2&url=https%3a%2f%2fowa.domain.com%2fowa%2f 401 1 1326 0
    2015-04-29 11:52:02 10.0.0.64 GET /owa/auth/logon.aspx url=https://owa.domain.com/owa/&reason=2 443 - 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://owa.domain.com/owa/auth/logon.aspx?replaceCurrent=1&reason=2&url=https%3a%2f%2fowa.domain.com%2fowa%2f 200 0 0 0
    2015-04-29 11:52:02 10.0.0.64 GET /owa/auth/logon.aspx replaceCurrent=1&reason=2&url=https%3a%2f%2fowa.domain.com%2fowa%2f 443 - 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko - 200 0 0 0

    The https://owa.domain.com/owa is not the directory name we have in Exchange just on the SSL certificate I thought worth trying this.

    I tried copying login.aspx file from other server to this but no luck. After the file change I tried again but same result in the log.  


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.Or please vote as helpful.

    Wednesday, April 29, 2015 12:21 PM
  • I think this is an important line (and the others like it)

    2015-04-29 11:51:59 10.0.0.64 POST /owa/auth.owa - 443 j6goodsin 10.0.0.33 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko https://owa.domain.com/owa/auth/logon.aspx?replaceCurrent=1&url=https%3a%2f%2fowa.domain.com%2fowa%2f 401 1 1326 1078

    I think you will only see that (the 401 1 at the end) if the supplied credentials are incorrect (try searching online for IIS status codes, if you're interested in that sort of thing). You should then be redirected back to the login page, but note that the URL should now have &reason=2 on the end, and the login page should also be telling you that the credentials are incorrect. Does that not match what you see?  Does it just say &reason=0 all the time?


    OWA For SmartPhone

    Wednesday, April 29, 2015 1:40 PM
  • Most of the time it says &reason=0 on my browser. Some users have seen reason=2 as well. When I try my mobile to browse to the URL it shows the login page but no images and when I type in my credential it stays at the same page nothing happens just refresh the page and back to login page.  

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.Or please vote as helpful.

    Wednesday, April 29, 2015 1:53 PM
  • Lee/Winnie,

    I have found the fix and it is working now. After checking the IIS log I spotted that there is 302 error and searched the error and it was related to page redirection. It was redirection set in the IIS. I high lighted the OWA directory http Redirect simply uncheck “Redirect requests to this destination” followed by clicking “Apply”.

    The box was ticked and there was /owa in the filed. After unchecking the box rest the IIS and WWW Publishing services it worked.

    Thank you guys for your help.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.Or please vote as helpful.

    • Marked as answer by Mshak Wednesday, April 29, 2015 3:11 PM
    Wednesday, April 29, 2015 3:11 PM
  • Hi, 

    I fought with this for weeks, in my case, i deleted the *.js from the Handler Mappings on the Default Web Site.

    It was a problem loading the js files from the owa folder, (use the f+12 option to verify wich error you have when you try to load owa).

    I hope it helps.

    Friday, September 21, 2018 10:02 PM