none
Creating DAG Problem RRS feed

  • Question

  • Hi,

    I have created a Database Availablility group and it has managed to add the first server, but has failed to create the second server. Both servers that will be DAG are in different AD Sites. The Error message I get is the following:

    Summary: 1 item(s). 0 succeeded, 1 failed.
    Elapsed time: 00:06:23


    MAIL-VSER-23
    Failed

    Error:
    A server-side database availability group administrative operation failed. Error: The operation failed. CreateCluster errors may result from incorrectly configured static addresses. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired"' failed. [Server: MAIL-VSER-04.2sms.com]

    An Active Manager operation failed. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"AddClusterNode() (MaxPercentage=100) failed with 0x5b4. Error: This operation returned because the timeout period expired"' failed..

    This operation returned because the timeout period expired
    Click here for help... http://technet.microsoft.com/en-US/library/ms.exch.err.default(EXCHG.141).aspx?v=14.1.267.0&t=exchgf1&e=ms.exch.err.ExC9C315

    Warning:
    The operation wasn't successful because an error was encountered. You may find more details in log file "C:\ExchangeSetupLogs\DagTasks\dagtask_2011-02-16_21-12-34.308_add-databaseavailabiltygroupserver.log".


    Exchange Management Shell command attempted:
    Add-DatabaseAvailabilityGroupServer -MailboxServer 'MAIL-VSER-23' -Identity 'MAIL-CSER-02'

    Elapsed Time: 00:06:23

    Any ideas?

    Trevor

     


    Trevor Wilcockson
    Wednesday, February 16, 2011 9:24 PM

All replies

  • I assume that the basic requirements are all met:

    ·         Must be running Windows Server 2008 Enterprise Edition or Windows Server 2008 R2 Enterprise Edition

    ·         Must not belong to any other DAGs

    ·         Must be in the same Active Directory domain as all other Mailbox servers in the DAG

    ·         Must not be configured as an Active Directory directory server

    Please make sure that the network latency between nodes is less than 250ms

    Please verify the settings of the NICs

    Network Adapter Configuration for DAGs” section in Planning for High Availability and Site Resilience

    Please verify that the “UseMachineId" entry (Value: 1, Type: Dword) is presented on the both nodes

    HKLM\system\CurrentControlSet\Control\Lsa

    Please remove the first DAG member and the DAG itself

    Remove a Database Availability Group

    Please disable “TCP Chimney Offload” (KB 951037) on the both nodes by using the command below, and then disable the “Checksum Offload” (Method). Reboot the nodes. Then, try to create the DAG and add the nodes again

    netsh int tcp set global chimney=disabled

    Also, you can check the add-databaseavailabiltygroupserver.log which could provide further more traces for troubleshooting


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Alan.GimModerator Friday, February 25, 2011 1:22 AM
    • Unmarked as answer by a2sms Wednesday, March 2, 2011 9:58 PM
    Wednesday, February 23, 2011 7:26 AM
    Moderator
  • Hi !

    • You must have Windows 2008 R2 Enterprise for FailOver clustering
    • Any Dag you create early remove it (Must not belong to any other DAGs)
    • Exchange Server not recommended that install on Domain Conntrolers

    High Avalaibility

    http://technet.microsoft.com/en-us/library/dd638104.aspx

    Best Regards

     

    • Proposed as answer by Ahmet Abdagic Wednesday, February 23, 2011 7:53 AM
    Wednesday, February 23, 2011 7:53 AM
  • How's the issue currently? Any further information?
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, February 24, 2011 3:20 AM
    Moderator
  • I have disabled everything that James-Luo has suggested, the Lsa registry has the value of 1 on both of the servers, both servers are Windows 2008 R2 Enterprise Edition, not a DC, not member of any DAG and the latency between the 2 servers is around 40ms.

    Both of these servers are virtual servers with the host running Windows 2003 R2. The Windows Firewall service has been disabled and the hardware firewalls have rules to allow all traffic between the 2 servers.

    I am going to try to bring both mailbox servers into the same AD site to see it is a issue relating to have the DAG in multiple AD sites.


    Trevor Wilcockson
    Wednesday, March 2, 2011 10:06 PM
  • I confirmed that if I put the second mailbox server on the same site it works fine.
    Trevor Wilcockson
    Friday, March 4, 2011 11:36 AM
  • I confirmed that if I put the second mailbox server on the same site it works fine.
    Trevor Wilcockson

    thats good. things seems to be ok. now question is unable to do it from remote side. so the things is if you by pass and allow all traffic between two server is that work for you

     

     


    "Abhi" "Exchange Specialist" ------------- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, August 17, 2011 8:20 AM
  • Hello Abhinav,

     

    can you help me to understand what is second mailbox serve??

     


    Wednesday, August 17, 2011 8:28 AM
  • second server mean another mailbox server on same site
    "Abhi" "Exchange Specialist" ------------- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, August 17, 2011 9:22 AM
  • in my case i have created a new database on problamatic server. which is not adding in Existing DAG. but still no luck. attached log. add-databaseavailabiltygroupserver started on machine WIN2. [2011-08-18T07:52:49] add-dagserver started [2011-08-18T07:52:49] commandline: $scriptCmd = {& $wrappedCmd @PSBoundParameters } [2011-08-18T07:52:49] Option 'Identity' = 'DAGA'. [2011-08-18T07:52:49] Option 'MailboxServer' = 'WIN2'. [2011-08-18T07:52:49] Option 'DatabaseAvailabilityGroupIpAddresses' = ''. [2011-08-18T07:52:49] Option 'WhatIf' = ''. [2011-08-18T07:52:49] Process: w3wp w3wp.exe:5172. [2011-08-18T07:52:49] User context = 'NT AUTHORITY\SYSTEM'. [2011-08-18T07:52:49] Member of group 'Everyone'. [2011-08-18T07:52:49] Member of group 'BUILTIN\Users'. [2011-08-18T07:52:49] Member of group 'NT AUTHORITY\SERVICE'. [2011-08-18T07:52:49] Member of group 'CONSOLE LOGON'. [2011-08-18T07:52:49] Member of group 'NT AUTHORITY\Authenticated Users'. [2011-08-18T07:52:49] Member of group 'NT AUTHORITY\This Organization'. [2011-08-18T07:52:49] Member of group 'BUILTIN\IIS_IUSRS'. [2011-08-18T07:52:49] Member of group 'LOCAL'. [2011-08-18T07:52:49] Member of group 'IIS APPPOOL\MSExchangePowerShellAppPool'. [2011-08-18T07:52:49] Member of group 'BUILTIN\Administrators'. [2011-08-18T07:52:49] Updated Progress 'Validating the parameters.' 2%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] Mailbox server: value passed in = WIN2, mailboxServer.Name = WIN2, mailboxServer.Fqdn = WIN2.dipak.ctcgroupltd.com [2011-08-18T07:52:49] LogClussvcState: clussvc is Stopped on WIN2.dipak.ctcgroupltd.com. Exception (if any) = none [2011-08-18T07:52:49] The IP addresses for the DAG are (blank means DHCP): [2011-08-18T07:52:49] Looking up IP addresses for DAGA. [2011-08-18T07:52:49] DAGA = [ 172.16.2.0 ]. [2011-08-18T07:52:49] Looking up IP addresses for win2. [2011-08-18T07:52:49] win2 = [ ::1, 172.16.0.60, 10.10.10.60 ]. [2011-08-18T07:52:49] Looking up IP addresses for WIN2.dipak.ctcgroupltd.com. [2011-08-18T07:52:49] WIN2.dipak.ctcgroupltd.com = [ ::1, 172.16.0.60, 10.10.10.60 ]. [2011-08-18T07:52:49] DAG DAGA has 1 servers: [2011-08-18T07:52:49] DAG DAGA contains server WIN. [2011-08-18T07:52:49] Updated Progress 'Checking if Mailbox server 'WIN2' is in a database availability group.' 4%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] GetRemoteCluster() for the mailbox server failed with exception = An Active Manager operation failed. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"OpenCluster(WIN2.dipak.ctcgroupltd.com) failed with 0x6d9. Error: There are no more endpoints available from the endpoint mapper"' failed.. This is OK. [2011-08-18T07:52:49] Ignoring previous error, as it is acceptable if the cluster does not exist yet. [2011-08-18T07:52:49] DumpClusterTopology: Opening remote cluster DAGA. [2011-08-18T07:52:49] Dumping the cluster by connecting to: DAGA. [2011-08-18T07:52:49] The cluster's name is: DAGA. [2011-08-18T07:52:49] Groups [2011-08-18T07:52:49] group: Available Storage [not a CMS] [2011-08-18T07:52:49] OwnerNode: WIN.dipak.ctcgroupltd.com [2011-08-18T07:52:49] State: Offline [2011-08-18T07:52:49] group: Cluster Group [Cluster Main Group] [2011-08-18T07:52:49] OwnerNode: WIN.dipak.ctcgroupltd.com [2011-08-18T07:52:49] State: Online [2011-08-18T07:52:49] Resource: Cluster Name [Online, type = Network Name, PossibleOwners = WIN ] [2011-08-18T07:52:49] NetName = [DAGA] [2011-08-18T07:52:49] Resource: Cluster IP Address [Online, type = IP Address, PossibleOwners = WIN ] [2011-08-18T07:52:49] Address = [172.16.2.0] [2011-08-18T07:52:49] EnableDhcp = [1] [2011-08-18T07:52:49] Network = [Cluster Network 1] [2011-08-18T07:52:49] Nodes [2011-08-18T07:52:49] node: WIN.dipak.ctcgroupltd.com [ state = Up ] [2011-08-18T07:52:49] Subnets [2011-08-18T07:52:49] Name(Cluster Network 1), Mask(172.16.0.0/21), Role(ClusterNetworkRoleInternalAndClient) [2011-08-18T07:52:49] NIC 172.16.0.10 on Node WIN in State=Up [2011-08-18T07:52:49] Name(Cluster Network 2), Mask(10.10.10.0/24), Role(ClusterNetworkRoleInternalUse) [2011-08-18T07:52:49] NIC 10.10.10.10 on Node WIN in State=Up [2011-08-18T07:52:49] Opening the cluster on nodes [win]. [2011-08-18T07:52:49] Other mailbox servers in the DAG are already members of cluster 'DAGA' [2011-08-18T07:52:49] The server WIN2 does not belong to a cluster, and the other servers belong to DAGA. [2011-08-18T07:52:49] Successfully resolved servers based on the AD configuration. [2011-08-18T07:52:49] The following servers are in the StartedServers list: [2011-08-18T07:52:49] The following servers are in the StoppedServers list: [2011-08-18T07:52:49] Verifiying that the members of database availability group 'DAGA' are also members of the cluster. [2011-08-18T07:52:49] Verifying that the members of cluster 'DAGA' are also members of the database availability group. [2011-08-18T07:52:49] According to GetNodeClusterState(), the server WIN2 is NotConfigured. [2011-08-18T07:52:49] The CNO is currently Online. [2011-08-18T07:52:49] InternalValidate() done. [2011-08-18T07:52:49] Updated Progress 'Adding server 'WIN2' to database availability group 'DAGA'.' 6%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] Updated Progress 'Adding server 'WIN2' to the cluster.' 8%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] The following log entry comes from a different process, run on machine 'WIN.dipak.ctcgroupltd.com'. BEGIN [2011-08-18T07:52:49] [2011-08-18T07:52:49] Opening a local AmCluster handle. [2011-08-18T07:52:49] Updated Progress 'Adding server 'win2' to database availability group 'DAGA'.' 2%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateNodeState, ePhaseType = ClusterSetupPhaseStart, ePhaseSeverity = ClusterSetupPhaseInformational, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x0 ) [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateNodeState, ePhaseType = ClusterSetupPhaseContinue, ePhaseSeverity = ClusterSetupPhaseFatal, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x800713bb ) [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateNodeState, ePhaseType = ClusterSetupPhaseEnd, ePhaseSeverity = ClusterSetupPhaseFatal, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x800713bb ) [2011-08-18T07:52:49] Found a matching exception: Microsoft.Exchange.Cluster.Replay.DagTaskValidateNodeTimedOutException: A server-side database availability group administrative operation failed. Error: Windows Failover Clustering timed out while trying to validate server 'WIN2'. If this is in a disjoint DNS namespace, the DNS suffixes for all servers in the database availability group must be present on every server. [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseFailureCleanup, ePhaseType = ClusterSetupPhaseStart, ePhaseSeverity = ClusterSetupPhaseInformational, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x0 ) [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseFailureCleanup, ePhaseType = ClusterSetupPhaseEnd, ePhaseSeverity = ClusterSetupPhaseInformational, dwPercentComplete = 12, szObjectName = , dwStatus = 0x0 ) [2011-08-18T07:52:49] The preceding log entry comes from a different process, run on machine 'WIN.dipak.ctcgroupltd.com'. END [2011-08-18T07:52:49] The operation wasn't successful because an error was encountered. You may find more details in log file "C:\ExchangeSetupLogs\DagTasks\dagtask_2011-08-18_07-52-49.066_add-databaseavailabiltygroupserver.log". [2011-08-18T07:52:49] WriteError! Exception = Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error: The operation failed with message: Windows Failover Clustering timed out while trying to validate server 'WIN2'. If this is in a disjoint DNS namespace, the DNS suffixes for all servers in the database availability group must be present on every server. ---> Microsoft.Exchange.Cluster.Replay.DagTaskValidateNodeTimedOutException: A server-side database availability group administrative operation failed. Error: Windows Failover Clustering timed out while trying to validate server 'WIN2'. If this is in a disjoint DNS namespace, the DNS suffixes for all servers in the database availability group must be present on every server. at Microsoft.Exchange.Cluster.ClusApi.AmCluster.AddNodeToCluster(AmServerName nodeName, IClusterSetupProgress setupProgress, IntPtr context, Exception& errorException, Boolean throwExceptionOnFailure) at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNode(AmServerName mailboxServerName, String& verboseLog) --- End of inner exception stack trace (Microsoft.Exchange.Cluster.Replay.DagTaskValidateNodeTimedOutException) --- at Microsoft.Exchange.Cluster.Replay.DagHelper.ThrowDagTaskOperationWrapper(Exception exception) at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNode(AmServerName mailboxServerName, String& verboseLog) at Microsoft.Exchange.Cluster.ReplayService.ReplayRpcServer.<>c__DisplayClass34.<RpcsAddNodeToCluster>b__33() at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.RunRpcServerOperation(String databaseName, RpcServerOperation rpcOperation) --- End of stack trace on server (WIN.dipak.ctcgroupltd.com) --- at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRethrowIfFailed(String databaseName, String serverName, RpcErrorExceptionInfo errorInfo) at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunRpcOperationDbName(String serverName, String databaseName, Int32 timeoutMs, ReplayRpcClient& rpcClient, IHaRpcExceptionWrapper rpcExceptionWrapperInstance, InternalRpcOperation rpcOperation) at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunRpcOperation(String serverName, Nullable`1 dbGuid, Int32 timeoutMs, ReplayRpcClient& rpcClient, IHaRpcExceptionWrapper rpcExceptionWrapperInstance, InternalRpcOperation rpcOperation) at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunAddNodeToCluster(AmServerName serverName, AmServerName newNode, String& verboseLog) at Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer.JoinNodeToCluster() [2011-08-18T07:52:49] Updated Progress 'Done!' 100%. [2011-08-18T07:52:49] COMPLETED add-databaseavailabiltygroupserver explicitly called CloseTempLogFile().
    Thursday, August 18, 2011 7:58 AM
  • Hi !

    • You must have Windows 2008 R2 Enterprise for FailOver clustering
    • Any Dag you create early remove it (Must not belong to any other DAGs)
    • Exchange Server not recommended that install on Domain Conntrolers

    High Avalaibility

    http://technet.microsoft.com/en-us/library/dd638104.aspx

    Best Regards

     


    1: Not neccessary to have R2 it could be SP2 as well but it sould be Enterprise.
    Gulab | MCITP: Exchange 2010-2007 | Lync Server 2010 | Windows Server 2008 | Skype: Exchange.Ranger | Blog: www.ExchangeRanger.Blogspot.com
    Thursday, August 18, 2011 8:02 AM
  • in my case i have created a new database on problamatic server. which is not adding in Existing DAG. but still no luck. attached log. add-databaseavailabiltygroupserver started on machine WIN2. [2011-08-18T07:52:49] add-dagserver started [2011-08-18T07:52:49] commandline: $scriptCmd = {& $wrappedCmd @PSBoundParameters } [2011-08-18T07:52:49] Option 'Identity' = 'DAGA'. [2011-08-18T07:52:49] Option 'MailboxServer' = 'WIN2'. [2011-08-18T07:52:49] Option 'DatabaseAvailabilityGroupIpAddresses' = ''. [2011-08-18T07:52:49] Option 'WhatIf' = ''. [2011-08-18T07:52:49] Process: w3wp w3wp.exe:5172. [2011-08-18T07:52:49] User context = 'NT AUTHORITY\SYSTEM'. [2011-08-18T07:52:49] Member of group 'Everyone'. [2011-08-18T07:52:49] Member of group 'BUILTIN\Users'. [2011-08-18T07:52:49] Member of group 'NT AUTHORITY\SERVICE'. [2011-08-18T07:52:49] Member of group 'CONSOLE LOGON'. [2011-08-18T07:52:49] Member of group 'NT AUTHORITY\Authenticated Users'. [2011-08-18T07:52:49] Member of group 'NT AUTHORITY\This Organization'. [2011-08-18T07:52:49] Member of group 'BUILTIN\IIS_IUSRS'. [2011-08-18T07:52:49] Member of group 'LOCAL'. [2011-08-18T07:52:49] Member of group 'IIS APPPOOL\MSExchangePowerShellAppPool'. [2011-08-18T07:52:49] Member of group 'BUILTIN\Administrators'. [2011-08-18T07:52:49] Updated Progress 'Validating the parameters.' 2%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] Mailbox server: value passed in = WIN2, mailboxServer.Name = WIN2, mailboxServer.Fqdn = WIN2.dipak.ctcgroupltd.com [2011-08-18T07:52:49] LogClussvcState: clussvc is Stopped on WIN2.dipak.ctcgroupltd.com. Exception (if any) = none [2011-08-18T07:52:49] The IP addresses for the DAG are (blank means DHCP): [2011-08-18T07:52:49] Looking up IP addresses for DAGA. [2011-08-18T07:52:49] DAGA = [ 172.16.2.0 ]. [2011-08-18T07:52:49] Looking up IP addresses for win2. [2011-08-18T07:52:49] win2 = [ ::1, 172.16.0.60, 10.10.10.60 ]. [2011-08-18T07:52:49] Looking up IP addresses for WIN2.dipak.ctcgroupltd.com. [2011-08-18T07:52:49] WIN2.dipak.ctcgroupltd.com = [ ::1, 172.16.0.60, 10.10.10.60 ]. [2011-08-18T07:52:49] DAG DAGA has 1 servers: [2011-08-18T07:52:49] DAG DAGA contains server WIN. [2011-08-18T07:52:49] Updated Progress 'Checking if Mailbox server 'WIN2' is in a database availability group.' 4%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] GetRemoteCluster() for the mailbox server failed with exception = An Active Manager operation failed. Error: An error occurred while attempting a cluster operation. Error: Cluster API '"OpenCluster(WIN2.dipak.ctcgroupltd.com) failed with 0x6d9. Error: There are no more endpoints available from the endpoint mapper"' failed.. This is OK. [2011-08-18T07:52:49] Ignoring previous error, as it is acceptable if the cluster does not exist yet. [2011-08-18T07:52:49] DumpClusterTopology: Opening remote cluster DAGA. [2011-08-18T07:52:49] Dumping the cluster by connecting to: DAGA. [2011-08-18T07:52:49] The cluster's name is: DAGA. [2011-08-18T07:52:49] Groups [2011-08-18T07:52:49] group: Available Storage [not a CMS] [2011-08-18T07:52:49] OwnerNode: WIN.dipak.ctcgroupltd.com [2011-08-18T07:52:49] State: Offline [2011-08-18T07:52:49] group: Cluster Group [Cluster Main Group] [2011-08-18T07:52:49] OwnerNode: WIN.dipak.ctcgroupltd.com [2011-08-18T07:52:49] State: Online [2011-08-18T07:52:49] Resource: Cluster Name [Online, type = Network Name, PossibleOwners = WIN ] [2011-08-18T07:52:49] NetName = [DAGA] [2011-08-18T07:52:49] Resource: Cluster IP Address [Online, type = IP Address, PossibleOwners = WIN ] [2011-08-18T07:52:49] Address = [172.16.2.0] [2011-08-18T07:52:49] EnableDhcp = [1] [2011-08-18T07:52:49] Network = [Cluster Network 1] [2011-08-18T07:52:49] Nodes [2011-08-18T07:52:49] node: WIN.dipak.ctcgroupltd.com [ state = Up ] [2011-08-18T07:52:49] Subnets [2011-08-18T07:52:49] Name(Cluster Network 1), Mask(172.16.0.0/21), Role(ClusterNetworkRoleInternalAndClient) [2011-08-18T07:52:49] NIC 172.16.0.10 on Node WIN in State=Up [2011-08-18T07:52:49] Name(Cluster Network 2), Mask(10.10.10.0/24), Role(ClusterNetworkRoleInternalUse) [2011-08-18T07:52:49] NIC 10.10.10.10 on Node WIN in State=Up [2011-08-18T07:52:49] Opening the cluster on nodes [win]. [2011-08-18T07:52:49] Other mailbox servers in the DAG are already members of cluster 'DAGA' [2011-08-18T07:52:49] The server WIN2 does not belong to a cluster, and the other servers belong to DAGA. [2011-08-18T07:52:49] Successfully resolved servers based on the AD configuration. [2011-08-18T07:52:49] The following servers are in the StartedServers list: [2011-08-18T07:52:49] The following servers are in the StoppedServers list: [2011-08-18T07:52:49] Verifiying that the members of database availability group 'DAGA' are also members of the cluster. [2011-08-18T07:52:49] Verifying that the members of cluster 'DAGA' are also members of the database availability group. [2011-08-18T07:52:49] According to GetNodeClusterState(), the server WIN2 is NotConfigured. [2011-08-18T07:52:49] The CNO is currently Online. [2011-08-18T07:52:49] InternalValidate() done. [2011-08-18T07:52:49] Updated Progress 'Adding server 'WIN2' to database availability group 'DAGA'.' 6%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] Updated Progress 'Adding server 'WIN2' to the cluster.' 8%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] The following log entry comes from a different process, run on machine 'WIN.dipak.ctcgroupltd.com'. BEGIN [2011-08-18T07:52:49] [2011-08-18T07:52:49] Opening a local AmCluster handle. [2011-08-18T07:52:49] Updated Progress 'Adding server 'win2' to database availability group 'DAGA'.' 2%. [2011-08-18T07:52:49] Working [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateNodeState, ePhaseType = ClusterSetupPhaseStart, ePhaseSeverity = ClusterSetupPhaseInformational, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x0 ) [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateNodeState, ePhaseType = ClusterSetupPhaseContinue, ePhaseSeverity = ClusterSetupPhaseFatal, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x800713bb ) [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseValidateNodeState, ePhaseType = ClusterSetupPhaseEnd, ePhaseSeverity = ClusterSetupPhaseFatal, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x800713bb ) [2011-08-18T07:52:49] Found a matching exception: Microsoft.Exchange.Cluster.Replay.DagTaskValidateNodeTimedOutException: A server-side database availability group administrative operation failed. Error: Windows Failover Clustering timed out while trying to validate server 'WIN2'. If this is in a disjoint DNS namespace, the DNS suffixes for all servers in the database availability group must be present on every server. [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseFailureCleanup, ePhaseType = ClusterSetupPhaseStart, ePhaseSeverity = ClusterSetupPhaseInformational, dwPercentComplete = 12, szObjectName = WIN2, dwStatus = 0x0 ) [2011-08-18T07:52:49] ClusterSetupProgressCallback( eSetupPhase = ClusterSetupPhaseFailureCleanup, ePhaseType = ClusterSetupPhaseEnd, ePhaseSeverity = ClusterSetupPhaseInformational, dwPercentComplete = 12, szObjectName = , dwStatus = 0x0 ) [2011-08-18T07:52:49] The preceding log entry comes from a different process, run on machine 'WIN.dipak.ctcgroupltd.com'. END [2011-08-18T07:52:49] The operation wasn't successful because an error was encountered. You may find more details in log file "C:\ExchangeSetupLogs\DagTasks\dagtask_2011-08-18_07-52-49.066_add-databaseavailabiltygroupserver.log". [2011-08-18T07:52:49] WriteError! Exception = Microsoft.Exchange.Cluster.Replay.DagTaskOperationFailedException: A server-side database availability group administrative operation failed. Error: The operation failed with message: Windows Failover Clustering timed out while trying to validate server 'WIN2'. If this is in a disjoint DNS namespace, the DNS suffixes for all servers in the database availability group must be present on every server. ---> Microsoft.Exchange.Cluster.Replay.DagTaskValidateNodeTimedOutException: A server-side database availability group administrative operation failed. Error: Windows Failover Clustering timed out while trying to validate server 'WIN2'. If this is in a disjoint DNS namespace, the DNS suffixes for all servers in the database availability group must be present on every server. at Microsoft.Exchange.Cluster.ClusApi.AmCluster.AddNodeToCluster(AmServerName nodeName, IClusterSetupProgress setupProgress, IntPtr context, Exception& errorException, Boolean throwExceptionOnFailure) at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNode(AmServerName mailboxServerName, String& verboseLog) --- End of inner exception stack trace (Microsoft.Exchange.Cluster.Replay.DagTaskValidateNodeTimedOutException) --- at Microsoft.Exchange.Cluster.Replay.DagHelper.ThrowDagTaskOperationWrapper(Exception exception) at Microsoft.Exchange.Cluster.Replay.DagHelper.AddDagClusterNode(AmServerName mailboxServerName, String& verboseLog) at Microsoft.Exchange.Cluster.ReplayService.ReplayRpcServer.<>c__DisplayClass34.<RpcsAddNodeToCluster>b__33() at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.RunRpcServerOperation(String databaseName, RpcServerOperation rpcOperation) --- End of stack trace on server (WIN.dipak.ctcgroupltd.com) --- at Microsoft.Exchange.Data.Storage.Cluster.HaRpcExceptionWrapperBase`2.ClientRethrowIfFailed(String databaseName, String serverName, RpcErrorExceptionInfo errorInfo) at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunRpcOperationDbName(String serverName, String databaseName, Int32 timeoutMs, ReplayRpcClient& rpcClient, IHaRpcExceptionWrapper rpcExceptionWrapperInstance, InternalRpcOperation rpcOperation) at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunRpcOperation(String serverName, Nullable`1 dbGuid, Int32 timeoutMs, ReplayRpcClient& rpcClient, IHaRpcExceptionWrapper rpcExceptionWrapperInstance, InternalRpcOperation rpcOperation) at Microsoft.Exchange.Cluster.Replay.ReplayRpcClientWrapper.RunAddNodeToCluster(AmServerName serverName, AmServerName newNode, String& verboseLog) at Microsoft.Exchange.Management.SystemConfigurationTasks.AddDatabaseAvailabilityGroupServer.JoinNodeToCluster() [2011-08-18T07:52:49] Updated Progress 'Done!' 100%. [2011-08-18T07:52:49] COMPLETED add-databaseavailabiltygroupserver explicitly called CloseTempLogFile().
    So you are trying to add the Database Copy? Can you post the error.

    Gulab | MCITP: Exchange 2010-2007 | Lync Server 2010 | Windows Server 2008 | Skype: Exchange.Ranger | Blog: www.ExchangeRanger.Blogspot.com
    Thursday, August 18, 2011 8:05 AM
  • Correct Gulab!!

    Please follow as Gulab suggested and MS as well.

    Thanks


    Mihir Nayak
    Thursday, August 18, 2011 8:06 AM
  • THANKS GULAB FOR YOUR RESPONSE.

     

    IN MY CASE, AFTER STRUGGLINK MORE THAN 10 DAYS I HAVE REINSTALL EXCHNAGE SERVER AND ON BOTH MACHINE. SINCE I AM TRYING THIS ON TEST ENVIORMENT THIS IS POSSIBLE FOR ME TO DO SO.

    AFTER REINSTALLING First THINK I DID IS TO CREATE A DAG. THIS TIME BOTH SERVERS ARE ADDED IN DAG.

    YES EARLIER also I AM USING

    WINDOWS 2008 R2 ENTERPRISE.

    AND I DONT HAVE ANY OTHER DAG IN MY SERVERS.

    AS of now it seems working.

    THANKS ONCE AGAIN

     

     

    Saturday, August 20, 2011 11:50 AM
  • THANKS GULAB FOR YOUR RESPONSE.

     

    IN MY CASE, AFTER STRUGGLINK MORE THAN 10 DAYS I HAVE REINSTALL EXCHNAGE SERVER AND ON BOTH MACHINE. SINCE I AM TRYING THIS ON TEST ENVIORMENT THIS IS POSSIBLE FOR ME TO DO SO.

    AFTER REINSTALLING First THINK I DID IS TO CREATE A DAG. THIS TIME BOTH SERVERS ARE ADDED IN DAG.

    YES EARLIER also I AM USING

    WINDOWS 2008 R2 ENTERPRISE.

    AND I DONT HAVE ANY OTHER DAG IN MY SERVERS.

    AS of now it seems working.

    THANKS ONCE AGAIN

     

     

    its working fine.

    please close the thread :)


    "Abhi" "Exchange Specialist" ------------- Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Saturday, August 20, 2011 11:51 AM