none
Exchange 2003 SMTP authentication failure

    Question

  • Hello Fellow Engineers

     

    I have a user that has an iPod that they are trying to get mail flow working properly through their handheld.  I tried to sync the iPod via Active Sync but for some reason it is failing.  I am able to get Active Sync to work with my droid so I am assuming that the problem lies on the provider side.  Meanwhile, I am trying to get the user to connect via POP until we can get Active Sync working.  POP connects just fine but when I try to send an email VIA SMTP the authentication fails.

    Our Exchange environment is a single 2003 Exchange server.  I have tried to authenticate using other accounts as well as using an Outlook 2003 mail client.  Both of these failed inside and outside of the network. After i edited the SMTP Virtual Server settings I tried to connect to the SMTP server using anonymous access and it worked just fine but as soon as I set the SMTP Virtual settings to require authentication outbound mail flow stops.  I can not allow the server to remain an open relay so I need to setup proper authentication.

    My Current SMTP Virtual Server settings are (Access > Authentication) Anonymous Access, Basic Authentication, Integrated Windows Authentication all checked.  For users under Integrated Windows Authentication I have assigned Authenticated Users Group with with submit permission.  Also for testing purposes I assigned Administrator both Submit and Relay Permission.  My Relay Restrictions are set to only allow my exchange servers IP to relay and I have checked "Allow all computers which successfully authenticate to relay regardless of the list above".  

    These settings would normally allow for SMTP Authentication but for some reason it is not.  Any ideas on how to allow a external SMTP user to send mail through Exchange as a SMTP server?



    Tuesday, May 31, 2011 7:56 PM

Answers

  • Hi,

     

    Per my understanding, your problem is that outlook 2003 client cannot send the mails to SMTP server when enable the option “My outgoing server (STMP requires authentication)” in the POP3 profile. If there is any misunderstand, please let me know.

     

    You mentioned “After i edited the SMTP Virtual Server settings I tried to connect to the SMTP server using anonymous access and it worked just fine but as soon as I set the SMTP Virtual settings to require authentication outbound mail flow stops.”

     

    What’s the SMTP virtual server setting you edited?

     

    What’s the error your got when sending the mails with authentication?

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    • Marked as answer by Gen Lin Monday, June 13, 2011 3:02 AM
    Friday, June 03, 2011 6:19 AM

All replies

  • Hi,

    Enable "anonymous access " does not mean allowing relay. If your exchange server is a Internet facing mail server, you should enable "anonymous access " under “Access” tab. This setting allows other mail servers connect to your exchange server and send the mails to your domain without authentication. Because the remote mail servers do not own an authenticated user account of your domain. But if the email is sent to another domain except your authorized domain, it will be rejected.

    As for the “Outbound Security” settings under “Delivery” tab,  the default setting is “Anonymous access”. This means your exchange server/SMTP virtual server will connect to other mail servers without authentication.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    Wednesday, June 01, 2011 4:06 AM
  • Thanks for you input and explanation.  Unfortunately nothing you have mentioned explains why users are not authenicating and are unable to send main via the exchange server as a SMTP server.  Can you clarify what steps I should take to fix the issue?
    Thursday, June 02, 2011 2:51 PM
  • Hi,

     

    Per my understanding, your problem is that outlook 2003 client cannot send the mails to SMTP server when enable the option “My outgoing server (STMP requires authentication)” in the POP3 profile. If there is any misunderstand, please let me know.

     

    You mentioned “After i edited the SMTP Virtual Server settings I tried to connect to the SMTP server using anonymous access and it worked just fine but as soon as I set the SMTP Virtual settings to require authentication outbound mail flow stops.”

     

    What’s the SMTP virtual server setting you edited?

     

    What’s the error your got when sending the mails with authentication?

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    • Marked as answer by Gen Lin Monday, June 13, 2011 3:02 AM
    Friday, June 03, 2011 6:19 AM
  • Hi,

    Is there any update?


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. Thanks Gen Lin-MSFT
    Wednesday, June 08, 2011 1:29 AM