none
FreeBusyViewOptions TimeWindow is too long RRS feed

  • Question

  • I'´m having the following error on event viewer:

    System.Web.Services.Protocols.SoapException: Microsoft.Exchange.InfoWorker.Common.Availability.TimeIntervalTooBigException: The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 62 days. ---> The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 62 days.

    But I don't have any application created here, just the exchange 2010 installed. The error occurs on exchange 2010 trying to make "access"  (i don't know which) on another Exchange 2007 (same domain and forest)

    I see some example from powersheel but i'´m not using any powershell (not by myself, maybe exchange 2010 itself)

    Any Idea?

    Tuesday, January 4, 2011 12:17 PM

Answers

  • Hi,

    I think IIS has the following procedure:

    Start IIS / Web Sites / EWS properties

    Tab ASP.net / Edit Configuration.

    Then on the general tab add the maximumQueryIntervalDays with value 62 to the Application settings

    Restart IIS: iisreset /noforce

    • Marked as answer by EASF-BR Wednesday, October 5, 2011 5:08 PM
    Tuesday, September 27, 2011 8:56 AM

All replies

  • are you using outlook 2003.
    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com, Follow me on twitter http://www.twitter.com/_busbar and if you Liked my post please mark it as helpful and accept it as an answer
    Tuesday, January 4, 2011 12:26 PM
  • I have outlook 2003, 2007 and also 2010, but this is happening on the event viewer of exchange 2010 server and in the event viewer it makes reference to anohter exchange server that is running exchange 2007 and has the mailbox refered on the event. Note that the event is being generated on exchange 2010, but the mailbox in the message is on exchange 2007.
    Tuesday, January 4, 2011 12:45 PM
  • I think this can be due outlook 2003 since it queries for 2 months but 2010 allows only 30 days of free/busy publishing,
    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com, Follow me on twitter http://www.twitter.com/_busbar and if you Liked my post please mark it as helpful and accept it as an answer
    Tuesday, January 4, 2011 12:56 PM
  • But one of the error was on January 1st, at 7:00am and nobody was working on this day. So there was not outlook opened either version. Remember that the error occurs on exchange 2010 server trying to reach exchange 2007 server. So there was no outlook here in this situation. I think there was some diference between time on exchange 2007 and 2010. It seems that EWS on 2007 accept at most 42 days, but exchange 2010 is trying to get more than that (in this case 62 days). I found some example how to set these days on powershell, but not in exchange 2010 configuration, when trying to access other server. Not that is not the case of change the time of the days on exchange 2010 when serving others over EWS, but when it is requesting to the others.
    Tuesday, January 4, 2011 3:44 PM
  • again it is guising no solid inputs here.
    Regards, Mahmoud Magdy Watch Arabic Level 300 Videos about Exchange 2010 here: http://vimeo.com/user3271816 Read pretty advanced Exchange stuff I post here: http://www.enowconsulting.com/ese/blog.asp, follow my blog: http://autodiscover.wordpress.com , corp blog: http://ingazat.wordpress.com, Follow me on twitter http://www.twitter.com/_busbar and if you Liked my post please mark it as helpful and accept it as an answer
    Tuesday, January 4, 2011 6:51 PM
  • I got the same problem, the  strange thing is that the "offending" user's mailbox is not even in EXchange 2010 mailboxes, it's in Exchange 2007 server only. She is using Outlook 2007 , please see the detailed log ( I changed computer names and user name):

     

    Log Name:      Application
    Source:        MSExchange Availability
    Date:          1/4/2011 3:22:49 PM
    Event ID:      4002
    Task Category: (4)
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      EXchange2010
    Description:
    Process 2156: ProxyWebRequest CrossSite from S-1-1-0 to https://exchange2007.mydomain.com/EWS/Exchange.asmx failed. Caller SIDs: NetworkCredentials. The exception returned is Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequestProcessingException: System.Web.Services.Protocols.SoapException: Microsoft.Exchange.InfoWorker.Common.Availability.TimeIntervalTooBigException: The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days. ---> The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling(). The request information is ProxyWebRequest type = CrossSite, url = https://exchagen2007.mydomain.com/EWS/Exchange.asmx
    Mailbox list = <First Name Last Name>SMTP:name@mydoamin.com, Parameters: windowStart = 1/1/2011 12:00:00 AM, windowEnd = 3/1/2011 12:00:00 AM, MergedFBInterval = 30, RequestedView = FreeBusy
    . ---> System.Web.Services.Protocols.SoapException: Microsoft.Exchange.InfoWorker.Common.Availability.TimeIntervalTooBigException: The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days. ---> The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling()
       --- End of inner exception stack trace ---
    . Name of the server where exception originated: exchange2010. Make sure that the Active Directory site/forest that contain the user's mailbox has at least one local Exchange 2010 server running the Availability service. Turn up logging for the Availability service and test basic network connectivity.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Availability" />
        <EventID Qualifiers="49156">4002</EventID>
        <Level>2</Level>
        <Task>4</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-01-04T20:22:49.000000000Z" />
        <EventRecordID>254061</EventRecordID>
        <Channel>Application</Channel>
        <Computer>exchange2010.mydomain.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>2156</Data>
        <Data>ProxyWebRequest CrossSite from S-1-1-0 to https://exchange2007.mydomain.com/EWS/Exchange.asmx</Data>
        <Data>NetworkCredentials</Data>
        <Data>Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequestProcessingException: System.Web.Services.Protocols.SoapException: Microsoft.Exchange.InfoWorker.Common.Availability.TimeIntervalTooBigException: The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days. ---&gt; The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling(). The request information is ProxyWebRequest type = CrossSite, url = https://exchangbe2007.mydomain.com/EWS/Exchange.asmx
    Mailbox list = &ltname;name SMTP:name@mydomain.com, Parameters: windowStart = 1/1/2011 12:00:00 AM, windowEnd = 3/1/2011 12:00:00 AM, MergedFBInterval = 30, RequestedView = FreeBusy
    . ---&gt; System.Web.Services.Protocols.SoapException: Microsoft.Exchange.InfoWorker.Common.Availability.TimeIntervalTooBigException: The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days. ---&gt; The requested time duration specified for FreeBusyViewOptions.TimeWindow is too long. The allowed limit = 42 days; the actual limit = 59 days.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling()
       --- End of inner exception stack trace ---
    . Name of the server where exception originated: exchange2010</Data>
      </EventData>
    </Event>

    Tuesday, January 4, 2011 8:46 PM
  • Hi,

    From the error message, I found the error came up when accessing the Free/Busy of the Exchange 2007's mailbox from the Exchange 2010's user. Is that right?

    Now please help me clarify the following qusetions:

    1, Did you test this issue on another Exchange 2007's user?

    2, Is it working fine when querying the free/busy between the Exchange 2007's users?

    Thanks

    Allen


    Allen Song
    Friday, January 7, 2011 8:37 AM
    Moderator
  • I've been having this exact same issue ever since we brought up our Exchange 2010 servers and moved some users. It is the same scenario for me, where an Exchange 2010 CAS server throws the error, and references an Exchange 2007 server.

     

    I've found this thread which seems to be a developer having the issue, but I have no idea what custom client app could be causing this. Is there any way that we can adjust the maximum time duration? What is the motivation for having it be so short?

    • Marked as answer by Allen SongModerator Monday, January 17, 2011 2:42 AM
    • Unmarked as answer by EASF-BR Wednesday, February 2, 2011 6:37 PM
    Monday, January 10, 2011 2:54 PM
  • I came across this issue not to long ago. The default values used for free\busy are different between Exchange 2007 and Exchange 2010. It took a few days to get resolution on this issue with Microsoft support. The fix is very simple though. Extend the free\busy value on the Exchange 2007 side.

    Here is how: Make this addition on each of your Exchange 2007 CAS servers.
    Open Internet Information Services (IIS) Manager
    Expand the Default Website
    Select the EWS virtual directory.
    Double click Applciation Settings
    Add a new application value:
    Name: maximumQueryIntervalDays
    Value: 62
    Click OK.. That's All.

    Make the change on all the 2007 CAS servers. You should see the 4002 event go away.
    • Proposed as answer by Glate Wednesday, October 5, 2011 4:41 PM
    Friday, September 2, 2011 6:41 PM
  • I'm missing something: When I Select EWS virtual directory I don't have "Application Settings" to Double click. Note: I'm using IIS 6.0
    Friday, September 2, 2011 7:05 PM
  • Hi,

    I think IIS has the following procedure:

    Start IIS / Web Sites / EWS properties

    Tab ASP.net / Edit Configuration.

    Then on the general tab add the maximumQueryIntervalDays with value 62 to the Application settings

    Restart IIS: iisreset /noforce

    • Marked as answer by EASF-BR Wednesday, October 5, 2011 5:08 PM
    Tuesday, September 27, 2011 8:56 AM
  • Hi,

    I think IIS 6.0 has the following procedure:

    Start IIS / Web Sites / EWS properties

    Tab ASP.net / Edit Configuration.

    Then on the general tab add the maximumQueryIntervalDays with value 62 to the Application settings

    Restart IIS: iisreset /noforce


    • Proposed as answer by WoCom Tuesday, September 27, 2011 8:56 AM
    • Edited by WoCom Tuesday, September 27, 2011 8:57 AM
    Tuesday, September 27, 2011 8:56 AM
  • I didn't tried it yet, but I believe you are right. I have a MS gold partner consultant that is scaring me about doing that. I just removed my last ex2003 server from organization, and it's causing a lot of problem. As soon I have my enviranment stable will do that.

    Wednesday, October 5, 2011 5:08 PM