none
Cannot delete mail in OWA only after upgrading Exchange Server 2010 to SP1

    Question

  • When trying to delete mail in OWA I get the error "An unexpected error occurred and your request couldn't be handled". Mail cannot be moved between folders either - same error occurs. These errors do not occur with the full client.
    Friday, September 10, 2010 8:19 PM

Answers

  • Do you have a host name configured in IIS under the bindings?

    On the CAS, open up IIS Manager. Navigate to Default Web Site and in the Actions Pane click on bindings. Make sure there isn't a host name configured. If there is remove the host name.  Login to OWA and try deleting and moving items again.

    In Exchange 2010 SP1, EWS is being used on the server-side to delete items, move items to different folders, mark read/unread items, etc.  If a host header is configured, they cannot connect to EWS on the server-side which causes the error to occur.  This also applies if you configure to Require\Accept client certificates under the SSL settings in IIS.

    Regards,

    Tom


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    Friday, September 10, 2010 9:13 PM

All replies

  • Are all the Exchange servers in your environment upgraded to SP1, or just client access servers?

    Steve Goodman
    Check out my Blog for more Exchange info or find me on Twitter

    • Proposed as answer by shauneenBanned Wednesday, June 08, 2011 10:01 AM
    Friday, September 10, 2010 8:54 PM
  • We only have 1 exchange server.

     

    Environment:

    Windows Server 2008 SP2, Std edition running Microsoft Exchange Server 2010 (now SP1)

    Windows Server 2008r2 Std. ed. 32bit running Active Directory.

    and an open source phone server of no consequence running TrixBox.

    Friday, September 10, 2010 9:11 PM
  • Do you have a host name configured in IIS under the bindings?

    On the CAS, open up IIS Manager. Navigate to Default Web Site and in the Actions Pane click on bindings. Make sure there isn't a host name configured. If there is remove the host name.  Login to OWA and try deleting and moving items again.

    In Exchange 2010 SP1, EWS is being used on the server-side to delete items, move items to different folders, mark read/unread items, etc.  If a host header is configured, they cannot connect to EWS on the server-side which causes the error to occur.  This also applies if you configure to Require\Accept client certificates under the SSL settings in IIS.

    Regards,

    Tom


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    Friday, September 10, 2010 9:13 PM
  • Yipes!!! that was it? Geesh I was working on this most of the day. I guess the service pack is too new to have much info on it. Thank you sir, my supervisor was about to make me re-image the server prior to the install of SP1! Much Appreciated!!!!
    Friday, September 10, 2010 10:19 PM
  •  

    It seems that this is pretty common issue from my searching.  We too are experiencing this one only 1 of our CAS servers (after apply SP1).  We do not have any host headers/host bindings, yet are still experiencing the same issue.

    Any ideas?


    Karl
    Monday, September 27, 2010 2:28 PM
  • Got off the phone with MS PSS (5 1/2 hours) - it appears to have been (for us) a redirection loop.  What ulimately fixed the problem was deleting (or renaming) the web.config file under ..\inetpub\wwwroot\config and then restarting IIS.

    Also, make sure to check that if you are using HTTP Redirect from the Default Web Site level that you uncheck the HTTP Redirect from all the sub/virtual directories as they inheritantly get the setting(s) that are applied at the top level.

    Karl


    Karl
    • Proposed as answer by Stanley18 Saturday, October 30, 2010 11:41 AM
    Monday, September 27, 2010 9:55 PM
  • Hi...

    I've got a similar problem. I'm also not able to perform certain actions (like delete messages) in Outlook OWA 2010 SP1. Before upgrade everything worket just fine. When I try to e.g. delete a message message is deleted and after a few secs is back together with popup message The action you tried to perform couldn't be completed because there's a configuration problem on the server. If the problem continues, contact your helpdesk. At the same time a message Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "null, webException.Status = ConnectFailure". appears in the application event log.

    No hostname bindings for default website, no http redirection configured, no web.config under ..\inetpub\wwwroot\config... nothing... What can be wrong...? Thanks a lot for any help / advice.

    Lubos

    Tuesday, September 28, 2010 11:31 AM
  • hmmm...seems a bit different.  But, may have something to do with your EWS virtual directory.  If you want (and feel comfortbable doing this) there is a nice new feature in SP1 that allows you to reset the virtual directory through the gui.  Open EMC > Click on Server Config > click on Client Access Servers > click on the server having issues > then on the right hand side, select Reset Virtual Directory.  This wizard will walk you through selecting the virtual directory (basically does a remove-webservicesvirtualdirectory and new-webserviceswebdirectory).  Following this, recycle IIS (iisreset) and see if that resolves your problems. 

    Something else to check, is all the virtual directories.  Make sure your redirect is only at the default level and is not propagating to the other virtual directories.  Also, you can check the authentication on the EWS virtual directory and ensure that only Anonymous and Windows Authentication are enabled.


    Karl
    • Proposed as answer by Amir Khalili Wednesday, January 18, 2012 8:54 AM
    Tuesday, September 28, 2010 6:49 PM
  • Hello

    I have the exact problem as Lubos. I checked bindings, re-enabled IPv6, checked and replaced SSL cert, disabled redirection, removed web.config from the wwwroot directory, tried all Test-* cmdlets. I have tried to reset EWS Virtual Directory, the problem persists while deleting an e-mail in "rich" OWA (the light version of OWA works without any problem).

    "The action you tried to perform couldn't be completed because there's a configuration problem on the server. If the problem continues, contact your helpdesk."

    Log Name:      Application
    Source:        MSExchange OWA
    Date:          30.9.2010 11:11:47
    Event ID:      108
    Task Category: Configuration
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      computer.domain.local
    Description:
    Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "null, webException.Status = ConnectFailure".

    I have found that after resetting EWS virtual directory only Windows Authentication is  enabled - Anonymous is disabled.

    I assume Lubos is from the Czech Republic too and probably uses the same server regional settings as me (Czech). It is strange that I have another Ex2010 SP1 installation, with the same settings and I am able to delete an e-mail in OWA.

    Other symptoms:
    - cannot insert picture in OWA
    - when using Firefox 3.6.10, I am not able to do anything in rich OWA. No problem with light version.

    Is it possible to uninstall Ex2010 SP1?

    Radek

    Thursday, September 30, 2010 9:37 AM
  • 1) Are you using redirection at all?  (have you modified the IISStart page)?

    2) Make sure your PowerShell virtual directory does not have SSL checked. 

    3) On your EWS, you should have both Anonymous and Windows Authentication enabled. 

    4) Lastly, check for the Kerbauth module under the PowerShell Virtual Directory, ensure it is there and the path is correct (Module Type shoudl = Native and the Entry Type = Local).

    5) OPTION! You can also try resetting your OWA virtual directory too.


    Karl
    Thursday, September 30, 2010 1:35 PM
  • Hi...

    To Radek:

    I'm from Czech Republic... ;) I have Czech regional settings enabled on many servers - only one does not work after SP1... :-/

    To Karl:

    1) No redirection enabled at all. On the Default Web Site there was SSL required, I have disabled it. No difference.

    2) PowerShell dir exists, no SSL checked

    3) On EWS both authentications checked

    4) Kerbauth there, settings and the dll itself ok

    5) Already done...

    Lubos

    Thursday, September 30, 2010 2:08 PM
  • what happens when you browse to http://servername/ews/exchange.asmx  (or if you have SSL enabled use https://servername/ews/exchange.asmx)  You should get a bunch of xml code.
    Karl
    Thursday, September 30, 2010 2:11 PM
  • Yes, I get the XML.

    Thursday, September 30, 2010 4:36 PM
  • hi,

    to bingdaddy:

    1) no redirection tested, no change, now only this wwwroot web.config content:
     <location path="index.htm">
      <system.webServer>
       <httpRedirect enabled="true" destination="https://mail.domain.cz/owa/" childOnly="true" />
      </system.webServer>
     </location>

    2) Powershell virtual directory does not have SSL checked

    3) EWS Anonymous enabled (why it was recreated without it?)

    4) PowerShell Kerbauth module path correct, parameters too. This is a difference between my Ex2010 SP1 installations - working OWA has Exchange installed in c:\Program Files\Microsoft\Exchange Server\V14\... and data moved manually to a dedicated logical disk later, while the other, non-working OWA has Exchange installed in d:\Exchange Server\V14\...

    5) OWA resetted too.

    6) http://servername/ews/exchange.asmx - a bunch of code appears

    7) all URLs checked with this script - http://msunified.net/exchange-downloads/script-internalexternalurls-ps1/

    IISRESET, no effect, reboot, no effect.

    Thursday, September 30, 2010 10:27 PM
  • Have you ran the EXBPA to see if that gives you any indications?  Also, what error is being logged in the Application Log after you try and delete something from OWA?

    Have you used the Exchange Connectivity Test found at:  https://www.testexchangeconnectivity.com/ ?  Is this spitting any errors?


    Karl
    Friday, October 01, 2010 2:26 PM
  • Rdolezel - what do you mean by "no redirection tested, no change"?  Looking at the web.config, you are infact using redirection (which is fine) - if you are redirecting, are you using it from the HTTP Redirect or are you using it via Error Page while modifying the IISStart page?

    Also, as I mentioned to Lubos: " Have you ran the EXBPA to see if that gives you any indications?  Also, what error is being logged in the Application Log after you try and delete something from OWA? Have you used the Exchange Connectivity Test found at:  https://www.testexchangeconnectivity.com/ ?  Is this spitting any errors?"

    Karl


    Karl
    Friday, October 01, 2010 2:28 PM
  • I have the same issue but got there a little bit differently.  I installed 2010 SP1 directly and utilized ports 80 / 443 in my IIS configuration and everything worked fine.  I changed the SSL port to 444 and this resulted in the unable to delete / unable to move issue with the following message in Event Viewer:

    Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "null, webException.Status = ConnectFailure".

    Updating EWS URLs with Set-WebServicesVirtualDirectory command did not make any difference.  Chane the port back to 443 and all functionality is restored.  Any thoughts as to why the port modification would cause this issue?  Could the upgrade to SP1 be causing the same root issue?

    Friday, October 01, 2010 4:08 PM
  • Hi,

    I had used a combination of http redirection (for index.html only) with customized aspx-based error page (website level) for 403.4 before SP1. Removed it after SP1 installed and OWA problems found - I wanted to isolate problem areas.

    ExBPA test ran ok, Exchange Remote Connectivy tests too.

    Friday, October 01, 2010 9:02 PM
  • Chane the port back to 443 and all functionality is restored.  Any thoughts as to why the port modification would cause this issue?  Could the upgrade to SP1 be causing the same root issue?

    With Exchange 2010 port 443 might be hard-coded to use SSL with OWA.  Using a non-standard port is not a supported configuration.
    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    • Proposed as answer by donio007 Wednesday, December 08, 2010 1:21 AM
    Saturday, October 02, 2010 9:56 PM
  • I had used a combination of http redirection (for index.html only) with customized aspx-based error page (website level) for 403.4 before SP1. Removed it after SP1 installed and OWA problems found - I wanted to isolate problem areas.

    ExBPA test ran ok, Exchange Remote Connectivy tests too.


    Since you mentioned that the host header is not configured in the bindings and you are still unable to delete items. Can you check to see if there are corresponding errors in the application logs?

    Also, do you have client certificates set to ignore on the EWS virtual directory.

    • Open up IIS Manager
    • Go to Default Web Site > EWS > SSL Settings
    • Make sure that the client certificates is not set to Accept\Require. If it is choose Ignore, apply the changes and perform IIS reset.
    • Then confirm if it still occurs

    This is probably an EWS issue.

    With Exchange 2010 SP1, EWS is being used for most of the functions performed on the server-side, such as deleting items, moving items to a different folder, mark read/unread items, etc. 


    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST
    Saturday, October 02, 2010 10:01 PM
  • I encountered the same error.  When I removed the web.config file in wwwroot the errors disappeared, but as soon as I re-created the OWA redirect the errors came back.  And we were seeing the issue on one of our two servers in our CAS array.  I was able to resolve the issue by doing the following:

    • Locate the web.config file in the ClientAccess\OWA directory in the Exchange Server install directory
    • The end of the file contained the following lines:
      <system.webServer>
         <httpRedirect enabled="true"/>
      </system.webServer>
    • Remove those lines
    • Save the web.config file
    • Reset the IIS services on the server

    After making those changes we are no longer getting errors in our OWA.

     

    • Proposed as answer by skuttan Monday, March 14, 2011 2:20 AM
    Tuesday, October 05, 2010 9:22 PM
  • Got off the phone with MS PSS (5 1/2 hours) - it appears to have been (for us) a redirection loop.  What ulimately fixed the problem was deleting (or renaming) the web.config file under ..\inetpub\wwwroot\config and then restarting IIS.

    Also, make sure to check that if you are using HTTP Redirect from the Default Web Site level that you uncheck the HTTP Redirect from all the sub/virtual directories as they inheritantly get the setting(s) that are applied at the top level.

    Karl


    Karl


    I do not have a folder in inetpub\wwwroot\ named config. 

    Here is my wwwroot directory listing

     Volume in drive C has no label.
     Volume Serial Number is 962C-CDBD
     Directory of C:\inetpub\wwwroot
    10/03/2010 11:32 PM  <DIR>     .
    10/03/2010 11:32 PM  <DIR>     ..
    10/03/2010 04:04 PM  <DIR>     aspnet_client
    10/03/2010 03:35 PM        689 iisstart.htm
    10/03/2010 11:32 PM        153 web.config
    10/03/2010 03:35 PM      184,946 welcome.png
            3 File(s)    185,788 bytes
     Directory of C:\inetpub\wwwroot\aspnet_client
    10/03/2010 04:04 PM  <DIR>     .
    10/03/2010 04:04 PM  <DIR>     ..
    10/03/2010 04:04 PM  <DIR>     system_web
            0 File(s)       0 bytes
     Directory of C:\inetpub\wwwroot\aspnet_client\system_web
    10/03/2010 04:04 PM  <DIR>     .
    10/03/2010 04:04 PM  <DIR>     ..
    10/03/2010 04:04 PM  <DIR>     2_0_50727
            0 File(s)       0 bytes
     Directory of C:\inetpub\wwwroot\aspnet_client\system_web\2_0_50727
    10/03/2010 04:04 PM  <DIR>     .
    10/03/2010 04:04 PM  <DIR>     ..
            0 File(s)       0 bytes
       Total Files Listed:
            3 File(s)    185,788 bytes
           11 Dir(s) 954,678,505,472 bytes free
    

    I do have a web.config file in wwwroot itself... I have checked all of the other items listed.  I have also:

    • removed/recreated all the exchange virtual directories,
    • reinstalled/reconfigured ssl certificates
    • Verified no host headers present in bindings
    • removed 127.0.0.1 from bindings
    • changed various authentication settings
    Thursday, October 07, 2010 3:15 PM
  • OK, I even though I didn't have the directory structure mentioned in the quote from above, I went in and renamed the web.config file in the wwwroot folder and ran iisreset from the powershell.  relogged into the website and...

    I CAN DELETE! 

    I tried so many other things, and this simple fix worked.  I'll never get back the 5-6 hours I've spent on this, but at least it's working now!

     

    delete/rename web.config in inetpub\wwwroot folder.

    Thursday, October 07, 2010 3:25 PM
  • I've fixed this by changing the authentication method for the EWS virtual directory under  IIS manager.

    In my case, I had changed the authentication methods for OWA to Basic and Windows authentication on the exchange manager, but it seems that you also need to change for the EWS virtual directory. Since this option is not available on the exchange management console you have to do it on the IIS Manager.

    Just select the EWS virtual directory, click on authentication and put the same authentication methods that you are using for the OWA virtual directory.

    Hope it can help.

    Cheers

    Thursday, November 04, 2010 2:38 PM
  • First of all, i receive the error although no host name is configured under IIS, bindings.
    Second, the web.config under inetpub\wwwroot is needed for the simplification of the OWA URL: http://technet.microsoft.com/en-us/library/aa998359(EXCHG.80).aspx
    When you make the redirection under IIS, the web.config file gets created. The redirection info is stored in it.
    Deleting the file is not a fix. If deleting the file removes the problem, the clearly there is a bug in exchange.

    Cinciberlandia: you can set the authentication methods using the Set-WebServicesVirtualDirectory.
    I think EWS virtual directory needs the default authentication methods and you shouldn't mess with it.

    Anyway, after OWA gives the error message, i can successfully delete.

    Anybody has any other solution?

    Thursday, November 04, 2010 5:35 PM
  • Savarina,

    You are right, I tried to delet web.config file and it removed my redirection, Stated following

    " Anyway, after OWA gives the error message, i can successfully delete"

    I can not delete still after message , Any suggestions ?

    I Found standard setting for IIS from microsoft , Tired to follow the same but no help

    http://blogs.technet.com/b/msaad/archive/2010/09/24/default-authentication-methods-in-exchange-2010-cas-and-mailbox-servers.aspx

     

     

    Thursday, November 18, 2010 5:32 PM
  • Even im facing the same issue, but when i logged in OWA with light mode im able to delete the emails. It not happening for all the users only for 1 or 2, this shouldn't be a issue with IIS in CAS.
    Friday, November 26, 2010 5:04 PM
  • A hours and hours, i find the issue (for me)

    In my case, i had to modify the authentification parameters in IIS management console.

    Caution : i'm not talking about files and folder permissions but the Authentification icon in iis management console when you click on each subfolder.

    For the subfolder ecp :

    • anonymous : disabled
    • basic : enabled
    • digest : disabled 
    • Forms : disabled
    • Windows : enabled
    • ASP.NET : disabled

    For the subfolder EWS :

    • anonymous : enabled
    • basic : enabled
    • digest : disabled 
    • Forms : disabled
    • Windows : enabled
    • ASP.NET : disabled

    For the subfolder owa :

    • anonymous : disabled
    • basic : enabled
    • digest : disabled 
    • Forms : disabled
    • Windows : enabled
    • ASP.NET : disabled

    And it works, i can delete / move messages in owa !!

    I think that if you use Form authentification, you need to disable Basic and enable forms in those three subfolders.

    Arnaud

    • Proposed as answer by RobertP89 Tuesday, July 03, 2012 2:25 AM
    Wednesday, December 01, 2010 4:31 PM
  • i have this warning:

     

    The mailbox you're trying to access isn't currently available. Please try again in a few minutes.

    to move or delete..... 

    after install SP1 only for Shared mailBox in OWA in IE7 & IE8...all mailbox ok ...but shared not

    with my account -is Domain admins- all right

    Please any suggestions

     

    Wednesday, December 01, 2010 9:17 PM
  • Chane the port back to 443 and all functionality is restored.  Any thoughts as to why the port modification would cause this issue?  Could the upgrade to SP1 be causing the same root issue?

    With Exchange 2010 port 443 might be hard-coded to use SSL with OWA.  Using a non-standard port is not a supported configuration.
    MCITP: Enterprise Messaging Administrator 2007/2010 | MCITP: Server Administrator | MCTS: Windows Server 2008 Applications Infrastructure, Configuring | MCP | MCDST

    That solved my problem with non-deleting messages. I tried run OWA on 8443 port, after deleting this binding everything works fine!
    Wednesday, December 08, 2010 1:23 AM
  • We had the can't-delete-message-using-OWA" problem and it was related to an IPV6 / EWS / WCF / Wildcard bug.  There is a hotfix that solved our problem.  Check the following KB articles: 

    Bug Info:  http://support.microsoft.com/kb/2249852
    Hotfix Info:  http://support.microsoft.com/kb/981667

    NOTE:  The first download link in the second KB article is wrong (at the time of this writing) - actually, it "looks" correct, but the hyperlink URL is/was different than the displayed text; the correct download link should be: 

    http://code.msdn.microsoft.com/KB981667/Release/ProjectReleases.aspx?ReleaseId=4485

    Hope it helps!

    Sunday, January 30, 2011 8:18 PM
  • One thing I found today....  I have a customer that was having this issue.  they had added another port in iis for ActiveSync users.  Basically, they have their users add a port to the end of the server url on their mobile devices.  There FW redirects to the exchange server on that port.

    If I take the port out of the bindings, the issue went away.

    Workaround:  created a new site in IIS called ActiveSync, then in Exchange I created a new virtual directory for activesync and applied it to the new site.  then I added the port to that site.  Presto, it all works fine now.

    Hope this help anyone else with similar issues.

     

    Ron

    Monday, February 07, 2011 8:38 PM
  • Thanks Greg - Your solution fixed my problem too!

     

    - Tony


    Tony
    Tuesday, March 01, 2011 10:15 PM
  • Hi,

    I have tried all the methods and all the suggessions, but still no luck. I am still facing an issue, users are not able to delete the mails from OWA.

    Unable to delete mails from OWA 2010 Premium version after updating SP1 for Exchange 2010 .

    Please help me.

    Monday, April 04, 2011 11:15 AM
  • Hi,

    Go through the following link and install the fix(Windows6.1-KB981667-x64.msu) provided by the microsoft.

    https://connect.microsoft.com/VisualStudio/Downloads/DownloadDetails.aspx?DownloadID=29422

    It will the fix the issue.

    Muthu

    • Proposed as answer by MSMuthu Friday, April 22, 2011 7:44 AM
    Friday, April 22, 2011 7:44 AM
  • Thanks Heaps.

    This fixed my exchange 2010 errors when deleting messages through OWA.

     

    Sunday, May 01, 2011 11:23 AM
  • I had this issue because I changed the SSL binding port to 4433.  I resolved the issue by changing my router to forward 4433 to internal port 443 and changing the SSL binding port back to 443.
    Monday, May 09, 2011 10:18 PM
  • fixed me!  Thanks!
    Thursday, May 26, 2011 7:14 PM
  • Thank you Tom,

     

    This is correct, but I want to notice that prior to SP1 you could configure a couple of host headers, including the server's fully qualified name, and EWS then worked correctly!

    If you believe that this isn't a Microsoft issue, can you provide us more technical information regarding this problem.

     

    Regards,

    Liridon

    Thursday, June 02, 2011 10:05 PM
  • I fixed this and a bunch of other issues by making sure you have Enable HTTP keep-alive checked in IIS>servername>HTTP Response Headers>Set Common Headers

    My issues were:

    1. Couldn't access OA via Outlook
    2. Couldn't delete email in OWA but I could delete in OWA/light
    3. EMC would not open
    4. Exchange Powershell was giving errors connecting to CAS servers

    I hope this info helps someone because I was going crazy trying to figure this out.

    Thanks,

    Steve

    Friday, June 24, 2011 6:02 PM
  • Thanks Arnaud-31.

    Just setting EWS with anonymous enabled did it for me :-)

    Much appreciated.

    Fowey Boy

    • Proposed as answer by Fowey Thursday, August 11, 2011 1:51 PM
    Thursday, August 11, 2011 1:50 PM
  • Hi,

     

    I solved it.  Tried everything on tthis board to no avail.  Users couldnt delete messages but they could under OWA light

     

    Open IIS, click on default web site and choose bindings.  Make sure you have two for HTTPS

    https all unassigned no host name and slect your assigned cert

    https 127.0.0.1 no host name and select your assigned cert

    I had a host name under port 80 (which i removed) but i think my real issue was i had just one https set using ip 192.168.10

     

    Also on another note if you get a blank screen or page cna not be displayed after loggin into OWA make sure your Microsoft Exchange Forms-Based authentication service is started. 

    - right click on computer choose manage adn under configuration choose serives.

     

    Mine wont start automatically for some reason  onto another battle

     

     

     

    • Proposed as answer by guiguy62 Monday, July 08, 2013 10:17 PM
    Thursday, October 13, 2011 9:15 PM
  • Cheers Greg it worked deleting the web.config file C:\inetpub\wwwroot\web.config just it starts working out of office,caledar and contact sharing sharing ,also moving and deleting in OWA tnx!!!!
    Thursday, November 03, 2011 12:56 PM
  • hmmm...seems a bit different.  But, may have something to do with your EWS virtual directory.  If you want (and feel comfortbable doing this) there is a nice new feature in SP1 that allows you to reset the virtual directory through the gui.  Open EMC > Click on Server Config > click on Client Access Servers > click on the server having issues > then on the right hand side, select Reset Virtual Directory.  This wizard will walk you through selecting the virtual directory (basically does a remove-webservicesvirtualdirectory and new-webserviceswebdirectory).  Following this, recycle IIS (iisreset) and see if that resolves your problems. 

    Something else to check, is all the virtual directories.  Make sure your redirect is only at the default level and is not propagating to the other virtual directories.  Also, you can check the authentication on the EWS virtual directory and ensure that only Anonymous and Windows Authentication are enabled.


    Karl

    Thanks bingdaddy ,

    you're great man! 

    This worked like a charm for me.

     

    Amir Khalili.

    Wednesday, January 18, 2012 8:55 AM
  • hmmm...seems a bit different.  But, may have something to do with your EWS virtual directory.  If you want (and feel comfortbable doing this) there is a nice new feature in SP1 that allows you to reset the virtual directory through the gui.  Open EMC > Click on Server Config > click on Client Access Servers > click on the server having issues > then on the right hand side, select Reset Virtual Directory.  This wizard will walk you through selecting the virtual directory (basically does a remove-webservicesvirtualdirectory and new-webserviceswebdirectory).  Following this, recycle IIS (iisreset) and see if that resolves your problems. 

    Something else to check, is all the virtual directories.  Make sure your redirect is only at the default level and is not propagating to the other virtual directories.  Also, you can check the authentication on the EWS virtual directory and ensure that only Anonymous and Windows Authentication are enabled.


    Karl

    Thanks bingdaddy ,

    you're great man! 

    This worked like a charm for me.

     

    Amir Khalili.

    Wednesday, January 18, 2012 8:57 AM
  • I also had to fix authentication in the EMC, not just in IIS.

    Server Configuration/Client Access/Exchange Control Panel/Properties/Authentication.

    When we checked, we had it set to forms-based for some reason.

    Tuesday, June 05, 2012 2:16 PM
  • Hello Tom,

    that´s work´s. And the Out-of-Office configuration by User via OWA works, too.

    Thank you

    Regards

    Thomas

    • Proposed as answer by jbelton Monday, October 22, 2012 10:45 AM
    Monday, June 11, 2012 2:13 PM
  • There's another bug which can cause this. We were affected as well. The bindinds are set in the IIS console BUT they are not applied for some reason. Fortunately we have a support contract with Microsoft so we raised a ticket in this regard. They asked us to run the following command:

    netstat -abno

    As it turned out, the server did not listen either on 127.0.0.1:443 nor on 0.0.0.0:443 even though they were added in IIS bindings. So their advice was to re-check the SSL certs, perhaps switch them to another one and then switch back, AND also, add the bindings manually:

    netsh http add iplisten ipaddress=127.0.0.1
    Guess what? Now we can delete messages in OWA. Meh.


    Saturday, June 23, 2012 6:13 PM
  • After hours of working through these fixes, the solution by OVTI-LONG worked for me.

    Thanks!

    Saturday, July 14, 2012 8:55 AM
  • Well for me is was a different solution. Hopefully this helps someone.

    I noticed that when I clicked Server Configuration in Exchange Management Console My SSL cert was only applied to SMTP for services.  This is normally fine for me, because I use an f5 Load Balancer to do SSL offload and I dont want SSL running on the client access servers.  so I didnt think anything of it.. but I was having the annoying issue of not being able to delete emails.

    This is what I did to fix it.

    • Re assign the SSL cert to IIS
    • Open IIS Manager
    • Click Default Web Site
    • Double Click SSL Setting
    • Then unchecked Require SSL

    Again only do this if you are using a SSL Offloader like the f5 LTM

    Everything working great now

    Thursday, August 02, 2012 9:08 AM
  • I'm having the same issues as above since I updated my Exchange 2010 environment to 14.2.318.2 . When I remove the bindings from my IIS website indeed works, but I'm not getting to work when accessing it from external clients? (I do when i have the binding, but then I get the errors) Also I'm wondering how to set a SSL Certificate properly when you can't have hostnames? Or can you set hostnames after all?
    Wednesday, September 26, 2012 8:37 AM
  • Just finished a 12 hr stretch battling this thing after hours. Tried all proposed method. This solution fixed it. If you are running Windows 2K8 SP2 there is a version of the hotfix with the same KB number that wont install. The files on this  page http://archive.msdn.microsoft.com/KB981667/Release/ProjectReleases.aspx?ReleaseId=4485 definitely fixed the issue. Thank you Double Java now on to clean up and back track redundant tries while battling this monster. then sleep. ;0)

    Wednesday, March 13, 2013 1:17 AM
  • Hi,

     

    I solved it.  Tried everything on tthis board to no avail.  Users couldnt delete messages but they could under OWA light

     

    Open IIS, click on default web site and choose bindings.  Make sure you have two for HTTPS

    https all unassigned no host name and slect your assigned cert

    https 127.0.0.1 no host name and select your assigned cert

    I had a host name under port 80 (which i removed) but i think my real issue was i had just one https set using ip 192.168.10

     

    Also on another note if you get a blank screen or page cna not be displayed after loggin into OWA make sure your Microsoft Exchange Forms-Based authentication service is started. 

    - right click on computer choose manage adn under configuration choose serives.

     

    Mine wont start automatically for some reason  onto another battle

     

     

     

    Only this worked for me !

    thanks a lot

    Monday, July 08, 2013 10:17 PM
  • This solution worked for.

    Thank you very much.... After a week of troubleshooting OWA and out of office replies are now working.

    Tuesday, October 15, 2013 4:51 AM
  • You know what would be great? If you actually explained how to get to the Clientaccess\owa directory...or is everyone just supposed to know where that is?
    Tuesday, July 22, 2014 6:48 PM
  • Great, another worthless answer. How about explaining how to get to that directory!

    Tuesday, July 22, 2014 6:49 PM
  • Thanks  everyone! Saved my day
    Thursday, September 18, 2014 12:35 PM
  • I was having issues with OWA users not being able to delete mail. We got an error that the operation couldn't be performed and that there was a server configuration problem. I still read through this post and here's most of what is mentioned:

    1. virtual directories - seemed a little "out there" so I didn't want to mess with them just yet

    2. web.config - did not exist in the wwwroot folder - thought this may be an issue but would have to revisit

    3. bindings - appeared all correct per the posts

    4. exchange connectivity tests - these came back normal so I was a little perplexed about redirects and SSL problems possibly being the culprit but I didn't want to mess with uninstalling/reinstalling SSLs just yet

    5. reviewed iis authentication methods for ecp, ews, and owa and they all checked out

    6. HTTP keep alive was checked

    It seemed like any one of these worked at any given time for some people so it's probably good to go through them but all I want to post is this:

    - if your system had been working fine and no other problems appear to be occurring and suddenly the only issue is that your users can't do anything in OWA then you can still check everything in this post but I recommend you that the first thing you do is open IIS manager and reset server. Now, it took about 5 times as long to reset than any apache I've ever restarted but once it was done my OWA was working as it should. 

    I actually installed some updates the day before and restarted the server and the server restarts every weekend so I really felt like everything was running fresh and I was wrong. I would say just try to manually restart IIS and give that a shot.

    • Proposed as answer by WNYfresh Tuesday, September 15, 2015 7:02 PM
    • Unproposed as answer by WNYfresh Tuesday, September 15, 2015 7:02 PM
    Friday, May 01, 2015 4:14 PM
  • In my case I tried just about everything I saw in this thread and it turned out to be a simple binding setting. In IIS under Sites we have 2 sites setup. One for Default Web Site and another for our external OWA email access. I checked the binding for that external site and https was in there but upon looking into that actual https binding setting (Edit) I noticed the SSL certificate was not selected. Hope this helps someone. Worth at least taking a look at if you're having an issue since it only takes a few seconds to check and fix.
    Tuesday, September 15, 2015 7:11 PM
  • In my case I tried just about everything I saw in this thread and it turned out to be a simple binding setting. In IIS under Sites we have 2 sites setup. One for Default Web Site and another for our external OWA email access. I checked the binding for that external site and https was in there but upon looking into that actual https binding setting (Edit) I noticed the SSL certificate was not selected. Hope this helps someone. Worth at least taking a look at if you're having an issue since it only takes a few seconds to check and fix.

    yes, this is fixed my problem,  on exchange 2010
    OWA just show blank page when try to access using https://server/owa
    so I open IIS manager --> Default Web Site --> Binding
    then select  https --> edit ---> SSL certificate show that it is "Not selected"

    Friday, October 23, 2015 10:20 AM
  • Perfect.

    Worked for me; thank you!

    Tuesday, July 19, 2016 2:11 PM