none
SCR331 card reader on Vista

    Question

  •  

    I need to get a SCR331 card reader (CAC reader) working on Vista.  The computer does not recognize the cardreader, is there a driver download or fix for this problem?  Anybody else able to get a card reader working, if so what model.
    Monday, August 04, 2008 7:26 PM

All replies

  • I have it working on my vista laptop Dell Inspiron E1505, for about 7 months.  It was a headache to get it going.  Big problem I found was there are two registry keys that need to be deleted to install the drivers to read that CAC reader.  I am trying to get CAC loaded on my wifes computer (just like my laptop) and I can't find the info for the keys that must be deleted...  I thought I saved it.  Once you remove the keys, it installs like normal and operates great...

    Thursday, August 07, 2008 5:11 PM
  • I'm also having the same prob.  i've got a SCR331 CAC Card Reader (the CAC Card used specifically on computers at work in the military) and I can't get it to operate on Vista 32 bit.

    FYI:  All military computers currently operate on Windows XP Pro

    I'm running a brand new desktop computer that I built myself, and I just formatted the hard drive yesterday.  I've got no issues with my PC other than the fact THAT I REALLY WANT THIS CAC CARD READER TO WORK.  There seems to be some confusion among techies out there in the IT community.  The CAC Card Hardware currently used by the military is the USB SCR331 (no exceptions).  I have no additional nomenclature information other than stated for that device.  The CAC software currently used by the military is ActivIdentity and Approveit-Silanis.  ActivIdentity does manufacture CAC Card Hardware "CAC Card Readers", but the military doesn't currently use their readers, we only use the SCR331's.

    I've googled for hours and couldn't find a driver that would work for the SCR331 on Windows Vista 32bit.  I'm pretty sure it has something to do with the registry, but i'm a nube when it comes to registry.  anyone out there have ideas?
    Sunday, September 28, 2008 8:10 PM
  • I got the SCR331 to work on my wife's new HP 4 months ago... seems like I found the answer Googling... but now I can't find the solution I used to get it installed on my new Toshiba.

     

    Tuesday, September 30, 2008 8:49 AM
  • After I ensured that all of the certificates were installed, i was having trouble getting to the NMCI webmail.  To make a long story short, right click on the IE icon and select "run as administrator."  It worked for me.

     

    Good Luck

     

    Tuesday, October 07, 2008 10:56 PM
  • Just bought a new Lenovo T500 with Vista Ultimate and a CAC card reader.  Somehow the ActiveClient software (XP Pro) from my unit installed without a hitch.  I downloaded the certs and then went to a secure website.  The site opened, I very cockily entered my CAC pin and then WAMMO....IE7 promptly crashed.  I think computers can sense confidence sort of like dogs sense fear.  Was about to give up when I read your post above....worked like a charm!!!!  Brother, You are THE man!!!  Many thanks, Best, Filio USAF

     

     

    Friday, October 10, 2008 11:51 AM
  • Did you ever get your SCR 331 to work on your Vista computer?  I've found that if you install the 1.40 driver for the SCR 331 driver it will work.  Visit:  http://militarycac.com/usbreaders.htm  click on the word driver under the little picture of the SCR-331. 

      There is instructions (if you need them) on how to update the driver in Vista on  http://militarycac.com/cacdrivers.htm

     

    Mike Danberry

    http://militarycac.com

     

    Sunday, November 02, 2008 1:00 PM
  • Something new with Vista... It operates a lot like Windows Server 2003/2008. To get the card reader going you should go to the "Control Panel", "Administrative Tools", "Services" and scroll down to "Smart Card". Make sure that it is started. Set it to "Automatic" in it's properties. Smart card use is not always automatic granted for users in Server or Vista.

     

    Monday, November 24, 2008 4:25 PM
  • www.Envoydata.com   is a great resource for support and drivers (vista) as well.

    heres a link to the SCR331 specifically, with drivers on the page.

    http://www.envoydata.com/security/scm/scr331.php

    Also, readers purchased from Envoy Data come with full support.
    • Proposed as answer by Super D Saturday, May 02, 2009 4:20 AM
    Friday, April 03, 2009 6:13 PM
  • I had the same problem, could not get SCR331 smart card reader to work on Windows Vista 64-bit laptop.  I looked at the registry, services were turned on and tried different versions of drivers, but nothing worked.  Every time I plugged in the smart card reader Windows would try to load driver but could not find one that was suitable.  This is what I found and it worked perfectly. 

    It appears my smart card reader (SCR331) was an older version non-CCID.  All I had to do was upgrade firmware to CCID.  This came from Smartcard Reader Installation and Troubleshooting Manual (Version 1.0 dated 17 Nov 2008) from SCM Mirosystems.  In the manual they listed the non-CCID readers will not work on WP (64-bit) and all version of Vista.  I plugged in the card reader into a computer that did not have a problem with the drivers and then updated firmware as defined in manual.  As soon as the computer updated firmware, I had to reload the driver on the computer that had a firmware update.  Once this was completed, I plugged the smart card reader into my new Vista 64-bit laptop and it loaded the driver.  Seconds later the card reader was working perfectly on all the sites I need to visit.

    Saturday, May 02, 2009 4:45 AM
  • I have tried EVERYTHING above - the lone exception being updating firmware as I don't have a reliable site to do that from and changing firmware can be dangerous - yet this complete POS STILL does not work on my Vista 64 (new) system.  It says it does not detect a reader attached to my PC, even though I have double/triple checked that it is, made sure it wasn't loose, tried another USB port, rebooted, etc etc. 

    Any other suggestions appreciated!!
    • Proposed as answer by Super D Saturday, August 15, 2009 2:03 AM
    Wednesday, August 05, 2009 3:05 PM
  • bill55,

    Try this link http://www.scmmicro.com/support/pcs_downloads.php?lang=en. If you have a 331 follow these instructions when you are on the site.
    - Select Driver/Firmware
    - Select SCR331 nonCCID USB
    - Select Windows XP 32 Bit ( I know you have a 64 Bit)
    - Check box in lower left corner and select Next
    In the Notes section it provides direction for updating legacy firmware.

    But on the same site click on Downloads (Middle left side of page),  It shoudl take you back to the begining.  Now select Utilities and check box lower left and select Next.  Halfway down is USB FW Update for Windows (all).  Also at the same area is PC/SC Diagnostic.

    Good luck!
    Saturday, August 15, 2009 2:32 AM
  • Thanks, but there were no "notes" of any kind on the download above.

    Also, when I tried running the "USB FW update" utility, it said "no USB reader found" even though my CAC reader was plugged in (I can see the green light on it lit even).


    Classic military SNAFU.....this is freaking ridiculous.  What really gets me is even the so-called experts at our mil technical helpdesks have no clue how to get this to work and said as much.  But appreciate the attempts to help; any other possible fixes welcomed (a well-aimed bazooka at the PC perhaps?).

    Tuesday, September 01, 2009 6:17 PM
  • rjblank,
    Did you ever figure out which two registry keys needed to be deleted for the CAC to work properly?
    Thursday, September 17, 2009 2:05 PM
  • Guys,

    I just did this tonight on my Dell Vista Home Premium 64bit and it finally works. It's kind of a long process but it works. 

    1. Find a XP machine

    2. Plug in your CAC Reader, it will try to install and it will fail.

    3. Go to Windows/Microsoft update and click custom instead of Express

    4. Install the Hardware that should be for the CAC Reader (remember your still on a XP machine)


    6. Install the firmware update, all defaults for installation (may take 10 mins, it did on my wifes netbook)

    7. Once firmware is updated, plug into your vista machine and it should be recognized. Now I have installed a much of drivers previously and not sure if that helped but this did work for me tonight. Let me know if it helps anyone else out.
    Saturday, September 26, 2009 7:39 AM
  • I am having the same problem it worked and installed just fineon my old laptop
    Tuesday, October 20, 2009 10:02 PM
  • I just assisted a fellow Soldier updating his firmware on an older SCR-331 USB CAC reader.  We followed the instructions on:  https://militarycac.com/cacdrivers.htm  under the section titled:  FIRMWARE UPDATE.  We were able to do the update via his Windows 7 64 bit computer. 

    Mike Danberry  https://militarycac.com
    612-328-8768 


    CW3 Michael J. Danberry 612-328-8768 http://militarycac.com
    Tuesday, December 29, 2009 10:10 AM
  • Ok so here is the easy way. 

    1. You need to update the firmware, you can get it here http://www.txsystems.com/cac.htm l, here is a direct link to the firmware download http://www.txsystems.com/downloads/SCRx31CCID_fw5.22.zip

    2.  Run the installer and update the Firmware.

    3.  Go here http://www.scmmicro.com/support/pc-security-support/downloads.html and download for your CAC reader if it's the SCR331 then download SCR331/SCR531 CCID USB and select your OS.

    4.  Install the drivers for your OS

    I just did this and finally my CAC reader works on Vista/7 64bit.
    Tuesday, January 26, 2010 12:08 PM
  • I am having the same problem, I have a 64 bit, i have installed the activeIdenty and approvit software, but when i trouble shoot is says "no smart card device driver installed" I installed the drivers for the cac.. but thats not working either.. please help, I don't know what to do, but need to be able to get this working.
    Sunday, February 07, 2010 4:19 AM
  • Hello bluenblnde,

      Have you received a new CAC within the past few weeks? 

      ID card offices are now issuing out new PIV II CAC's.  You can tell if yours is one of these by looking for either of these on the back at the top.  "Gemalto TOP DL GX4 144K" or "Oberthur ID One 128 v5.5 Dual."  
     
      Three possible fixes are known right now for this problem.  First is to install the newest DoD certificates, second is to run this fix for your version of Windows (either 32 or 64 bit), and the third is to install ActivClient 6.2.

      There are also (unfortunately) some computers that will not read the new CACs.  :(

    CW3 Michael J. Danberry 612-328-8768 http://militarycac.com
    Sunday, February 07, 2010 2:19 PM
  • Hello
    Thursday, April 08, 2010 4:24 AM
  • Hi.  What a useful post.

    FWIW I had a truckload of problems with this (SRC331 reader with Vista 64) and installing the activeclient 6.2 middleware upgrade (I had to uninstall earlier version first) worked.  If you are AF you can get this via the AF Portal (call for a temp password to get in and get it).  Also go into "Services" and make sure anything called "Active Client" anything is on "automatic" setting (vs "Disabled" etc).  NOTHING until that point worked.

    It's amazing how something as simple as being able to have proper middleware/drivers for a simple card reader can be made so ridiculously hard, isn't it?

    PS:  I do NOT recommend trying what's at "militarycac.com," what a horribly designed site and didn't do a thing.  Apparently they don't even know about the 6.2 upgrade and they have a screwball roundabout way of getting you to update the driver.   I just went into the device driver thing in Windows for my CAC device and clicked on "update driver."

    Wednesday, April 21, 2010 1:29 AM
  • Hello SgtBill,

      Welcome to the world of troubleshooting computers.  You found out that what worked on other computers did not work on yours.  Unfortunately this is the way it is working with CAC readers, firmware, drivers, and different branches of the military's version of ActivClient.

      I can assure anyone reading this forum that what is at MilitaryCAC.com has helped thousands of people.  SgtBill is one of the few exceptions.  He would rather downgrade my site, than to send a polite email letting me know that he found a better way of doing this.  I recommend he contacts me at:  chief at MilitaryCAC.com  and let me know what I can do to make it a better website.  Most people are able to find what they need and are successful. 

      The information regarding the 6.2 upgrade (for the Air Force version) is new to me. I did make a note of it that the Air Force version is NOT an upgrade.  The other branches of the military use the Commercial Off the Shelf (COTS) version of ActivClient, so the upgrade works fine.  The Air Force takes a version and tweaks it.  This is why SgtBill had this problem with attempting to upgrade his ActivClient.

      The SCR-331 readers do need firmware updates on some of the older ones.  Unfortunately, updating the driver alone, does not update the firmware.  Read more at: https://militarycac.com/cacdrivers.htm#FIRMWARE_UPDATE 


    CW3 Michael J. Danberry 703-679-8989 / 612-328-8768 (Sprint) https://militarycac.com
    Wednesday, April 21, 2010 9:43 AM
  • Chief Danberry (& Sgt. Bill,)

    After 4 hours of fighting with this %&#** confounded CAC reader driver/firmware/Air Force-tweaked ActivClient, I finally searched on 'can't get my cac reader to work' and found this incredibly long string of other equally confounded technophiles. I read down and almost got excited when I saw that SuperD had achieved success in his first post, but then he didn't provide enough detail. When I got to Chied Danbury's 2nd post of 29 Nov, I tried that, although I had been there 2-1/2 hours ago with no success. Followed your detail concerning updating the firmware and followed it to the 'T' and voila, bully, I say, damn well good, success, Eureka! Now I can spend the rest of the night doing my on-line testing to get my voucher for commercial certification in Security+, so I can maintain my Information Assurance Officer shred for a network at work I don't even have admin rights on - go figure. I think I'm gonna have a cold beer, then one for Sgt. Bill, then one for you, Chief. Then another one for me, then... THANKS!

    Saturday, April 24, 2010 9:36 PM