none
can no longer ping dag

    Question

  • I've created a dag with a server in another offices.  Both offices are connected via 100 mb cogent circuit.   It let me create the dag.  However, once i added the other office's exchange server to the dag, i can no longer ping the dag and my symantec backups started to fail.    Through the powershell command

    Get-DatabaseAvailabilityGroup -identity "dagname" | fl *ip*


    I've verified that the ip address of the dag hasn't changed, but still cannot ping and i have a feeling that may be why the backups are failing.   When i go into the gui, it looks like the dag is online.   And i was able to ping before adding my other server to the dag.  Any ideas as to what's going on?

    Tuesday, August 03, 2010 12:48 PM

Answers

All replies

  • Yep, BE connects to the DAG object, so that is why backups are failing.

    What GUI did you check? Did you look in the Failover Cluster Manager? Check there for errors as well.

     

     

    Tuesday, August 03, 2010 1:04 PM
    Moderator
  • Have you configured the DAG IP address statically to have two IP's one in Main site and one in the other site ?

    This can be done using:

    New-DatabaseAvailabilityGroup -Name DAG3 -WitnessServer EXHUB2 -WitnessDirectory C:\DAG3 -DatabaseAvailabilityGroupIPAddresses 10.0.0.8,192.168.0.8

     

    and you can check the two ip's and status for DAG name through the failover cluster manager.


    Tamer Sherif Mahmoud
    Tuesday, August 03, 2010 1:29 PM
  • i haven't created a second ip in the other site...is that what i need to do?  
    Tuesday, August 03, 2010 3:12 PM
  • Ok.  I created a secondary ip...now the backups are working and i can ping the ip address of the dag.   However, i noticed that the mounted copy of my database shows my failover server and not the primary.  does that mean that my failover is now the active database?  the activation preference is 2 but it shows mounted and the server that's suppose to be the primary it shows as healthy. 
    Tuesday, August 03, 2010 5:12 PM
  • Activate it back on the Primary server and monitor it, it should be working fine.

    Having it without the second IP statically assigned might caused some instability


    Tamer Sherif Mahmoud
    Tuesday, August 03, 2010 5:15 PM
  • so under database copies i select the one on my primary server and  choose activate database copy, correct?
    Tuesday, August 03, 2010 5:23 PM
  • Yes, and select loseless option after.
    Tamer Sherif Mahmoud
    Tuesday, August 03, 2010 5:25 PM
  • cool.  that worked seemlessly.  

     

    one more question...how do you know that the replication  without taking one of your servers offline.   i see that one is mounted and the other is healthy.    Is there a place where you can check the replication...like maybe see the famous windows files flying through the air?

    Tuesday, August 03, 2010 11:27 PM
  • http://technet.microsoft.com/en-us/library/bb691314.aspx

    Test-ReplicationHealth

    http://technet.microsoft.com/en-us/library/dd298044.aspx

    Get-MailboxDatabaseCopyStatus

     

    are 2 very useful commands.

    Tuesday, August 03, 2010 11:30 PM
    Moderator
  • Ok.  all the tests passed.  

     

    Another question...i assigned 2 ip addresses to my dag, one for each node (since they are in a different subnet).   I can't ping the secondary ip and it doesn't show up in the failover cluster manager.  just the see the one ip.  when i click in the gui in the failover cluster manager i don't see the option to add one there.    But when i open up the exchange power shell and type:

    Get-DatabaseAvailabilityGroup -identity "dagname" | fl *ip*

     

    It shows both ip addresses.   Shouldn't i be able to ping the second ip address and shouldn't it show up in the cluster manager?

    Wednesday, August 04, 2010 12:34 AM
  • I'm using class A subnets.  Primary node is 10.100.0.0/22 and secondary is 10.234.31.0/24.  not sure if that makes a difference or not.
    Wednesday, August 04, 2010 12:41 AM
  • That's normal this IP will come online only if the DAG has failedover to secondary site, and that will happen when you have you primary servers down.
    Tamer Sherif Mahmoud
    Wednesday, August 04, 2010 7:16 AM
  • Cool. 

     

    A couple of more things.   I activated the database copy on my primary server; however when i rebooted the primary server and it came back up, it had mounted the copy on my secondary server and i had to activate the copy again on my primary server.  is this normal?

     

    Also, my symantec backups starting failing.  they were working when the copy was mounted on the secondary/failover server but now that i've activated the copy on my primary they're failing with the error message "the media server couldn't connect to the remote computer."   I did notice that when i ping from my exchange server i get the auto ip from the virtual failover cluster adapter (local adapter 9) instead of my primary network adapter. In fact i don't even see where the failover cluster adapter is located?    is this normal?

    Wednesday, August 04, 2010 4:04 PM
  • Quote: “I activated the database copy on my primary server; however when i rebooted the primary server and it came back up, it had mounted the copy on my secondary server and i had to activate the copy again on my primary server”

    It is normal. It’s the failover

    Quote: “I did notice that when i ping from my exchange server i get the auto ip from the virtual failover cluster adapter (local adapter 9) instead of my primary network adapter. In fact i don't even see where the failover cluster adapter is located?”

    It is normal. The articles below will explain it

    How to remove 169.254.x.x addresses from message headers of messages coming from CCR clusters

    What is a Microsoft Failover Cluster Virtual Adapter anyway?

    Windows Server 2008 Failover Clusters: Networking

    Quote: “my symantec backups starting failing”

    Please check if there’s any further event in the application log

    Please check if you can backup the database with windows server backup

    Please refer Doc 355481 to check the configuration


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    Thursday, August 05, 2010 7:40 AM
    Moderator
  • had to call symantec support.   it was a simple fix.  if you click on the backup job properties, and go to the exchange tab, you would select backup only the active copy.   

     

    so looks like it's all good.  

     

    thanks for everyone's help!

    Thursday, August 05, 2010 5:18 PM