exchange 2007 sp1 setup fails with code 8202 RRS feed

  • Question


    i am running the exchange 2007 sp1 setup and i get the following error:

    An error has occured when executing 'ldifde.exe' to import schema file 'D:\tools\exchangesp1\setup\serverroles\common\setup\data\postexchange2003_schema6.ldf. Error code 8202. more details can be found in the error file  ... ldif.err


    in the ldif.err shows


    Entry DN: CN=ms-Exch-Resource-Schema,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Add error on line 180: No Such Attribute

    The server side error is "The parameter is incorrect."

    An error has occurred in the program


    in ldf.log i see the following

    Importing directory from file "D:\Tools\ExchangeSp1\Setup\ServerRoles\Common\Setup\Data\PostExchange2003_schema6.ldf"

    Loading entries
    1: CN=ms-Exch-UM-Server-Dial-Plan-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-Server-Dial-Plan-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    2: CN=ms-Exch-UM-Server-Dial-Plan-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-Server-Dial-Plan-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    3: CN=ms-Exch-UM-IP-Gateway-Dial-Plan-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-IP-Gateway-Dial-Plan-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    4: CN=ms-Exch-UM-IP-Gateway-Dial-Plan-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-IP-Gateway-Dial-Plan-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    5: CN=ms-Exch-UM-IP-Gateway-Server-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-IP-Gateway-Server-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    6: CN=ms-Exch-UM-IP-Gateway-Server-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-IP-Gateway-Server-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    7: CN=ms-Exch-UM-Auto-Attendant-Dial-Plan-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-Auto-Attendant-Dial-Plan-Link,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    8: CN=ms-Exch-UM-Auto-Attendant-Dial-Plan-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-UM-Auto-Attendant-Dial-Plan-BL,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    9: (null)
    Entry DN: (null)
    Entry modified successfully.


    10: CN=ms-Exch-Recipient-Template,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-Recipient-Template,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry modified successfully.


    11: CN=ms-Exch-Resource-Schema,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Entry DN: CN=ms-Exch-Resource-Schema,CN=Schema,CN=Configuration,DC=buckleyschoolnyc,DC=org
    Add error on line 180: No Such Attribute

    The server side error is "The parameter is incorrect."

    10 entries modified successfully.

    An error has occurred in the program


    Anybody has any idea what is the issue? i am getting this even if i run from command prompt



    Tuesday, December 11, 2007 3:42 AM

All replies

  • I am getting the same Identical error. I cannot find a resolution and may have to result to calling Microsot to fix it. Anyone have any ideas?


    Thursday, December 13, 2007 7:36 PM

    we resolved  the issue


    you have to use adsiedit and modify some attributes in AD


    go to the ms-Exch-Resource-Schema under schema configuration


    then where it says display name if you see anything that says DUP with some numbers, remove the DUP and numbers and should just show the schema atrribute for example


    ms-Exch-Resource-Schema should show as ms-Exch-Resource-Schema not as DUP12312311ms-Exch-Resource-Schema


    we had to do that on 2 location which i do not remember right now

    Thursday, December 13, 2007 7:44 PM
  • If I bring up the properties of ms-Exch-Resource-Schema the classDisplayName and DisplayName show as <Not Set>. Do you think I need to set these? I cannot find a value with DUP anywhere in the properties.


    Thursday, December 13, 2007 7:54 PM
  • it was somewhere there if you scroll down. it might be a different situation for you. if you do not see anything there, then you better contact microsoft support

    Thursday, December 13, 2007 7:57 PM
  • Thanks. Guess I'll have to call them


    Thursday, December 13, 2007 8:06 PM
  • did you ever get this resolved?  i have the same issue.


    Saturday, December 29, 2007 4:22 PM
  • ADSI Edit

    Connect to Schema

    Double Click on CN=ms-Exch-Resource-Schema


    check all these attributes in the schema:


    changetype: ntdsSchemaAdd
    adminDescription: ms-Exch-Resource-Schema
    adminDisplayName: ms-Exch-Resource-Schema
    defaultHidingValue: TRUE
    defaultSecurityDescriptor: D : S : [there are not supposed to be spaces there, but it kept giving me a smiley]
    governsID: 1.2.840.113556.1.5.7000.62.50047
    lDAPDisplayName: msExchResourceSchema
    name: ms-Exch-Resource-Schema
    objectCategory: CN=Class-Schema,<SchemaContainerDN>
    objectClass: classSchema
    objectClassCategory: 1
    rDNAttID: cn
    schemaIdGuid:: EdNJrXyVzUO3zdAFqGir7g==
    subClassOf: top
    possSuperiors: container
    mayContain: msExchResourceLocationSchema
    mayContain: msExchResourcePropertySchema


    in my case, the mayContain attribute had a DUP entry in it.  remove that DUP entry.  hit ok.  hit ok.  allow the schema time to propigate throughout the directory.

    try to install again.


    Thursday, January 3, 2008 2:38 PM
  • also had to go to


    change ldapdisplayname that had a dup prefix and guid suffix to:


    Thursday, January 3, 2008 2:57 PM