none
Setting up Android with Exchange 2013

    Question

  • Hello All,

    Our shop is still an Exchange 2003 shop. I have set up Exchange 2013 in our lab, for testing. So far everything is working great, except the mobile connection.....

    I'm presently testing with my phone (Galaxy III). I am successfule connecting and accessing my mailbox from the 2003 Server. But with the 2013 server, I'm able to connect but all I get is the spinning circle.

    From my research, I'm suppose to log into the EAC and set the type of phone in the Device Access Rules, but when I look at the phone types, I only see EASProbeDeviceType.

    Am I missing something?

    Thanks


    Armando Diaz

    Monday, December 31, 2012 3:11 AM

All replies

  • Hi Armando,

    1- Is there a firewall in between?

    2- Have you published ActiveSync?

    3- Used Microsoft Remote Connectivity Analyser? https://www.testexchangeconnectivity.com/ Is there any error message you getting there?

    ecword

    Monday, December 31, 2012 12:27 PM
  • Thanks for the reply.

    1-No firewall, (other than the Windows OS)

    2-Not sure where to publish

    3-Ran the analyser and had multiple failures

    Is there a how to write-up?

    FYI: I'm able to use OWA to access from any PC on the web.

    Thanks


    Armando Diaz


    • Edited by ArmandoDiaz Wednesday, January 02, 2013 3:52 PM
    Wednesday, January 02, 2013 3:51 PM
  • Hi,

    No worries.

    1- If there's no firewall does your Exchange server have a Public IP Address?

    2- What error messages are you getting?

    Wednesday, January 02, 2013 4:06 PM
  • Here are the results:

    ExRCA is testing Exchange ActiveSync.
    The Exchange ActiveSync test failed.
    Test Steps
    Attempting the Autodiscover and Exchange ActiveSync test (if requested).
    Testing of Autodiscover for Exchange ActiveSync failed.
    Test Steps
    Attempting each method of contacting the Autodiscover service.
    The Autodiscover service couldn't be contacted successfully by any method.
    Test Steps
    Attempting to test potential Autodiscover URL https://diazracing.com/AutoDiscover/AutoDiscover.xml
    Testing of this potential Autodiscover URL failed.
    Test Steps
    Attempting to resolve the host name diazracing.com in DNS.
    The host name resolved successfully.
    Additional Details
    IP addresses returned: 75.145.226.233
    Testing TCP port 443 on host diazracing.com to ensure it's listening and open.
    The port was opened successfully.
    Testing the SSL certificate to make sure it's valid.
    The SSL certificate failed one or more certificate validation checks.
    Test Steps
    ExRCA is attempting to obtain the SSL certificate from remote server diazracing.com on port 443.
    ExRCA successfully obtained the remote SSL certificate.
    Additional Details
    Remote Certificate Subject: CN=Diaz05, Issuer: CN=Diaz05.
    Validating the certificate name.
    Certificate name validation failed.
    <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl00_ctl02_ctl01_tmmArrow">Tell me more about this issue and how to resolve it</label>
    Additional Details
    Host name diazracing.com doesn't match any name found on the server certificate CN=Diaz05.
    Attempting to test potential Autodiscover URL https://autodiscover.diazracing.com/AutoDiscover/AutoDiscover.xml
    Testing of this potential Autodiscover URL failed.
    Test Steps
    Attempting to resolve the host name autodiscover.diazracing.com in DNS.
    The host name couldn't be resolved.
    <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl01_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>
    Additional Details
    Host autodiscover.diazracing.com couldn't be resolved in DNS InfoDomainNonexistent.
    Attempting to contact the Autodiscover service using the HTTP redirect method.
    The attempt to contact Autodiscover using the HTTP Redirect method failed.
    Test Steps
    Attempting to resolve the host name autodiscover.diazracing.com in DNS.
    The host name couldn't be resolved.
    <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl02_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>
    Additional Details
    Host autodiscover.diazracing.com couldn't be resolved in DNS InfoDomainNonexistent.
    Attempting to contact the Autodiscover service using the DNS SRV redirect method.
    ExRCA failed to contact the Autodiscover service using the DNS SRV redirect method.
    Test Steps
    Attempting to locate SRV record _autodiscover._tcp.diazracing.com in DNS.
    The Autodiscover SRV record wasn't found in DNS.
    <label for="testSelectWizard_ctl12_ctl06_ctl00_ctl00_ctl03_ctl00_tmmArrow">Tell me more about this issue and how to resolve it</label>

    Armando Diaz

    Wednesday, January 02, 2013 4:32 PM
  • Hi Armando,

    You don't have anything configured on an external DNS server nor published any services. Please look into the following articles. hope they help.

    Configuring ActiveSync publishing
    http://technet.microsoft.com/en-us/library/cc995186.aspx

    Exchange Autodiscover
    http://www.msexchange.org/articles_tutorials/exchange-server-2010/management-administration/exchange-autodiscover.html

    Understanding Digital Certificates and SSL

    http://technet.microsoft.com/en-us/library/dd351044(v=exchg.141).aspx

     

    ecsword

    • Proposed as answer by CanKILIC Monday, January 21, 2013 9:11 PM
    Wednesday, January 02, 2013 4:54 PM
  • Thanks!

    I'll check those out.


    Armando Diaz

    Wednesday, January 02, 2013 5:35 PM
  • Thanks!

    I'll check those out.


    Armando Diaz

    Hi Armando,

    I am in the same exact situation, did you solve it?

    //Ase

    Sunday, February 10, 2013 8:04 PM
  • Hi,

    Here is the solution I found:

     1.Log onto Domain Controller
     2.Start AD Users and Computers
     3.Click on View - Advanced Features
     4.Double-click on the user who's account wont work with ActiveSync
     5.Go to the security tab and then select the advanced button
     6.Select Exchange Servers, and tick the Include inheritable permissions toggle then Apply and OK.
     7.Reconfigure your phone and walk away happy

    //Ase

    • Proposed as answer by ckovamees Monday, February 25, 2013 5:45 PM
    Monday, February 11, 2013 8:04 PM
  • Ase - that solved my problem that's been bothering me for two months.

    Stort tack!

    /Carl

    Monday, February 25, 2013 5:47 PM
  • Can mods mark question as answered so Ase gets credit?

    Not sure if it would have solved original question but OP never got back - maybe ecsword's proposal's are solutions too.


    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you.


    Tuesday, February 26, 2013 5:28 PM
  • Thank you for the solution!
    Sunday, May 12, 2013 3:06 PM
  • ckovamees, Le Pivert, PCSpandau,

    Thanks for your feedback that the solution worked for you as well.

    //Ase

    Sunday, May 12, 2013 4:05 PM
  • Thanks Ase! Worked as advertised
    • Edited by msheena Tuesday, December 03, 2013 12:42 AM
    Tuesday, December 03, 2013 12:41 AM
  • I had a similar issue on my own account.  When I reset permissions to enable inheritance, it would revert back to disabled after a period of time.  If found the resolution here - http://msmvps.com/blogs/UlfBSimonWeidner/archive/2005/05/29/49659.aspx


    IAITGUY

    Friday, February 21, 2014 5:06 PM
  • +1 for Ase, I confirm it resolved the same trouble I had.

    Regards, Philippe

    Don't forget to mark as answer or vote as helpful to help identify good information. ( linkedin endorsement never hurt too :o) )

    Answer an interesting question ? Create a wiki article about it!

    Friday, September 05, 2014 1:21 PM
  • This worked. So simple. So quick. So genius! Thank you for sharing.

    Sue, Senior Network Administrator

    Wednesday, December 23, 2015 6:26 AM