Mapi over HTTP issue RRS feed

  • Question

  • Hi all!

    Hope somebody can help me out. In my test lab, where I`m experimenting with Exchange 2013 SP1 and Outlook 2013 SP1 I came across very annoying thing.

    Let me explain a little bit more about config that worked.

    Outlook 2013 connected to Exchange 2013 via RPC over HTTPS is working great actually really great. I have created my own certs and imported ROOT CA cert to all of my machines and things are working peachy. As part of my plans for 2014 I have to test and deploy MAPI over HTTP sometime at the end of 2014 in our company (and migrate fromEX2007 but this is different story).

    OK so I`ve enabled MAPI over HTTP on my test server and configured 5 virtual machines with different accounts to test things out. Started Outlooks, accepted "Your administrator has made change ....." prompts and here we go, I`m connected MAPI/HTTP and all works really great.

    Except for one thing. When it does connect, things are super fast and it works as it should. But sometimes it does not connect right away and it is sluggish in performance. Also Outlook is missing "Quick steps" menu, see attached image:

    I restarted all servers, clients, clean Outlook install nothing helps.

    When RPC/HTTPS I could quit and start Outlook 10 times and it worked 10/10 without problems.
    When MAPI/HTTP I restart outlook and it works 6/10, so 4 times I get messed up Outlook and very poor performance.

    Any idea where to start troubleshooting? Maybe Outlook has a bug or 2 with this mode?
    Server is correctly sized and backed up by enough of memory and CPU, mailboxes have 100-3500 items in them.
    Again, RPC/HTTPS works every time without any problem.
    MAPI/HTTP works lets say 6 times without any prolem at all and really works great but 4 times out of 10 it makes me want to throw it away :)

    If someone knows best way to troubleshoot this one, please let me know.



    Sunday, May 18, 2014 3:31 PM

All replies

  • Hi,

    According to your description,  there will be random connectivity issue if Outlook 2013 sp1 use MAPI over HTTP. If I misunderstand your meaning, please feel free to let me know.

    If yes,  I recommend you check the log to find the root cause.
    Here are the path of logs showing MAPI over HTTP activity:
    •%ExchangeInstallPath%Logging\MAPI Address Book Service\
    •%ExchangeInstallPath%Logging\MAPI Client Access\
    And we can also check the event log.


    Angela Shi
    TechNet Community Support

    Monday, May 19, 2014 9:33 AM
  • Hello!

    Will check this logs, event log is empty on client and on server...

    Will delete logs and try to reproduce the issue.

    Monday, May 19, 2014 10:40 AM
  • Log files:

    MAPIAB: http://pastebin.com/ap52pqxL

    MAPIMB: http://pastebin.com/UpgtKvpL

    HTTPPROXY: too big to paste, file here: http://www.sendspace.com/file/viacd9

    I don`t get it really, all seems to be just fine, no errors...

    Sometimes it works sometimes not. And when I force close Outlook and restart it it starts to work just fine again until next time (2-4 outlook restarts).



    Monday, May 19, 2014 11:30 AM
  • Hmmmm one more thing...

    Are there any limits how many times can user restart outlook in a given time interval?

    Maybe some sort of back pressure or throttling mechanism behind the scenes?



    Monday, May 19, 2014 5:06 PM
  • Hi,

    As far as I know, it's unlimited to restart Outlook and there will be 9646 error in event log if the MAPI session is exceeded.  However, there is no error anywhere.

    We can continue to check MAPI over HTTP connection when Outlook 2013 sp1 disconnects:

    Test-OutlookConnectivity -RunFromServerId ContosoMail -ProbeIdentity OutlookMapiHttpSelfTestProbe

    We can also check if the issue is related to performance by performance monitor.


    Angela Shi
    TechNet Community Support

    • Edited by Angela Shi Wednesday, May 21, 2014 3:07 AM
    Wednesday, May 21, 2014 3:04 AM
  • OK, when I ran PS cmdlet I got:

    [PS] C:\Windows\system32>Test-OutlookConnectivity -RunFromServerId Exchange2013 -ProbeIdentity OutlookMapiHttpSelfT
    WARNING: An unexpected error has occurred and a Watson dump is being generated: Failed to find the probe result for
    invoke now request id 460a6da8e82b49ab83a558f61bd4da9c and probe workdefinition id 285.
    Failed to find the probe result for invoke now request id 460a6da8e82b49ab83a558f61bd4da9c and probe workdefinition id
        + CategoryInfo          : NotSpecified: (:) [Test-OutlookConnectivity], InvalidOperationException
        + FullyQualifiedErrorId : System.InvalidOperationException,Microsoft.Exchange.Management.Tasks.TestOutlookConnecti
        + PSComputerName        : exchange2013.domain.local

    Performance issue?
    Don`t think so, this is Core i5 and 8GB RAM, total 10 mailboxes, 2 GB database and almost NEVER more than 1 connection from client at the time :)

    Wednesday, May 21, 2014 11:48 AM
  • Hi again!

    Found this in mapi log:

    S:5-ESn1eA==,,mapihttp: failure,00:00:00,,MapiHttpEndPoint: [NotificationWait] [ProtocolFailureException] Client has dropped connection [ResponseCode=NoClient] [LID=63520] ,,
    2014-05-24T18:52:28.736Z,,,,,,,,CLIENT_IP,,,MapiHttp:[MapiHttp:DOMAIN\username],,R:{A11EB4B4-714C-41C2-9B4E-1E345EE212F4}:8|A:cd66d8f3-fee2-4dc3-8c83-bf13241f4da6,C:MAPIAAAAAOC4+7PyvPu+jLyNvpPB89440uPX+sr/0uD14MX9x/PK8M14qom7iryFsIS2gLcPAABAAAAAAA==|S:5-aH4DUw==,,mapihttp: failure,00:00:00,,MapiHttpEndPoint: [NotificationWait] [ProtocolFailureException] Client has dropped connection [ResponseCode=NoClient] [LID=63520] ,,

    Since this is happening on all of my Outlooks I really think this is bug somwhere in Outlook code.

    Saturday, May 24, 2014 7:00 PM
  • I forgot to mention that Outlooks connect in online mode not in cached mode and clients are not domain joned machines.

    I re-checked DNS, uninstalled AV software, restarted everything from managed switch to firewall still problems... It is totally random.

    And also it is weird to me, that this command does not work: Test-OutlookConnectivity -RunFromServerId ContosoMail -ProbeIdentity OutlookMapiHttpSelfTestProbe
    • Edited by Grega_SLO Monday, May 26, 2014 1:00 PM
    Monday, May 26, 2014 12:51 PM
  • Applied CU5 and still same result.

    I also tried something new.

    On PC A outlook hanged and when I tried to connect at the same time from computer B there was no problem at all.

    Really noone has this problems with MAPI?

    Wednesday, May 28, 2014 11:17 AM
  • There is a know performance bug in MapiOverHTTP - Please note the solution presented in the TechNet article I link to below, contains errors as the paths they set is wrong and the set command is formed badly as well. You must specify the patsh manually to make them Work!

    MAPI over HTTP may experience poor performance when you upgrade to Exchange 2013 SP1  
    Scroll down to "Client Connectivity" here http://technet.microsoft.com/library/jj150489(v=exchg.150).aspx

    The error you get when using the Test-OutlookConnectiviy is "also known" as in, I'll bet they (one team) deprectated the CMDlet but (another team) added the Probeidentity to it, so the result is = not working. I'm currently talking to MS about this.

    I've made a short post on HTTPoverMapi here, where all the above is listed http://www.itnotes.eu/?p=2603

    Thursday, May 29, 2014 8:20 AM
  • Hi,

    From your information, when Outlook hang on PC A, there was no problem to connect at the same time from computer B, so the client side related issue causing this problem is more likely. For example, when Outlook was trying to connect to Exchange server, it fails due to the temporary Network issue, or it hang when loading something. As far as I know, it may also be caused by the local OST file. But it is difficult to do troubleshooting since there could be many possible causes and more logs may be required to do troubleshooting.

    Please try to run Outlook in safe mode by running "Outlook.exe /safe", see if we can reproduce this issue.



    Thursday, May 29, 2014 9:23 AM
  • Hi!

    Thanks for heads up, I did all of the modifications described in technet article under client connectivity. Still no change.

    These 2 PCs are brand new virtual machines, Windows 8.1 and latest Outlook on them. NO additional software is installed. Also WIN and Office are up to date.

    Tried also with domain joined PC and same stutter occured. Its like someone would plug out and back in the network cable.

    Same behaviour occoures on WAN or on LAN or on VM (traffic does not go trough switch at all in VM so switch is not to blame).

    Network interruption on LAN ?

    I don`t think so :)

    Tried with safe mode, same result...

    If I start and close outlook it will hang randomly (6 times run and close OK 7th time sluggish performance, disconnect and then 8th time again completeley normal...).

    • Edited by Grega-slo Thursday, May 29, 2014 12:19 PM
    Thursday, May 29, 2014 11:54 AM
  • Hi,

    If it can be reproduced on several clients, in different Network environment, and in safe mode. I suggest you open a ticket with MS Outlook support team, they may help to analyze this kind of Outlook hang issue with dump or other files.



    Friday, May 30, 2014 8:33 AM
  • LOL.

    I installed new DC and new Exchange on different server, imported mailbox from PST, used different machine for client Outlook and second time I tried to connect Outlook froze. :)

    What can I say.

    Friday, May 30, 2014 12:42 PM
  • Ahhh after extensive testing I have come to conclusion that:

    - If Outlook 2013 installed on Windows 8.1 there will be problems connecting
    - If Outlook 2013 installed on Windows 7 there is absolutley NO problem at all

    Tried with my old server and Win7 client with Outlook 2013 had no problems but Win8.1 client with same version of Outlook and SAME mailbox had a lot of problems connecting.

    When it connects it works just fine, but if I stop and start Outlook 10 times in 1 minute WIN8.1 machine fails 2-3 times but WIN7 machine with same Outlook and mailbox won`t fail even 1 single time.

    If somebody has WIN 8.1 and latest outlook and has enabled MAPI over HTTP, how many times does connect fail out of 15 attempts? (Basically just open outlook and close it and again open and close etc...).

    I really do believe now that Win8.1 is having problems in conjunction with Outlook 2013 SP1 and MAPI over HTTP.

    Can someone also confirm my findings?


    Friday, May 30, 2014 1:27 PM
  • Hi again!

    I installed 2 fresh Win7 machines and used also 1 old notebook with WIN7.

    I installed Outlook 2013 SP1 on all machines.

    And on all machines MAPI over HTTP works like a charm :)

    Then I set up Win8.1 machine from scratch and installed Outlook 2013 SP1. Again it worked great for 2 times but 3rd time outlook crashed. Then it worked 4 times and 5th time outlook hanged.

    On WIN7 no such problem persist.

    I just wrote this because now I`m 1000% sure that WIN8.1 has serious problems with MAPI over HTTP with Outlook 2013 SP1.

    So server is OK, what now?

    Friday, May 30, 2014 3:47 PM
  • Hi,

    Yes, from your test result, the server side configuration could be OK.  It could be Windows 8.1 client side issue. Have you tried to setup a brand-new Windows 8.1 or make sure the client is fully patched? Or you may open a support ticket to the Outlook support team, they could help you narrow down or confirm this issue.



    Saturday, May 31, 2014 5:13 AM
  • Hi!

    Yes I tried with brand new fully patched Windows 8.1 and fully patched Outlook 2013 SP1.

    Its strange that nobody else is having same issues as me but on the other hand there is not a lot of ppl that enabled mapi over http and use Windows 8.1 and Outlook 2013 SP1 :)

    Saturday, May 31, 2014 6:27 AM
  • Went back to RPC/HTTPS :(

    This did the trick:

    Key: HKEY_CURRENT_USER\Software\Microsoft\Exchange
    DWORD: MapiHttpDisabled
    Value: 1

    Now all works just fine.

    Now we wait and see what happens on MS side :)

    Saturday, May 31, 2014 1:09 PM
  • Greg_SLO

    I am experiencing the exact same issue. I am running in production and all of my 8.1 users are experiencing the issue, some to the point they cannot effectively work. I am turning off Mapi/Http at the server until MS resolves the issue.

    Thank you for putting this out there. I was beginning to think MAPI/HTTP just flat out sucked.

    Monday, June 2, 2014 3:19 PM
  • Sure no problem :)

    I`m using test enviroment for like 8 months now, rebuilding it from scratch every 2 months :)

    And along came MAPI over HTTPS and my production deployment is yet again postponed :)

    At first I tought that IPv6 is having problems with MAPI so I initially spent 4 hours of network diag just to confirm IPv6 is working just fine with it :)

    • Edited by Grega_SLO Monday, June 2, 2014 4:37 PM
    Monday, June 2, 2014 4:27 PM
  • I turned off IPv6 to no avail and I ran the commands listed above in the TechNet article as I did upgrade to CU4 from CU3. CU5 was just released; I will install that and see if anything changes.

    Thanks again.

    Monday, June 2, 2014 7:42 PM
  • Check if the problem machine has a proxy configured either in IE or in winhttp. If yes, remove proxy settings and check if issue remains
    Tuesday, June 3, 2014 12:33 PM
  • I'm using Windows 8.1 Update 1 and don't have this issue. I'm also running Exchange 2013 CU5. I have applied the App Pool Config fixes mentioned in the article (not sure if they are relevant with CU5 but did them anyway). I don't have any IE Proxy.

    As a hunch, do you have Lync running at the same time? Try to re-test without Lync running, as Lync can 'hold onto' and lock the connection.

    I've tested in Online and Cached mode, assume you've tried both too.

    Wednesday, June 4, 2014 4:01 PM
  • Hi,

    Do you have any update? Have you tried the suggestions Bhalchandra and Steven suggested?



    Friday, June 6, 2014 9:22 AM
  • I installed CU5 on Exchange over the weekend and turned MAIP/HTTP on again. I have not seen the same issue again, nor have I had any reports from anyone else. At this point, CU5 seems to have corrected the issue.
    • Marked as answer by Richard Kuai Wednesday, June 11, 2014 5:36 AM
    • Unmarked as answer by Jessie Yuan Friday, June 13, 2014 9:10 AM
    Tuesday, June 10, 2014 6:35 PM
  • Also, Lync nor a Proxy setting played a part in the issue I saw and that Greg_SLO described.
    Tuesday, June 10, 2014 6:36 PM
  • I have installed CU5 from scratch as well and STILL have same problems, so this is definitly NOT the answer.

    I don`t have Lync or proxy configured.

    Wednesday, June 11, 2014 6:58 AM
  • Hi,
    As Dintid said, there is a known performance issue of MapiOverHTTP in Exchange 2013 SP1. You may refer to the TechNet article he linked:
    Please scroll down to "Client Connectivity" in this article:
    Wednesday, June 11, 2014 7:21 AM
  • I really don`t know what to say to you.
    Can you read?

    I installed Exchange 2013 CU5.

    Technet says: "This issue doesn't occur if you upgrade to Exchange 2013 SP1 from Exchange 2013 RTM or if you install a new Exchange 2013 SP1 or later server."


    • Edited by Grega-slo Wednesday, June 11, 2014 8:58 AM
    Wednesday, June 11, 2014 8:46 AM
  • Hi,

    Since the issue persists after upgrading to Exchange 2013 CU5, it is more likely a client side issue. Have you checked the system information on the affected client (by running "msinfo32")? There could be some records about application hang. Please also check the application log on client again. If we cannot find any clues here, I suggest you open a ticket to MS Office team. You can ask the professionals in Office team help you investigate the cause of Outlook hang.



    Thursday, June 12, 2014 5:06 AM
  • Hi!

    Outlook does not hang as application hang.

    It just behaves like there is a enormous lag on network and it tries to fetch data from exchange server.

    If I restart it, it will work just fine for few runs and then again this slowness.

    And I already determined that it is a client side issue as WIN7 + Outlook 2013 SP1 does NOT have this issue.

    I`m actually surprised that not many ppl have this issue.

    But I`m confident that when ppl upgrade to Exchange 2013 and Win 8.1 and enable MAPI there will be huge volume of support calls regarding this (because I did fresh CU5 install and still experience this issue).

    Where can I contact support team? I have only Office 2013 licensed, Exchange is trial.



    Thursday, June 12, 2014 6:20 AM
  • Hi,

    You may open the ticket by choosing the product in the following website:






    Thursday, June 12, 2014 9:03 AM
  • This issue was not resolved for us with CU5 update as previously stated. While it seemed fine for awhile, it is now happening again just as before.
    Thursday, June 12, 2014 6:32 PM
  • Hehe I told u that I installed CU5 from scratch :)

    Moderator please unmark the answer, this is still unresolved.

    Friday, June 13, 2014 6:15 AM
  • Hi,

    Have you opened the support ticket? If you have any update, we would be appreciate if you could share it here.



    Friday, June 13, 2014 9:14 AM
  • Same here, outlook connectivity hasn't been so unstable since I enabled mapi/http. Outlook hangs several times during usage and sometimes it even hangs during start-up. I've disabled mapi/http again and outlook is stable again.

    Friday, June 13, 2014 9:33 AM
  • I can't say I'm seeing the same issues.

    Open the support ticket and go through the proper support methods. Use Fiddler and Procmon to understand what the application is doing on the client side. Also analyse the MAPI logs on the Exchange server to see if there is anything in there. Fiddler especially will show up anything like network issues.


    Friday, June 13, 2014 9:55 AM
  • Mapi logs are clear.

    I see no difference in them if connection fails or if it is OK.

    I ruled out network issues days ago... RPC over HTTP is much more problematic when it comes to network problems but in my case it works flawlessly.

    Note, this is LAN we are talking about. But Even outside of LAN eg. client connecting from outside there are identical problems. Only with Win8.1 + Outlook 2013 SP1.

    Win7 + Outlook 2013 SP1 works like a charm.

    Friday, June 13, 2014 11:16 AM
  • Do you have antivirus running on the client? Sounds obvious but disable it to check it's not that. Sophos especially holds onto worker processes. Just crossing t's and dotting i's...

    The support ticket will help though, a ProcDump can even be done to analyse what Outlook is doing against the source code. You have to have a ticket for that.

    Friday, June 13, 2014 12:31 PM
  • Vanilla 8.1 X64 with Outlook 2013 +SP1 and both products FULLY updated.
    NO AV, NO firewall, nothing.

    I can`t open ticket if I use trial version of Exchange server.

    • Edited by Grega-slo Friday, June 13, 2014 1:45 PM
    Friday, June 13, 2014 1:44 PM
  • Is it a physical or virtual client? If physical, spin up a VM and see if it's the same there. If it's a VM, try a physical.

    I'd welcome Jessie's input on the support ticket issue. And make the issue known on social media so that it attracts some MSFT attention. If there's no known issues then you need to do a lot of eliminating. It must be something on the machine because if it were product related it would be more widespread believe me.

    Friday, June 13, 2014 3:14 PM
  • Tried with both, PHY and VM.

    Every time is the same story.

    I`m not the only one having this issues (2 in this thread already confirmed it), you will see when ppl start to deploy it, there will be a mess.

    Its only Windows 8.X that is affected and not many people have them in production yet = not so widespread.

    Friday, June 13, 2014 4:46 PM
  • Hi,

    This issue is difficult to troubleshoot here. It is better if we can open a ticket to MS so the engineers will help you analyze the related logs and investigate this issue.  As we known, the same issue could always be caused by different reasons. By analyzing the related logs, we may find the cause and then a solution.



    Tuesday, June 17, 2014 10:20 AM
  • Actually I`m done with it.

    No more testing, I`ve disabled the whole thing, switched back to RPC/HTTPs which works stable as rock for me for quite few years now.

    I really don`t have time to repeat myself, I pasted log files already and since there is no single response from MS I don`t care as well :)

    I`m not the only one with problem so log files will eventually come to MS :)

    Tuesday, June 17, 2014 12:44 PM
  • Hi,

    So the current workaround is to switch back to RPC/HTTPs. You may watch our TechNet website and our Exchange Team Blogs to see if there is any update about this feature.



    Thursday, June 19, 2014 9:44 AM
  • OK, I just made some Fiddler inspections on my server.

    Actually now my fried has issue too, so we investigate together...

    Fiddler says this:

    We both tested on Windows 8.1 x64 and above is the result.
    Then we both tried on Win7.

    Not a single error in Fiddler or Outlook.

    Monday, June 23, 2014 1:28 PM
  • Hi,

    This message means that it is a response message from the server has a header but the body is missing. It is just a header.

    Have you seen the same message on Windows 7? Do we get this message every time when the issue being reproduced?



    Tuesday, June 24, 2014 8:44 AM
  • Just done some more testing and still don't see this issue. Fiddler shows a clean connection every time for me. Can you use Process Explorer or Process Monitor to see which processes are being used to ensure that there are no other applications hooking into the Outlook processes? It could be that something is stripping out traffic such as security software.

    Another thought, have you tried this on a workgroup machine vs a domain joined machine external to the network? If authentication was an issue this may help troubleshoot.


    Tuesday, June 24, 2014 9:06 AM
  • Hi!

    @Jessie: No, on Windows 7 there is nice and clean flow all the way and I have encountered 0 problems on Win7 machines - from inside or outside or domain joined or not. Works everytime.

    @Steve: Tried everything, different hardware, physical or virtual, domain joined or not, inside the network or outside I always get stutter and unresponsive outlook and Fiddler shows that response body is missing.

    @ALL: I use new Exchange 2013 CU5 and new DC 2012 R2 with combination of vanilla Windows 8.1 X64 with all updates.

    In all tests NO security software was installed on machines, not even MS defender.

    But I have to say, when it does connect it works just as it should, no lag, no stutter everything works as expected. Lets say in 10 attempts to connect 7-8 are OK and the rest is unbearable and painfully slow with proccessing being displayed for 65 seconds or more etc...


    Tuesday, June 24, 2014 9:45 AM
  • We are running CU5 with Outlook 2013 SP1.

    Cached mode clients (mix of win8 and win8.1) don't appear to have any mapi/http issues.

    I did have problems with our remote desktop server which runs in online mode. It kept having serious lag and I had to use the registry to disable mapi/http and rpc/http is fine.

    Tuesday, June 24, 2014 1:53 PM
  • Hi,

    Since everything is OK from Windows 7 client, I suppose this could be the compatibility issue on Windows 8.1. I'd like to suggest you upgrade the IE to the latest version on Windows 7 machine, see if we can reproduce the issue.



    Wednesday, June 25, 2014 10:11 AM
  • Not sure what u mean but IE IS at latest version on Win7:
    • Edited by Grega-slo Thursday, June 26, 2014 8:33 AM
    Thursday, June 26, 2014 6:57 AM
  • Same problem here. Sharing your frustration. 

    As far as I can tell, the issue occurs on Windows 8.1, when running Outlook 2013 in online (non-cached) mode. It's not a lack of updates or bandwidth, but based on what others are saying here, it may be very specific to Windows 8.1 and non-cached mode. 

    Bill Coulter

    • Edited by Barebodkin Thursday, July 31, 2014 1:50 PM Additional info, clarification
    Monday, June 30, 2014 3:30 PM
  • Installed latest Windows Updates on both, server and client, also installed Office updates still same behaviour.
    Wednesday, July 9, 2014 6:59 AM
  • We are noticing that when the bandwidth we have allocated for client connections out of our datacenter is saturated, mapi-over-http basically breaks down and is unusable.  RPCoverHTTP appears to handle this condition just fine.

    Anyone else seeing this?  We may have to revert back to Outlook Anywhere for now - mapi over http appears to still be rather green.

    Friday, July 11, 2014 12:05 AM
  • Hi again!

    In next 2 months I`m doing migration from Ex2007 to Ex2013 here at work. So I created exact copy of my DC and Exchange 2007. I successfuly migrated all data to Exchange 2013 CU5 and everything works just fine. Then for sake of this long thread I decided to play with MAPI.

    Enabled it, rebooted Exchange server, rebooted client and connected. Its still the same story, but "serious" hardware. Exchange has 30GB of RAM and one 10 core Xenon, storage is local on 8HP SAS 15k RPM disks.Databases are 27GB in total. So HW is not to blame, there is really something going on with mapi on Windows 8.1 machines.

    Fiddler shown exactly the same symptoms as in my home test enviroment...



    Tuesday, July 15, 2014 1:58 PM
  • Hello,

    I have just built a brand new system for one of our customers which is running on Xenapp 7.5 on Microsoft Windows server 2012 R2 SP1 update 1. Outlook runs on these servers in online mode.

    The Exchange server setup consists of two Exchange 2013 CU5 servers with four databases in DAG. I have enabled Mapi over HTTP.

    The customer is experiencing the exact same issues as described above.

    Hopefully we'll see some attention from Microsoft on this issue, soon.


    Wednesday, July 30, 2014 11:19 AM
  • Thank you for reporting the issue.

    We are investing the issue further and will post further updates here as well as via KB articles.

    Thursday, July 31, 2014 12:43 PM
  • Amazing.

    After 2,5 months someone finally recognising that the issue really exists...

    Thursday, July 31, 2014 4:21 PM
  • Just wanted to add that I am experiencing the exact same symptoms as Grega-slo, from quicksteps disappearing to flacky Outlook 2013 Sp1 startup. In my environment this seems to happen on Windows 7 as well as Windows 8.1. both in Online and Cached Exchange mode. Guess will have to revert to RPC/HTTP, at least till a solution to this issue is found.

    Edit: This issue became apparent to me as soon as I created and shared a couple of Public folders. Before that, I had no reports from the users that Outlook was mis-behaving. Just thought I'd add this little detail.



    • Edited by Vectivus Thursday, July 31, 2014 8:53 PM
    Thursday, July 31, 2014 8:10 PM
  • Still no joy after Update 2 for Windows 8.1 and latest Office 2013 patches.
    • Edited by Grega-slo Tuesday, August 12, 2014 8:35 PM
    Tuesday, August 12, 2014 8:28 PM
  • Grega-slo,

    I sent you an email to follow up on this issue.  If you did not get it, please let me know.  The Outlook Product Team is working to address this issue and I would like to see if you could do customer validation of the fix. 

    Friday, August 15, 2014 5:56 PM
  • Hi!

    I did not received any mail...

    Also I have no more exchange or outlook installed since my trial license has expired.

    I will wait for update and then set up another test lab.

    BTW is culprit already identified? What is causing this behavior?


    • Edited by Grega-slo Monday, August 18, 2014 12:27 PM
    Monday, August 18, 2014 12:25 PM
  • Thanks for the update Greg-slo.  The Product Team is working on a fix and one other customer is also helping validate but we wanted to confirm that it addresses your issue too.  If you get your lab set back up and still see the issue, please let me know.
    Monday, August 18, 2014 5:11 PM
  • Hi!

    This fix will be public and distributed via WU?



    Tuesday, August 19, 2014 6:02 AM
  • When the fix is released it will ship as a public update via windows update for MSI installs.  For Click to Run it will be pushed directly to the client.  I'll post back when the fix becomes available. 
    Tuesday, August 19, 2014 2:54 PM
  • Hi Gabriel!

    If you can send me fix I can test it with my friend and in my lab when it is set up properly.

    If not we will just have to wait :)



    Tuesday, August 19, 2014 5:11 PM
  • Hello!

    Whats the status of this issue?

    Another patch tuesday around and problems are still here...

    Wednesday, September 10, 2014 7:32 AM
  • The fix is currently scheduled to release in the October 14th CU/PU. 
    Wednesday, September 10, 2014 8:05 PM
  • Thanks man!

    If it is possible to obtain it sooner please let me know :)


    Thursday, September 11, 2014 7:08 AM
  • Hi Grega-slo,

    i have similar problems. So you are not alone :/

    @Gabriel Bratton

    For which microsoft product is the fix? Office 2013 SP1?



    Thursday, September 25, 2014 3:22 PM
  • Daniel,

    The fix is scheduled for the October Public Update and is a post SP 1 update for Outlook 2013. 

    Thursday, September 25, 2014 5:22 PM
  • Well today is the day.

    5 months later and I sure hope that fix finally arrived :)

    Tuesday, October 14, 2014 6:32 AM
  • Ok I`ve installed all the updates, did a reboot and so far so good....

    I will test it tomorrow trough the day, but I did 30 restarts of Outlook and 0 failed...

    Tuesday, October 14, 2014 6:00 PM
  • I've installed the patch: http://support.microsoft.com/kb/2986204 and all the connection issues seems to be resolved. But I have an issue with groups under contacts.

    If I use Outlook 2013 (mapi over http) and try to create a New Contact group in people/contacts is it not possible to add a member from the global address list. But is it possible to choose a member from my own contact list. It works fine if I don't use mapi over http.

    @Grega_SLO maybe you can test it too.

    Wednesday, October 15, 2014 11:31 AM
  • Yup, I can confirm this.when I try to add from GAL exchange connectivity breaks and then reconnects again...

    If I add any other contact which is nOT in GAL it`s ok.

    Maybe best to open new thread?


    Or maybe just rename it to MAPI over HTTP issues :)

    This protocol is by far most unreliable thing I have ever seen with MS... :(

    • Edited by Grega-slo Wednesday, October 15, 2014 6:24 PM
    Wednesday, October 15, 2014 4:37 PM
  • Daniel and Grega-slo,

    What problem or error do you see when trying to add a user from the GAL to a new Contact Group?  I've been trying to repro the issue.  At one time I did get an error message and a slight pause waiting for the GAL to focus but its not persistent.  Is that what you see as well?  Or, are you not able to add users at all? 

    Wednesday, October 15, 2014 10:47 PM
  • Hi!

    I can select user and click add, but then nothing happens, user is not added and exchange connectivity breaks.
    It reconnects right back but I still cannot add user.

    Thursday, October 16, 2014 6:05 AM
  • Grega-slo and I installed at least from Exchange Server 2013 SP1, therefore we don't have the poor performance issue.

    If i try to add a contact from the GAL my connection goes for few seconds from Established to Connecting and back to Established. The contact list is still empty. It is possible to add contacts if you using RPC over HTTP or OWA.

    Thursday, October 16, 2014 7:52 AM
  • Thanks for posting the issue.  After looking into this further we are able to repro the issue.  The issue has been submitted to the Product Team for a fix.  I'll post back and update when the fix will release as soon as I find out. 
    Thursday, October 16, 2014 3:56 PM
  • We also see the GAL contact to local group problem with MAPI/HTTP + Outlook 2010 (Feb. 2015 update), any news on this?
    Tuesday, February 17, 2015 6:09 PM
  • Hi Gabriel,

    do you have information when an update will be released?

    Wednesday, March 4, 2015 8:48 AM
  • GAL contact to local group problem with MAPI/HTTP fixed in CU8:


    • Proposed as answer by Daniel Be Wednesday, March 18, 2015 10:19 PM
    • Unproposed as answer by Daniel Be Wednesday, March 18, 2015 10:21 PM
    • Edited by Daniel Be Wednesday, March 18, 2015 10:22 PM
    Wednesday, March 18, 2015 10:19 PM
  • Did the Win 8.1 / MAPI over HTTP bugfix (http://support.microsoft.com/en-us/kb/2986204) ever find it's way into Outlook 2010?

    I have the same problem with hanging Outlook with fully patched Outlook 2010 / Server 2012R2 , disabling MAPI over HTTP helps...

    Tuesday, November 3, 2015 4:08 PM
  • I realize this thread if nearly 1 year old... but it still seemed the best place to post this:

    This issue exists in Windows10/Outlook365 (2016) too.  I have recreated the same behavior that Greg posts about above. 

    Wednesday, September 7, 2016 5:17 AM
  • I have the same problem on Exchange 2016.

    Can MAPI/HTTP disabled in Exchange 2016?

    Monday, December 19, 2016 10:46 AM