none
5.7.1 Client was not authenticated

    Question

  • i am getting this error message 

    Server returned status code 530 - The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated
    Exception details:
    Message: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated
    Type: System.Net.Mail.SmtpException
    Stack trace:
    at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
    at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
    at System.Net.Mail.SmtpClient.Send(MailMessage message)
    at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()


    You can either be part of the problem or be part of the solution.
    Friday, August 06, 2010 5:55 PM

Answers

  • Hi,

    Is this when sending mail external or when you try to send mail to your own environment? I assume the last, if so check the default receive connector. On the permissions groups tab you will need to check the option anonymous once this is changed try again.

    Regards,

    Johan


    Exchange-blog: www.johanveldhuis.nl
    Friday, August 06, 2010 7:18 PM
  • Hello BoTN,

    i am getting this error message 

    Server returned status code 530 - The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated

    ANS. Most of the time you will get this error from form Internet mail. if permission on the Receive connector is not proper.

    If you are using E2K7 OR E2010 Server then please check the Default <SERVER> Receive connector and checked the Anonymous users permission.

    If it is E2K3 then checked the Default Smtp Virtual server.

    It will help you.


    EXCHANGE2010, MCSE, MCTS, MCSA MESSAGING, CCNA & GNIIT
    • Proposed as answer by PKT_ Friday, August 06, 2010 9:10 PM
    • Marked as answer by Allen SongModerator Wednesday, August 11, 2010 7:14 AM
    Friday, August 06, 2010 9:10 PM
  • Hi BoTN,

    Yes your right to receive mail from the internet you would need to make this modifications. Clients will use the default client connector which requires authentication before sending. If for example you have legacy applications or applications which can't perform authenticaten then my advice would be to create a seperate receive connector for those devices.

    Regards,

    Johan


    Exchange-blog: www.johanveldhuis.nl
    Saturday, August 07, 2010 11:31 AM

All replies

  • this is the exact message

     

    Testing Inbound SMTP Mail flow for domain username@contoso.com
     Failed to test inbound SMTP mail flow.
     Test Steps
     Attempting to retrieve DNS MX records for domain contoso.com
     One or more MX records were successfully retrieved from DNS.
     Additional Details
     MX Records Host mail.contoso.com, Preference 10
    , Host mx1.netfirms.com, Preference 20


    Testing Mail Exchanger mail.contoso.com.
     One or more SMTP tests failed for this Mail Exchanger.
     Test Steps
     Attempting to resolve the host name mail.contoso.com in DNS.
     Host successfully resolved
     Additional Details
     IP(s) returned: 173.xxx.xxx.xxx

    Testing TCP Port 25 on host mail.contoso.com to ensure it is listening and open.
     The port was opened successfully.
     Additional Details
     Banner Received: 220 server.contoso.com Microsoft ESMTP MAIL Service ready at Fri, 6 Aug 2010 11:08:23 -0700

    Attempting to send test email message to username@contoso.com using MX mail.contoso.com.
     Delivery of the test message failed.
     Additional Details
     Server returned status code 530 - The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated
    Exception details:
    Message: The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated
    Type: System.Net.Mail.SmtpException
    Stack trace:
    at System.Net.Mail.MailCommand.CheckResponse(SmtpStatusCode statusCode, String response)
    at System.Net.Mail.SmtpTransport.SendMail(MailAddress sender, MailAddressCollection recipients, String deliveryNotify, SmtpFailedRecipientException& exception)
    at System.Net.Mail.SmtpClient.Send(MailMessage message)
    at Microsoft.Exchange.Tools.ExRca.Tests.SmtpMessageTest.PerformTestReally()


    You can either be part of the problem or be part of the solution.
    Friday, August 06, 2010 6:12 PM
  • Hi,

    Is this when sending mail external or when you try to send mail to your own environment? I assume the last, if so check the default receive connector. On the permissions groups tab you will need to check the option anonymous once this is changed try again.

    Regards,

    Johan


    Exchange-blog: www.johanveldhuis.nl
    Friday, August 06, 2010 7:18 PM
  • Hello BoTN,

    i am getting this error message 

    Server returned status code 530 - The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.1 Client was not authenticated

    ANS. Most of the time you will get this error from form Internet mail. if permission on the Receive connector is not proper.

    If you are using E2K7 OR E2010 Server then please check the Default <SERVER> Receive connector and checked the Anonymous users permission.

    If it is E2K3 then checked the Default Smtp Virtual server.

    It will help you.


    EXCHANGE2010, MCSE, MCTS, MCSA MESSAGING, CCNA & GNIIT
    • Proposed as answer by PKT_ Friday, August 06, 2010 9:10 PM
    • Marked as answer by Allen SongModerator Wednesday, August 11, 2010 7:14 AM
    Friday, August 06, 2010 9:10 PM
  • Hi,

    Is this when sending mail external or when you try to send mail to your own environment? I assume the last, if so check the default receive connector. On the permissions groups tab you will need to check the option anonymous once this is changed try again.

    Regards,

    Johan


    Exchange-blog: www.johanveldhuis.nl


    that was it

    question thou:

    this was not enabled by default, is it save to assume for security resonse?

    also, could that open any security issues? from what i understand this would have to be enabled for anonymous in order o receive email from anyone other then on the domain or connected to the local LAN. is that correct?


    You can either be part of the problem or be part of the solution.
    Saturday, August 07, 2010 3:40 AM
  • Hi BoTN,

    Yes your right to receive mail from the internet you would need to make this modifications. Clients will use the default client connector which requires authentication before sending. If for example you have legacy applications or applications which can't perform authenticaten then my advice would be to create a seperate receive connector for those devices.

    Regards,

    Johan


    Exchange-blog: www.johanveldhuis.nl
    Saturday, August 07, 2010 11:31 AM
  • Hi,

    I'm also getting the same error but when sending (not receiving) emails through code in .NET.

    Does providing the 'anonymous' permissions to receive connector resolves the issue in sending emails also? Then i will ask my mail server provider to do this change.

     

    I don't have Outlook on that machine where website is hosted and i get this error. How can i test sending an email from that system, other than outlook?

     

    Many Thanks,

    Vishal.

    Friday, November 26, 2010 5:00 AM