none
Unable to initialize the Microsoft Exchange Information Store service because the clocks on the client and on the server machine are skewed RRS feed

  • Question

  • Each time I restart this exchange server, the Information Store and System Attendant don't start. If It try to manually start the services, I get the follow errors:

    Event ID 5003:
    Unable to initialize the Microsoft Exchange Information Store service because the clocks on the client and on the server machine are skewed. This may be caused by a time change either in the client or the server machine, and may require a reboot of that machine. Other than that, verify that your domain is properly configured and is currently online.

    Event ID 1005:
    Unexpected error The clocks on the client and server machines are skewed. ID no: 80090324 Microsoft Exchange System Attendant  occurred.

    The clocks on the domain controllers and the exchange server are set to the same time zones. As well, all three clocks are in sync down to the second. Any ideas on what's causing this and how to fix it?

    Thursday, February 11, 2010 10:58 PM

All replies

  • Make sure the clock in your system tray shows the same time/date for both the Exchange server and the domain controllers.

    Also check this out http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Windows_2003_Active_Directory/Q_22648594.html
    Raj
    Thursday, February 11, 2010 11:01 PM
  • Run this Command from the Exchange Server

    Net time \\ADServerName /Set

    and confirm the action,

    and then you need to restart the service

    Microsoft Exchange Active Directory Topology Service

     

    and confirm you are not getting the Error 4001 in the event Viewer.

     

    • Proposed as answer by Jim'P Saturday, November 12, 2011 2:50 AM
    Sunday, April 17, 2011 8:45 AM
  • I've now seen this error twice to two separate installs of Exchange 2010 after installing SP1 RU3.  Both environments run Windows 2003 Domain Controllers with Windows 2008 R2 hosting the Exchange 2010 installs and both are using three member DAGs.  After about 25 minutes of sitting idle the IS and SA can be started manually.

    We have a ticket open with Microsoft, but we have not heard anything back yet.

    Tuesday, April 26, 2011 5:02 PM
  • I started seeing this problem after I installed the CAS role on the mailbox server.  The mailbox server is in a two-node DAG as well.  Often I'd find adjusting the time manually by a small amount then restarting the MSExchangeADTopology service would fix it... at least until the next reboot.

     

    Tuesday, May 24, 2011 2:56 PM
  • Anyone get anywhere with this?  I have a 4 member dag all with mbx/cas/ht roles.

    Two members are in our west coast AD site and two are in our east coast site.  The clocks are synched, just 3 hours apart due to the time zones.

    When the east coast servers are rebooted, they throw the skew error above and can't start either the IS or SA service.

    Boxes are all 2008 r2 sp1 with ex2010sp1 ru4v2, brand new domain and exchange org.

    Thursday, August 11, 2011 3:13 PM
  • Is the time zone properly configured on each one?

    All internal operations are supposed to use the GMT time, which is calculated based on the time zone setting. So all servers in your cluster (and really, everything in your domain) should be showing the same GMT.

    Monday, August 15, 2011 2:53 PM
  • Run this Command from the Exchange Server

    Net time \\ADServerName /Set

    and confirm the action,

    and then you need to restart the service

    Microsoft Exchange Active Directory Topology Service

     

    and confirm you are not getting the Error 4001 in the event Viewer.

     

    Thank you, it resolved my issue after being sweating looking for solution.

     

    Friday, November 25, 2011 8:17 PM
  • Run this Command from the Exchange Server

    Net time \\ADServerName /Set

    and confirm the action,

    and then you need to restart the service

    Microsoft Exchange Active Directory Topology Service

     

    and confirm you are not getting the Error 4001 in the event Viewer.

     

    Thank you, it resolved my issue after being sweating looking for solution.

     

    How can I prevent this from happening? I cannot restart services on each server reboot nor lose 5 years of my life!!!


    Sokratis Laskaridis MCP, MCTS, MCITP, Small Business Specialist Netapp ASAP, Symantec STS


    Monday, April 9, 2012 10:03 AM
  • Never had this problem untill now.

    Migrated my (virtual) exchange server with the Mailbox role to another host (with different type of netwerk card ! ? )

    The above solution works (also just waiting half hour works), restarting the server brings the problem back

    Win 2008R2 SP1, Exchange 2010 SP1 latest Rollup

    Clocks are the same to the second on all servers!

    Did anybody solved this re-curring problem?

    Thanks


    Daniel

    Friday, April 13, 2012 7:59 AM
  • Hy,

    ia hade the same problem by one of our customers. Ad the fix Above solved the Problem. The Exchange was also a VM hosted on vSphere. The ESX Host had a wrong Time set and however they gave it to the Exchange server. Of Course the "Time Sync" Feature of the vmware tools was disabled. 

    best regards

    Thursday, April 26, 2012 6:23 PM
  • In my case my Windows environment time was set correctly.  The problem ended up being the time on the VMWare host itself.  After setting the time correctly on the vmware host, the Microsoft Information Store Service started correctly.
    • Proposed as answer by Fowljewl Tuesday, July 3, 2012 1:49 PM
    Tuesday, July 3, 2012 1:48 PM
  • Ugh, thank you. This problem has been plaguing me for days now. I'm creating my own Exchange 2010 environment and both the DC and Exchange server are set to external time sources, and I couldn't complete my Edge Subscription because of clock sync errors, and now my Information Store is failing to start with the error message the Op mentioned.

    I am SO happy to find the issue was solved because I did not sync my ESX host (even though the VM's weren't looking towards it for their time sources!).

    And now I face the problem of my Hub and Edge servers not able to sync to LDS. Well, at least we're at step further and it's back to Google ;)

    Sunday, July 22, 2012 7:31 AM
  • I Concur with the VMware Timing issue

    Exchange - Failed to mount database (hr=0x80040115, ec=-2147221227)

    Pete


    Regards Pete Long http://www.petenetlive.com

    • Proposed as answer by R-X Monday, May 6, 2013 8:13 AM
    Tuesday, August 28, 2012 8:14 PM
  • Hi,

    My exchange is on VM, and the time being synch from Physical PDC that pull the time from Internet Root Source. All servers are okay including HUB and CAS except the Mailbox server giving this issue.

    I don't use VMWare Tools Time Synch, I relay only on the PDC Domain Time Synchronization, even-though the issue happens whenever I reboot the Exchange Mailbox Server.

    Thanks the resolution once again.

    Saturday, September 15, 2012 9:53 AM
  • Hi Pete

    I was running into the exact issue . The server and DC were in syc but the time on the ESX host was off.

    and this solved my problem and saved me a lot of time with troubleshooting.

    Exchange - Failed to mount database (hr=0x80040115, ec=-2147221227)

    Thanks

    Harry

    Thursday, September 27, 2012 3:47 PM
  • Run this Command from the Exchange Server

    Net time \\ADServerName /Set

    and confirm the action,

    and then you need to restart the service

    Microsoft Exchange Active Directory Topology Service

     

    and confirm you are not getting the Error 4001 in the event Viewer.

     

    Thank you man!!!!

    You saved me :)

    Wednesday, October 10, 2012 8:37 AM
  • Run this Command from the Exchange Server

    Net time \\ADServerName /Set

    and confirm the action,

    and then you need to restart the service

    Microsoft Exchange Active Directory Topology Service

     

    and confirm you are not getting the Error 4001 in the event Viewer.

     


    Thanks, it work!
    Tuesday, July 9, 2013 10:30 AM
  • esx host had a wrong time...i found the time error in the events viewer. the above worked but when the VM restarted the issue was back!

    managed to resolve the issue by changing the time on the host and restarted the VM

    information store started and exchange db mounted.

    thx all.

    Thursday, November 7, 2013 12:45 AM
  • The ESX host should be keeping its time by using a NTP time source, just as your PDC FSMO role server should.

    --- Rich Matheisen MCSE&I, Exchange MVP

    Thursday, November 7, 2013 3:15 AM
  • This worked. Thank you!
    Wednesday, March 26, 2014 7:46 PM
  • Thank you for posting this, had my storage groups up in ten minutes flat!
    Friday, March 28, 2014 4:29 PM
  • I ran across this same issue tonight after restarting our exchange server. Restarting the Microsoft Exchange System Attendant service allowed me to manually start the other services that were not starting properly. When I first logged on to the server, I noticed the clock was off by approx. 10 minutes but corrected itself almost instantly.  As a solution to keep this happening again, I changed the startup type for the service from 'automatic' to 'automatic (delayed)'
    Tuesday, July 22, 2014 4:29 AM
  • This is the correct answer and worked for me, thank you.
    Wednesday, July 22, 2015 1:53 PM
  • These steps resolved my issue:

    1. Make sure that exchange server is member of "Exchange servers" and "Exchange Trusted Subsystem" exchange security groups

    2. Sync the time of exchange server with AD using command "Net time \\AD server /set"

    3. Restart Microsoft Exchange Active Directory Topology service (All exchange services)

    4. Make sure that DNS lookup work fine for exchange server and AD server is reachable

    Monday, July 27, 2015 11:45 AM
  • Really helpful. Thanks..
    Thursday, June 14, 2018 3:12 PM
  • I had the same issue and this step working fine in my case.

    Thanks guys.

    Saturday, May 25, 2019 7:41 AM