none
ECP redirects to OWA in Exchange 2013

    Question

  • When logging into ECP 2013, the Exchange Admin Center login does not come up. A Windows Security login window comes up instead and it takes me into Outlook Web App.

    What am I missing?

    July 2, 2014 Update. This has been resolved via reinstall. Thank you everyone to assist with this issue.
    • Edited by Fremont1 Wednesday, July 02, 2014 8:00 PM
    Monday, December 17, 2012 8:09 PM

Answers

  • Try from the box Exchange is on

    https://localhost/ecp/?ExchClientVer=15

    • Marked as answer by Fremont1 Wednesday, July 02, 2014 7:58 PM
    Wednesday, July 02, 2014 7:47 AM
  • Log in as the administrator and it should get you into the EAC instead.   I see the same on my Exchange 2013 environment.    Here is the behavior I have observed:

    Exchange Admin Center

    • https://servername/ecp
    • Login as administrator
    • Get into the EAC.

    Outlook Web App

    • https//servername/owa
    • Login as administrator
    • Get into OWA.

    I know it seems a bit confusing, but if you use the ECP virtual directory to connect, you will get into the EAC for Exchange 2013.


    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Monday, December 17, 2012 9:14 PM
  • Is there any other way to access ECP?

    Hi Fremont1,

    Please access EAC via Internal URL: https://<CASServerName>/ecp

    External URL: https://mail.contoso.com/ecp

    For more information, please see:

    Exchange Administration Center

    http://technet.microsoft.com/en-us/library/jj150562.aspx


    Frank Wang
    TechNet Community Support

    • Marked as answer by emma.yoyo Monday, December 24, 2012 2:30 AM
    Friday, December 21, 2012 6:12 AM

All replies

  • Log in as the administrator and it should get you into the EAC instead.   I see the same on my Exchange 2013 environment.    Here is the behavior I have observed:

    Exchange Admin Center

    • https://servername/ecp
    • Login as administrator
    • Get into the EAC.

    Outlook Web App

    • https//servername/owa
    • Login as administrator
    • Get into OWA.

    I know it seems a bit confusing, but if you use the ECP virtual directory to connect, you will get into the EAC for Exchange 2013.


    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Monday, December 17, 2012 9:14 PM
  • Any updates?

    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Tuesday, December 18, 2012 4:24 PM
  • The issue is I am logged in as an admin and trying to access the ECP. It doesn't take me to the Exchange Admin Center login.

    Wednesday, December 19, 2012 3:19 PM
  • Strange, I eplied to this earlier. 

    I have the experience in Exchange 2013 RTM.  However, in my Exchange Preview 2013 I see Exchange Admin Center.  Either way, if I use the ECP virtual directory, log in as the admin, I get the Admin console no matter what the login screen says.


    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Wednesday, December 19, 2012 7:37 PM
  • Is there any other way to access ECP?

    Wednesday, December 19, 2012 8:41 PM
  • Not as far as I know.  When I work with Exchange I spend 1/2 my time in the EAC and 1/2 in PowerShell.

    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Wednesday, December 19, 2012 8:44 PM
  • Is there any other way to access ECP?

    Hi Fremont1,

    Please access EAC via Internal URL: https://<CASServerName>/ecp

    External URL: https://mail.contoso.com/ecp

    For more information, please see:

    Exchange Administration Center

    http://technet.microsoft.com/en-us/library/jj150562.aspx


    Frank Wang
    TechNet Community Support

    • Marked as answer by emma.yoyo Monday, December 24, 2012 2:30 AM
    Friday, December 21, 2012 6:12 AM
  • I get the exact same problem, clean install in test environment now.

    EAC via Internal URL: https://<CASServerName>/ecp   ->Redirects to Outlook Web App
    OWA via Internal URL: https://<CASServerName>/OWA   ->Redirects to Outlook Web App

    Not able to get in to Exchange Managment Console.

    Totally frustraterating..


    Sunday, January 13, 2013 2:10 PM
  • Hello All,

    I had been through this issue ever since I completed my E2k13 Lab, both /Ecp and /Owa took me to Outlook Web App.

    Here is how it got solved for me, from AD> Microsoft Exchange Security Groups> I manually added the user (Domain Administrator itself/or custom user) into following groups, wildly...

    * Server Management

    *Recipient Management

    *Organizations Management

    *Helpdesk

    Retried, it again came up with the OWA screen but once logged in, I am inside the EAC :)

    Hope it helps

    • Proposed as answer by Insaf Muhammed Monday, January 21, 2013 6:57 AM
    Monday, January 21, 2013 6:57 AM
  • I did as you suggested by adding the domain admin to those security groups and it did not address the issue. Could it possibly be the opposite? Could the domain admin be in a security group that would prevent him from accessing the Exchange Admin Console?

    Tuesday, January 22, 2013 5:02 PM
  • Totally frustraterating 

    Same here, and when I create a 'new' user in Aduc and try to reach the ECP page (after adding this new user to some Exchange Groups), I receive the "Sorry! Access denied You don't have permission to open this page. if you're a new user or were recently assigned crdentials, please wait 15 minutes and try again."

    Grrr



    • Edited by Onedutch Tuesday, February 12, 2013 12:05 AM
    Tuesday, February 12, 2013 12:04 AM
  • Hi 

    I had the same problem. I found a good tutorial to install exchange correctly. Try this: http://www.youtube.com/watch?v=auircJQPujM

    Thursday, February 14, 2013 9:07 PM
  • Have a look here:
    http://technet.microsoft.com/en-us/library/jj150562.aspx

    "If you’re in a coexistence scenario, where you’re running Exchange 2010 and Exchange 2013 in the same organization, and your mailbox is still housed on the Exchange 2010 Mailbox server, the browser will default to the Exchange 2010 ECP. You can access the EAC by adding the Exchange version to the URL. For example, to access the EAC whose virtual directory is hosted on the Client Access server CAS15-NA, use the following URL: https://CAS15-NA/ecp?ExchClientVer=15. Conversely, if you want to access the Exchange 2010 ECP and your mailbox resides on an Exchange 2013 Mailbox server, use the following URL: https://CAS14-NA/ecp?ExchClientVer=14."

    Try the URL modification:
    https://<Exchange_2013_CAS_FQDN>/ecp?ExchClientVer=15

    It will show up as OWA authentication but after you provide credentials it will redirect back to EAC.

    Flame to MS guys: this modification does not harm the scenario when you do not have the exchange 2010 or 2007 coexistance. Why could not you set the param by default when accessing Exchange 2013 CAS ECP application? Why make all those who attempt to migrate from older exchange versions (2007 and 2010) stumble upon this problem? Shame on you.

    Regards,
    Eugene






    • Edited by Zverev Eugene Saturday, February 16, 2013 6:32 PM
    • Proposed as answer by Zverev Eugene Saturday, February 16, 2013 6:34 PM
    Saturday, February 16, 2013 6:23 PM
  • I ran into the same problem and I noticed that if you add a "/" at the end of the url it brings up EAC.

    <a href="https:///ecp/">https://<CASServerName>/ecp/ 

    • Proposed as answer by Teqnickel Wednesday, November 13, 2013 8:27 PM
    Sunday, February 17, 2013 4:40 PM
  • Thank you very much - works for me.

    • Proposed as answer by MasterMark2013 Sunday, February 24, 2013 7:56 PM
    • Unproposed as answer by MasterMark2013 Sunday, February 24, 2013 7:56 PM
    • Proposed as answer by MasterMark2013 Sunday, February 24, 2013 7:56 PM
    Sunday, February 24, 2013 7:56 PM
  • This was a test enviroment and had to blow away the Exchange server and Domain Controller and start from scratch again. Thanks for everyone's help.
    Thursday, March 14, 2013 7:39 PM
  • Hi,

    If you have this problem, you can add the Exchange Version to the URL using “?ExchClientVer=15″.

    So https://exchange2013/ecp?ExchClientVer=15 will redirect you to the correct Management Interface.


    Adam Aladdin

    Tuesday, April 16, 2013 1:57 PM
  • Hi,

    If you have this problem, you can add the Exchange Version to the URL using “?ExchClientVer=15″.

    So https://exchange2013/ecp?ExchClientVer=15 will redirect you to the correct Management Interface.


    Adam Aladdin

    Tuesday, April 16, 2013 1:58 PM
  • Zverev Eugene thanks so much buddy that fixed it for me.  My account was still on the 2010 mail server so adding the Version to the URL did it.  
    Thursday, May 02, 2013 7:06 PM
  • Got mine working mostly due to these last two previous posts. I didn't think I needed the CAS role so I just installed mail server, no CAS. So that's likely all my issue was. I got it working simply by loading the ISO (DVD)for Exchange 2013 into my virtual machine (Hyper-V), checked the CAS check box (other two were grayed out) to add the CAS role to the (only) mail server (standard 2012) and ran setup. The setup completed successfully and the final page of the setup wizard had a check box to open the management console so I checked it and clicked the finish button. It opened https://mail/ecp that finally gave me the Exchange admin center login and after entering my domain admin creds I was in. What's a little odd was the port for the ECP virtual directory was 81 for HTTP and 444 for HTTPS. But now it appears to be back on 80 now though. At least in my case it seems from the recent posts in this thread the root cause for me was not installing the CAS role anywhere.

    Sunday, May 05, 2013 10:23 AM
  • If you've set up an HTTP redirect for simple OWA URLs in IIS, you will find that the redirect has been inherited by subsites on the Default Web Site.  You'll need to go into each of the subsites, verify whether the redirect is enabled, and then disable it.  Afterwards, perform an iisreset (/noforce) to put the changes into effect.  
    • Proposed as answer by marwanu2000 Tuesday, June 25, 2013 11:00 AM
    Friday, May 24, 2013 6:56 PM
  • Thank you very much, works for me.
    Tuesday, June 25, 2013 11:01 AM
  • Hi ,

             Youe are really superb ....... it works for me ..keep posting this kind of good solutions 

    Tuesday, July 02, 2013 3:50 PM
  • Have a look here:
    http://technet.microsoft.com/en-us/library/jj150562.aspx

    "If you’re in a coexistence scenario, where you’re running Exchange 2010 and Exchange 2013 in the same organization, and your mailbox is still housed on the Exchange 2010 Mailbox server, the browser will default to the Exchange 2010 ECP. You can access the EAC by adding the Exchange version to the URL. For example, to access the EAC whose virtual directory is hosted on the Client Access server CAS15-NA, use the following URL: https://CAS15-NA/ecp?ExchClientVer=15. Conversely, if you want to access the Exchange 2010 ECP and your mailbox resides on an Exchange 2013 Mailbox server, use the following URL: https://CAS14-NA/ecp?ExchClientVer=14."

    Try the URL modification:
    https://<Exchange_2013_CAS_FQDN>/ecp?ExchClientVer=15

    It will show up as OWA authentication but after you provide credentials it will redirect back to EAC.

    Flame to MS guys: this modification does not harm the scenario when you do not have the exchange 2010 or 2007 coexistance. Why could not you set the param by default when accessing Exchange 2013 CAS ECP application? Why make all those who attempt to migrate from older exchange versions (2007 and 2010) stumble upon this problem? Shame on you.

    Regards,
    Eugene






    I added the user to groups and that didnt work. But https://<Exchange_2013_CAS_FQDN>/ecp?ExchClientVer=15 as suggested in above posted worked for me. (make sure you log out 1st and then try it)
    • Edited by EvilWasp Wednesday, July 31, 2013 4:30 PM
    Wednesday, July 31, 2013 4:30 PM
  • Have a look here:
    http://technet.microsoft.com/en-us/library/jj150562.aspx

    "If you’re in a coexistence scenario, where you’re running Exchange 2010 and Exchange 2013 in the same organization, and your mailbox is still housed on the Exchange 2010 Mailbox server, the browser will default to the Exchange 2010 ECP. You can access the EAC by adding the Exchange version to the URL. For example, to access the EAC whose virtual directory is hosted on the Client Access server CAS15-NA, use the following URL: https://CAS15-NA/ecp?ExchClientVer=15. Conversely, if you want to access the Exchange 2010 ECP and your mailbox resides on an Exchange 2013 Mailbox server, use the following URL: https://CAS14-NA/ecp?ExchClientVer=14."

    Try the URL modification:
    https://<Exchange_2013_CAS_FQDN>/ecp?ExchClientVer=15

    It will show up as OWA authentication but after you provide credentials it will redirect back to EAC.

    Flame to MS guys: this modification does not harm the scenario when you do not have the exchange 2010 or 2007 coexistance. Why could not you set the param by default when accessing Exchange 2013 CAS ECP application? Why make all those who attempt to migrate from older exchange versions (2007 and 2010) stumble upon this problem? Shame on you.

    Regards,
    Eugene


    I aslo had the prblem wtih wrong redirect to /owa - but it helped also writing: ?ExchClientVer=15

    /FLEMMING



    WE

    Saturday, August 10, 2013 8:54 PM
  • This solved the problem for me, thank you!
    Tuesday, October 08, 2013 12:43 PM
  • I am a total novice in Exchange much less the 2013 version. In my VM lab I have found where I installed Exchange 2013 with a user account that had Admin privileges. When attempting to log into ECP I found that the true Administrator's account log in sends me to OWA. If I use the account that I installed Exchange with I get into the Exchange Admin Center. Have not uninstalled/reinstalled Exchange to test assumption.
    Wednesday, October 16, 2013 11:36 PM
  • That is so odd. I ran into the same issue on my new 2013 install. Even moving the admin mailbox to the 2013 server and using the ecp?ExchClientVer=15 did not work. Everything redirected me back to the 2010 CAS OWA. The "/" at the end of the URL works like a charm. No idea why that should work, but it does. Thanks.
    Friday, November 08, 2013 4:29 PM
  • This worked perfectly for me, thanks for the tip!

    I wonder why the administrator wasn't added to these groups by default seeing as I used that account to install Exchange.

    Sunday, December 08, 2013 10:49 PM
  • Check out the short script andy created for making a shortcut on your server's desktop - http://www.telnetport25.com/2012/11/quick-tipcreating-an-icon-on-the-desktop-for-the-exchange-2013-eac/

    I use it on every deployment !

    ilantz

    Monday, December 23, 2013 10:12 AM
  • Logging into this is not the issue for me. I log in and it simply takes me to the user settings for the administrator account. If I specify version, I get this error:

    Outlook Web App Options

    There was a problem opening Options in Outlook Web App. You may have already signed in to the Exchange Administration Center with a specific version specified. If so, please sign out of the Exchange Administration Center or close your browser window and sign in again without a version specified. If that doesn't work, try deleting cookies from your browser and signing in again.

    Monday, January 06, 2014 3:37 PM
  • ^^ Same here...Any ideas?
    Thursday, March 06, 2014 1:08 PM
  • Is it possible to use this SP1?

    http://www.microsoft.com/en-us/download/details.aspx?id=41994

    But my installation is in Czech language, and SP1 is in english....

    Thank you for the solution.

    Monday, March 10, 2014 9:25 AM
  • Hello all,

    Please stop hijacking this thread.  This thread was answered a long time ago.  I can tell you from experience that most people that are answering questions are not looking at these posts because when they filter for questions they are looking at unanswered ones.   Please make a new post if you still have questions that you need answered.

    To answer the questions above:

    Yes <a href="https:///ecp?ExchClientVer=15">https://<Exchange_2013_CAS_FQDN>/ecp?ExchClientVer=15 still works in Service Pack 1.  Can't say for the language installation if it makes a difference or not, but I cant see why it would.

    As for the error about the version, start up a new thread as this is a different issue.


    JAUCG - Please remeber to mark replies as helpful if they were or as answered if I provided a solution.

    Monday, March 10, 2014 2:14 PM
  • Hallelujah! that worked for me!
    Friday, March 14, 2014 2:29 AM
  • Man that worked for me!, for anyone who ran to the same problem try this and save time.. Thanks Teqnickle
    Wednesday, April 09, 2014 4:19 PM
  • Try from the box Exchange is on

    https://localhost/ecp/?ExchClientVer=15

    • Marked as answer by Fremont1 Wednesday, July 02, 2014 7:58 PM
    Wednesday, July 02, 2014 7:47 AM
  • This worked for me. I was getting this error because i am migrating Exchange 2010 to Exchange 2013 SP1. This was happening because the administrator account was still located on the old exchange 2010 server.

    Wednesday, August 13, 2014 1:01 AM
  • Hello all,

    Please stop hijacking this thread.  This thread was answered a long time ago.  I can tell you from experience that most people that are answering questions are not looking at these posts because when they filter for questions they are looking at unanswered ones.   Please make a new post if you still have questions that you need answered.

    To answer the questions above:

    Yes <a href="https:///ecp?ExchClientVer=15">https://<Exchange_2013_CAS_FQDN>/ecp?ExchClientVer=15 still works in Service Pack 1.  Can't say for the language installation if it makes a difference or not, but I cant see why it would.

    This issue is still neither answered properly or resolved, there are no issues connecting the the ECP. I can connect and login, my colleague gets redirected to OWA. I am still looking for an answer to this. The Original Poster did not use your answer, they reinstalled exchange.


    Wednesday, August 27, 2014 5:08 AM
  • Holy crap.  I spent 6 hours with this problem, changing permission, etc and the answer was putting a"/" at the end.  Thank you very much.  why do the Microsoft techs not know this?
    Saturday, September 13, 2014 8:28 AM
  • Hello All,

    I had been through this issue ever since I completed my E2k13 Lab, both /Ecp and /Owa took me to Outlook Web App.

    Here is how it got solved for me, from AD> Microsoft Exchange Security Groups> I manually added the user (Domain Administrator itself/or custom user) into following groups, wildly...

    * Server Management

    *Recipient Management

    *Organizations Management

    *Helpdesk

    Retried, it again came up with the OWA screen but once logged in, I am inside the EAC :)

    Hope it helps

    Excellent, thanks for this, it works perfectly
    Wednesday, October 22, 2014 10:01 AM
  • I added the user I was trying to access the EAC with to the "Server Management" group only and it worked like a charm.   
    Monday, November 17, 2014 6:33 PM
  • Thanks, that's the trick. Without ?ExchClientVer=15 full console does not appear.
    Tuesday, February 17, 2015 7:18 PM
  • This is a rather large oversight by Microsoft.

    This should be added as a "tech note" within their upgrade/migration steps!

    https://localhost/ecp/?ExchClientVer=15

    Thanks to those who found/provided the answer!


    tnjman

    Friday, April 03, 2015 4:20 PM
  • I know this post is old, but I found it while looking for a solution to this.  So it's likely that other will too.  None of the replies marked as "Answers" were helpful in my situation.  In my situation, I had setup HTTP redirect following the instructions here: https://support.microsoft.com/en-us/kb/975341.   What they don't tell you to do is to turn the redirect OFF for ecp or it won't work.  Go to ecp in IIS, uncheck the box for redirect.  Do the same under the Exchange Back End.  Then, and this is technically optional, mark the SSL setting as "Require SSL."  Now when you try to get to https://yoursite.com/ecp it should work.  Hopefully this helps someone else.  

    Tuesday, August 04, 2015 12:27 PM
  • This group done the job : Recipient Management
    Thursday, April 07, 2016 8:17 AM
  • I Love you , thanks
    Friday, April 08, 2016 8:04 PM
  • We had a similar issue that was not to do with permissions or redirections, when we failed over our mailboxes to our secondary site we were unable to access ECP as the only CAS box with ECP enabled was at the primary site. The secondary site had a CAS but has no ECP enabled.

    For us the fix was to remove ExternalURL entries from the ECP virtual directories, at this point ECP was silently proxied to the CAS at the secondary site and everything worked OK.

    If we loose our primary site completely then we would need to re-enable ECP on the surviving CAS to manage the environment, this is now part of our DR plan.

    Hope this helps someone!

    Monday, April 11, 2016 12:01 PM
  • Thanks
    Monday, October 17, 2016 9:21 AM
  • This actually worked for me after trying all kinds of things.  Well I thought it did.  I now can get to the OWA options, but still cannot access EAC

    Lee Feldman SMB Consultant


    • Edited by dirtydawg69 Wednesday, April 05, 2017 6:23 PM
    Wednesday, April 05, 2017 6:21 PM