none
End-user item search limit @ 250, increase?

    Question

  • Hello,

     I am wondering if there is a way to increase the limit of items returned for a search from 250 to something more?

     Example -

    • UserA has a mailbox. 3000+ emails, 1 year worth of data in the Inbox.
    • UserA has his Outlook configured in "online" mode (cache disabled). "Improve search speed by limiting the number of results shown" is disabled as well (in the Options > Search). 
    • UserA runs a search for letter "a".
    • Search returns 250 items - no option to get more at the bottom of search results.
    • UserA logs in to OWA.
    • Runs a search for letter "a" again.
    • OWA returns 250 items and says "If you can't find what you were looking for, please try more specific terms"

     Exception -

    If UserA puts his Outlook in cached mode, and allows it to cache everything, the search (performed locally by the indexer on UserA's machine) will find way more than 250 items.

     This behavior is observed in Outlook 2010 and Outlook 2013.
     This was not an issue when UserA was on Exchange 2010 - when the user clicked "Get More" after the initial results from Search, it would load everything else it found.

     Question - Where on the Exchange server can I modify the setting for this, and is it modifiable?

     Answers similar to "have user use more specific terms" or "have user specify a time range" are not what I am looking for. This worked in 2010 and having to tell the user to use more specific terms will equal to a disaster.

    Please advise, thanks.

    Tuesday, December 10, 2013 1:15 AM

Answers

  • Hello,

    I'm afraid that there is no way to modify the setting.


    Cara Chen
    TechNet Community Support

    • Marked as answer by cara chen Monday, December 23, 2013 3:08 AM
    Wednesday, December 11, 2013 7:44 AM

All replies

  • Hello,

    I'm afraid that there is no way to modify the setting.


    Cara Chen
    TechNet Community Support

    • Marked as answer by cara chen Monday, December 23, 2013 3:08 AM
    Wednesday, December 11, 2013 7:44 AM
  • Is it something that can be requested as a feature for the coming up SP/CU?
    Thursday, December 12, 2013 5:01 PM
  • Hello,

    Sorry for delayed response.

    At present, there is no related sp/cu to modify the setting.


    Cara Chen
    TechNet Community Support

    Tuesday, December 17, 2013 7:48 AM
  • I ran into this limitation as well. If the client is in non-cached Exchange mode it will only return 250 search results.

    I've tested this with Outlook 2007 and Outlook 2013.  I'm not sure why this changed or if it is even mentioned in Exchange 2013 documentation. It is a headache for sure.

    Friday, January 3, 2014 12:09 AM
  • Hello,

    I'm afraid that there is no way to modify the setting.


    Cara Chen
    TechNet Community Support

    You are kidding, right??
    How should I explain this to our users who works on a terminal server?
    Oh my god!!
    We are running Outlook in Online mode on the terminal servers (Best practices).

    Tuesday, June 10, 2014 1:19 PM
  • What should we tell our users who have been extensively using search for years without limit? After purchasing new servers with the latest version of Microsoft Exchange, one of the most important and frequently-used features has actually been crippled. Is it your advice that we tell our customers to avoid Exchange 2013? And Office365 as well?
    Friday, October 17, 2014 12:32 AM
  • Is this stil the case?

    On my local PC with Win 8.1 and Office 2013 Pro Plus, my Outlook is able to show more than 250 results.

    Is this specific to Office 2013 on Remote Desktop servers (2012 R2) running up against an Exchange 2013??

    Regards

    Tuesday, October 21, 2014 2:04 PM
  • Dears,

    I have Exchange 2013 CU6, searching by old terms (One year ago) in my mailbox give me no results.

    Even if I change the time range of te search.

    May be the "Fast Search Engine" is a step back for Exchange Team.

    Saturday, March 7, 2015 5:58 AM
  • Hi ,

    We are facing an issue after migrating from exchange 2007 to 2013.

    If we open a mailbox in outlook 2007 for exchange 2007 and search by any character (Ex: Se) the search is returning more than 500 values. The return value is different in case of other search .

    But If we open a mailbox in outlook 2007 for exchange 2007 and search by some character (Ex: Se) it is returning max 250 values.

    Is there any fix to this issue Please ..

    Tuesday, September 22, 2015 2:25 PM
  • Hi ,

    We are facing an issue after migrating from exchange 2007 to 2013.

    If we open a mailbox in outlook 2007 for exchange 2007 and search by any character (Ex: Se) the search is returning more than 500 values. The return value is different in case of other search .

    But If we open a mailbox in outlook 2007 for exchange 2007 and search by some character (Ex: Se) it is returning max 250 values.

    Is there any fix to this issue Please ..

    Okay, you're getting different results when performing a search twice in Exchange 2007? hehe :P
    Just kidding, I guess you talking about Exchange 2013.
    You're searching Outlook in online mode and not cached, right?

    To receive more search results in Oulook you need to install the CU 10 for Exchange 2013. M$ Has fixed this issue now.
    https://support.microsoft.com/en-us/kb/3093866

    I've not tried the CU myself because we're running Symantec Enterprise Vault that's not compatible with this CU yet.
    Wednesday, September 23, 2015 8:16 AM
  • Unfortunately this didn't fix my issue - even after installing CU10 over the weekend, I'm still limited to 250 results when searching from an Outlook client in Online mode.
    Monday, September 28, 2015 1:55 PM
  • Unfortunately this didn't fix my issue - even after installing CU10 over the weekend, I'm still limited to 250 results when searching from an Outlook client in Online mode.

    Thank you for reporting back, to bad that it did not work!

    Can you try to remove the checkbox "Improve search speed by limiting the number og results shown" in Outlook?

    You find it under Search options...

    Tuesday, September 29, 2015 8:08 AM
  • Oh yeah, already did that, I don't think it even gets to 250 unless I do that. I seem to get more in OWA but not all of them and I can't even select them all to find out how many there are.  I probably have no choice but to open a call with PSS but I don't want it to cost $ and I don't know if they'll refund for this.  Definitely no configuration options for this anyone knows about?
    Tuesday, September 29, 2015 12:19 PM
  • Facing exactly the same issue in my exchange 2013 CU10 environment. Search results still limited to 250.

    Tuesday, September 29, 2015 1:42 PM
  • Good luck calling M$

    Our users did not understand why we upgraded from EX2007 to Ex2013, it's hard to explain them that things not working as it should do....


    Tuesday, September 29, 2015 1:57 PM
  • MS changed the KB to Rev. 2.0: https://support.microsoft.com/en-us/kb/3093866 
    Article ID: 3093866 - Last Review: 10/02/2015 21:00:00 - Revision: 2.0

    Tuesday, October 6, 2015 7:13 AM
  • Wow. Even after MS issued CU11 which they say fixes this bug, I'm experiencing the exact same behavior. Outlook in online mode limited to 250 results, OWA has more but still doesn't give me all of them.  This is what happens when you lay off all your testers.
    Monday, December 28, 2015 1:33 PM
  • I've just installed the CU11 and still have this bug too. It's completely ridiculous to have such a slip-shod implementation in what has become such an important feature for emails.

    Wednesday, January 27, 2016 12:39 AM
  • Still listed as fixed in CU11... 

    https://support.microsoft.com/en-us/kb/3093866
    That sucks!

    Wednesday, January 27, 2016 12:25 PM
  • I've raised this with MS, who advised the following:

    "There has been an feature change in the product and hence its going to remain the same. As of now the product team has informed us that the change is fixed and there might not be an update regarding the same."

    Apparently the support article 3093866 is going to be pulled. I'm not sure that they have any intentions of fixing this.

    Tuesday, February 2, 2016 11:35 AM
  • MS have also advised the following for 2016/O365:

    "As of now the design is not going to change and it’s the same for Exchange 2016, and Office 365.

    Product team is aware of the same, however there is no ETA if it will be ever fixed. "

    Thursday, February 4, 2016 1:35 PM
  • Hi all

    Fixed on CU11 but with an additional parameter configuration.

    See my post: http://somoit.net/exchange/exchange-2013-solved-the-search-results-limited-to-250-bug

    Thursday, February 11, 2016 10:02 AM
  • Yeah guys, it would help if you would actually read the KB article supplied rather than just clicking Download and hoping for the best. This is not a magic fix by just installing the CU. It simply enables a configuration option for the administrator to modify the setting. 

    After installing the CU, the old setting of 250 IS STILL IN PLACE. You must change it yourself using the steps provided in the KB. 

    Please check SomoIT.net's post above if you need further assistance.

    Friday, March 18, 2016 2:10 PM
  • The KB has been updated. Snapshop from 18th March 2016:

    To fix this issue, install Cumulative Update 11 or a later cumulative update for Exchange Server 2013.

    After you have installed the update, the default value is still 250, but you can edit the Microsoft.Exchange.Store.Worker.exe.CONFIG file to increase the limit of search results. To do that, you must add the following entries under the <appSettings> section as follows:

    <appSettings>
        <add key="MaxHitsForFullTextIndexSearches" value="<var class="sbody-var">5000</var>" />
      </appSettings> 


    Note If <appSettings> doesn't exist, you will need to add it after the </runtime> tag.

    The above example will increase the search items returned to 5000.  The MaxHitsForFullTextIndexSearches value can be between 1 and 1000000.  Care should be taken with this value as setting this too big could cause performance impact on the server.

    Once the above file has been edited, restart the information store service on the server for the change to take effect.4

    On my CU12 server the contents of Microsoft.Exchange.Store.Worker.exe.CONFIG is:

    <?xml version="1.0" encoding="utf-8" ?>
    <configuration>
      <runtime>
        <generatePublisherEvidence enabled="false"/>
        <disableCommitThreadStack enabled="1"/>
      </runtime>
    </configuration>

    Note the MaxHitsForFullTextIndexSearches  is NOT present. 


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Friday, March 18, 2016 2:36 PM
  • I too would like to know why this fix was apparently was removed from Exchange 2016 CU1 and above (the link provided by touchxxx above).   We have CU2 installed and it doesn't work even after adding the entry to the .CONFIG file and restarting the Information Store service.
    Wednesday, July 6, 2016 2:40 AM
  • In the same exact boat.  Worked with Exchange 2016 initially.  Updated to CU2 and it no longer works no matter what I add to the Microsoft.Exchange.Store.Worker.exe.config.  Is there a fix anyone has been able to implement to resolve this???
    Wednesday, August 3, 2016 5:48 PM
  • Experiencing the same issue here. Exchange 2016 CU2, Office 2016 ProPlus deferred channel build 16.0.6741.2063. Modifying the Microsoft.Exchange.Store.Worker.exe.config file and then restarting the info store service does nothing.
    Monday, August 15, 2016 4:39 PM
  • Just upgraded to Exchange 2016 CU3 and search items are still limited to 250 items in Outlook and OWA.
    Monday, September 26, 2016 5:49 PM
  • lichen, did you reapply the changes to the .config files? Usually CUs will reset them.    I was hoping CU3 was going to fix it as well.   Doh!
    Wednesday, October 5, 2016 11:10 PM
  • We're running Exchange 2016 CU4. Tonight I took a shot in the dark and applied the config file changes and restarted the services. We're still limited to 250 results.

    EDIT: I found a solution that works in the comments thread of the post below (starting with Eduardo's comment):
    https://somoit.net/exchange/exchange-2013-solved-the-search-results-limited-to-250-bug

    In our case, I wanted the setting to apply across all exchange servers, so I did not set a server-specific variable. I chose to complete most of the variables line by line, so I entered:

    New-SettingOverride -Name "Increase Search Results Limit"

    ...and then completed as follows (hitting enter at Parameter [1]):

    cmdlet New-SettingOverride at command pipeline position 1
    Supply values for the following parameters:
    Component: ManagedStore
    Parameters[0]: MaxHitsForFullTextIndexSearches=5000
    Parameters[1]:
    Reason: "Increases Search Results limits from 250 to 5000"
    Section: StoreSettings

    I probably could've entered this all in one shot with the following:

    New-SettingOverride -Name "Increase Search Results Limit" -Component ManagedStore -Section StoreSettings -Parameters @("MaxHitsForFullTextIndexSearches=5000") -Reason "Increases Search Result Limit from 250 to 5000"



    Read into the New-SettingOverride cmdlet before using, there's some dire warnings about getting it right.



    • Edited by Absol D Saturday, February 11, 2017 5:02 PM solution found
    Saturday, February 11, 2017 1:19 AM
  • Same problem also with Exchange 2016 CU6, but neither absoldan's hint nor the .config change works for me.

    Limited at 250 search results in OWA and Outlook.


    Is there any solution for that or do you have the same problems?
    Wednesday, July 5, 2017 4:36 PM
  • I've made some progress finally.    It looks like the ".config" method doesn't work anymore (not in 2016 anyway), but the 'New-SettingOverride' method does, BUT you also have to adjust a setting within the Outlook client as well. By default there is a checkbox set under Outlook Options -> Search labeled "Improve search speed by limiting the number of results shown".  This must be unchecked.  There is no direct Group Policy object to change it globally, but if you do some googling you can find the registry key to adjust and do it via GPP.

    Also, after I issued the New-SettingOverride command, I had to fully restart.  Just an Information Store restart didn't do it (or there might be another service that needs to be restarted as well).





    • Edited by jdobi1978 Wednesday, November 22, 2017 12:04 AM
    • Proposed as answer by BLShrestha Friday, February 2, 2018 4:58 AM
    Tuesday, November 21, 2017 11:53 PM
  • You can modify the setting. See link below

    https://somoit.net/exchange/exchange-2013-solved-the-search-results-limited-to-250-bug


    Head, Network Security and Infrastructure

    Wednesday, December 27, 2017 7:45 AM
  • Hello,

     I am wondering if there is a way to increase the limit of items returned for a search from 250 to something more?

     Example -

    • UserA has a mailbox. 3000+ emails, 1 year worth of data in the Inbox.
    • UserA has his Outlook configured in "online" mode (cache disabled). "Improve search speed by limiting the number of results shown" is disabled as well (in the Options > Search). 
    • UserA runs a search for letter "a".
    • Search returns 250 items - no option to get more at the bottom of search results.
    • UserA logs in to OWA.
    • Runs a search for letter "a" again.
    • OWA returns 250 items and says "If you can't find what you were looking for, please try more specific terms"

     Exception -

    If UserA puts his Outlook in cached mode, and allows it to cache everything, the search (performed locally by the indexer on UserA's machine) will find way more than 250 items.

     This behavior is observed in Outlook 2010 and Outlook 2013.
     This was not an issue when UserA was on Exchange 2010 - when the user clicked "Get More" after the initial results from Search, it would load everything else it found.

     Question - Where on the Exchange server can I modify the setting for this, and is it modifiable?

     Answers similar to "have user use more specific terms" or "have user specify a time range" are not what I am looking for. This worked in 2010 and having to tell the user to use more specific terms will equal to a disaster.

    Please advise, thanks.

    Here is what you're looking for.

    https://blogs.technet.microsoft.com/esexblog/2016/02/19/solucion-al-limite-de-250-resultados-cuando-realizamos-una-busqueda-de-emails-en-exchange-server-2013/


    Senior Systems Analyst https://xvand.com/

    Sunday, December 9, 2018 2:43 PM
  • Some one can help me..

    When i tried above solution, I got error message:

    Active directory operation failed on "domain controller". the object 'CN=increase search limit, CN=setting overrides, CN=global setting, CN=first organization, cn=microsoft excahnge, cn=services, cn=configuration, dc=*****, dc=** already exists.

    Wednesday, March 13, 2019 8:28 PM
  • Hello,

     I am wondering if there is a way to increase the limit of items returned for a search from 250 to something more?

     Example -

    • UserA has a mailbox. 3000+ emails, 1 year worth of data in the Inbox.
    • UserA has his Outlook configured in "online" mode (cache disabled). "Improve search speed by limiting the number of results shown" is disabled as well (in the Options > Search). 
    • UserA runs a search for letter "a".
    • Search returns 250 items - no option to get more at the bottom of search results.
    • UserA logs in to OWA.
    • Runs a search for letter "a" again.
    • OWA returns 250 items and says "If you can't find what you were looking for, please try more specific terms"

     Exception -

    If UserA puts his Outlook in cached mode, and allows it to cache everything, the search (performed locally by the indexer on UserA's machine) will find way more than 250 items.

     This behavior is observed in Outlook 2010 and Outlook 2013.
     This was not an issue when UserA was on Exchange 2010 - when the user clicked "Get More" after the initial results from Search, it would load everything else it found.

     Question - Where on the Exchange server can I modify the setting for this, and is it modifiable?

     Answers similar to "have user use more specific terms" or "have user specify a time range" are not what I am looking for. This worked in 2010 and having to tell the user to use more specific terms will equal to a disaster.

    Please advise, thanks.

    Someone definitely had modified the search result limit on the Exchange 2010 server, that is why you were able to return more than 250 items. You achieve same on your 2013 servers by following this process

    To increase the search limit we must modify the Microsoft.Exchange.Store.Worker.exe.config file on the Exchange servers. This file is in the following directory:

    % ExchangeInstallPath% \ Bin \ Microsoft.Exchange.Store.Worker.exe.config

    After the line  </ runtime> we must add:

    <appSettings>      <add key = "MaxHitsForFullTextIndexSearches" value = "1000" /> </ appSettings>

    https://blogs.technet.microsoft.com/esexblog/2016/02/19/solucion-al-limite-de-250-resultados-cuando-realizamos-una-busqueda-de-emails-en-exchange-server-2013/

    For 2016 server, it's a different ball game, run the following command on 2016 servers

    New-SettingOverride -Name “Exceed Search Limit over 250” -Server servername-Component ManagedStore -Section StoreS

    ettings -Reason “Override Search limit over 250 limits”

    Type: MaxHitsForFullTextIndexSearches=2500 on the first parameter and hit enter twice.

    After that you should be able to query more than 250

    https://social.technet.microsoft.com/Forums/en-US/6d8d819a-52ad-4065-9a87-49b060ab5ebf/search-results-with-exchange-2016-cu1?forum=Exch2016GD


    Senior Systems Analyst https://xvand.com/

    Monday, April 29, 2019 6:53 PM