Exchange Server 2010: Active Directory Preparation


  • hi guys,

    I'm installing the first Exchange server 2010 and co-existing with Exchange 2003,

    When I run "Setup /preparead", I got the below error:

    [01/31/2011 21:48:26.0682] [2] [WARNING] An unexpected error has occurred and a Watson dump is being generated: Bad IL range.
    [01/31/2011 21:48:26.0682] [2] [ERROR] Bad IL range.
    [01/31/2011 21:48:32.0150] [1] The following 1 error(s) occurred during task execution:
    [01/31/2011 21:48:32.0181] [1] 0.  ErrorRecord: Bad IL range.
    [01/31/2011 21:48:32.0181] [1] 0.  ErrorRecord: System.BadImageFormatException: Bad IL range.
       at Microsoft.Exchange.Management.Tasks.InstallCannedRbacRoleAssignments.CreateRoleAssignment(ExchangeRole role, ADRecipient recipient, RoleAssignmentDelegationType delegationType)
       at Microsoft.Exchange.Management.Tasks.InstallCannedRbacRoleAssignments.CreateRoleAssignmentDefinition(RoleAssignmentDefinition roleAssignmentDefinition, ADGroup roleGroup, List`1 precannedRoles)
       at Microsoft.Exchange.Management.Tasks.InstallCannedRbacRoleAssignments.InternalProcessRecord()
       at Microsoft.Exchange.Configuration.Tasks.Task.ProcessRecord()
       at System.Management.Automation.CommandProcessor.ProcessRecord()
    [01/31/2011 21:48:32.0244] [1] [ERROR] The following error was generated when "$error.Clear();
     Install-CannedRbacRoleAssignments -InvocationMode $RoleInstallationMode -DomainController $RoleDomainController

    " was run: "Bad IL range.".
    [01/31/2011 21:48:32.0244] [1] [ERROR] Bad IL range.
    [01/31/2011 21:48:32.0244] [1] [ERROR-REFERENCE] Id=38656544 Component=

    I updated the WIndows 2008 R2 server that I'm using with all Microsoft hotfixes, Please I need your help in this one.



    Tuesday, February 01, 2011 5:13 AM


All replies

  • Hi Omar,

    Your existing infrastructure respects all Exchange 2010 prerequisites ?

    1. Check Exchange 2003 version -> You must use Exchange 2003 with SP2 (version 6.5 build 7638.2: Service Pack 2).
    2. Exchange 2003 must be in Native Mode (no-pre-Exchange 2000 servers).
    3. Your AD must be in Domain fonctional level & Forest fonctional level at least "Windows Server 2003".
    4. Your schema master is running Windows Server 2003 with Service Pack 1 (SP1) or later.
    5. For all server roles other than the Edge Transport server role, you must first join the new exchange server to AD.
    6. AD must be fully replicated, and check your AD if no Error happen in Event logs.
    7. Install AD tools on Exchange 2010 server (if not DC) -> Powershell command : ServerManagerCmd -i RSAT-ADDS
    8. Prepare your domain for Exchange 2010 ( )
        a. Setup /PrepareLegacyExchangePermissions
        b. Setup /PrepareSchema
        c. Setup /PrepareAD
        d. Setup /PrepareDomain (for single Domain, otherwise use Setup /Preparealldomain )





    Tuesday, February 01, 2011 9:21 AM
  • hello

    Yes you need to prepare you schema,Legacy permissions and Active Directory

    To run this command to prepare every domain in the forest, you must be a member of the Enterprise Admins group. To run this command to prepare a specific domain, or if the forest has only one domain, you must be delegated the Exchange Organization Management role, and you must be a member of the Domain Admins group in the domain that you will prepare

    Thanks Mhussain
    Tuesday, February 01, 2011 10:51 AM
  • Thanks for your reply. I checked and double-checked to make sure that all the pre-requises are installed, but unfortunately it didn't work. Using virtual machines hosted on Windows 2008 R2, I built a new forest with only one Windows 2008 R2 DC, and it is fully updated, I ran "setup /prepareschema", and it went fine, but it gave me the same error when i ran "setup /preparead /OrganizationName:ASD". The virtual HD is a fixed one. Both of Windows 2008 R2 and Exchange 2010 SP1 are MSDN ISOs, is there any possibility with an error in the images themselves? I mean I found "System.BadImageFormatException: Bad IL Range"

    Also, I used "Set-Executionpolicy Unrestricted" in powershell, just to make sure that no policy or security setting is prevent "/preparead /OrganizationName:ASD" from running properly.

    After the production of the error, I opened ADSIEdit.msc, and browsed the Configuration partition. I found "cn=ASDMail,cn=Microsoft Exchange,cn=Services,cn=configuration,dc=ASD,dc=com" but this object is without any attributes when I open its properties. A container, I also found, is "cn=Microsoft Exchange Autodiscover,cn=Services,cn=configuration,dc=ASD,dc=com" and it has attributes.

    I used Administrator account, and I checked that it was added to all administrative groups in the domain.
    Tuesday, February 01, 2011 1:18 PM

  • If you install Exchange 2010 SP1, some hotfixes are needed under Windows 2008 R2 (windows 6.1 for hotfixe windows version).   (for .NET Framework 2.0)   (for ASP .NET 2.0)   (for AD Remote management services client)   (for .NET Framework 3.5 SP1)   (for .NET Framework 2.0)

    Your error "System.BadImageFormatException: Bad IL Range" seem a ASP problem (???), the previous hotfix for .NET are installed ?

    have you try to install Exchange 2010 without SP1, for updating Exchange in SP1 after ?


    Tuesday, February 01, 2011 2:52 PM
  • For the updates, I installed the recommended ones then I ran Windows Update a couple of times until the server got fully updated, then I ran the updates again just to double-check. I even removed ADDS and reinstalled it again with different name but with no luck.

    The MSDN ISO that I used is for Exchange Server 2010 with SP1 (en_exchange_server_2010_sp1_x64_dvd_587827) with size of 4.77 GBs, so I can't separate its installation from Exchange.

    I checked other articles and they were all pointing to ASP.NET issue, but eventhough, the server is updated.
    Could it be a corrupted file in Windows 2008 R2 iso image? like System.Transactions.dll? I'm saying this because in one of the articles of SQL, I saw the same error and it was due to a corrupted file, System.Transactions.dll.


    Tuesday, February 01, 2011 5:45 PM
  • If I were you I'd download a fresh copy of the Exchange bits. It looks like you have some bad binaries.
    My Book - Active Directory, 4th Edition
    My Blog -
    • Marked as answer by Omar Faqih Saturday, February 05, 2011 3:11 PM
    Tuesday, February 01, 2011 8:48 PM
  • Thank you guys for your support.

    As Brian recommended, I downloaded a new image of Exchange 2010 and everything went fine.


    Saturday, February 05, 2011 3:13 PM
  • Hello Hussain,

    Please can we chat, i ll need your assistance on exchange server 2010. I need to deploy it and would need you to guild me pls. our best can we chat?

    Tuesday, November 29, 2011 12:30 PM